<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html class="no-js"  lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ og: http://ogp.me/ns# rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema# schema: http://schema.org/ article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video#"><!--<![endif]-->

<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
  <meta charset="utf-8" />
<link href="https://opensource.com/rss.xml" rel="alternate" title="Opensource.com RSS" />
<link rel="shortcut icon" href="https://opensource.com/sites/all/themes/opensource/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="What were your favorite tech books of 2016? We round up a few hot releases." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://opensource.com/article/16/12/yearbook-publishers-picks" />
<link rel="shortlink" href="https://opensource.com/node/33561" />
<meta name="revisit-after" content="1 day" />
<meta property="og:site_name" content="Opensource.com" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://opensource.com/article/16/12/yearbook-publishers-picks" />
<meta property="og:title" content="Publisher&#039;s picks: Top 2016 open source books" />
<meta property="og:description" content="What were your favorite tech books of 2016? We round up a few hot releases." />
<meta property="og:image" content="https://opensource.com/sites/default/files/images/life/open_book_color.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@opensourceway" />
<meta name="twitter:title" content="Publisher&#039;s picks: Top 2016 open source books" />
<meta name="twitter:description" content="What were your favorite tech books of 2016? We round up a few hot releases." />
<meta name="twitter:image:src" content="https://opensource.com/sites/default/files/images/life/open_book_color.jpg" />
  <title>Top tech books of 2016 | Opensource.com</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_9l6C3kYa2UtdyBcxXB4DFxuteCTBikPA_st-XAMOo9M.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_P6yxQtOQeoGPm5Jqmt7Zs0aGtSznRIcpk9ZiCEZWWRU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_2sSTLhfz-nAupTlriBjCxX1Sq66ed6IcT_IYQDrIPg8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_7CQfPwU1OuZAW4nOwd57aDf6Ghx9AcoTy3Tgm0k0SM0.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans.css?oifeum" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold.css?oifeum" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-italic.css?oifeum" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold-italic.css?oifeum" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_wigS70piKQxAQ-PhuV0Kv5yYuTDEoD4yq0VyEj5L7HY.css" media="all" />
<style>.header-banner{position:relative;background-color:#008fbe;padding:17px 12px 17px 20px;background-image:url(/sites/all/themes/opensource/images/header-banner-desktop.png);background-size:cover;height:144px;}@media screen and (max-width:700px){.header-banner{padding:0;background-image:url(/sites/all/themes/opensource/images/header-banner-mobile.png);background-repeat:no-repeat;background-position:0 100%;background-color:#0b4f70;background-size:100%;height:auto;}}
</style>
  <script src="https://use.typekit.net/elz3yuz.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  <script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js?v=1.7.2"></script>
<script src="https://opensource.com/misc/jquery.once.js?v=1.2"></script>
<script src="https://opensource.com/misc/drupal.js?oifeum"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.core.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.widget.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/media.core.js?v=7.x-2.0-alpha3+12-dev"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.tabs.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.accordion.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.mouse.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.resizable.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.draggable.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.button.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.position.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.dialog.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/util/json2.js?v=7.x-2.0-alpha3+12-dev"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/util/ba-debug.min.js?v=7.x-2.0-alpha3+12-dev"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/better-autocomplete/jquery.better-autocomplete.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/external/jquery.cookie.js?v=67fb34f6a866c40d0570"></script>
<script src="https://opensource.com/misc/form.js?v=7.52"></script>
<script src="https://opensource.com/sites/all/modules/contrib/comment_notify/comment_notify.js?oifeum"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_admin/panopoly-admin.js?oifeum"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_magic/panopoly-magic.js?oifeum"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_theme/js/panopoly-accordion.js?oifeum"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/caption_filter/js/caption-filter.js?oifeum"></script>
<script src="https://opensource.com/sites/all/modules/contrib/loginlogout/loginlogout.js?oifeum"></script>
<script src="https://opensource.com/sites/all/modules/custom/os_events/os_events.js?oifeum"></script>
<script src="//static.addtoany.com/menu/page.js"></script>
<script src="https://opensource.com/sites/all/modules/contrib/pollanon/js/jquery.cookie.min.js?oifeum"></script>
<script src="https://opensource.com/sites/all/modules/contrib/pollanon/js/pollanon.pack.js?oifeum"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/media.popups.js?v=7.x-2.0-alpha3+12-dev"></script>
<script src="https://opensource.com/misc/collapse.js?v=7.52"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/js/linkit.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/js/linkit.dialog.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/editors/ckeditor/linkitDialog.js?v=7.2"></script>
<script src="https://opensource.com/misc/textarea.js?v=7.52"></script>
<script src="https://opensource.com/modules/filter/filter.js?oifeum"></script>
<script src="https://opensource.com/sites/all/modules/contrib/mollom/mollom.js?oifeum"></script>
<script src="https://opensource.com/sites/all/modules/contrib/rate/rate.js?oifeum"></script>
<script src="https://opensource.com/sites/all/modules/contrib/google_analytics/googleanalytics.js?oifeum"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-33294138-1", {"cookieDomain":".opensource.com"});ga("send", "pageview");</script>
<script src="https://opensource.com/sites/all/libraries/superfish/jquery.hoverIntent.minified.js?oifeum"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/sfsmallscreen.js?oifeum"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/supposition.js?oifeum"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/superfish.js?oifeum"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/supersubs.js?oifeum"></script>
<script src="https://opensource.com/sites/all/modules/contrib/superfish/superfish.js?oifeum"></script>
<script src="https://opensource.com/sites/all/themes/opensource/js/script.js?oifeum"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-33561 node-type-article region-content section-article page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<div id="page">

  <header class="header" id="header" role="banner">

    
      <div class="region region-navigation-top">
    <div id="block-system-user-menu" class="block block-system block-menu first odd" role="navigation">

      
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf leaf"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
<li class="menu__item is-leaf last leaf"><a href="/feed" title="Feeds" class="menu__link">Feed</a></li>
</ul>
</div>
<div id="block-superfish-1" class="block block-superfish last even">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-default sf-total-items-5 sf-parent-items-5 sf-single-items-0"><li id="menu-1906-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-8 sf-parent-children-4 sf-single-children-4 menuparent"><a href="/" title="" class="sf-depth-1 menuparent">Articles</a><ul><li id="menu-12341-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/containers" title="" class="sf-depth-2">Containers</a></li><li id="menu-12346-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/gaming" title="" class="sf-depth-2">Gaming</a></li><li id="menu-12351-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/hardware" title="" class="sf-depth-2 menuparent">Hardware</a><ul><li id="menu-12376-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/3d-printing" title="" class="sf-depth-3">3D printing</a></li><li id="menu-12386-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/arduino" title="" class="sf-depth-3">Arduino</a></li><li id="menu-12381-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/raspberry-pi" title="" class="sf-depth-3">Raspberry Pi</a></li></ul></li><li id="menu-1946-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/tags/law" title="" class="sf-depth-2 menuparent">Law</a><ul><li id="menu-12391-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/licensing" title="" class="sf-depth-3">Licensing</a></li><li id="menu-12396-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/patents" title="" class="sf-depth-3">Patents</a></li></ul></li><li id="menu-12356-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/tags/linux" title="" class="sf-depth-2">Linux</a></li><li id="menu-12361-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/tags/openstack" title="" class="sf-depth-2">OpenStack</a></li><li id="menu-12366-1" class="middle odd sf-item-7 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/programming" title="" class="sf-depth-2 menuparent">Programming</a><ul><li id="menu-12411-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/javascript" title="" class="sf-depth-3">JavaScript</a></li><li id="menu-12401-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/perl" title="" class="sf-depth-3">Perl</a></li><li id="menu-12406-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/python" title="" class="sf-depth-3">Python</a></li></ul></li><li id="menu-12371-1" class="last even sf-item-8 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/tags/sysadmin" title="" class="sf-depth-2 menuparent">SysAdmin</a><ul><li id="menu-12416-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/devops" title="" class="sf-depth-3">DevOps</a></li></ul></li></ul></li><li id="menu-1921-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-7 sf-parent-children-2 sf-single-children-5 menuparent"><a href="/resources" title="" class="sf-depth-1 menuparent">Resources</a><ul><li id="menu-2016-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/resources/projects-and-applications" title="" class="sf-depth-2">Projects and applications</a></li><li id="menu-2026-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/conferences-and-events-monthly" title="" class="sf-depth-2">Conferences and events</a></li><li id="menu-2021-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/resources/organizations" title="" class="sf-depth-2">Organizations</a></li><li id="menu-5556-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-8 sf-parent-children-0 sf-single-children-8 menuparent"><a href="/resources/cloud" title="" class="sf-depth-2 menuparent">The open source cloud</a><ul><li id="menu-5576-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/resources/big-data" title="" class="sf-depth-3">Big data</a></li><li id="menu-5566-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/what-docker" title="" class="sf-depth-3">Docker</a></li><li id="menu-5591-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/resources/internet-of-things" title="" class="sf-depth-3">Internet of things</a></li><li id="menu-5596-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/resources/what-is-kubernetes" title="" class="sf-depth-3">Kubernetes</a></li><li id="menu-5571-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/what-are-linux-containers" title="" class="sf-depth-3">Linux containers</a></li><li id="menu-5586-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/resources/what-are-microservices" title="" class="sf-depth-3">Microservices</a></li><li id="menu-5561-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/resources/what-is-openstack" title="" class="sf-depth-3">OpenStack</a></li><li id="menu-5581-1" class="last even sf-item-8 sf-depth-3 sf-no-children"><a href="/resources/what-is-software-defined-networking" title="" class="sf-depth-3">Software defined networking</a></li></ul></li><li id="menu-2036-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-11 sf-parent-children-0 sf-single-children-11 menuparent"><a href="/alternatives" title="" class="sf-depth-2 menuparent">Open source alternatives</a><ul><li id="menu-4646-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/alternatives/adobe-acrobat" class="sf-depth-3">Alternatives to Acrobat</a></li><li id="menu-4656-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/alternatives/autocad" class="sf-depth-3">Alternatives to AutoCAD</a></li><li id="menu-4636-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/alternatives/dreamweaver" class="sf-depth-3">Alternatives to Dreamweaver</a></li><li id="menu-5506-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/alternatives/gmail" class="sf-depth-3">Alternatives to Gmail</a></li><li id="menu-5551-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/alternatives/matlab" class="sf-depth-3">Alternatives to MATLAB</a></li><li id="menu-5501-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/alternatives/minecraft" class="sf-depth-3">Alternatives to Minecraft</a></li><li id="menu-4651-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/alternatives/picasa" class="sf-depth-3">Alternatives to Picasa</a></li><li id="menu-4661-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/alternatives/microsoft-publisher" class="sf-depth-3">Alternatives to Publisher</a></li><li id="menu-5511-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/alternatives/slack" class="sf-depth-3">Alternatives to Slack</a></li><li id="menu-4641-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/alternatives/trello" class="sf-depth-3">Alternatives to Trello</a></li><li id="menu-5546-1" class="last odd sf-item-11 sf-depth-3 sf-no-children"><a href="/alternatives" title="" class="sf-depth-3">More...</a></li></ul></li><li id="menu-2011-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/ebooks" title="" class="sf-depth-2">eBooks</a></li><li id="menu-12466-1" class="last odd sf-item-7 sf-depth-2 sf-no-children"><a href="/yearbook/2015" title="" class="sf-depth-2">Open source yearbook</a></li></ul></li><li id="menu-1911-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-7 sf-parent-children-2 sf-single-children-5 menuparent"><a href="/tags/community" title="" class="sf-depth-1 menuparent">Community</a><ul><li id="menu-1976-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/participate" class="sf-depth-2 menuparent">Join the community</a><ul><li id="menu-1981-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/user/register" title="" class="sf-depth-3">Register</a></li><li id="menu-2066-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/rules-comments-and-discussions" title="" class="sf-depth-3">Rules for comments and discussions</a></li><li id="menu-2056-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/community-moderator-program" class="sf-depth-3">Community Moderator program</a></li><li id="menu-4621-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/community-columnist-program" class="sf-depth-3">Community Columnist program</a></li><li id="menu-2061-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/points-and-badges" class="sf-depth-3">Points and badges</a></li></ul></li><li id="menu-1956-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/editorial-calendar" title="" class="sf-depth-2">Editorial calendar</a></li><li id="menu-1986-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/how-submit-article" class="sf-depth-2">Submit your story</a></li><li id="menu-2251-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/writer-testimonials" class="sf-depth-2">Writer Testimonials</a></li><li id="menu-1966-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/writers" class="sf-depth-2 menuparent">Guides for writers</a><ul><li id="menu-2041-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/submission-style-guide" class="sf-depth-3">Article submission and style guide</a></li><li id="menu-2046-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/how-conduct-interview-opensourcecom" class="sf-depth-3">How to conduct an interview</a></li><li id="menu-2051-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/article-entering-and-editing-guidelines" class="sf-depth-3">How to enter an article</a></li><li id="menu-4616-1" class="last even sf-item-4 sf-depth-3 sf-no-children"><a href="/promoting-articles" class="sf-depth-3">Tips for promoting your Opensource.com article</a></li></ul></li><li id="menu-4666-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/contributor-club" title="" class="sf-depth-2">Contributor Club</a></li><li id="menu-4671-1" class="last odd sf-item-7 sf-depth-2 sf-no-children"><a href="/community/16/8/editorial-writing-topics" class="sf-depth-2">Editorial writing topics</a></li></ul></li><li id="menu-4691-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/about" title="" class="sf-depth-1 menuparent">About</a><ul><li id="menu-1991-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-source-way" class="sf-depth-2">The Open Source Way</a></li><li id="menu-1971-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/opensourcecom-team" class="sf-depth-2">Meet the team</a></li><li id="menu-2006-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/press-kit" class="sf-depth-2">Press kit</a></li><li id="menu-2001-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/contact" title="" class="sf-depth-2">Contact</a></li></ul></li><li id="menu-2136-1" class="last odd sf-item-5 sf-depth-1 sf-total-children-7 sf-parent-children-2 sf-single-children-5 menuparent"><a href="/open-organization" title="" class="sf-depth-1 menuparent">The Open Org</a><ul><li id="menu-12471-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="sf-depth-2">What is an open organization?</a></li><li id="menu-2181-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/open-organization/resources/what-open-organization" title="" class="sf-depth-2">What is The Open Organization?</a></li><li id="menu-12421-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-decision-framework" title="" class="sf-depth-2">What is the Open Decision Framework?</a></li><li id="menu-4606-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/open-organization/resources/twitter-chats" title="" class="sf-depth-2">Twitter chats</a></li><li id="menu-2246-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/open-organization/resources/faq" title="" class="sf-depth-2">Open Org FAQs</a></li><li id="menu-2146-1" class="middle even sf-item-6 sf-depth-2 sf-total-children-7 sf-parent-children-0 sf-single-children-7 menuparent"><a href="/open-organization/resources" title="" class="sf-depth-2 menuparent">Resources</a><ul><li id="menu-3206-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/field-guide" class="sf-depth-3">Field guide download</a></li><li id="menu-4631-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/catalyst-in-chief" class="sf-depth-3">Catalyst in Chief download</a></li><li id="menu-12456-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="https://opensource.com/open-organization/resources/leaders-manual" title="Download the Open Organization Leaders Manual" class="sf-depth-3">Leaders Manual download</a></li><li id="menu-2271-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/chapter1" title="" class="sf-depth-3">Chapter download</a></li><li id="menu-2151-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/guides" title="" class="sf-depth-3">Discussion guide download</a></li><li id="menu-3201-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/reading-list" title="" class="sf-depth-3">Readling list</a></li><li id="menu-2256-1" class="last odd sf-item-7 sf-depth-3 sf-no-children"><a href="/open-organization/resources/2015-book-club" title="" class="sf-depth-3">Book club</a></li></ul></li><li id="menu-3166-1" class="last odd sf-item-7 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/open-organization/resources/ambassadors-program" title="" class="sf-depth-2 menuparent">Ambassadors program</a><ul><li id="menu-2691-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/meet-ambassadors" title="" class="sf-depth-3">Meet the ambassadors</a></li></ul></li></ul></li></ul>
</div>
  </div>

    <div class="header-banner">
      <div class="js-mobile-header-buttons"></div>
              <div class="header__name-and-slogan" id="name-and-slogan">
                      <div class="header__site-name" id="site-name">
              <a href="/" title="Home" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/logo.svg" onerror="this.src='/sites/all/themes/opensource/logo.png';this.onerror=null;" /></a>
              <a href="http://www.redhat.com/?sc_cid=701600000011l7VAAQ" title="Home" class="header__sponsor-link" rel="home"><img alt="RedHat" src="/sites/all/themes/opensource/images/redhat-logo.svg" onerror="this.src='/sites/all/themes/opensource/images/redhat-logo.png';this.onerror=null;"/></a>
            </div>
          
                  </div>
      
        <div class="header__region region region-header">
    <div id="block-search-form" class="block block-search first last odd" role="search">

      
  <form action="/article/16/12/yearbook-publishers-picks" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-DJgeuS31N9S_7U8M4RdoKvj0w3IIgf8U_mKhJ2D99iw" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>
</div>
  </div>
    </div>

    <div class="mobile--menu-region">
        <div class="region region-navigation">
    <div id="block-system-main-menu" class="block block-system block-menu first last odd" role="navigation">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/" title="" class="menu__link">Articles</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/containers" title="" class="menu__link">Containers</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/gaming" title="" class="menu__link">Gaming</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/hardware" title="" class="menu__link">Hardware</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/3d-printing" title="" class="menu__link">3D printing</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/arduino" title="" class="menu__link">Arduino</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/raspberry-pi" title="" class="menu__link">Raspberry Pi</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/law" title="" class="menu__link">Law</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/linux" title="" class="menu__link">Linux</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/openstack" title="" class="menu__link">OpenStack</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/programming" title="" class="menu__link">Programming</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/javascript" title="" class="menu__link">JavaScript</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/perl" title="" class="menu__link">Perl</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/python" title="" class="menu__link">Python</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded"><a href="/tags/sysadmin" title="" class="menu__link">SysAdmin</a><ul class="menu"><li class="menu__item is-leaf first last leaf"><a href="/tags/devops" title="" class="menu__link">DevOps</a></li>
</ul></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/projects-and-applications" title="" class="menu__link">Projects and applications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/conferences-and-events-monthly" title="" class="menu__link">Conferences and events</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/organizations" title="" class="menu__link">Organizations</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/resources/cloud" title="" class="menu__link">The open source cloud</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/alternatives" title="" class="menu__link">Open source alternatives</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/ebooks" title="" class="menu__link">eBooks</a></li>
<li class="menu__item is-leaf last leaf"><a href="/yearbook/2015" title="" class="menu__link">Open source yearbook</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/tags/community" title="" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/participate" class="menu__link">Join the community</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/register" title="" class="menu__link">Register</a></li>
<li class="menu__item is-leaf leaf"><a href="/rules-comments-and-discussions" title="" class="menu__link">Rules for comments and discussions</a></li>
<li class="menu__item is-leaf leaf"><a href="/community-moderator-program" class="menu__link">Community Moderator program</a></li>
<li class="menu__item is-leaf leaf"><a href="/community-columnist-program" class="menu__link">Community Columnist program</a></li>
<li class="menu__item is-leaf last leaf"><a href="/points-and-badges" class="menu__link">Points and badges</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/resources/editorial-calendar" title="" class="menu__link">Editorial calendar</a></li>
<li class="menu__item is-leaf leaf"><a href="/how-submit-article" class="menu__link">Submit your story</a></li>
<li class="menu__item is-leaf leaf"><a href="/writer-testimonials" class="menu__link">Writer Testimonials</a></li>
<li class="menu__item is-expanded expanded"><a href="/writers" class="menu__link">Guides for writers</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/submission-style-guide" class="menu__link">Article submission and style guide</a></li>
<li class="menu__item is-leaf leaf"><a href="/how-conduct-interview-opensourcecom" class="menu__link">How to conduct an interview</a></li>
<li class="menu__item is-leaf leaf"><a href="/article-entering-and-editing-guidelines" class="menu__link">How to enter an article</a></li>
<li class="menu__item is-leaf last leaf"><a href="/promoting-articles" class="menu__link">Tips for promoting your Opensource.com article</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/resources/contributor-club" title="" class="menu__link">Contributor Club</a></li>
<li class="menu__item is-leaf last leaf"><a href="/community/16/8/editorial-writing-topics" class="menu__link">Editorial writing topics</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/about" title="" class="menu__link">About</a></li>
<li class="menu__item is-expanded last expanded"><a href="/open-organization" title="" class="menu__link">The Open Org</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="menu__link">What is an open organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/what-open-organization" title="" class="menu__link">What is The Open Organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-decision-framework" title="" class="menu__link">What is the Open Decision Framework?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/twitter-chats" title="" class="menu__link">Twitter chats</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/faq" title="" class="menu__link">Open Org FAQs</a></li>
<li class="menu__item is-expanded expanded"><a href="/open-organization/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/field-guide" class="menu__link">Field guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/catalyst-in-chief" class="menu__link">Catalyst in Chief download</a></li>
<li class="menu__item is-leaf leaf"><a href="https://opensource.com/open-organization/resources/leaders-manual" title="Download the Open Organization Leaders Manual" class="menu__link">Leaders Manual download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/chapter1" title="" class="menu__link">Chapter download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/guides" title="" class="menu__link">Discussion guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/reading-list" title="" class="menu__link">Readling list</a></li>
<li class="menu__item is-leaf last leaf"><a href="/open-organization/resources/2015-book-club" title="" class="menu__link">Book club</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/open-organization/resources/ambassadors-program" title="" class="menu__link">Ambassadors program</a></li>
</ul></li>
</ul>
</div>
  </div>
    </div>

  </header>

      <div id="main">
        <div class="pre-content">
                                                          </div>
        <div id="content" class="column" role="main">
                    <a id="main-content"></a>
                                <h1 class="page__title title" id="page-title">Top tech books of 2016</h1>
                              



<div class="panel-display os-article clearfix " id="article-template">

      <div class="os-article__sidebar">
      <div class="panel-pane pane-views-panes pane-author-info-panel-pane-1" >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-1557718c984d77b4567f5f662c943dd8">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/rikki_small.png?itok=I1h_27jm" width="100" height="100" alt="Rikki Endsley" /></div>
<div class="authorbio__content">
  <span class="authorbio__name">Rikki Endsley</span> - <span class="authorbio__about">Rikki Endsley is a community manager for Opensource.com. In the past, she worked as the community evangelist on the Open Source and Standards (OSAS) team at Red Hat; a freelance tech journalist; community manager for the USENIX Association; associate publisher of Linux Pro Magazine, ADMIN, and Ubuntu User; and as the managing editor of Sys Admin magazine and UnixReview.com. Follow her on Twitter at: <a href="https://twitter.com/rikkiends" target="_blank">@rikkiends</a>.
</span>
  <div class="authorbio__more-link"><a href="/users/rikki-endsley">» More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-article-contributions" >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block" >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__header">
      <div class="panel-pane pane-node-title" >
  
      
  
  <h1>Publisher&#039;s picks: Top 2016 open source books </h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-article-subhead" >
  
      
  
  <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden">
    <div class="field-items">
          <h2>What were your favorite tech books of 2016? We round up a few hot releases.</h2>
      </div>
</div>

  
  </div>
<div class="panel-pane pane-os-article-byline" >
  
      
  
  <div class="byline"><span class="byline__date">Posted 06 Jan 2017</span>
<span class="byline__author"><a href="/users/rikki-endsley" title="View user profile." class="username" xml:lang="" about="/users/rikki-endsley" typeof="sioc:UserAccount" property="foaf:name" datatype="">Rikki Endsley <span class="redhat-employee">(Red Hat)</span></a><span class="byline__feed"><a href="/user/23316/feed">Feed</a></span>
</span>
<span class="byline__social"><span class="byline__voting-widget"><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-be1bcaf7ee5b4e9462ec550abf1f0731 rate-node-33561-1-1" id="rate-node-33561-1-1"><div class="rate-info">8</div><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/16/12/yearbook-publishers-picks?rate=Va6plP9tf7T7pT86OuCbembwHWHpzrJGUHENO3El46M" title="up">up</a></div></span>
</span>
</div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-lead-image" >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/image-full-size/public/images/life/open_book_color.jpg?itok=N6UkVk47"><img class="image-full-size" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/image-full-size/public/images/life/open_book_color.jpg?itok=N6UkVk47" width="610" height="343" alt="Publisher&#039;s picks: Top 2016 open source books " title="Publisher&#039;s picks: Top 2016 open source books " /></div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-file-field-file-image-caption" >
  
      
  
  <div class="field field-name-field-file-image-caption field-type-text-long field-label-inline clearfix"><div class="field-label">Image by :&nbsp;</div><div class="field-items"><div class="field-item even"><p>opensource.com</p>
</div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__content">
      <div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:articleBody content:encoded"><p>Book publishers share their picks for must-read 2016 open source-related book releases.</p>
<h2>No Starch Press</h2>
<p><em>(Contributed by Anna Morrow)</em></p>
<p><img alt="carhackerbook" class="media-image attr__typeof__foaf:Image img__fid__335311 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__carhackerbook attr__field_file_image_title_text[und][0][value]__carhackerbook attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/carhackershandbook_sm.png" style="width: 150px; height: 198px; float: right;" title="carhackerbook" typeof="foaf:Image" width="150" height="198" /><b><a href="https://www.nostarch.com/carhacking" target="_blank">The Car Hacker's Handbook</a><br />
By Craig Smith<br />
304 Pages<br />
Published: March 2016</b></p>
<p>With its focus on low-cost, open source hacking tools, <i>The Car Hacker's Handbook</i> will give you a deeper understanding of the computer systems and embedded software in modern vehicles. The book begins by examining vulnerabilities and providing detailed explanations of communications over the CAN bus and between devices and systems. You'll learn how to build an accurate threat model for your vehicle, reverse engineer the CAN bus to fake engine signals, exploit vulnerabilities, build physical and virtual test benches, and much more. If you're curious about automotive security, <i>The Car Hacker's Handbook</i> is for you.</p>
<p><b><a href="https://www.nostarch.com/electronicsforkids" target="_blank">Electronics for Kids</a><br />
By Øyvind Nydal Dahl</b><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335316 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/electronicsforkids_sm.png" style="width: 150px; height: 198px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="198" /><br /><b>328 Pages<br />
Published: July 2016</b></p>
<p><i>Electronics for Kids</i> is perfect for feeding kids' natural curiosity about electronics through hands-on projects. Kids (and the adults in their lives!) will build projects like an electronic coin tosser, an electromagnet, an electric motor, an intruder alarm, a musical instrument, a touch sensor LED circuit, and even a lemon-powered LED light. Along the way, they'll learn how current, voltage, and circuits work. With clear explanations and fun projects, this book will have kids building their own circuits in no time.</p>
<p>To read more from Øyvind Nydal Dahl, author of <i>Electronics for Kids</i>, visit his <a href="https://opensource.com/users/oyvdahl">Opensource.com author page</a>.</p>
<p><b><a href="https://www.nostarch.com/forensicimaging" target="_blank">Practical Forensic Imaging</a></b><br /><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335321 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/practicalforensicimaging_sm.png" style="width: 150px; height: 198px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="198" /><b>By Bruce Nikkel<br />
320 Pages<br />
Published: September 2016</b></p>
<p>When forensic investigations involve digital activity, the proper handling of media evidence is critical. <i>Practical Forensic Imaging</i> takes a detailed look at how to use open source command=line tools to secure and manage digital evidence. Author Bruce Nikkel walks you through the entire forensic acquisition process and covers practical scenarios and situations related to the imaging of storage media. <i>Practical Forensic Imaging</i> is an invaluable resource for experienced digital forensic investigators wanting to advance their Linux skills and experienced Linux administrators wanting to learn digital forensics.</p>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335326 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/scratchprogrammingplayground_sm.png" style="width: 150px; height: 198px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="198" /><b><a href="https://www.nostarch.com/scratchplayground" target="_blank">Scratch Programming Playground</a><br />
By Al Sweigart<br />
288 Pages<br />
Published: September 2016</b></p>
<p>Scratch is the standard language for teaching kids to program, with more than 14-million users worldwide. In <i>Scratch Programming Playground</i>, kids can learn to program by making cool games. Each game includes easy-to-follow instructions, review questions, and creative coding challenges that allow kids to make the games their own. Kids will make games like Maze Runner, Snake, a Fruit Ninja clone, a remake of Breakout, and even a game inspired by Super Mario Bros. From the author of fan favorite <i>Automate the Boring Stuff with Python</i>, <i>Scratch Programming Playground</i> proves that learning to program isn't dreary when you make a game of it. To read more from Al Sweigart, author of <i>Scratch Programming Playground</i>, visit his <a href="https://opensource.com/users/alsweigart" target="_blank">Opensource.com author page</a>.</p>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335331 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/wickedcoolshellscripts2e_sm.png" style="width: 150px; height: 198px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="198" /><b><a href="https://www.nostarch.com/wcss2" target="_blank">Wicked Cool Shell Scripts, 2nd Edition</a><br />
By Dave Taylor and Brandon Perry<br />
392 Pages<br />
Published: October 2016</b></p>
<p>An update to the beloved first edition, the second edition of <i>Wicked Cool Shell Scripts</i> offers a collection of useful, customizable, and fun shell scripts for solving common problems and personalizing your computing environment. This edition features 23 brand-new scripts, such as a ZIP code lookup tool, a bitcoin address information retriever, image processing and editing tools, and classic games like hangman. Whether you want to save time managing your system or just find new ways to goof off, you'll love these wicked cool scripts.</p>
<p>To read more from Dave Taylor, author of <i>Wicked Cool Shell Scripts, 2nd Edition</i>, visit his <a href="https://opensource.com/users/davetaylor" target="_blank">Opensource.com author page</a>.</p>
<h2>O'Reilly Media</h2>
<p><em>(Contributed by Susan Conant)</em></p>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335336 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/reactup_sm.png" style="width: 150px; height: 197px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="197" /><b><a href="http://shop.oreilly.com/product/0636920042266.do" target="_blank">React: Up &amp; Running</a><br />
Building Web Applications<br />
By Stoyan Stefanov<br />
222 Pages<br />
Published: July 2016</b></p>
<p>Hit the ground running with React, the open-source technology from Facebook for building rich web applications fast. With this practical guide, Yahoo! web developer Stoyan Stefanov teaches you how to build components—React's basic building blocks—and organize them into maintainable, large-scale apps. If you're familiar with basic JavaScript syntax, you're ready to get started.</p>
<p>Once you understand how React works, you'll build a complete custom Whinepad app that helps users rate wines and keep notes. You'll quickly learn why some developers consider React the key to the web app development puzzle.</p>
<ul>
<li>Set up React and write your first "Hello world" web app</li>
<li>Create and use custom React components alongside generic DOM components</li>
<li>Build a data table component that lets you edit, sort, search, and export its contents</li>
<li>Use the JSX syntax extension as an alternative to function calls</li>
<li>Set up a lean, low-level build process that helps you focus on React</li>
<li>Build a complete custom app that lets you store data on the client</li>
<li>Use ESLint, Flow, and Jest tools to check and test your code as your app evolves</li>
<li>Manage communication between components with Flux</li>
</ul>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335341 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/reactiverxjava_sm.png" style="width: 150px; height: 197px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="197" /><b><a href="http://shop.oreilly.com/product/0636920042228.do" target="_blank">Reactive Programming with RxJava</a><br />
Creating Asynchronous, Event-Based Applications<br />
By Tomasz Nurkiewicz, Ben Christensen<br />
372 Pages<br />
Published: October 2016</b></p>
<p>In today's app-driven era, when programs are asynchronous and responsiveness is so vital, reactive programming can help you write code that's more reliable, easier to scale, and better-performing. With this practical book, Java developers will first learn how to view problems in the reactive way, and then build programs that leverage the best features of this exciting new programming paradigm.</p>
<p>Authors Tomasz Nurkiewicz and Ben Christensen include concrete examples that use the RxJava library to solve real-world performance issues on Android devices as well as the server. You'll learn how RxJava leverages parallelism and concurrency to help you solve today's problems. This book also provides a preview of the upcoming 2.0 release.</p>
<ul>
<li>Write programs that react to multiple asynchronous sources of input without descending into "callback hell"</li>
<li>Get to that aha! moment when you understand how to solve problems in the reactive way</li>
<li>Cope with Observables that produce data too quickly to be consumed</li>
<li>Explore strategies to debug and to test programs written in the reactive style</li>
<li>Efficiently exploit parallelism and concurrency in your programs</li>
<li>Learn about the transition to RxJava version 2</li>
</ul>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335346 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/learningnode_sm.png" style="width: 150px; height: 197px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="197" /><b><a href="http://shop.oreilly.com/product/0636920046936.do" target="_blank">Learning Node, 2nd Edition</a><br />
Moving to the Server-Side<br />
By Shelley Powers<br />
288 Pages<br />
Published: May 2016</b></p>
<p>Take your web development skills from browser to server with Node—and learn how to write fast, highly scalable network applications on this JavaScript-based platform. Updated for the latest Node Long Term Support (LTS) and Node Current (6.0) releases, this hands-on edition helps you master Node's core fundamentals and gain experience with several built-in and contributed modules.</p>
<p>Get up to speed on Node's event-driven, asynchronous I/O model for developing data-intensive applications that are frequently accessed but computationally simple. If you're comfortable working with JavaScript, this book provides many programming and deployment examples to help you take advantage of server-side development with Node.</p>
<ul>
<li>Explore the frameworks and functionality for full-stack Node development</li>
<li>Dive into Node's module system and package management support</li>
<li>Test your application or module code on the fly with Node's REPL console</li>
<li>Use core Node modules to build web applications and an HTTP server</li>
<li>Learn Node's support for networks, security, and sockets</li>
<li>Access operating system functionality with child processes</li>
<li>Learn tools and techniques for Node development and production</li>
<li>Use Node in microcontrollers, microcomputers, and the Internet of Things</li>
</ul>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335351 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/machinelearning_sm.png" style="width: 150px; height: 197px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="197" /><strong><a href="http://shop.oreilly.com/product/0636920030515.do" target="_blank">Introduction to Machine Learning with Python</a><br />
A Guide for Data Scientists<br />
By Andreas C. Müller, Sarah Guido<br />
392 Pages</strong><br /><b>Published</b><strong>: September 2016</strong></p>
<p>Machine learning has become an integral part of many commercial applications and research projects, but this field is not exclusive to large companies with extensive research teams. If you use Python, even as a beginner, this book will teach you practical ways to build your own machine learning solutions. With all the data available today, machine learning applications are limited only by your imagination.</p>
<p>You'll learn the steps necessary to create a successful machine-learning application with Python and the scikit-learn library. Authors Andreas Müller and Sarah Guido focus on the practical aspects of using machine learning algorithms, rather than the math behind them. Familiarity with the NumPy and matplotlib libraries will help you get even more from this book.</p>
<p>With this book, you'll learn:</p>
<ul>
<li>Fundamental concepts and applications of machine learning</li>
<li>Advantages and shortcomings of widely used machine learning algorithms</li>
<li>How to represent data processed by machine learning, including which data aspects to focus on</li>
<li>Advanced methods for model evaluation and parameter tuning</li>
<li>The concept of pipelines for chaining models and encapsulating your workflow</li>
<li>Methods for working with text data, including text-specific processing techniques</li>
<li>Suggestions for improving your machine learning and data science skills</li>
</ul>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335356 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/arduino_sm.png" style="width: 150px; height: 197px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="197" /><strong><a href="http://shop.oreilly.com/product/0636920037880.do" target="_blank">Arduino: A Technical Reference</a><br />
A Handbook for Technicians, Engineers, and Makers<br />
By J. M. Hughes<br />
638 Pages </strong><br /><b>Published</b><strong>: May 2016</strong></p>
<p>Rather than yet another project-based workbook, <i>Arduino: A Technical Reference</i> is a reference and handbook that thoroughly describes the electrical and performance aspects of an Arduino board and its software. This book brings together in one place all the information you need to get something done with Arduino. It will save you from endless web searches and digging through translations of datasheets or notes in project-based texts to find the information that corresponds to your own particular setup and question.</p>
<p>Reference features include pinout diagrams, a discussion of the AVR microcontrollers used with Arduino boards, a look under the hood at the firmware and run-time libraries that make the Arduino unique, and extensive coverage of the various shields and add-on sensors that can be used with an Arduino. One chapter is devoted to creating a new shield from scratch. The book wraps up with detailed descriptions of three different projects: a programmable signal generator, a "smart" thermostat, and a programmable launch sequencer for model rockets. Each project highlights one or more topics that can be applied to other applications.</p>
<h2>Packt</h2>
<p><em>(Contributed by Richard Gall)</em></p>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335361 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/c6_sm.png" style="width: 150px; height: 185px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="185" /><b><a href="https://www.packtpub.com/application-development/c-6-and-net-core-10" target="_blank">C#6 and .NET Core</a><br />
By Mark J. Price<br />
550 Pages<br />
Published: March 2016</b></p>
<p>There's a lot of talk about open source going mainstream—Microsoft's launch of .NET Core in June 2016 confirmed that fact. It redefined the way the development world saw one of the most established tech giants, and appeared to be an admission that the world hadn't been going in the direction they thought it would decades earlier. This book provides developers with a comprehensive look at Microsoft's powerful language and impressive open-source framework, designed to give readers fluency and confidence to build cross-platform applications. At 550 pages, there's just about everything you'd need to know, which means it acts both as a great tutorial and a reliable resource. Open source might mean rapid change and constant iteration, but this book provides readers with a stable and trusted source of knowledge.</p>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335366 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/learningang_sm.png" style="width: 150px; height: 185px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="185" /><b><a href="https://www.packtpub.com/web-development/learning-angular-2" target="_blank">Learning Angular 2 </a><br />
By Pablo Deeleman<br />
352 Pages<br />
Published: May 2016</b></p>
<p>Angular 2 was easily the most anticipated software release of 2016. Google kept the world waiting—it wasn't until May that we properly got to see what the new framework actually looked like. That was when Packt released Learning Angular 2, a no nonsense and fast paced guide to the new features of the framework. Showing readers how to build Angular 2 components, demonstrating how to get to grips with the TypeScript syntax and working with directives and services, the book brings together everything the curious and ambitious web developer needs to get started with this cutting-edge framework.</p>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335371 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/tensorflow_sm.png" style="width: 150px; height: 185px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="185" /><b><a href="https://www.packtpub.com/big-data-and-business-intelligence/getting-started-tensorflow" target="_blank">Getting Started with TensorFlow</a><br />
By Giancarlo Zaccone<br />
180 Pages<br />
Published: July 2016</b></p>
<p>TensorFlow was the surprise hit of 2016. But we probably shouldn't have been so surprised. With machine learning becoming one of the biggest trends across the technology world, the arrival of a tool like TensorFlow, which is so easy—and enjoyable—to use, was inevitable. <i>Getting Started with TensorFlow</i> does exactly what it says on the cover—and it's created specifically for those people that want to get up and running with machine learning as quickly as possible. From basic mathematics to neural networks and deep learning, this book proves that using software in a smart and impactful way doesn't have to be a steep learning curve and doesn't require you to wade through theory.</p>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335376 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/smartiot_sm.png" style="width: 150px; height: 185px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="185" /><b><a href="https://www.packtpub.com/hardware-and-creative/smart-internet-things-projects" target="_blank">Smart Internet of Things Projects</a><br />
By Agus Kurniawan<br />
258 Pages<br />
Published: September 2016</b></p>
<p>The Internet of Things has been a buzzword for a little while now, but this year we've started to see it become more of a reality. And the point, really, is simple—you've just got to build it yourself. The book includes fun real-world projects, from building an automomous remote control car to speech technology, and is a great way to help you get creative.</p>
<p><img alt="bookcover" class="media-image attr__typeof__foaf:Image img__fid__335381 img__view_mode__default attr__format__default attr__field_file_image_alt_text[und][0][value]__bookcover attr__field_file_image_title_text[und][0][value]__bookcover attr__field_file_image_caption[und][0][value]__ attr__field_file_image_caption[und][0][format]__panopoly_wysiwyg_text attr__field_folder[und]__9402" src="https://opensource.com/sites/default/files/reactjs_sm.png" style="width: 150px; height: 185px; float: right;" title="bookcover" typeof="foaf:Image" width="150" height="185" /><b><a href="https://www.packtpub.com/web-development/reactjs-blueprints" target="_blank">ReactJS Blueprints</a><br />
By Sven A. Robbestad<br />
422 Pages<br />
Published: July 2016</b></p>
<p>Angular 2 might have been hotly anticipated in 2016, but React has slowly been taking a hold of the JavaScript imagination for a couple of years now—in 2016, Facebook's impressive library went mainstream. It's also a tool that highlights the nature of the web today: dynamic, fast, and lightweight in our data intensive age. ReactJS Blueprints takes you straight into React, showing readers how to build a complete application with the library. It doesn't just teach—it demonstrates how React works by showing you how to use it yourself.</p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-default-license" >
  
      
  
  <div class="field field-name-field-default-license field-type-text field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:license"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" style="border-width:0" src="/sites/all/themes/opensource/images/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a></div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-tags" >
  
        <h2 class="pane-title">Tags</h2>
    
  
  <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:keywords"><a href="/tags/2016-yearbook">2016 Open Source Yearbook</a>,</div><div class="field-item odd" rel="schema:keywords"><a href="/tags/books">Books</a>,</div><div class="field-item even" rel="schema:keywords"><a href="/tags/yearbook">Yearbook</a></div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__sidebar--bottom">
      <div class="panel-pane pane-views-panes pane-author-info-panel-pane-1" >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-1557718c984d77b4567f5f662c943dd8">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/rikki_small.png?itok=I1h_27jm" width="100" height="100" alt="Rikki Endsley" /></div>
<div class="authorbio__content">
  <span class="authorbio__name">Rikki Endsley</span> - <span class="authorbio__about">Rikki Endsley is a community manager for Opensource.com. In the past, she worked as the community evangelist on the Open Source and Standards (OSAS) team at Red Hat; a freelance tech journalist; community manager for the USENIX Association; associate publisher of Linux Pro Magazine, ADMIN, and Ubuntu User; and as the managing editor of Sys Admin magazine and UnixReview.com. Follow her on Twitter at: <a href="https://twitter.com/rikkiends" target="_blank">@rikkiends</a>.
</span>
  <div class="authorbio__more-link"><a href="/users/rikki-endsley">» More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-article-contributions" >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block" >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__content-below">
      <div class="panel-pane pane-views-panes pane-related-articles-panel-pane-1" >
  
        <h2 class="pane-title">Recommended reading</h2>
    
  
  <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 related-content view-dom-id-537279ae9c5e806a3fe0518f96bdbddd">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/1/yearbook-10-steps-innersource-your-organization"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/business/step-walk-hat-suit-10-yearbook_sm.png?itok=aNfnzs4s" width="288" height="162" alt="10 steps to innersource in your organization in 2017" title="10 steps to innersource in your organization in 2017" /><br />
10 steps to innersource in your organization in 2017</a></span>  </div>  </div>  <div class="views-row views-row-2 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/1/yearbook-50-ways-avoid-getting-hacked"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/business/rh_003601_05_mech_osyearbook2016_security_cc.png?itok=dlS3Sx-d" width="288" height="162" alt="secure your systems" title="secure your systems" /><br />
50 ways to avoid getting hacked in 2017</a></span>  </div>  </div>  <div class="views-row views-row-3 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/1/yearbook-4-hot-skills-linux-pros-2017"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/business/lightbulb-idea-think-yearbook-lead.png?itok=ZbgMnarT" width="288" height="162" alt="4 hot skills for Linux pros in 2017" title="4 hot skills for Linux pros in 2017" /><br />
4 hot skills for Linux pros in 2017</a></span>  </div>  </div>  <div class="views-row views-row-4 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/1/yearbook-7-notable-legal-developments-2016"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/law/law_fingerprint-forensics_yearbook_520.png?itok=cGLp0kmi" width="288" height="162" alt="7 notable legal developments in open source in 2016" title="7 notable legal developments in open source in 2016" /><br />
7 notable legal developments in open source in 2016</a></span>  </div>  </div>  <div class="views-row views-row-5 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/16/12/yearbook-top-programming-trends-2016"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/u23316/climb-top-bridge-yearbook_red.png?itok=XD63l-dT" width="288" height="162" alt="Top programming trends in 2016" title="Top programming trends in 2016" /><br />
Hot programming trends in 2016</a></span>  </div>  </div>  <div class="views-row views-row-6 views-row-even views-row-last">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/16/12/yearbook-top-linux-games-2016"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/u23316/game-dogs-chess-play-lead.png?itok=r_cF8VPI" width="288" height="162" alt="Top Linux Games of 2016" title="Top Linux Games of 2016" /><br />
Top 7 Linux games of 2016</a></span>  </div>  </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-node-comment-form" >
  
        <h2 class="pane-title">Comment now</h2>
    
  
  <form class="comment-form user-info-from-cookie" action="/article/16/12/yearbook-publishers-picks#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div id="edit-login-register" class="form-item form-type-item">
 <a href="/user/login?destination=node/33561">Login or Register</a> to earn points for your comments.
</div>
<div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<input type="hidden" name="form_build_id" value="form-PZxmbRr_53f_vOkssifFkrdUJlcTZvUWRoozsWQ4_g0" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/legal">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><input class="mollom-content-id" type="hidden" name="mollom[contentId]" value="" />
<input class="mollom-captcha-id" type="hidden" name="mollom[captchaId]" value="" />
<div style="display: none;"><div class="form-item form-type-textfield form-item-mollom-homepage">
  <label for="edit-mollom-homepage">Home page </label>
 <input autocomplete="off" type="text" id="edit-mollom-homepage" name="mollom[homepage]" value="" size="60" maxlength="128" class="form-text" />
</div>
</div><div class="description mollom-privacy">By submitting this form, you accept the <a href="https://www.mollom.com/web-service-privacy-policy" class="mollom-target" rel="nofollow">Mollom privacy policy</a>.</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div></div></form>
  
  </div>
    </div>
  
</div><!-- /.os-article -->
                  </div>


        
        
      </div>

        <div class="region region-pre-footer">
    <div id="block-os-common-components-footer-call-to-action" class="block block-os-common-components first last odd">

      
  
<div class="fieldable-panels-pane cta cta--green-on-blue cta--no-link">

  <div class="cta__content cta__content--no-link">
            <h2 class="cta__title">Sign up for Opensource.com news</h2>
<div class="field field-name-field-cta-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><iframe frameborder="0" height="50" id="fkfkx" scrolling="no" src="/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></p>
</div></div></div>  </div>

</div>


</div>
  </div>

        <div class="region region-footer-nav">
    <div id="block-menu-menu-footer" class="block block-menu first odd" role="navigation">

        <h2 class="block__title block-title">Footer</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/legal" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact" class="menu__link">Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="/opensourcecom-team" title="" class="menu__link">Meet the Team</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://opensource.org/" title="" class="menu__link">Visit opensource.org</a></li>
</ul>
</div>
<div id="block-bean-social-media" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/social-media" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><span>Find us:</span> 
</p>
<ul>
<li><a class="footer-twitter" href="https://twitter.com/OpenSourceWay" title="Twitter">Twitter</a></li>
<li><a class="footer-facebook" href="https://www.facebook.com/opensourceway" title="Facebook">Facebook</a></li>
<li><a class="footer-gplus" href="https://plus.google.com/108750398488318674353" title="Google Plus">Google Plus</a></li>
<li><a class="footer-instagram" href="https://www.instagram.com/opensourceway/" title="Instagram">Instagram</a></li>
<li><a class="footer-youtube" href="http://www.youtube.com/opensourceway" title="Youtube">Youtube</a></li>
<li><a class="footer-linkedin" href="https://www.linkedin.com/grps/Open-Source-Professionals-Advocates-2769297" title="LinkedIn">LinkedIn</a></li>
<li><a class="footer-flickr" href="http://www.flickr.com/photos/opensourceway" title="Flickr">Flickr</a></li>
<li><a class="footer-feed" href="https://opensource.com/rss-feeds" title="RSS">RSS</a></li>
</ul>
</div></div></div>  </div>
</div>

</div>
  </div>

        <footer id="footer" class="region region-footer">
    <div id="block-bean-copyrigt-block" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/copyrigt-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>For more discussion on open source and the role of the CIO in the enterprise, join us at <a href="http://enterprisersproject.com">The EnterprisersProject.com</a>.</p>
<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>
<p>Opensource.com aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Shadowman logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div></div></div>  </div>
</div>

</div>
<div id="block-bean-footer-logo" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/footer-logo" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><img src="/sites/all/themes/opensource/images/footer_logo.svg" /></p>
</div></div></div>  </div>
</div>

</div>
  </footer>

    </div>

    
      <div class="region region-os-social">
    <div id="block-os-social-os-social-share" class="block block-os-social first last odd">

      
  <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div>
</div>
  </div>
    <div class="region region-page-bottom">
    <!-- begin Eloqua tracking -->
<script type='text/javascript' language='JavaScript' src='//www.redhat.com/j/elqNow/elqCfg.js'></script>
<script type='text/javascript' language='JavaScript' src='//www.redhat.com/j/elqNow/elqImg.js'></script>
<!-- end Eloqua tracking -->
<!-- begin Adobe Analytics -->
<script type="text/javascript" src="/sites/all/libraries/sitecatalyst/s_code.js?20100731?oifeum"></script>
<script type="text/javascript" language="JavaScript"><!--

s.pageName="opensource||article|publisher's-picks:-top-2016-open-source-books-";
s.server="opensource.com";
s.channel="opensource";
s.prop13="osdc 33561";
s.eVar26="osdc 33561";
s.prop14="";
s.eVar27="";
s.prop61="2017-01-06";
/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
//--></script><script type="text/javascript" src="/sites/all/libraries/sitecatalyst/rh_omni_footer.js"></script>
<script language="JavaScript" type="text/javascript"><!--
if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')
//--></script><noscript><img src="https://smtrcs.redhat.com/b/ss/redhatglobal,redhatopensourcecom/1/H.25--NS/0?[AQB]&amp;amp;amp;cdp=3&amp;amp;amp;[AQE]" height="1" width="1" border="0" alt="" /></noscript><!--/DO NOT REMOVE/-->
<!-- end Adobe Analytics1 --><!-- begin Google Remarketing -->
<img height="1" width="1" style="border-style:none;display:block;" alt=""  src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" onerror="this.src='/sites/all/themes/opensource/images/1x1.png';this.onerror=null" /><!-- end Google Remarketing -->
  </div>
<script src="https://opensource.com/sites/all/modules/contrib/ckeditor/plugins/media/library.js?oifeum"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_widgets/panopoly-widgets.js?oifeum"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_widgets/jquery-ui-tabs-rotate.js?oifeum"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script>var a2a_config = a2a_config || {};
a2a_config.templates = {
    twitter: "Publisher's picks: Top 2016 open source books  http://red.ht/2ilHxLQ via @opensourceway by @rikkiends"
};</script>
</body>
</html>
