<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html class="no-js"  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema# schema: http://schema.org/"><!--<![endif]-->

<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
  <meta charset="utf-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1044.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<link rel="shortcut icon" href="https://opensource.com/sites/all/themes/opensource/favicon.ico" type="image/vnd.microsoft.icon" />
<link href="https://opensource.com/rss.xml" rel="alternate" title="Opensource.com RSS" />
<meta name="description" content="Learn more about App Inventor, a programming framework for building Android applications using a visual blocks language." />
<meta name="rating" content="general" />
<meta name="referrer" content="no-referrer" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://opensource.com/article/17/8/app-inventor-android-app-development" />
<link rel="shortlink" href="https://opensource.com/node/38091" />
<meta name="revisit-after" content="1 day" />
<meta property="og:site_name" content="Opensource.com" />
<meta property="og:url" content="https://opensource.com/article/17/8/app-inventor-android-app-development" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Learn Android development with this drag-and-drop framework" />
<meta property="og:description" content="Learn more about App Inventor, a programming framework for building Android applications using a visual blocks language." />
<meta property="og:image" content="https://opensource.com/sites/default/files/images/life/code_development_programming.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@opensourceway" />
<meta name="twitter:creator" content="@pfooti" />
<meta name="twitter:title" content="Learn Android development with this drag-and-drop framework" />
<meta name="twitter:description" content="Learn more about App Inventor, a programming framework for building Android applications using a visual blocks language." />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/images/life/code_development_programming.png" />
  <title>Learn Android development with this drag-and-drop framework | Opensource.com</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_Rdur8XVJnPlTNehlWLFbY-WXVG0stXacIOxyox8i_wE.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_O3CPEURmXDbUpZiheRCANsQmaK9chqzwlSTTFzUORC4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_-Xesw9LMs4NcvDjFd-j8qkAGDIQRUXkozw3d--q-mX8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_xw7SV6b8URqZ0JDoM4EGZBvqalMiM34TscspPHYE5Rg.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans.css?ou5qk1" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold.css?ou5qk1" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-italic.css?ou5qk1" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold-italic.css?ou5qk1" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_wigS70piKQxAQ-PhuV0Kv5yYuTDEoD4yq0VyEj5L7HY.css" media="all" />
  <script src="https://use.typekit.net/elz3yuz.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  <script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js?v=1.7.2"></script>
<script src="https://opensource.com/misc/jquery.once.js?v=1.2"></script>
<script src="https://opensource.com/misc/drupal.js?ou5qk1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.core.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.widget.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/media.core.js?v=7.x-2.8"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.tabs.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.accordion.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.button.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.mouse.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.draggable.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.position.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.resizable.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.dialog.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/better-autocomplete/jquery.better-autocomplete.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/util/json2.js?v=7.x-2.8"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/util/ba-debug.min.js?v=7.x-2.8"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/external/jquery.cookie.js?v=67fb34f6a866c40d0570"></script>
<script src="https://opensource.com/misc/form.js?v=7.56"></script>
<script src="https://opensource.com/misc/ajax.js?v=7.56"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/js/jquery_update.js?v=0.0.1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/comment_notify/comment_notify.js?ou5qk1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_admin/panopoly-admin.js?ou5qk1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_magic/panopoly-magic.js?ou5qk1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_theme/js/panopoly-accordion.js?ou5qk1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/caption_filter/js/caption-filter.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/loginlogout/loginlogout.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/modules/custom/os_events/os_events.js?ou5qk1"></script>
<script src="//static.addtoany.com/menu/page.js"></script>
<script src="https://opensource.com/sites/all/modules/contrib/pollanon/js/jquery.cookie.min.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/pollanon/js/pollanon.pack.js?ou5qk1"></script>
<script src="https://opensource.com/misc/progress.js?v=7.56"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/ctools/js/ajax-responder.js?ou5qk1"></script>
<script src="https://opensource.com/misc/collapse.js?v=7.56"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/js/linkit.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/js/linkit.dialog.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/editors/ckeditor/linkitDialog.js?v=7.2"></script>
<script src="https://opensource.com/misc/textarea.js?v=7.56"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/media.popups.js?v=7.x-2.8"></script>
<script src="https://opensource.com/modules/filter/filter.js?ou5qk1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/modules/media_wysiwyg/js/media_wysiwyg.filter.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/mollom/mollom.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/rate/rate.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/google_analytics/googleanalytics.js?ou5qk1"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-33294138-1", {"cookieDomain":".opensource.com"});ga("send", "pageview");</script>
<script src="https://opensource.com/sites/all/libraries/superfish/jquery.hoverIntent.minified.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/sftouchscreen.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/supposition.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/superfish.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/supersubs.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/superfish/superfish.js?ou5qk1"></script>
<script src="https://opensource.com/sites/all/themes/opensource/js/script.js?ou5qk1"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-38091 node-type-article region-content section-article page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<header class="header" id="header" role="banner">

    
    <div class="header-banner">
      <div class="header-banner__inner">
                  <div class="header__name-and-slogan" id="name-and-slogan">
                          <div class="header__site-name" id="site-name">
                <a href="/" title="Home" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/logo.svg" onerror="this.src='/sites/all/themes/opensource/logo.png';this.onerror=null;" /></a>
                <a href="http://www.redhat.com/en?intcmp=701600000011l7VAAQ" title="Home" class="header__sponsor-link" rel="home"><img alt="RedHat" src="/sites/all/themes/opensource/images/redhat-logo.svg" onerror="this.src='/sites/all/themes/opensource/images/redhat-logo.png';this.onerror=null;"/></a>
              </div>
            
                      </div>
                <nav class="desktop-user-links">
            <div class="header__region region region-header">
    <div id="block-menu-block-1" class="block block-menu-block first last odd" role="navigation">

      
  <div class="menu-block-wrapper menu-block-1 menu-name-user-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-195"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1179"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul></div>

</div>
  </div>
        </nav>
      </div>
    </div>

    <div class="sf-nav">
      <div class="sf-nav__inner">
          <div class="js-mobile-header-buttons region region-navigation-top">
    <div id="block-os-solr-search-form" class="block block-os-solr-search first odd">

      
  <form action="/article/17/8/app-inventor-android-app-development" method="post" id="os-search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search">
  <label class="element-invisible" for="edit-search">Search </label>
 <input title="Enter the terms you wish to search for." placeholder="Search opensource.com" type="text" id="edit-search" name="search" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="GO" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-ZoFglwacjUQhuZPZLKonXEJAu-7ALOzllGqxLD04X38" />
<input type="hidden" name="form_id" value="os_search_block_form" />
</div>
</div></form>
</div>
<div id="block-superfish-1" class="block block-superfish even">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-default sf-total-items-5 sf-parent-items-5 sf-single-items-0"><li id="menu-1906-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-8 sf-parent-children-4 sf-single-children-4 menuparent"><a href="/" title="" class="sf-depth-1 menuparent">Articles</a><ul><li id="menu-12341-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/containers" title="" class="sf-depth-2">Containers</a></li><li id="menu-12346-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/gaming" title="" class="sf-depth-2">Gaming</a></li><li id="menu-12351-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/hardware" title="" class="sf-depth-2 menuparent">Hardware</a><ul><li id="menu-12376-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/3d-printing" title="" class="sf-depth-3">3D printing</a></li><li id="menu-12386-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/arduino" title="" class="sf-depth-3">Arduino</a></li><li id="menu-12381-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/raspberry-pi" title="" class="sf-depth-3">Raspberry Pi</a></li></ul></li><li id="menu-1946-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/tags/law" title="" class="sf-depth-2 menuparent">Law</a><ul><li id="menu-12391-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/licensing" title="" class="sf-depth-3">Licensing</a></li><li id="menu-12396-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/patents" title="" class="sf-depth-3">Patents</a></li></ul></li><li id="menu-12356-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/tags/linux" title="" class="sf-depth-2">Linux</a></li><li id="menu-12361-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/tags/openstack" title="" class="sf-depth-2">OpenStack</a></li><li id="menu-12366-1" class="middle odd sf-item-7 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/programming" title="" class="sf-depth-2 menuparent">Programming</a><ul><li id="menu-12411-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/javascript" title="" class="sf-depth-3">JavaScript</a></li><li id="menu-12401-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/perl" title="" class="sf-depth-3">Perl</a></li><li id="menu-12406-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/python" title="" class="sf-depth-3">Python</a></li></ul></li><li id="menu-12371-1" class="last even sf-item-8 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/tags/sysadmin" title="" class="sf-depth-2 menuparent">SysAdmin</a><ul><li id="menu-12416-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/devops" title="" class="sf-depth-3">DevOps</a></li></ul></li></ul></li><li id="menu-1921-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-8 sf-parent-children-2 sf-single-children-6 menuparent"><a href="/resources" title="" class="sf-depth-1 menuparent">Resources</a><ul><li id="menu-2016-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/resources/projects-and-applications" title="" class="sf-depth-2">Projects and applications</a></li><li id="menu-2026-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/conferences-and-events-monthly" title="" class="sf-depth-2">Conferences and events</a></li><li id="menu-2021-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/resources/organizations" title="" class="sf-depth-2">Organizations</a></li><li id="menu-5556-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-9 sf-parent-children-0 sf-single-children-9 menuparent"><a href="/resources/cloud" title="" class="sf-depth-2 menuparent">The open source cloud</a><ul><li id="menu-5576-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/resources/big-data" title="" class="sf-depth-3">Big data</a></li><li id="menu-5566-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/what-docker" title="" class="sf-depth-3">Docker</a></li><li id="menu-5591-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/resources/internet-of-things" title="" class="sf-depth-3">Internet of things</a></li><li id="menu-5596-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/resources/what-is-kubernetes" title="" class="sf-depth-3">Kubernetes</a></li><li id="menu-5571-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/what-are-linux-containers" title="" class="sf-depth-3">Linux containers</a></li><li id="menu-5586-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/resources/what-are-microservices" title="" class="sf-depth-3">Microservices</a></li><li id="menu-5561-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/resources/what-is-openstack" title="" class="sf-depth-3">OpenStack</a></li><li id="menu-5581-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/resources/what-is-software-defined-networking" title="" class="sf-depth-3">Software defined networking</a></li><li id="menu-12601-1" class="last odd sf-item-9 sf-depth-3 sf-no-children"><a href="/resources/virtualization" title="" class="sf-depth-3">Virtualization</a></li></ul></li><li id="menu-2036-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-11 sf-parent-children-0 sf-single-children-11 menuparent"><a href="/alternatives" title="" class="sf-depth-2 menuparent">Open source alternatives</a><ul><li id="menu-4646-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/alternatives/adobe-acrobat" class="sf-depth-3">Alternatives to Acrobat</a></li><li id="menu-4656-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/alternatives/autocad" class="sf-depth-3">Alternatives to AutoCAD</a></li><li id="menu-4636-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/alternatives/dreamweaver" class="sf-depth-3">Alternatives to Dreamweaver</a></li><li id="menu-5506-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/alternatives/gmail" class="sf-depth-3">Alternatives to Gmail</a></li><li id="menu-5551-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/alternatives/matlab" class="sf-depth-3">Alternatives to MATLAB</a></li><li id="menu-5501-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/alternatives/minecraft" class="sf-depth-3">Alternatives to Minecraft</a></li><li id="menu-4651-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/alternatives/picasa" class="sf-depth-3">Alternatives to Picasa</a></li><li id="menu-4661-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/alternatives/microsoft-publisher" class="sf-depth-3">Alternatives to Publisher</a></li><li id="menu-5511-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/alternatives/slack" class="sf-depth-3">Alternatives to Slack</a></li><li id="menu-4641-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/alternatives/trello" class="sf-depth-3">Alternatives to Trello</a></li><li id="menu-5546-1" class="last odd sf-item-11 sf-depth-3 sf-no-children"><a href="/alternatives" title="" class="sf-depth-3">More...</a></li></ul></li><li id="menu-2011-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/ebooks" title="" class="sf-depth-2">eBooks</a></li><li id="menu-15046-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/irc-cheat-sheet" title="" class="sf-depth-2">IRC Cheat Sheet</a></li><li id="menu-12466-1" class="last even sf-item-8 sf-depth-2 sf-no-children"><a href="/yearbook/2016" title="" class="sf-depth-2">Open Source Yearbook</a></li></ul></li><li id="menu-4691-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/about" class="sf-depth-1 menuparent">About</a><ul><li id="menu-1991-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-source-way" class="sf-depth-2">The Open Source Way</a></li><li id="menu-1971-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/opensourcecom-team" class="sf-depth-2">Meet the team</a></li><li id="menu-2006-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/press-kit" class="sf-depth-2">Press kit</a></li><li id="menu-2001-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/contact" title="" class="sf-depth-2">Contact</a></li></ul></li><li id="menu-12511-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-6 sf-parent-children-2 sf-single-children-4 menuparent"><a href="/tags/opensourcecom-community" title="" class="sf-depth-1 menuparent">Community</a><ul><li id="menu-12516-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/participate" class="sf-depth-2 menuparent">Join the community</a><ul><li id="menu-12521-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/user/register" title="" class="sf-depth-3">Register</a></li><li id="menu-12526-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/rules-comments-and-discussions" title="" class="sf-depth-3">Rules for comments and discussions</a></li><li id="menu-12531-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/community-moderator-program" title="" class="sf-depth-3">Community Moderator program</a></li><li id="menu-12541-1" class="last even sf-item-4 sf-depth-3 sf-no-children"><a href="/points-and-badges" title="" class="sf-depth-3">Points and badges</a></li></ul></li><li id="menu-12546-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/editorial-calendar" title="" class="sf-depth-2">Editorial calendar</a></li><li id="menu-12551-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/how-submit-article" class="sf-depth-2">Submit your story</a></li><li id="menu-12556-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/writer-testimonials" title="" class="sf-depth-2">Writer testimonials</a></li><li id="menu-1966-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/writers" class="sf-depth-2 menuparent">Guides for writers</a><ul><li id="menu-2041-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/submission-style-guide" class="sf-depth-3">Article submission and style guide</a></li><li id="menu-4616-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/promoting-articles" class="sf-depth-3">Tips for promoting your Opensource.com article</a></li><li id="menu-12586-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/community/16/8/editorial-writing-topics" title="" class="sf-depth-3">Writing topics</a></li></ul></li><li id="menu-12581-1" class="last even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/contributor-club" title="" class="sf-depth-2">Contributor Club</a></li></ul></li><li id="menu-2136-1" class="last odd sf-item-5 sf-depth-1 sf-total-children-5 sf-parent-children-3 sf-single-children-2 menuparent"><a href="/open-organization" title="" class="sf-depth-1 menuparent">The Open Org</a><ul><li id="menu-12471-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="sf-depth-2">What is an open organization?</a></li><li id="menu-15056-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-maturity-model" title="" class="sf-depth-2">How open is your organization?</a></li><li id="menu-15051-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/open-organization/resources/book-series" title="" class="sf-depth-2 menuparent">Book series</a><ul><li id="menu-12606-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/culture-change" class="sf-depth-3">Guide to IT Culture Change download</a></li><li id="menu-12456-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/leaders-manual" title="Download the Open Organization Leaders Manual" class="sf-depth-3">Leaders Manual download</a></li><li id="menu-4631-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/catalyst-in-chief" class="sf-depth-3">Catalyst in Chief download</a></li><li id="menu-3206-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/field-guide" class="sf-depth-3">Field guide download</a></li><li id="menu-2271-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/chapter1" title="" class="sf-depth-3">Chapter download</a></li></ul></li><li id="menu-2146-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-7 sf-parent-children-0 sf-single-children-7 menuparent"><a href="/open-organization/resources" title="" class="sf-depth-2 menuparent">Resources</a><ul><li id="menu-2181-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/what-open-organization" title="" class="sf-depth-3">What is The Open Organization?</a></li><li id="menu-12421-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-decision-framework" title="" class="sf-depth-3">What is the Open Decision Framework?</a></li><li id="menu-2151-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/guides" title="" class="sf-depth-3">Discussion guide download</a></li><li id="menu-2246-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/faq" title="" class="sf-depth-3">Open Org FAQs</a></li><li id="menu-4606-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/twitter-chats" title="" class="sf-depth-3">Twitter chats</a></li><li id="menu-3201-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/reading-list" title="" class="sf-depth-3">Reading list</a></li><li id="menu-2256-1" class="last odd sf-item-7 sf-depth-3 sf-no-children"><a href="/open-organization/resources/2015-book-club" title="" class="sf-depth-3">Book club</a></li></ul></li><li id="menu-3166-1" class="last odd sf-item-5 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/open-organization/resources/ambassadors-program" title="" class="sf-depth-2 menuparent">Ambassadors program</a><ul><li id="menu-2691-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/meet-ambassadors" title="" class="sf-depth-3">Meet the ambassadors</a></li></ul></li></ul></li></ul>
</div>
<div id="block-system-user-menu" class="block block-system block-menu odd" role="navigation">

      
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul>
</div>
<div id="block-menu-block-2" class="block block-menu-block last even" role="navigation">

      
  <div class="menu-block-wrapper menu-block-2 menu-name-menu-social-links parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-13171"><a href="http://twitter.com/opensourceway" title="twitter" class="menu__link">Twitter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-13176"><a href="https://www.facebook.com/opensourceway" title="facebook" class="menu__link">Facebook</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-13166"><a href="/feed" title="feed" class="menu__link">Feed</a></li>
</ul></div>

</div>
  </div>

        <div class="mobile--menu-region">
            <div class="region region-navigation">
    <div id="block-system-main-menu" class="block block-system block-menu first last odd" role="navigation">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/" title="" class="menu__link">Articles</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/containers" title="" class="menu__link">Containers</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/gaming" title="" class="menu__link">Gaming</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/hardware" title="" class="menu__link">Hardware</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/3d-printing" title="" class="menu__link">3D printing</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/arduino" title="" class="menu__link">Arduino</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/raspberry-pi" title="" class="menu__link">Raspberry Pi</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/law" title="" class="menu__link">Law</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/linux" title="" class="menu__link">Linux</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/openstack" title="" class="menu__link">OpenStack</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/programming" title="" class="menu__link">Programming</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/javascript" title="" class="menu__link">JavaScript</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/perl" title="" class="menu__link">Perl</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/python" title="" class="menu__link">Python</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded"><a href="/tags/sysadmin" title="" class="menu__link">SysAdmin</a><ul class="menu"><li class="menu__item is-leaf first last leaf"><a href="/tags/devops" title="" class="menu__link">DevOps</a></li>
</ul></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/projects-and-applications" title="" class="menu__link">Projects and applications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/conferences-and-events-monthly" title="" class="menu__link">Conferences and events</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/organizations" title="" class="menu__link">Organizations</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/resources/cloud" title="" class="menu__link">The open source cloud</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/alternatives" title="" class="menu__link">Open source alternatives</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/ebooks" title="" class="menu__link">eBooks</a></li>
<li class="menu__item is-leaf leaf"><a href="/irc-cheat-sheet" title="" class="menu__link">IRC Cheat Sheet</a></li>
<li class="menu__item is-leaf last leaf"><a href="/yearbook/2016" title="" class="menu__link">Open Source Yearbook</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/about" class="menu__link">About</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/opensourcecom-community" title="" class="menu__link">Community</a></li>
<li class="menu__item is-expanded last expanded"><a href="/open-organization" title="" class="menu__link">The Open Org</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="menu__link">What is an open organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-org-maturity-model" title="" class="menu__link">How open is your organization?</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/open-organization/resources/book-series" title="" class="menu__link">Book series</a></li>
<li class="menu__item is-expanded expanded"><a href="/open-organization/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/what-open-organization" title="" class="menu__link">What is The Open Organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-decision-framework" title="" class="menu__link">What is the Open Decision Framework?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/guides" title="" class="menu__link">Discussion guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/faq" title="" class="menu__link">Open Org FAQs</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/twitter-chats" title="" class="menu__link">Twitter chats</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/reading-list" title="" class="menu__link">Reading list</a></li>
<li class="menu__item is-leaf last leaf"><a href="/open-organization/resources/2015-book-club" title="" class="menu__link">Book club</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/open-organization/resources/ambassadors-program" title="" class="menu__link">Ambassadors program</a></li>
</ul></li>
</ul>
</div>
  </div>
        </div>
      </div>
    </div>

</header>

<div id="page">

      <div id="main">
        <div class="pre-content">
                                                </div>
        <div id="content" class="column" role="main">
                              <a id="main-content"></a>
                                <h1 class="page__title title" id="page-title">Learn Android development with this drag-and-drop framework</h1>
                              



<div class="panel-display os-article clearfix os-article--with-image " id="article-template">

      <div class="os-article__top">
      <div class="os-article__top-inner">
        <div class="panel-pane pane-node-title" >
  
      
  
  <h1>Learn Android development with this drag-and-drop framework</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-article-subhead" >
  
      
  
  <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden">
    <div class="field-items">
          <h2>App Inventor is programming framework for building Android applications using a visual blocks language.</h2>
      </div>
</div>

  
  </div>
<div class="panel-pane pane-os-article-byline" >
  
      
  
  <div class="byline"><span class="byline__thumbnail"><a href="/users/eric-eslinger"><img class="byline-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/byline_thumbnail/public/pictures/img_20170721_194240.jpg?itok=-Dc5hDp-" width="50" height="50" alt="Blue-haired Eric next to a slate shingle with a cow and the word &quot;welcome&quot; painted upon it." title="Eric Eslinger" /></a></span>
<span class="byline__date">04 Aug 2017</span>
<span class="byline__author"><a href="/users/eric-eslinger" title="View user profile." class="username" xml:lang="" about="/users/eric-eslinger" typeof="sioc:UserAccount" property="foaf:name" datatype="">Eric Eslinger</a>&nbsp;<span class="byline__feed"><a href="/user/161656/feed">Feed</a></span>
</span>
<span class="byline__social"><span class="byline__voting-widget"><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-08c28c898b81ea57447c1b8d25ba246a rate-node-38091-1-1" id="rate-node-38091-1-1"><div class="rate-info">2</div><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/17/8/app-inventor-android-app-development?rate=pXOy1Ba4c6Y9N_z6P7EHFCRn2LiqC2-Z6kEe3nN01cY" title="up">up</a></div></span>
</span>
<span class="byline__comment-count"><a href="#comments">1 comment</a></span>
</div>
  
  </div>
      </div>
    </div>
  
      <div class="os-article__image">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image" >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/image-full-size/public/images/life/code_development_programming.png?itok=eYK4UXiq"><img class="image-full-size" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/image-full-size/public/images/life/code_development_programming.png?itok=eYK4UXiq" width="520" height="292" alt="Learn Android development with this drag-and-drop framework" title="Learn Android development with this drag-and-drop framework" /></div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-file-field-file-image-caption" >
  
      
  
  <div class="field field-name-field-file-image-caption field-type-text-long field-label-inline clearfix"><div class="field-label">Image by :&nbsp;</div><div class="field-items"><div class="field-item even"><p>opensource.com</p>
</div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__middle">
      <div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:articleBody content:encoded"><p>When I started doing classroom-based research involving computers in the late 1990s, the first thing I had to do was bring some computers into a classroom. My adviser had gotten a grant for six first-generation Bondi Blue iMacs to be installed at the middle school where we doing our research. As soon as we entered the school carrying those inviting gumdrop-shaped machines, my worries about finding participants evaporated.</p>
<p>Computers anywhere, especially in middle school classrooms, were still relatively uncommon back then, and we were able to parlay their novelty into direct engagement with our educational intervention.</p>
<p><div class="embedded-callout-text callout-float-right">App Inventor makes it possible to quickly and easily dive into building mobile applications for phones and tablets.</div></p>
<p>Nowadays, computers are far more prevalent, and students routinely carry mobile devices with far more computing power than those first-generation iMacs. While there is still a subset of students (adult and youth) who are interested enough in computer science that they'll sit in front of whatever device is available, the novelty and engagement of working on a computer are not enough to pull in kids that might otherwise pass by.</p>
<p>It's still possible to grab students with engaging device-based education, but now you need to use the mobile devices that your learners use all the time. This is where App Inventor shines.</p>
<h2>A mobile programming framework</h2>
<p><a href="http://appinventor.mit.edu/explore/" target="_blank">App Inventor</a> is a programming framework for building Android applications using a visual blocks language (similar to <a href="https://scratch.mit.edu/" target="_blank">Scratch</a> or <a href="http://snap.berkeley.edu/" target="_blank">Snap</a>). It was first prototyped by Hal Abelson and Mark Friedman while Hal was on sabbatical from MIT at Google, and it has since evolved from its original roots as a Java-based frontend to the USB debugger to a web-based one using the Blockly library.</p>
<p>App Inventor makes it possible to quickly and easily dive into building mobile applications for phones and tablets.</p>
<p>In the canonical introductory exercise, learners build a simple soundboard application—tap the picture of a cat and the phone plays a "meow" sound. After building the framework, learners can replace the sound with whatever they would like, add extra buttons, and build a custom soundboard with whatever amusing sound effects they desire. As soon as their first app is built, learners tend to immediately show off their work to their peers (especially ones that aren't yet working on an App Inventor project), playing whatever humorous sounds they recorded.</p>
<p>It's that phenomenon, where novice programmers immediately show off what they've built—a legitimate standalone application that can run on any Android device—that makes App Inventor such a compelling platform for teaching computer programming today. There may come a day when hand-built mobile applications go the way of the early iMac hockey puck mouse, but that day has not yet come.</p>
<h2>Event-driven approach</h2>
<p>App Inventor encourages learners to take an event-driven approach to thinking about their program. This model is very useful for modern programming (consider how much work is done by modern programs inside an event dispatch loop). By skipping over the notion of a <b>main()</b> that executes to completion, we can dive directly into asking questions like "what should happen when the user presses this button?" This can be a very natural way to teach programming concepts, especially with a project-based approach.</p>
<p>The App Inventor environment has two major parts, client and server, both of which are <a href="https://github.com/mit-cml/appinventor-sources" target="_blank">open source</a>, under the Apache 2.0 license.</p>
<p>While you can run your own instance (especially cool if you want to build custom blocks that extend the language in some way), most users use the free instance running at <a href="http://appinventor.mit.edu/explore/" target="_blank">appinventor.mit.edu</a>. The web client is built around the <a href="https://developers.google.com/blockly/" target="_blank">Blockly</a> library, another open source project that originated at Google. Blockly is designed as a kind of meta-language, a framework for building blocks-based programming languages for the web. I frequently use the <a href="https://blockly-games.appspot.com/maze" target="_blank">Maze</a> Blockly puzzle as the first introduction to blocks-based programming and thinking like a programmer, but Blockly can also be used to generate <a href="https://blockly-demo.appspot.com/static/demos/generator/index.html" target="_blank">JavaScript code</a> as well.</p>
</p>
<div class="media media-element-container media-default media-wysiwyg-align-center">
<div id="file-365581" class="file file-image file-image-png">
<h2 class="element-invisible"><a href="/file/365581">ai1.png</a></h2>
<div class="content">
    <img alt="Example of the Maze Blockly puzzle" title="Example of the Maze Blockly puzzle" class="media-element file-default" data-delta="1" typeof="foaf:Image" src="https://opensource.com/sites/default/files/u128651/ai1.png" width="800" height="443" /><br />
<div class="field field-name-field-file-image-caption field-type-text-long field-label-hidden">
<div class="field-items">
<div class="field-item even"></div>
</div>
</div>
</div>
</div>
</div>
<p>On the server end of things, App Inventor is a big Java server built to run in a Google App Engine container. The server handles mundane things like storing people's work, login credentials, and so on, as well as the more exciting and interesting compilation process by which users' blocks representations are converted to Android Package Kit (<a href="https://en.wikipedia.org/wiki/Android_application_package" target="_blank">APK</a>) files that can be downloaded and run.</p>
<p>In addition to the programming interface, users need to have an execution context. The simplest option is installing a <a href="https://play.google.com/store/apps/details?id=edu.mit.appinventor.aicompanion3" target="_blank">special companion app</a> on their Android devices. The companion app can be paired with their App Inventor session and will provide a live-updating instance of their work. In practice, I have found some school WiFi environments can't support this, as it requires peer network connections between the users' computers and devices). In those situations, either a USB debugger connection can be used between the phone and computer or an emulator can be run on the computer itself. If there is a shortage of usable devices, having students work on the emulator first makes sense, and then they can take turns uploading their applications to the phone. Students can also work by exporting their code as an APK and installing it directly on a device (provided third-party, unsigned apps are allowed on the phone), but that workflow is slow. That's why it's better to use live updating, especially for the companion app, as the USB connection can be quite tricky to establish (sometimes requiring the installation of drivers and always requiring the installation of the Android Debug Bridge).</p>
<h2>Putting App Inventor into practice</h2>
</p>
<div class="media media-element-container media-default media-wysiwyg-align-center">
<div id="file-365586" class="file file-image file-image-png">
<h2 class="element-invisible"><a href="/file/365586">ai2.png</a></h2>
<div class="content">
    <img alt="Starting to program the &quot;Appy Bird&quot; app" title="Starting to program the &quot;Appy Bird&quot; app" class="media-element file-default" data-delta="2" typeof="foaf:Image" src="https://opensource.com/sites/default/files/u128651/ai2.png" width="800" height="537" /><br />
<div class="field field-name-field-file-image-caption field-type-text-long field-label-hidden">
<div class="field-items">
<div class="field-item even"></div>
</div>
</div>
</div>
</div>
</div>
<p>The design environment allows the user to build screens out of interface widgets such as buttons, input fields, and canvases (which can contain movable sprites or be painted to directly). The design environment also allows the activation of phone-specific inputs, such as orientation/shake sensing, the camera, and even Ajax requests to remote APIs.</p>
<p>The programming environment, as mentioned above, is largely event-driven. A block of code is triggered when <em>something</em> happens, often a tap or a clock tick every N milliseconds. The block can contain standard imperative language constructs (loops and branches) and can set an app-global variable state. It is also possible to define functions with local parameters and return values (or ones that manipulate global state, which is a common novice approach with straightforward applications).</p>
</p>
<div class="media media-element-container media-default media-wysiwyg-align-center">
<div id="file-365591" class="file file-image file-image-png">
<h2 class="element-invisible"><a href="/file/365591">ai3.png</a></h2>
<div class="content">
    <img alt="Programming the pig's movements" title="Programming the pig's movements" class="media-element file-default" data-delta="3" typeof="foaf:Image" src="https://opensource.com/sites/default/files/u128651/ai3.png" width="800" height="277" /><br />
<div class="field field-name-field-file-image-caption field-type-text-long field-label-hidden">
<div class="field-items">
<div class="field-item even"></div>
</div>
</div>
</div>
</div>
</div>
</p>
<div class="media media-element-container media-default media-wysiwyg-align-center">
<div id="file-365596" class="file file-image file-image-png">
<h2 class="element-invisible"><a href="/file/365596">ai4.png</a></h2>
<div class="content">
    <img alt="Setting the global failspeed" title="Setting the global failspeed" class="media-element file-default" data-delta="4" typeof="foaf:Image" src="https://opensource.com/sites/default/files/u128651/ai4.png" width="670" height="278" /><br />
<div class="field field-name-field-file-image-caption field-type-text-long field-label-hidden">
<div class="field-items">
<div class="field-item even"></div>
</div>
</div>
</div>
</div>
</div>
<p>This, for example, is the animation routine for a Flappy Bird clone called "Appy Bird"—the sprite moves every clock tick. Also, on the clock tick, the sprite's velocity is reduced by a constant amount (simulating acceleration downwards), and on a screen tap, the velocity is set to an upward (positive) constant value. By adjusting the game's tick rate and acceleration, it is possible to fine tune for the most satisfying gameplay feel.</p>
<p>The Appy Bird game is a bit complicated when introducing App Inventor, but it's well within the reach of someone who has a bit more experience (or wants to continue building games after a week or so of introductory work).</p>
</p>
<div class="media media-element-container media-default media-wysiwyg-align-center">
<div id="file-365601" class="file file-image file-image-gif">
<h2 class="element-invisible"><a href="/file/365601">ai5.gif</a></h2>
<div class="content">
    <img alt="Playing the Appy Bird game" title="Playing the Appy Bird game" class="media-element file-default" data-delta="5" typeof="foaf:Image" src="https://opensource.com/sites/default/files/u128651/ai5.gif" width="288" height="512" /><br />
<div class="field field-name-field-file-image-caption field-type-text-long field-label-hidden">
<div class="field-items">
<div class="field-item even"></div>
</div>
</div>
</div>
</div>
</div>
<p>While it is (or perhaps <em>was</em> three years ago when Flappy Bird was in the pop culture zeitgeist) fun to build an interactive flying pig game, App Inventor provides a handle on many other features that are unique to mobile devices. For example, your students may enjoy building something that responds to the tilt orientation of the device (perhaps moving a marble sprite around a maze by tilting), records the G forces the phone is experiencing (and graphs it by <a href="http://ai2.appinventor.mit.edu/reference/components/animation.html#Canvas" target="_blank">direct-drawing to a canvas</a>), or interacts with the phone's SMS system to auto-reply to all incoming texts with, "Sorry, I'm driving right now, but I'll get back to you later," whenever the phone is traveling above a certain velocity (as computed by its GPS).</p>
<p>One of my students built a tool that allowed students to take geotagged pictures of murals in their neighborhood to upload to a Google <a href="https://support.google.com/fusiontables/answer/2571232" target="_blank">Fusion Table</a> (which then displayed the murals on a map overlay for the class and school to see). The direct-draw canvas (where students learn the strange coordinate system of computer displays) can be quite compelling to math students. A common challenge I give is: "draw a square wherever the user taps," extended to "let the user pick a number N, and then draw regular N-gons where they tap," culminating in "use the application storage system to remember the drawing the user made so they can reload and edit it later." (Note that the app storage erases when the application is run in debug mode, so direct-loading an APK is needed to really test this feature).</p>
<h2>3 tips for teaching App Inventor</h2>
<p>There are a number of good resources about using App Inventor to teach programming concepts, such as David Wolber's book <i><a href="http://www.appinventor.org/book2" target="_blank">App Inventor 2: Create Your Own Android Apps</a></i> and the material at <a href="http://appinventor.mit.edu/explore/" target="_blank">appinventor.mit.edu</a>.</p>
<p>In addition, I've discovered a few principles you can use with any App Inventor lessons, whether you're teaching younger kids or adult learners. These principles derive from a model of project-based inquiry learning, which is used in math and science education in grades six through 12 (which, naturally, is aligned with the research I was doing in the late 1990s with those iMacs).</p>
<h3>1. Engage your learners with a simple project that encapsulates some programming concept, but don't explicitly teach the concept first.</h3>
<p>It is common in teaching to lecture about an idea first, and then provide a lab or problem set that exemplifies that concept. I prefer inverting this relationship; as the teacher, I know that my students are ready to learn about <b>if/then/else</b> constructs, but I don't need to start the class in front of the whiteboard explaining them. Instead, I can leverage a strength of a blocks-based language: Syntax errors are very difficult to create and blocks tend to be self-documenting. If I create a simple challenge that requires a language construct, I can usually let students figure out how those constructs work in the service of solving the challenge. As a specific example, after they do the simple cat soundboard exercise described above, I challenge my students to make the cat stop meowing after the button has been pressed five times. There are a number of ways to accomplish this, but all require tracking some kind of state and making a decision based on that state. Afterward, I will do a brief lecture that synthesizes what they did and then return to a new challenge: After the silent cat has been tapped an additional five times, it should say, "stop it." Ultimately, this program does not differ much from a <a href="https://en.wikipedia.org/wiki/Fizz_buzz" target="_blank">FizzBuzz</a> assignment (except that it does not use modular arithmetic), but it is far more engaging.</p>
<p>This single and simple principle for teaching using App Inventor is extraordinarily powerful and important. While many people in computer science learned well in the lecture-then-demonstrate environment that pervades education, orders of magnitude more people did not respond well to that teaching style. In general, a lecture is more useful when the listeners know enough about the topic that it makes sense to them immediately—that is, they see the utility while you are talking about it.</p>
<h3>2. Allow your students a chance to be smart in different ways.</h3>
<p>Some people want to learn to program because they want to make games, or tell stories, or build clever interactions. If you structure assignments in a way that affords creative expression, you will be constantly surprised with what your students build. In practice, this primarily means making sure that the underlying projects you select are extendible in many directions. The soundboard could easily evolve into a multi-button synthesizer panel, it could embody a game of remember-the-sequence, or it could just have a lot of really clever sounds and funny images. If you give your students different ideas about what they could build and then give them time to build interesting things, they will not only stretch their own understanding, they will usually run up against the next important concept in your progression (such as in the soundboard lesson sequence, either looping or functional decomposition, depending on which features the students elaborate on).</p>
<h3>3. Encourage small group work.</h3>
<p>This aligns with the first two points: If you allow for a rich set of project-based learning experiences, your students will work and learn better together in groups, especially groups that are heterogeneously mixed by ability and interest. It is important to keep a close eye on how your groups are functioning and encourage frequent role switching (e.g., who is driving the keyboard, who is asking questions and monitoring progress, who is designing interactions).</p>
<p>If you apply these three principles to teaching App Inventor (or really, any kind of programming education), your students are likely to be more actively engaged with the lessons and constantly surprising you with how much they can build with relatively few language constructs.</p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-tags" >
  
        <h2 class="pane-title">Topics</h2>
    
  
  <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:keywords"><a href="/tags/education" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Education</a></div><div class="field-item odd" rel="schema:keywords"><a href="/tags/web-development" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Web development</a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-author-info-panel-pane-1" >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-6dd4b005cc2a63db826aa0f0072b371c">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><a href="/users/eric-eslinger"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/pictures/img_20170721_194240.jpg?itok=okTZadxi" width="100" height="100" alt="Blue-haired Eric next to a slate shingle with a cow and the word &quot;welcome&quot; painted upon it." /></a></div>
<div class="authorbio__content">
  <span class="authorbio__name">Eric Eslinger</span> - <span class="authorbio__about">I am a technologist, educator, intersectional feminist, and optimist.
 
I've spent time as a professor, researching how kids learn science by inquiry and as a software engineer, building tools to help kids learn by inquiry (and tools to help carry out research in those classrooms). Most recently, I've been working in educational technology, teaching teachers how to use tech in their classroom, and building online collaborative spaces for those teachers.
</span>
  <div class="authorbio__more-link"><a href="/users/eric-eslinger">More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-article-contributions" >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block" >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__bottom">
      <div class="panel-pane pane-views-panes pane-related-articles-panel-pane-1" >
  
        <h2 class="pane-title">Recommended reading</h2>
    
  
  <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 related-content view-dom-id-626ecc2f406f30a85eaf0e0588595c25">
        
  
  
      <div id="related-content-footer" class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/8/raspberry-pi-teachers"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/education/edu_raspberry-pi-classroom_lead.png?itok=0MyPdw1n" width="314" height="177" alt="5 ways to use Raspberry Pi in the classroom" title="5 ways to use Raspberry Pi in the classroom" /><br />
5 ways to use Raspberry Pi in the classroom</a></span>  </div>  </div>  <div class="views-row views-row-2 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/8/teach-kid-code-change-life"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/OSDC_women_computing_2.png?itok=vC3w2hKa" width="315" height="177" alt="How to get the next generation coding early" title="How to get the next generation coding early" /><br />
How to get the next generation coding early</a></span>  </div>  </div>  <div class="views-row views-row-3 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/7/college-alternatives"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/education/OSDC_Education_OpenAccess_520x292_12268077_0614MM.png?itok=wTAMY45z" width="315" height="177" alt="How open courses are slashing the cost of higher education" title="How open courses are slashing the cost of higher education" /><br />
How open courses are slashing the cost of higher education</a></span>  </div>  </div>  <div class="views-row views-row-4 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/7/save-planet-board-game"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/dice_tabletop_board_gaming_game.jpg?itok=4-vMGf5W" width="315" height="177" alt="How an open source board game is saving the planet" title="How an open source board game is saving the planet" /><br />
How an open source board game is saving the planet</a></span>  </div>  </div>  <div class="views-row views-row-5 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/7/open-school-leadership"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/education/rh_003588_01_rd3os.combacktoschoolseriesk12_rh_011x_0.png?itok=sZGloVpL" width="315" height="177" alt="Three leadership ideas for an open school culture" title="Three leadership ideas for an open school culture" /><br />
These 3 practices revolutionized Penn Manor&#039;s school culture</a></span>  </div>  </div>  <div class="views-row views-row-6 views-row-even views-row-last">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/7/left-handed-plea-equality"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/bubblehands_fromRHT_520_0612LL.png?itok=9XHmHSLf" width="315" height="177" alt="A left-handed software user&#039;s plea" title="A left-handed software user&#039;s plea" /><br />
A left-handed software user&#039;s plea</a></span>  </div>  </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
    </div>
  
      <div class="os-article__footer">
      <div class="panel-pane pane-node-comments"  id="comments">
  
        <h2 class="pane-title">1 Comments</h2>
    
  
  <a id="comment-138276"></a>
<div class="comment first last odd clearfix" about="/comment/138276#comment-138276" typeof="sioc:Post sioct:Comment">

  <div class="user-picture-badges">
    <img class="comment-avatar" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/comment_avatar/public/osdc_default_avatar.png?itok=pk-4pxZV" width="50" height="50" alt="marienedia" title="marienedia" />      </div>

  
  <div class="submitted">
    <span property="dc:date dc:created" content="2017-08-04T06:13:26-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/marienedia" class="username">Mariene</a> on 04 Aug 2017</span>    <a href="/comment/138276#comment-138276" class="permalink" rel="bookmark">Permalink</a>      </div>

  <div class="content">
    <span rel="sioc:reply_of" resource="/article/17/8/app-inventor-android-app-development" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>When I originally commented I seem to have clicked </p>
<p>on the -Notify me when new comments are added- checkbox and from now on every time a comment is added I recieve </p>
<p>four emails with the same comment. Is there an easy method you can remove me </p>
<p>from that service? Kudos!</p>
<p>Recomendo que veja mais infos sobre esse foco acessando ao homepage dicas de saúde para cães - <a href="http://www.cha28.com/comment/html/index.php?page=1&amp;id=239514" rel="nofollow">www.cha28.com</a>,</p>
</div></div></div>      </div>

  <div class="comment__meta">
    <ul class="links inline"><li class="comment-reply first last"><a href="/comment/reply/38091/138276">reply</a></li>
</ul>        <div class="vud-widget vud-widget-upanddown" id="widget-comment-138276">
  <div class="up-score clear-block">
                    <div class="up-active" title="Vote up!"></div>
          <div class="element-invisible">Vote up!</div>
              <span class="up-current-score">0</span>
  </div>

  </div>
  </div>
</div>

  
  </div>
<div class="panel-pane pane-node-comment-form" >
  
        <h2 class="pane-title">Comment now</h2>
    
  
  <form class="comment-form user-info-from-cookie" action="/article/17/8/app-inventor-android-app-development#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div id="edit-login-register" class="form-item form-type-item">
 <a href="/user/login?destination=node/38091">Login or Register</a> to earn points for your comments.
</div>
<div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<input type="hidden" name="form_build_id" value="form-VST8LNluAXNXhoIfBj91k5ur8NEgzi3qgsBSSaGETW0" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/legal">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><input class="mollom-content-id" type="hidden" name="mollom[contentId]" value="" />
<input class="mollom-captcha-id" type="hidden" name="mollom[captchaId]" value="17080414d8846fc0b6" />
<div class="form-item form-type-textfield form-item-mollom-captcha">
  <label for="edit-mollom-captcha">Verification <span class="form-required" title="This field is required.">*</span></label>
 <span class="field-prefix">
<span class="mollom-captcha-container">
  <span class="mollom-image-captcha-instructions">Type the characters you see in the picture; if you can't read them, submit the form and a new image will be generated. Not case sensitive.&nbsp;&nbsp;<a href="#" class="mollom-switch-captcha mollom-audio-captcha">Switch to audio verification.</a></span>
  <a href="javascript:void(0);" class="mollom-refresh-captcha mollom-refresh-image"><img typeof="foaf:Image" src="https://opensource.com/sites/all/modules/contrib/mollom/images/refresh.png" alt="Refresh" /></a>
  <span class="mollom-captcha-content mollom-image-captcha"><img typeof="foaf:Image" src="https://rest-production.mollom.com:443/v1/captcha/17080414d8846fc0b6.png" alt="Type the characters you see in this picture." /></span>
</span>
</span> <input title="Enter the characters from the verification above." type="text" id="edit-mollom-captcha" name="mollom[captcha]" value="" size="10" maxlength="128" class="form-text required" />
</div>
<div style="display: none;"><div class="form-item form-type-textfield form-item-mollom-homepage">
  <label for="edit-mollom-homepage">Home page </label>
 <input autocomplete="off" type="text" id="edit-mollom-homepage" name="mollom[homepage]" value="" size="60" maxlength="128" class="form-text" />
</div>
</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div></div></form>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-default-license" >
  
      
  
  <div class="field field-name-field-default-license field-type-text field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:license"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" style="border-width:0" src="/sites/all/themes/opensource/images/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a></div></div></div>
  
  </div>
    </div>
  
</div>
                  </div>


        
        
      </div>

        <div class="region region-pre-footer">
    <div id="block-os-common-components-footer-call-to-action" class="block block-os-common-components first last odd">

      
  
<div class="fieldable-panels-pane cta cta--green-on-blue cta--no-link">

  <div class="cta__content cta__content--no-link">
            <h2 class="cta__title">Sign up for Opensource.com news</h2>
<div class="field field-name-field-cta-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><iframe frameborder="0" height="50" id="fkfkx" scrolling="no" src="/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></p>
</div></div></div>  </div>

</div>


</div>
  </div>

        <div class="region region-footer-nav">
    <div id="block-bean-social-media" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/social-media" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><span>Find us:</span> 
</p>
<ul>
<li><a class="footer-twitter" href="https://twitter.com/OpenSourceWay" title="Twitter">Twitter</a></li>
<li><a class="footer-facebook" href="https://www.facebook.com/opensourceway" title="Facebook">Facebook</a></li>
<li><a class="footer-gplus" href="https://plus.google.com/108750398488318674353" title="Google Plus">Google Plus</a></li>
<li><a class="footer-instagram" href="https://www.instagram.com/opensourceway/" title="Instagram">Instagram</a></li>
<li><a class="footer-youtube" href="http://www.youtube.com/opensourceway" title="Youtube">Youtube</a></li>
<li><a class="footer-linkedin" href="https://www.linkedin.com/grps/Open-Source-Professionals-Advocates-2769297" title="LinkedIn">LinkedIn</a></li>
<li><a class="footer-irc" href="https://opensource.com/participate" title="IRC">IRC</a></li>
<li><a class="footer-feed" href="https://opensource.com/feed" title="RSS">RSS</a></li>
</ul>
</div></div></div>  </div>
</div>

</div>
<div id="block-menu-menu-footer" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Footer</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/legal" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact" class="menu__link">Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="/opensourcecom-team" title="" class="menu__link">Meet the Team</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://opensource.org/" title="" class="menu__link">Visit opensource.org</a></li>
</ul>
</div>
  </div>

        <footer id="footer" class="region region-footer">
    <div id="block-bean-copyrigt-block" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/copyrigt-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>For more discussion on open source and the role of the CIO in the enterprise, join us at <a href="http://enterprisersproject.com">The EnterprisersProject.com</a>.</p>
<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>
<p>Opensource.com aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Shadowman logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div></div></div>  </div>
</div>

</div>
<div id="block-bean-footer-logo" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/footer-logo" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><img src="/sites/all/themes/opensource/images/footer_logo.svg" /></p>
</div></div></div>  </div>
</div>

</div>
  </footer>

    </div>

    
      <div class="region region-os-social">
    <div id="block-os-social-os-social-share" class="block block-os-social first last odd">

      
  <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div>
</div>
  </div>
    <div class="region region-page-bottom">
    <!-- begin Google Remarketing --><img height="1" width="1" style="border-style:none;display:block;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" onerror="this.src='/sites/all/themes/opensource/images/1x1.png';this.onerror=null" /><!-- end Google Remarketing -->  </div>
<script src="https://opensource.com/sites/all/modules/contrib/media_ckeditor/js/plugins/media/library.js?ou5qk1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_widgets/panopoly-widgets.js?ou5qk1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_widgets/jquery-ui-tabs-rotate.js?ou5qk1"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script>var a2a_config = a2a_config || {};
a2a_config.templates = {
    twitter: "Learn Android development with this drag-and-drop framework http://red.ht/2fbLmHn via @opensourceway by @pfooti"
};</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"65779638","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkgHX1xuW1BXU1YEF2pWCVxcbkBYXEVuEQRSXQ==","queueTime":0,"applicationTime":971,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
