<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html class="no-js"  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema# schema: http://schema.org/"><!--<![endif]-->

<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
  <meta charset="utf-8" /><script type="text/javascript">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</script>
<link href="https://opensource.com/rss.xml" rel="alternate" type="application/rss+xml" title="Opensource.com RSS" />
<link rel="shortcut icon" href="https://opensource.com/sites/all/themes/opensource/favicon.ico" type="image/vnd.microsoft.icon" />
<script src="https://www.google.com/recaptcha/api.js?hl=en" async="async" defer="defer"></script>
<meta name="description" content="Generate a vanity .onion website to protect your anonymity—and your visitors&#039; privacy, too." />
<meta name="rating" content="general" />
<meta name="referrer" content="no-referrer" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://opensource.com/article/19/8/how-create-vanity-tor-onion-address" />
<link rel="shortlink" href="https://opensource.com/node/55281" />
<meta name="revisit-after" content="1 day" />
<meta property="og:site_name" content="Opensource.com" />
<meta property="og:url" content="https://opensource.com/article/19/8/how-create-vanity-tor-onion-address" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to create a vanity Tor .onion web address" />
<meta property="og:description" content="Generate a vanity .onion website to protect your anonymity—and your visitors&#039; privacy, too." />
<meta property="og:image" content="https://opensource.com/sites/default/files/lead-images/security_password_mask_secret.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@opensourceway" />
<meta name="twitter:creator" content="@areahintsng" />
<meta name="twitter:title" content="How to create a vanity Tor .onion web address" />
<meta name="twitter:description" content="Generate a vanity .onion website to protect your anonymity—and your visitors&#039; privacy, too." />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/lead-images/security_password_mask_secret.png" />
  <title>How to create a vanity Tor .onion web address | Opensource.com</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_rPk7Et6wjNyH7pw3qgw9a85Yiqd9m38Ov-4hY99oyhM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_vamxBRmWk2Q7fxdiL4tDdJ_YjZN5fmFXzhYuV4x6kIk.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_1HAxiQy0ym2_Wq8hTu-6qsXiyLz9C2U7glSaTTu6UTk.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_v0CtiJaVnDK75UyA4_mnXJcPqXTFFDc4Qj3KIXRXBJU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_PxsPpITToy8ZnO0bJDA1TEC6bbFpGTfSWr2ZP8LuFYo.css" media="all" />
  <script src="/sites/all/themes/opensource/js/use-typekit.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  <script src="https://opensource.com/sites/default/files/js/js_0RyHJ63yYLuaWsodCPCgSD8dcTIA0dqcDf8-7c2XdBw.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_R9xDkoIXbrDQhdBhQ3W4GF5TzHxKYFK0UB8wjqE0DbE.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_tBWHhFjU_NjWsmd07Hrx5ScmFu-4-PJD_GwzNMH3UwA.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_VQpdyHm5xCOVZuJDT1qsHx0ol1ROIpb8g515ZxRqX4o.js"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-33294138-1", {"cookieDomain":".opensource.com"});ga("send", "pageview");</script>
<script src="https://opensource.com/sites/default/files/js/js_rVcPYhZ5_LfvT-dWbCnRngMcccEhwUaw2iNYx0yXj_Q.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_KbByFnBctcQt9juhHXNabaQDr4mJAc1OExQYJ-HcyXk.js"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-55281 node-type-article region-content section-article page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<header class="header" id="header" role="banner">

    
    <div class="header-banner">
      <div class="header-banner__inner">
                  <div class="header__name-and-slogan" id="name-and-slogan">
                          <div class="header__site-name" id="site-name">
                <a href="/" title="Home" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/logo.svg" onerror="this.src='/sites/all/themes/opensource/logo.png';this.onerror=null;" /></a>
                <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" title="Home" class="header__sponsor-link" rel="home"><img alt="RedHat" src="/sites/all/themes/opensource/images/redhat-logo.svg" onerror="this.src='/sites/all/themes/opensource/images/redhat-logo.png';this.onerror=null;"/></a>
              </div>
            
                      </div>
                <nav class="desktop-user-links">
            <div class="header__region region region-header">
    <div id="block-menu-block-1" class="block block-menu-block first last odd" role="navigation">

      
  <div class="menu-block-wrapper menu-block-1 menu-name-user-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-195"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1179"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul></div>

</div>
  </div>
        </nav>
      </div>
    </div>

    <div class="sf-nav">
      <div class="sf-nav__inner">
          <div class="js-mobile-header-buttons region region-navigation-top">
    <div id="block-os-solr-search-form" class="block block-os-solr-search first odd">

      
  <form action="/article/19/8/how-create-vanity-tor-onion-address" method="post" id="os-search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search">
  <label class="element-invisible" for="edit-search">Search </label>
 <input title="Enter the terms you wish to search for." placeholder="Search opensource.com" type="text" id="edit-search" name="search" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="GO" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-Qy6jjXI1ibTAUilUzYYGCZsM1l7p3MIHmGeoXposiDY" />
<input type="hidden" name="form_id" value="os_search_block_form" />
</div>
</div></form>
</div>
<div id="block-superfish-1" class="block block-superfish even">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-default sf-total-items-5 sf-parent-items-5 sf-single-items-0"><li id="menu-1906-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-10 sf-parent-children-3 sf-single-children-7 menuparent"><a href="/" title="" class="sf-depth-1 menuparent">Articles</a><ul><li id="menu-12341-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/containers" title="" class="sf-depth-2">Containers</a></li><li id="menu-12416-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/devops" title="" class="sf-depth-2">DevOps</a></li><li id="menu-12346-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/tags/gaming" title="" class="sf-depth-2">Gaming</a></li><li id="menu-17776-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/tags/government" title="" class="sf-depth-2">Government</a></li><li id="menu-12351-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/hardware" title="" class="sf-depth-2 menuparent">Hardware</a><ul><li id="menu-12376-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/3d-printing" title="" class="sf-depth-3">3D printing</a></li><li id="menu-12386-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/arduino" title="" class="sf-depth-3">Arduino</a></li><li id="menu-12381-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/raspberry-pi" title="" class="sf-depth-3">Raspberry Pi</a></li></ul></li><li id="menu-1946-1" class="middle even sf-item-6 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/tags/law" title="" class="sf-depth-2 menuparent">Law</a><ul><li id="menu-12391-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/licensing" title="" class="sf-depth-3">Licensing</a></li><li id="menu-12396-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/patents" title="" class="sf-depth-3">Patents</a></li></ul></li><li id="menu-12356-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/tags/linux" title="" class="sf-depth-2">Linux</a></li><li id="menu-12361-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="/tags/openstack" title="" class="sf-depth-2">OpenStack</a></li><li id="menu-12366-1" class="middle odd sf-item-9 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/programming" title="" class="sf-depth-2 menuparent">Programming</a><ul><li id="menu-17771-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/go" title="" class="sf-depth-3">Go</a></li><li id="menu-12411-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/javascript" title="" class="sf-depth-3">JavaScript</a></li><li id="menu-12406-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/python" title="" class="sf-depth-3">Python</a></li></ul></li><li id="menu-12371-1" class="last even sf-item-10 sf-depth-2 sf-no-children"><a href="/tags/sysadmin" title="" class="sf-depth-2">SysAdmin</a></li></ul></li><li id="menu-1921-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-5 sf-parent-children-2 sf-single-children-3 menuparent"><a href="/resources" title="" class="sf-depth-1 menuparent">Resources</a><ul><li id="menu-2016-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/resources/projects-and-applications" title="" class="sf-depth-2">Projects and applications</a></li><li id="menu-2021-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/organizations" title="" class="sf-depth-2">Organizations</a></li><li id="menu-1991-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/open-source-way" class="sf-depth-2">The open source way</a></li><li id="menu-5556-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-9 sf-parent-children-0 sf-single-children-9 menuparent"><a href="/resources/cloud" title="" class="sf-depth-2 menuparent">Cloud technology</a><ul><li id="menu-5576-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/resources/big-data" title="" class="sf-depth-3">Big data</a></li><li id="menu-5566-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/what-docker" title="" class="sf-depth-3">Docker</a></li><li id="menu-5591-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/resources/internet-of-things" title="" class="sf-depth-3">Internet of things</a></li><li id="menu-5596-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/resources/what-is-kubernetes" title="" class="sf-depth-3">Kubernetes</a></li><li id="menu-5571-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/what-are-linux-containers" title="" class="sf-depth-3">Linux containers</a></li><li id="menu-5586-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/resources/what-are-microservices" title="" class="sf-depth-3">Microservices</a></li><li id="menu-5561-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/resources/what-is-openstack" title="" class="sf-depth-3">OpenStack</a></li><li id="menu-5581-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/resources/what-is-software-defined-networking" title="" class="sf-depth-3">Software defined networking</a></li><li id="menu-12601-1" class="last odd sf-item-9 sf-depth-3 sf-no-children"><a href="/resources/virtualization" title="" class="sf-depth-3">Virtualization</a></li></ul></li><li id="menu-2036-1" class="last odd sf-item-5 sf-depth-2 sf-total-children-11 sf-parent-children-0 sf-single-children-11 menuparent"><a href="/alternatives" title="" class="sf-depth-2 menuparent">Open source alternatives</a><ul><li id="menu-4646-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/alternatives/adobe-acrobat" class="sf-depth-3">Alternatives to Acrobat</a></li><li id="menu-4656-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/alternatives/autocad" class="sf-depth-3">Alternatives to AutoCAD</a></li><li id="menu-4636-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/alternatives/dreamweaver" class="sf-depth-3">Alternatives to Dreamweaver</a></li><li id="menu-5506-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/alternatives/gmail" class="sf-depth-3">Alternatives to Gmail</a></li><li id="menu-5551-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/alternatives/matlab" class="sf-depth-3">Alternatives to MATLAB</a></li><li id="menu-5501-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/alternatives/minecraft" class="sf-depth-3">Alternatives to Minecraft</a></li><li id="menu-4651-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/alternatives/picasa" class="sf-depth-3">Alternatives to Picasa</a></li><li id="menu-4661-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/alternatives/microsoft-publisher" class="sf-depth-3">Alternatives to Publisher</a></li><li id="menu-5511-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/alternatives/slack" class="sf-depth-3">Alternatives to Slack</a></li><li id="menu-4641-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/alternatives/trello" class="sf-depth-3">Alternatives to Trello</a></li><li id="menu-5546-1" class="last odd sf-item-11 sf-depth-3 sf-no-children"><a href="/alternatives" title="" class="sf-depth-3">More...</a></li></ul></li></ul></li><li id="menu-19666-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-9 sf-parent-children-2 sf-single-children-7 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-1 menuparent">Downloads</a><ul><li id="menu-19406-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-16 sf-parent-children-0 sf-single-children-16 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Cheat sheets</a><ul><li id="menu-19651-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-awk-features" class="sf-depth-3">AWK cheat sheet</a></li><li id="menu-18641-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/blender-hotkey-cheat-sheet" class="sf-depth-3">Blender cheat sheet</a></li><li id="menu-18856-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/downloads/freedos-commands-cheat-sheet" class="sf-depth-3">FreeDOS cheat sheet</a></li><li id="menu-19721-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/content/cheat-sheet-gimp" class="sf-depth-3">GIMP cheat sheet</a></li><li id="menu-19696-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-gnome-3" class="sf-depth-3">GNOME cheat sheet</a></li><li id="menu-18661-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/downloads/groff-macros-cheat-sheet" class="sf-depth-3">Groff macros cheat sheet</a></li><li id="menu-19731-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/downloads/go-cheat-sheet" class="sf-depth-3">Go cheat sheet</a></li><li id="menu-19716-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-i3-window-manager-keybinding" class="sf-depth-3">i3 window manager cheat sheet</a></li><li id="menu-19781-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/downloads/inkscape-cheat-sheet" class="sf-depth-3">Inkscape Cheat Sheet</a></li><li id="menu-16886-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/irc-cheat-sheet" class="sf-depth-3">IRC cheat sheet</a></li><li id="menu-19301-1" class="middle odd sf-item-11 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-networking" class="sf-depth-3">Networking cheat sheet</a></li><li id="menu-18636-1" class="middle even sf-item-12 sf-depth-3 sf-no-children"><a href="/downloads/pandoc-cheat-sheet" class="sf-depth-3">Pandoc cheat sheet</a></li><li id="menu-19711-1" class="middle odd sf-item-13 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-python-37-beginners" class="sf-depth-3">Python 3.7 cheat sheet</a></li><li id="menu-19726-1" class="middle even sf-item-14 sf-depth-3 sf-no-children"><a href="/downloads/getting-started-raspberry-pi-cheat-sheet" class="sf-depth-3">Raspberry Pi cheat sheet</a></li><li id="menu-19691-1" class="middle odd sf-item-15 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-selinux" class="sf-depth-3">SELinux cheat sheet</a></li><li id="menu-18591-1" class="last even sf-item-16 sf-depth-3 sf-no-children"><a href="/downloads/advanced-ssh-cheat-sheet" class="sf-depth-3">SSH cheat sheet</a></li></ul></li><li id="menu-12466-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/yearbook/2017" title="" class="sf-depth-2 menuparent">Open Source Yearbook</a><ul><li id="menu-19681-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/yearbook/2015" title="" class="sf-depth-3">2015</a></li><li id="menu-19676-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/yearbook/2016" title="" class="sf-depth-3">2016</a></li><li id="menu-19671-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/yearbook/2017" title="" class="sf-depth-3">2017</a></li><li id="menu-19786-1" class="last even sf-item-4 sf-depth-3 sf-no-children"><a href="/yearbook/2018" title="" class="sf-depth-3">2018</a></li></ul></li><li id="menu-19801-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="https://opensource.com/downloads/ansible-quickstart" title="" class="sf-depth-2">Ansible Automation for Sysadmins</a></li><li id="menu-19706-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/downloads/containers-primer" class="sf-depth-2">Containers primer</a></li><li id="menu-19686-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/downloads/devops-hiring-guide" class="sf-depth-2">DevOps hiring guide</a></li><li id="menu-19701-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/downloads/devops-monitoring-guide" class="sf-depth-2">DevOps monitoring tools guide</a></li><li id="menu-19771-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/downloads/devsecops" title="" class="sf-depth-2">Getting started with DevSecOps</a></li><li id="menu-19776-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="/downloads/small-scale-scrum" class="sf-depth-2">Introduction to Small Scale Scrum</a></li><li id="menu-19806-1" class="last odd sf-item-9 sf-depth-2 sf-no-children"><a href="/downloads/devops-transformation" title="" class="sf-depth-2">Starting a DevOps transformation</a></li></ul></li><li id="menu-4691-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-5 sf-parent-children-2 sf-single-children-3 menuparent"><a href="/about" class="sf-depth-1 menuparent">About</a><ul><li id="menu-12516-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-7 sf-parent-children-0 sf-single-children-7 menuparent"><a href="/participate" class="sf-depth-2 menuparent">Join us</a><ul><li id="menu-12521-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/user/register" title="" class="sf-depth-3">Register</a></li><li id="menu-12526-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/rules-comments-and-discussions" class="sf-depth-3">Rules for comments and discussions</a></li><li id="menu-17781-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/devops-team" class="sf-depth-3">Contribute to DevOps resources</a></li><li id="menu-12531-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/community-moderator-program" class="sf-depth-3">Community Moderator program</a></li><li id="menu-12581-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/contributor-club" title="" class="sf-depth-3">Contributor Club</a></li><li id="menu-12541-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/points-and-badges" class="sf-depth-3">Points and badges</a></li><li id="menu-17766-1" class="last odd sf-item-7 sf-depth-3 sf-no-children"><a href="/delete-account" title="" class="sf-depth-3">Delete your account</a></li></ul></li><li id="menu-1966-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-6 sf-parent-children-0 sf-single-children-6 menuparent"><a href="/writers" title="" class="sf-depth-2 menuparent">For writers</a><ul><li id="menu-17761-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/how-submit-article" class="sf-depth-3">Write for us</a></li><li id="menu-12546-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/editorial-calendar" title="" class="sf-depth-3">Editorial calendar</a></li><li id="menu-12586-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/article/19/1/write-for-us" title="" class="sf-depth-3">Writing topics</a></li><li id="menu-2041-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/submission-style-guide" class="sf-depth-3">Article submission and style guide</a></li><li id="menu-4616-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/promoting-articles" class="sf-depth-3">Tips for promoting your Opensource.com article</a></li><li id="menu-12556-1" class="last even sf-item-6 sf-depth-3 sf-no-children"><a href="/writer-testimonials" class="sf-depth-3">Writer testimonials</a></li></ul></li><li id="menu-1971-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/opensourcecom-team" class="sf-depth-2">Meet the team</a></li><li id="menu-2006-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/press-kit" class="sf-depth-2">Press kit</a></li><li id="menu-2001-1" class="last odd sf-item-5 sf-depth-2 sf-no-children"><a href="/contact" title="" class="sf-depth-2">Contact</a></li></ul></li><li id="menu-2136-1" class="last odd sf-item-5 sf-depth-1 sf-total-children-5 sf-parent-children-3 sf-single-children-2 menuparent"><a href="/open-organization" title="" class="sf-depth-1 menuparent">The Open Org</a><ul><li id="menu-12471-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="sf-depth-2">What is an open organization?</a></li><li id="menu-15056-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-maturity-model" title="" class="sf-depth-2">How open is your organization?</a></li><li id="menu-15051-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/open-organization/resources/book-series" title="" class="sf-depth-2 menuparent">Book series</a><ul><li id="menu-18656-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/organize-innovation" class="sf-depth-3">Organize for Innovation download</a></li><li id="menu-17796-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/workbook" class="sf-depth-3">Open Organization Workbook download</a></li><li id="menu-16896-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/culture-change" class="sf-depth-3">Guide to IT Culture Change download</a></li><li id="menu-16891-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/leaders-manual" class="sf-depth-3">Leaders Manual download</a></li><li id="menu-16906-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/field-guide" class="sf-depth-3">Field guide download</a></li></ul></li><li id="menu-2146-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-8 sf-parent-children-0 sf-single-children-8 menuparent"><a href="/open-organization/resources" title="" class="sf-depth-2 menuparent">Resources</a><ul><li id="menu-2181-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/what-open-organization" title="" class="sf-depth-3">What is The Open Organization?</a></li><li id="menu-12421-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-decision-framework" title="" class="sf-depth-3">What is the Open Decision Framework?</a></li><li id="menu-2151-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/guides" title="" class="sf-depth-3">Discussion guide download</a></li><li id="menu-17821-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/newsletter" class="sf-depth-3">Newsletter sign-up</a></li><li id="menu-2246-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/faq" title="" class="sf-depth-3">Open Org FAQs</a></li><li id="menu-4606-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/twitter-chats" title="" class="sf-depth-3">Twitter chats</a></li><li id="menu-3201-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/open-organization/resources/reading-list" title="" class="sf-depth-3">Reading list</a></li><li id="menu-2256-1" class="last even sf-item-8 sf-depth-3 sf-no-children"><a href="/open-organization/resources/2015-book-club" title="" class="sf-depth-3">Book club</a></li></ul></li><li id="menu-3166-1" class="last odd sf-item-5 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/open-organization/resources/ambassadors-program" title="" class="sf-depth-2 menuparent">Ambassadors program</a><ul><li id="menu-2691-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/meet-ambassadors" title="" class="sf-depth-3">Meet the ambassadors</a></li></ul></li></ul></li></ul>
</div>
<div id="block-system-user-menu" class="block block-system block-menu odd" role="navigation">

      
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul>
</div>
<div id="block-menu-block-2" class="block block-menu-block last even" role="navigation">

      
  <div class="menu-block-wrapper menu-block-2 menu-name-menu-social-links parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-13171"><a href="http://twitter.com/opensourceway" title="twitter" class="menu__link">Twitter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-13176"><a href="https://www.facebook.com/opensourceway" title="facebook" class="menu__link">Facebook</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-13166"><a href="/feed" title="feed" class="menu__link">Feed</a></li>
</ul></div>

</div>
  </div>

        <div class="mobile--menu-region">
            <div class="region region-navigation">
    <div id="block-system-main-menu" class="block block-system block-menu first last odd" role="navigation">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/" title="" class="menu__link">Articles</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/containers" title="" class="menu__link">Containers</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/devops" title="" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/gaming" title="" class="menu__link">Gaming</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/government" title="" class="menu__link">Government</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/hardware" title="" class="menu__link">Hardware</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/3d-printing" title="" class="menu__link">3D printing</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/arduino" title="" class="menu__link">Arduino</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/raspberry-pi" title="" class="menu__link">Raspberry Pi</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/law" title="" class="menu__link">Law</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/linux" title="" class="menu__link">Linux</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/openstack" title="" class="menu__link">OpenStack</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/programming" title="" class="menu__link">Programming</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/go" title="" class="menu__link">Go</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/javascript" title="" class="menu__link">JavaScript</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/python" title="" class="menu__link">Python</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/tags/sysadmin" title="" class="menu__link">SysAdmin</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/projects-and-applications" title="" class="menu__link">Projects and applications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/organizations" title="" class="menu__link">Organizations</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-source-way" class="menu__link">The open source way</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/resources/cloud" title="" class="menu__link">Cloud technology</a></li>
<li class="menu__item is-collapsed last collapsed"><a href="/alternatives" title="" class="menu__link">Open source alternatives</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/downloads/cheat-sheets" title="" class="menu__link">Downloads</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/about" class="menu__link">About</a></li>
<li class="menu__item is-expanded last expanded"><a href="/open-organization" title="" class="menu__link">The Open Org</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="menu__link">What is an open organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-org-maturity-model" title="" class="menu__link">How open is your organization?</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/open-organization/resources/book-series" title="" class="menu__link">Book series</a></li>
<li class="menu__item is-expanded expanded"><a href="/open-organization/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/what-open-organization" title="" class="menu__link">What is The Open Organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-decision-framework" title="" class="menu__link">What is the Open Decision Framework?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/guides" title="" class="menu__link">Discussion guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/newsletter" class="menu__link">Newsletter sign-up</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/faq" title="" class="menu__link">Open Org FAQs</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/twitter-chats" title="" class="menu__link">Twitter chats</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/reading-list" title="" class="menu__link">Reading list</a></li>
<li class="menu__item is-leaf last leaf"><a href="/open-organization/resources/2015-book-club" title="" class="menu__link">Book club</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/open-organization/resources/ambassadors-program" title="" class="menu__link">Ambassadors program</a></li>
</ul></li>
</ul>
</div>
  </div>
        </div>
      </div>
    </div>

</header>

<div id="page">

      <div id="main">
        <div class="pre-content">
                                                </div>
        <div id="content" class="column" role="main">
                              <a id="main-content"></a>
                                <h1 class="page__title title" id="page-title">How to create a vanity Tor .onion web address | Opensource.com</h1>
                              



<div class="panel-display os-article clearfix os-article--with-image " id="article-template">

      <div class="os-article__top">
      <div class="os-article__top-inner">
        <div class="panel-pane pane-node-title"  >
  
      
  
  <h1>How to create a vanity Tor .onion web address</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-article-subhead"  >
  
      
  
  <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden">
    <div class="field-items">
          <h2>Generate a vanity .onion website to protect your anonymity—and your visitors&#039; privacy, too.</h2>
      </div>
</div>

  
  </div>
<div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__date">15 Aug 2019</span>
<span class="byline__author-name"><a href="/users/areahints" title="View user profile." class="username" xml:lang="" about="/users/areahints" typeof="sioc:UserAccount" property="foaf:name" datatype="">Kc Nwaezuoke</a>&nbsp;<span class="byline__feed"><a href="/user/293116/feed">Feed</a></span>
</span>
<span class="byline__social"><span class="byline__voting-widget"><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-071e2355466458888111f86b2b0f5467 rate-node-55281-1-1" id="rate-node-55281-1-1"><div class="rate-info">12</div><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/19/8/how-create-vanity-tor-onion-address?rate=g0M66RrNvgbqRxGcJn_gRDqQRvbOvzo6owCSNOT-pEQ" title="up">up</a></div></span>
</span>
</div>
  
  </div>
      </div>
    </div>
  
      <div class="os-article__image">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/security_password_mask_secret.png?itok=EjqwosxY"><img class="image-full-size" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/security_password_mask_secret.png?itok=EjqwosxY" width="520" height="292" alt="Password security with a mask" title="Password security with a mask" /></div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__left">
      <div class="panel-pane pane-block pane-bean-email-capture widget-block widget-block__left"  >
      <div class="target-band-never-show-button">x</div>
        <h2 class="pane-title">
      Subscribe now    </h2>
    
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/email-capture" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe frameborder="0" height="100" id="fkfkx" scrolling="no" src="/eloqua-embedded-email-capture-block.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="250"></iframe></p>
</div></div></div>  </div>
</div>

  
  </div>
    </div>
  
  
      <div class="os-article__middle">
      <div class="panel-pane pane-entity-field pane-node-body"  >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:articleBody content:encoded"><p><a href="https://www.torproject.org/" target="_blank">Tor</a> is a powerful, open source network that enables anonymous and non-trackable (or difficult to track) browsing of the internet. It's able to achieve this because of users running Tor nodes, which serve as intentional detours between two otherwise direct paths. For instance, if you are in New Zealand and visit python.nz, instead of being routed next door to the data center running python.nz, your traffic might be routed to Pittsburgh and then Berlin and then Vanuatu and finally to python.nz. The Tor network, being built upon opt-in participant nodes, has an ever-changing structure. Only within this dynamic network space can there exist an exciting, transient top-level domain identifier: the .onion address.</p>

<p>If you own or are looking to create a website, you can generate a vanity .onion site to protect your and your visitors' anonymity.</p>

<h2 id="what-are-onion-addresses">What are onion addresses?</h2>

<p>Because Tor is dynamic and intentionally re-routes traffic in unpredictable ways, an onion address makes both the information provider (you) and the person accessing the information (your traffic) difficult to trace by one another, by intermediate network hosts, or by an outsider. Generally, an onion address is unattractive, with 16-character names like 8zd335ae47dp89pd.onion. Not memorable, and difficult to identify when spoofed, but a few projects that culminated with Shallot (forked as eschalot) provides "vanity" onion addresses to solve those issues.</p>

<p>Creating a vanity onion URL on your own is possible but computationally expensive. Getting the exact 16 characters you want could take a single computer billions of years to achieve.</p>

<p>Here's a rough example (courtesy of <a href="https://github.com/katmagic/Shallot" target="_blank">Shallot</a>) of how much time it takes to generate certain lengths of characters on a 1.5GHz processor:</p>

<table border="1"><thead><tr><th>Characters</th>
			<th>Time</th>
		</tr></thead><tbody><tr><td>1</td>
			<td>Less than 1 second</td>
		</tr><tr><td>2</td>
			<td>Less than 1 second</td>
		</tr><tr><td>3</td>
			<td>Less than 1 second</td>
		</tr><tr><td>4</td>
			<td>2 seconds</td>
		</tr><tr><td>5</td>
			<td>1 minute</td>
		</tr><tr><td>6</td>
			<td>30 minutes</td>
		</tr><tr><td>7</td>
			<td>1 day</td>
		</tr><tr><td>8</td>
			<td>25 days</td>
		</tr><tr><td>9</td>
			<td>2.5 years</td>
		</tr><tr><td>10</td>
			<td>40 years</td>
		</tr><tr><td>11</td>
			<td>640 years</td>
		</tr><tr><td>12</td>
			<td>10 millennia</td>
		</tr><tr><td>13</td>
			<td>160 millennia</td>
		</tr><tr><td>14</td>
			<td>2.6 million years</td>
		</tr></tbody></table><p>I love how this table goes from 25 days to 2.5 years. If you wanted to generate 56 characters, it would take 10<sup>78</sup> years.</p>

<p>An onion address with 16 characters is referred to as a version 2 onion address, and one with 56 characters is a version 3 onion address. If you're using the Tor browser, you can check out this <a href="http://6zdgh5a5e6zpchdz.onion/" target="_blank">v2 address</a> or this <a href="http://vww6ybal4bd7szmgncyruucpgfkqahzddi37ktceo3ah7ngmcopnpyyd.onion/" target="_blank">v3 address</a>.</p>

<p>A v3 address has several advantages over v2:</p>

<ul><li>Better crypto (v3 replaced SHA1/DH/RSA1024 with SHA3/ed25519/curve25519)</li>
	<li>Improved directory protocol that leaks much less information to directory servers</li>
	<li>Improved directory protocol with a smaller surface for targeted attacks</li>
	<li>Better onion address security against impersonation</li>
</ul><p>However, the downside (supposedly) of v3 is the marketing effort you might need to get netizens to type that marathon-length URL in their browser.</p>

<p>You can <a href="https://www.torproject.org/docs/tor-onion-service.html.en#four" target="_blank">learn more about v3</a> in the Tor docs.</p>

<h2 id="why-you-might-need-an-onion-address">Why you might need an onion address</h2>

<p>A .onion domain has a few key advantages. Its key feature is that it can be accessed only with a Tor browser. Many people don't even know Tor exists, so you shouldn't expect massive traffic on your .onion site. However, the Tor browser provides numerous layers of anonymity not available on more popular browsers. If you want to ensure near-total anonymity for both you and your visitors, onion addresses are built for it.</p>

<p>With Tor, you do not need to register with ICANN to create your own domain. You don't need to hide your details from Whois searches, and your ICANN account won't be vulnerable to malicious takeovers. You are completely in control of your privacy and your domain.</p>

<p>An onion address is also an effective way to bypass censorship restrictions imposed by a government or regime. Its privacy helps protect you if your site may be viewed as a threat to the interests of the political class. Sites like Wikileaks are the best examples.</p>

<h2 id="what-do-you-need-to-generate-vanity-urls-">What you need to generate a vanity URL</h2>

<p>To configure a vanity onion address, you need to generate a new private key to match a custom hostname.</p>

<p>Two applications that you can use for generating .onion addresses are <a href="https://github.com/ReclaimYourPrivacy/eschalot" target="_blank">eschalot</a> for v2 addresses and <a href="https://github.com/cathugger/mkp224o" target="_blank">mkp224o</a> for v3 addresses.</p>

<p>Eschalot is a Tor hidden service name generator. It allows you to produce a (partially) customized vanity .onion address using a brute-force method. Eschalot is distributed in source form under the BSD license and should compile on any Unix or Linux system.</p>

<p>mkp224o is a vanity address generator for ed25519 .onion services that's available on GitHub with the CC0 1.0 Universal license. It generates vanity 56-character onion addresses.</p>

<p>Here's a simple explanation of how these applications work. (This assumes you are comfortable with Git.)</p>

<h3>Eschalot</h3>

<p>Eschalot requires <a href="https://www.openssl.org/" target="_blank">OpenSSL</a> 0.9.7 or later libraries with source headers. Confirm your version with this command:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ openssl version<br />
OpenSSL 1.1.1c FIPS &nbsp;<span class="nu0">28</span> May <span class="nu0">2019</span></div></div></pre>

<p>You also need a <a href="https://en.wikipedia.org/wiki/Make_(software)" target="_blank">Make</a> utility (either BSD or GNU Make will do) and a C compiler (GCC, PCC, or LLVM/Clang).</p>

<p>Clone the eschalot repo to your system, and then compile:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">git clone</span> https:<span class="sy0">//</span>github.com<span class="sy0">/</span>ReclaimYourPrivacy<span class="sy0">/</span>eschalot.git<br />
$ <span class="kw3">cd</span> eschalot-1.2.0<br />
$ <span class="kw2">make</span></div></div></pre>

<p>If you're not using GCC, you must set the <strong>CC</strong> environment variable. For example, to use PCC instead:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">make</span> clean<br />
$ <span class="kw2">env</span> <span class="re2">CC</span>=pcc <span class="kw2">make</span></div></div></pre>

<h4 id="use-eschalot">Using eschalot</h4>

<p>To see Echalot's Help pages, type <strong>./eschalot</strong> in the terminal:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ .<span class="sy0">/</span>eschalot<br />
Version: 1.2.0<br />
<br />
usage:<br />
eschalot <span class="br0">&#91;</span>-c<span class="br0">&#93;</span> <span class="br0">&#91;</span>-v<span class="br0">&#93;</span> <span class="br0">&#91;</span>-t count<span class="br0">&#93;</span> <span class="br0">&#40;</span><span class="br0">&#91;</span>-n<span class="br0">&#93;</span> <span class="br0">&#91;</span>-l min-max<span class="br0">&#93;</span> <span class="re5">-f</span> filename<span class="br0">&#41;</span> <span class="sy0">|</span> <span class="br0">&#40;</span>-r regex<span class="br0">&#41;</span> <span class="sy0">|</span> <span class="br0">&#40;</span>-p prefix<span class="br0">&#41;</span><br />
&nbsp; <span class="re5">-v</span> &nbsp; &nbsp; &nbsp; &nbsp; : verbose mode - print extra information to STDERR<br />
&nbsp; <span class="re5">-c</span> &nbsp; &nbsp; &nbsp; &nbsp; : <span class="kw3">continue</span> searching after the <span class="kw3">hash</span> is found<br />
&nbsp; <span class="re5">-t</span> count &nbsp; : number of threads to spawn default is one<span class="br0">&#41;</span><br />
&nbsp; <span class="re5">-l</span> min-max : look <span class="kw1">for</span> prefixes that are from <span class="st_h">'min'</span> to <span class="st_h">'max'</span> characters long<br />
&nbsp; <span class="re5">-n</span> &nbsp; &nbsp; &nbsp; &nbsp; : Allow digits to be part of the prefix <span class="br0">&#40;</span>affects wordlist mode only<span class="br0">&#41;</span><br />
&nbsp; <span class="re5">-f</span> filename: name of the text <span class="kw2">file</span> with a list of prefixes<br />
&nbsp; <span class="re5">-p</span> prefix &nbsp;: single prefix to look <span class="kw1">for</span> <span class="br0">&#40;</span><span class="nu0">1</span>-<span class="nu0">16</span> characters long<span class="br0">&#41;</span><br />
&nbsp; <span class="re5">-r</span> regex &nbsp; : search <span class="kw1">for</span> a POSIX-style regular expression<br />
<br />
Examples:<br />
&nbsp; eschalot <span class="re5">-cvt4</span> <span class="re5">-l8-12</span> <span class="re5">-f</span> wordlist.txt <span class="sy0">&gt;&gt;</span> results.txt<br />
&nbsp; eschalot <span class="re5">-v</span> <span class="re5">-r</span> <span class="st_h">'^test|^exam'</span><br />
&nbsp; eschalot <span class="re5">-ct5</span> <span class="re5">-p</span> <span class="kw3">test</span><br />
<br />
&nbsp; base32 alphabet allows letters <span class="br0">&#91;</span>a-z<span class="br0">&#93;</span> and digits <span class="br0">&#91;</span><span class="nu0">2</span>-<span class="nu0">7</span><span class="br0">&#93;</span><br />
&nbsp; Regex pattern examples:<br />
&nbsp; &nbsp; xxx &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; must contain <span class="st_h">'xxx'</span><br />
&nbsp; &nbsp; ^foo &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;must begin with <span class="st_h">'foo'</span><br />
&nbsp; &nbsp; bar$ &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;must end with <span class="st_h">'bar'</span><br />
&nbsp; &nbsp; b<span class="br0">&#91;</span>aoeiu<span class="br0">&#93;</span>r &nbsp; &nbsp; must have a vowel between <span class="st_h">'b'</span> and <span class="st_h">'r'</span><br />
&nbsp; &nbsp; <span class="st_h">'^ab|^cd'</span> &nbsp; &nbsp; must begin with <span class="st_h">'ab'</span> or <span class="st_h">'cd'</span><br />
&nbsp; &nbsp; <span class="br0">&#91;</span>a-z<span class="br0">&#93;</span><span class="br0">&#123;</span><span class="nu0">16</span><span class="br0">&#125;</span> &nbsp; &nbsp; must contain letters only, no digits<br />
&nbsp; &nbsp; ^dusk.<span class="sy0">*</span>dawn$ &nbsp;must begin with <span class="st_h">'dusk'</span> and end with <span class="st_h">'dawn'</span><br />
&nbsp; &nbsp; <span class="br0">&#91;</span>a-z2-<span class="nu0">7</span><span class="br0">&#93;</span><span class="br0">&#123;</span><span class="nu0">16</span><span class="br0">&#125;</span> &nbsp;any name - will succeed after one iteration</div></div></pre>

<p>You can use eschalot to generate an address using the prefix <strong>-p</strong> for <em>privacy</em>. Assuming your system has multiple CPU cores, use <em>multi-threading</em> (<strong>-t</strong>) to speed up the URL generation. To<em> get verbose output</em>, use the <strong>-v</strong> option. Write the results of your calculation to a file named <strong>newonion.txt</strong>:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash">.<span class="sy0">/</span>eschalot <span class="re5">-v</span> <span class="re5">-t4</span> <span class="re5">-p</span> privacy <span class="sy0">&gt;&gt;</span> newonion.txt</code></span></pre>

<p>The script executes until it finds a suitable match:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ .<span class="sy0">/</span>eschalot <span class="re5">-v</span> <span class="re5">-t4</span> <span class="re5">-p</span> privacy <span class="sy0">&gt;&gt;</span> newonion.txt<br />
Verbose, single result, no digits, <span class="nu0">4</span> threads, prefixes <span class="nu0">7</span>-<span class="nu0">7</span> characters long.<br />
Thread <span class="co0">#1 started.</span><br />
Thread <span class="co0">#2 started.</span><br />
Thread <span class="co0">#3 started.</span><br />
Thread <span class="co0">#4 started.</span><br />
Running, collecting performance data...<br />
Found a key <span class="kw1">for</span> privacy <span class="br0">&#40;</span><span class="nu0">7</span><span class="br0">&#41;</span> - privacyzofgsihx2.onion</div></div></pre>

<p>To access the public and private keys eschalot generates, locate <strong>newonion.txt</strong> in the eschalot folder.</p>

<h3>mkp224o</h3>

<p>mkp224o requires a C99 compatible compiler, Libsodium, GNU Make, GNU Autoconf, and a Unix-like platform. It has been tested on Linux and OpenBSD.</p>

<p>To get started, clone the mkp224o repo onto your system, generate the required <a href="https://opensource.com/article/19/7/introduction-gnu-autotools">Autotools infrastructure</a>, configure, and compile:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">git clone</span> https:<span class="sy0">//</span>github.com<span class="sy0">/</span>cathugger<span class="sy0">/</span>mkp224o.git<br />
$ <span class="kw3">cd</span> mkp224o<br />
$ .<span class="sy0">/</span>autogen.sh<br />
$ .<span class="sy0">/</span>configure<br />
$ <span class="kw2">make</span></div></div></pre>

<h4 id="use-mkp224o">Using mkp224o</h4>

<p>Type <strong>./mkp224o -h</strong> to view Help:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ .<span class="sy0">/</span>mkp224o <span class="re5">-h</span><br />
Usage: .<span class="sy0">/</span>mkp224o filter <span class="br0">&#91;</span>filter...<span class="br0">&#93;</span> <span class="br0">&#91;</span>options<span class="br0">&#93;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp;.<span class="sy0">/</span>mkp224o <span class="re5">-f</span> filterfile <span class="br0">&#91;</span>options<span class="br0">&#93;</span><br />
Options:<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-h</span> &nbsp;- print <span class="kw3">help</span> to stdout and quit<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-f</span> &nbsp;- specify filter <span class="kw2">file</span> <span class="kw2">which</span> contains filters separated by newlines<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-D</span> &nbsp;- deduplicate filters<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-q</span> &nbsp;- <span class="kw1">do</span> not print diagnostic output to stderr<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-x</span> &nbsp;- <span class="kw1">do</span> not print onion names<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-v</span> &nbsp;- print <span class="kw2">more</span> diagnostic data<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-o</span> filename &nbsp;- output onion names to specified <span class="kw2">file</span> <span class="br0">&#40;</span>append<span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-O</span> filename &nbsp;- output onion names to specified <span class="kw2">file</span> <span class="br0">&#40;</span>overwrite<span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-F</span> &nbsp;- include directory names <span class="kw1">in</span> onion names output<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-d</span> <span class="kw2">dirname</span> &nbsp;- output directory<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-t</span> numthreads &nbsp;- specify number of threads to utilise <span class="br0">&#40;</span>default - CPU core count or <span class="nu0">1</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-j</span> numthreads &nbsp;- same <span class="kw2">as</span> <span class="re5">-t</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-n</span> numkeys &nbsp;- specify number of keys <span class="br0">&#40;</span>default - <span class="nu0">0</span> - unlimited<span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-N</span> numwords &nbsp;- specify number of words per key <span class="br0">&#40;</span>default - <span class="nu0">1</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-z</span> &nbsp;- use faster key generation method; this is now default<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-Z</span> &nbsp;- use slower key generation method<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-B</span> &nbsp;- use batching key generation method <span class="br0">&#40;</span><span class="sy0">&gt;</span>10x faster than -z, experimental<span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-s</span> &nbsp;- print statistics each <span class="nu0">10</span> seconds<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-S</span> t &nbsp;- print statistics every specified ammount of seconds<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-T</span> &nbsp;- <span class="kw1">do</span> not reset statistics counters when printing<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-y</span> &nbsp;- output generated keys <span class="kw1">in</span> YAML format instead of dumping them to filesystem<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="re5">-Y</span> <span class="br0">&#91;</span>filename <span class="br0">&#91;</span>host.onion<span class="br0">&#93;</span><span class="br0">&#93;</span> &nbsp;- parse YAML encoded input and extract key<span class="br0">&#40;</span>s<span class="br0">&#41;</span> to filesystem</div></div></pre>

<p>One or more filters are required for mkp224o to work. When executed, mkp224o creates a directory with secret and public keys, plus a hostname for each discovered service. By default, <strong>root</strong> is the current directory, but that can be overridden with the <strong>-d</strong> switch.</p>

<p>Use the <strong>-t numthreads</strong> option to define how many threads you want to use during processing, and <strong>-v</strong> to see verbose output. Use the <strong>fast</strong> filter, and generate four keys by setting the <strong>-n </strong>option:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ .<span class="sy0">/</span>mkp224o filter fast <span class="re5">-t</span> <span class="nu0">4</span> <span class="re5">-v</span> <span class="re5">-n</span> <span class="nu0">4</span> <span class="re5">-d</span> ~<span class="sy0">/</span>Extracts<br />
<span class="kw1">set</span> workdir: <span class="sy0">/</span>home<span class="sy0">/</span>areahints<span class="sy0">/</span>Extracts<span class="sy0">/</span><br />
sorting filters... done.<br />
filters:<br />
&nbsp; &nbsp; &nbsp; &nbsp; fast<br />
&nbsp; &nbsp; &nbsp; &nbsp; filter<br />
<span class="kw1">in</span> total, <span class="nu0">2</span> filters<br />
using <span class="nu0">4</span> threads<br />
fastrcl5totos3vekjbqcmgpnias5qytxnaj7gpxtxhubdcnfrkapqad.onion<br />
fastz7zvpzic6dp6pvwpmrlc43b45usm2itkn4bssrklcjj5ax74kaad.onion<br />
fastqfj44b66mqffbdfsl46tg3c3xcccbg5lfuhr73k7odfmw44uhdqd.onion<br />
fast4xwqdhuphvglwic5dfcxoysz2kvblluinr4ubak5pluunduy7qqd.onion<br />
waiting <span class="kw1">for</span> threads to finish... done.</div></div></pre>

<p>In the directory path set with <strong>-d</strong>, mkp224o creates a folder with the v3 address name it has generated, and within it you see your hostname, secret, and public files.</p>

<p>Use the <strong>-s</strong> switch to enable printing statistics, which may be useful when benchmarking different ed25519 implementations on your machine. Also, read the <strong>OPTIMISATION.txt</strong> file in mkp224o for performance-related tips.</p>

<h2 id="notes-about-security">Notes about security</h2>

<p>If you're wondering about the security of v2 generated keys, <a href="https://github.com/katmagic/Shallot" target="_blank">Shallot</a> provides an interesting take:</p>

<blockquote>
<p>It is sometimes claimed that private keys generated by Shallot are less secure than those generated by Tor. This is false. Although Shallot generates a keypair with an unusually large public exponent <strong>e</strong>, it performs all of the sanity checks specified by PKCS #1 v2.1 (directly in <strong>sane_key</strong>), and then performs all of the sanity checks that Tor does when it generates an RSA keypair (by calling the OpenSSL function <strong>RSA_check_key</strong>).</p>
</blockquote>

<p>"<a href="https://en.wikipedia.org/wiki/Zooko%27s_triangle" target="_blank">Zooko's Triangle</a>" (which is discussed in <a href="http://www.skyhunter.com/marcs/petnames/IntroPetNames.html" target="_blank">Stiegler's Petname Systems</a>) argues that names cannot be global, secure, and memorable at the same time. This means while .onion names are unique and secure, they have the disadvantage that they cannot be meaningful to humans.</p>

<p>Imagine that an attacker creates an .onion name that looks similar to the .onion of a different onion service and replaces its hyperlink on the onion wiki. How long would it take for someone to recognize it?</p>

<p>The onion address system has trade-offs, but vanity addresses may be a reasonable balance among them.</p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-listacles-panel-pane-1"  >
  
      
  
  <div class="view view-listacles view-id-listacles view-display-id-panel_pane_1 view-dom-id-400e1759e1352995e489b622b202c376">
        
  
  
      <div class="view-content">
              
  <div class="views-field views-field-field-listacles">        <div class="field-content">
<div class="panelizer-view-mode node node-teaser-listacles node-article node-54531 node-promoted node-promoted">
        
<div class="panel-display teaser clearfix " >

  <div class="teaser__first">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/BUSINESS_buildtogether.png?itok=NBzhDg7w"><a href="/article/19/7/make-linux-stronger-firewalls"><img class="teaser-wide" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/BUSINESS_buildtogether.png?itok=NBzhDg7w" width="249" height="140" alt="People working together to build " title="People working together to build " /></a></div></div></div>
  
  </div>
  </div>

  <div class="teaser__second">
    <h2 class="teaser__title"><div class="panel-pane pane-node-title"  >
  
      
  
  <a href="/article/19/7/make-linux-stronger-firewalls">Make Linux stronger with firewalls</a>
  
  </div>
</h2>
    <div class="teaser__body"><div class="panel-pane pane-token pane-node-field-article-subhead"  >
  
      
  
  Learn how firewalls work and which settings to tweak for better Linux security.
  
  </div>
</div>
    <div class="teaser__byline"><div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__author-name"><a href="/users/seth" title="View user profile." class="username" xml:lang="" about="/users/seth" typeof="sioc:UserAccount" property="foaf:name" datatype="">Seth Kenlon <span class="content-moderator">(Red Hat)</span></a></span>
</div>
  
  </div>
</div>
  </div>

</div>
</div>
</div>  </div>          
  <div class="views-field views-field-field-listacles">        <div class="field-content">
<div class="panelizer-view-mode node node-teaser-listacles node-article node-54466 node-promoted node-promoted">
        
<div class="panel-display teaser clearfix " >

  <div class="teaser__first">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/password.jpg?itok=u6PYJUmp"><a href="/article/19/6/check-passwords"><img class="teaser-wide" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/password.jpg?itok=u6PYJUmp" width="249" height="140" alt="Password lock" title="Password lock" /></a></div></div></div>
  
  </div>
  </div>

  <div class="teaser__second">
    <h2 class="teaser__title"><div class="panel-pane pane-node-title"  >
  
      
  
  <a href="/article/19/6/check-passwords">Check your password security with Have I Been Pwned? and pass</a>
  
  </div>
</h2>
    <div class="teaser__body"><div class="panel-pane pane-token pane-node-field-article-subhead"  >
  
      
  
  Periodically checking for password compromise is an excellent way to help ward off most attackers in most threat models.
  
  </div>
</div>
    <div class="teaser__byline"><div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__author-name"><a href="/users/bexelbie" title="View user profile." class="username" xml:lang="" about="/users/bexelbie" typeof="sioc:UserAccount" property="foaf:name" datatype="">Brian "bex" Exelbierd <span class="content-moderator">(Red Hat)</span></a></span>
</div>
  
  </div>
</div>
  </div>

</div>
</div>
</div>  </div>          
  <div class="views-field views-field-field-listacles">        <div class="field-content">
<div class="panelizer-view-mode node node-teaser-listacles node-article node-46251 node-promoted node-promoted">
        
<div class="panel-display teaser clearfix " >

  <div class="teaser__first">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/openweb-osdc-lead.png?itok=o3zCgR32"><a href="/article/18/7/apache-url-shortener"><img class="teaser-wide" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/openweb-osdc-lead.png?itok=o3zCgR32" width="249" height="140" alt="Closeup of a spider web, purple background" title="Closeup of a spider web, purple background" /></a></div></div></div>
  
  </div>
  </div>

  <div class="teaser__second">
    <h2 class="teaser__title"><div class="panel-pane pane-node-title"  >
  
      
  
  <a href="/article/18/7/apache-url-shortener">How to build a URL shortener with Apache</a>
  
  </div>
</h2>
    <div class="teaser__body"><div class="panel-pane pane-token pane-node-field-article-subhead"  >
  
      
  
  Create your own short links with Apache HTTP server&#039;s mod_rewrite feature.
  
  </div>
</div>
    <div class="teaser__byline"><div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__author-name"><a href="/users/bcotton" title="View user profile." class="username" xml:lang="" about="/users/bcotton" typeof="sioc:UserAccount" property="foaf:name" datatype="">Ben Cotton <span class="content-moderator">(Red Hat, Community Moderator)</span></a></span>
</div>
  
  </div>
</div>
  </div>

</div>
</div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-tags"  >
  
        <h2 class="pane-title">
      Topics    </h2>
    
  
  <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:keywords"><a href="/tags/security" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Security and privacy</a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-author-info-panel-pane-1"  >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-d9eeab212f38d5b612e2f93e4f7e4b69">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><a href="/users/areahints"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/pictures/boj5t4hn.jpg?itok=tT8ZJvL3" width="100" height="100" alt="Kc" /></a></div>
<div class="authorbio__content">
  <span class="authorbio__name">Kc Nwaezuoke</span> - <span class="authorbio__about">I am a self-taught developer focused on learning more about computers, I love to design, build websites and implement SEO, I also enjoy using python to automate boring, repetitive and tedious work. you will generally find me on opensource.com, Github, Dev.to, StackOverflow and any anime streaming site!
</span>
  <div class="authorbio__more-link"><a href="/users/areahints">More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-content-article-contributions"  >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block"  >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__bottom">
      <div class="panel-pane pane-views-panes pane-related-articles-panel-pane-1"  >
  
        <h2 class="pane-title">
      Recommended reading    </h2>
    
  
  <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 related-content view-dom-id-efc6e86e5ccacae6c6a15949ec6405a7">
        
  
  
      <div id="related-content-footer" class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/8/protect-your-privacy-internet"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/privacy_keyboard_security.jpg?itok=6fkXJeeZ" width="315" height="177" alt="A keyboard with privacy written on it." title="A keyboard with privacy written on it." /><br />
Protect your privacy on the internet</a></span>  </div>  </div>  <div class="views-row views-row-2 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/7/security-scanning-your-devops-pipeline"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/target-security.png?itok=BZJI1u_3" width="315" height="177" alt="Target practice" title="Target practice" /><br />
Security scanning your DevOps pipeline</a></span>  </div>  </div>  <div class="views-row views-row-3 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/7/make-linux-stronger-firewalls"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/BUSINESS_buildtogether.png?itok=fpIOUopX" width="315" height="177" alt="People working together to build " title="People working together to build " /><br />
Make Linux stronger with firewalls</a></span>  </div>  </div>  <div class="views-row views-row-4 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/6/check-passwords"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/password.jpg?itok=8ZuQ9wpq" width="315" height="177" alt="Password lock" title="Password lock" /><br />
Check your password security with Have I Been Pwned? and pass</a></span>  </div>  </div>  <div class="views-row views-row-5 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/6/cryptography-basics-openssl-part-2"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/rh_003784_02_os.comcareers_os_rh2x.png?itok=qKi9BUs7" width="315" height="177" alt="A person working." title="A person working." /><br />
How to use OpenSSL: Hashes, digital signatures, and more</a></span>  </div>  </div>  <div class="views-row views-row-6 views-row-even views-row-last">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/6/cryptography-basics-openssl-part-1"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/BUSINESS_3reasons.png?itok=2__78jVn" width="315" height="177" alt="A lock on the side of a building" title="A lock on the side of a building" /><br />
Getting started with OpenSSL: Cryptography basics</a></span>  </div>  </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
    </div>
  
      <div class="os-article__footer">
      <div class="panel-pane pane-node-comment-form"  >
  
        <h2 class="pane-title">
      Comment now    </h2>
    
  
  <form class="comment-form user-info-from-cookie" action="/article/19/8/how-create-vanity-tor-onion-address#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div id="edit-login-register" class="form-item form-type-item">
 <a href="/user/login?destination=node/55281">Login or Register</a> to earn points for your comments.
</div>
<div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<input type="hidden" name="form_build_id" value="form-X8wGo70XNHFlmuDVr6H7642h-Y3wEvGyQOXzTbUKOCE" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="honeypot_time" value="1565910084|Wuf-c6UJVV5yTMbg8t_ITIMAK5QL4DZKQtzRiskFNiE" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/legal">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><fieldset class="captcha form-wrapper"><legend><span class="fieldset-legend">CAPTCHA</span></legend><div class="fieldset-wrapper"><div class="fieldset-description">This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.</div><input type="hidden" name="captcha_sid" value="206537021" />
<input type="hidden" name="captcha_token" value="3e22c8aea1f597134902f7f9277a5797" />
<input type="hidden" name="captcha_response" value="Google no captcha" />
<div class="g-recaptcha" data-sitekey="6LdyKzYUAAAAAIwIfHYM0eXeqI_HRmLhM-Msg6nM" data-theme="light" data-type="image"></div></div></fieldset>
<div class="website-url-textfield"><div class="form-item form-type-textfield form-item-website-url">
  <label for="edit-website-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-website-url" name="website-url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div></div></form>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-default-license"  >
  
      
  
  <div class="field field-name-field-default-license field-type-text field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:license"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" style="border-width:0" src="/sites/all/themes/opensource/images/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a></div></div></div>
  
  </div>
    </div>
  
</div>
                  </div>


        
        
      </div>

        <div class="region region-pre-footer">
    <div id="block-os-common-components-footer-call-to-action" class="block block-os-common-components first last odd">

      
  
<div class="fieldable-panels-pane cta cta--green-on-blue cta--no-link">

  <div class="cta__content cta__content--no-link">
            <h2 class="cta__title">Subscribe to our weekly newsletter</h2>
<div class="field field-name-field-cta-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><iframe class="eloqua-embedded-bottom" frameborder="0" height="50" id="fkfkx" scrolling="no" src="/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></p>

<p>Get the highlights in your inbox every week.</p>
</div></div></div>  </div>

</div>


</div>
  </div>

        <div class="region region-footer-nav">
    <div id="block-bean-social-media" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/social-media" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><span>Find us:</span> 
</p>
<ul>
<li><a class="footer-twitter" href="https://twitter.com/OpenSourceWay" title="Twitter">Twitter</a></li>
<li><a class="footer-facebook" href="https://www.facebook.com/opensourceway" title="Facebook">Facebook</a></li>
<li><a class="footer-youtube" href="http://www.youtube.com/opensourceway" title="Youtube">Youtube</a></li>
<li><a class="footer-mastodon" href="https://fosstodon.org/@osdc" title="">Mastodon</a></li>
<li><a class="footer-irc" href="/join-us-irc" title="IRC">IRC</a></li>
<li><a class="footer-feed" href="/feed" title="RSS">RSS</a></li>
</ul>
</div></div></div>  </div>
</div>

</div>
<div id="block-menu-menu-footer" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Footer</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/legal" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact" class="menu__link">Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="/opensourcecom-team" title="" class="menu__link">Meet the Team</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://opensource.org/" title="" class="menu__link">Visit opensource.org</a></li>
</ul>
</div>
  </div>

        <footer id="footer" class="region region-footer">
    <div id="block-bean-copyrigt-block" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/copyrigt-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>For more discussion on open source and the role of the CIO in the enterprise, join us at <a href="https://enterprisersproject.com">The EnterprisersProject.com</a>.</p>

<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>

<p>Opensource.com aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>

<p>Copyright ©2019 Red Hat, Inc.</p>
</div></div></div>  </div>
</div>

</div>
<div id="block-bean-footer-logo" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/footer-logo" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><img src="/sites/all/themes/opensource/images/footer_logo.svg" /></p>
</div></div></div>  </div>
</div>

</div>
  </footer>

    </div>

    
      <div class="region region-os-social">
    <div id="block-os-social-os-social-share" class="block block-os-social first last odd">

      
  <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://opensource.com/article/19/8/how-create-vanity-tor-onion-address">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <a class="a2a_button_mastodon a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <a class="a2a_button_mastodon a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div>
</div>
  </div>
    <div class="region region-page-bottom">
    <!-- begin Google Remarketing --><img height="1" width="1" style="border-style:none;display:block;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" onerror="this.src='/sites/all/themes/opensource/images/1x1.png';this.onerror=null" /><!-- end Google Remarketing -->  </div>
<script src="https://opensource.com/sites/default/files/js/js_29qYXJz8NLGg8Aomg-RZPjJcj9yEdEst1BMZ9gZbs-4.js"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script src="https://opensource.com/sites/default/files/js/js_skcw_uw28w93NamnwquPyMMZNIyaa2eQ6iAc5B_1jjA.js"></script>
<script>var a2a_config = a2a_config || {};
              a2a_config.callbacks = a2a_config.callbacks || [];
a2a_config.templates = {
    twitter: "How to create a vanity Tor .onion web address https://red.ht/2yvMGen via @opensourceway by @areahintsng"
};</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"65779638","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkgHX1xuW1BXU1YEF2pWCVxcbkBYXEVuEQRSXQ==","queueTime":0,"applicationTime":491,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
