<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="og: https://ogp.me/ns#">
  <head>
    <meta charset="utf-8" /><script type="text/javascript">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</script>
<link rel="canonical" href="https://opensource.com/article/22/7/learn-rust-rustlings" />
<link rel="shortlink" href="https://opensource.com/node/70126" />
<meta name="description" content="Rustlings is an open source project by the Rust team that helps you learn Rust through the process of debugging." />
<meta property="og:type" content="Learn Rust by debugging Rust" />
<meta property="og:url" content="https://opensource.com/article/22/7/learn-rust-rustlings" />
<meta property="og:title" content="Learn Rust by debugging Rust" />
<meta property="og:description" content="Rustlings is an open source project by the Rust team that helps you learn Rust through the process of debugging." />
<meta property="og:image" content="https://opensource.com/sites/default/files/lead-images/rust_programming_crab_sea.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Rustlings is an open source project by the Rust team that helps you learn Rust through the process of debugging." />
<meta name="twitter:title" content="Learn Rust by debugging Rust" />
<meta name="twitter:creator" content="@kamatheg" />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/lead-images/rust_programming_crab_sea.png" />
<meta name="Generator" content="Drupal 9 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="icon" href="/themes/osdc/assets/img/favicons/favicon.ico" type="image/vnd.microsoft.icon" />

    <title>Learn Rust by debugging Rust | Opensource.com</title>
    <link rel="stylesheet" media="all" href="/sites/default/files/css/css_G5pAaR4ZJDuk3M1Ws0PhOVFEzHL-MTALCtZ51bx1jRs.css" />
<link rel="stylesheet" media="all" href="https://opensource.com/sites/default/files/geshi/geshifilter-languages.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_bl_SPeJ7HUIBbLYtDj4lytk2w1adrkj7TTagxIPIPr4.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css__7a-geNxhv6kW_S0HwtK3wov74f5PsQoKutC5CMHavc.css" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css2?family=Red+Hat+Text:wght@400;500;700&amp;display=swap" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css2?family=Red+Hat+Mono:wght@400;500;700&amp;display=swap" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_otU0i_XDW9yaP1zkorv6fQLcgdo8HsLyDPdVgRHLzaw.css" />

    <script id="adobe_dtm" src="https://www.redhat.com/ma/dpal.js" type="text/javascript"></script>
    
    <script type="module" src="/themes/osdc/node_modules/@patternfly/pfe-modal/dist/pfe-modal.min.js"></script>
  </head>
  <body class="path-node page-node-type-article">
        <a href="#main-content" class="visually-hidden focusable skip-link">
      Skip to main content
    </a>
    
      <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    <div class="layout-container">

  <header>
      <div class="region region-messages">
    <div data-drupal-messages-fallback class="hidden"></div>

  </div>

    
<div class="region-top-bar">
  <div class="region wrapper region-user-menu">
    <div class="hamburger__container">
        <div class="hamburger">
            <button id="mobnav-btn" aria-label="Toggle main menu" class="button--plain toggle-menu"></button>
            <div class="bar"></div>
        </div>
    </div>

    <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" target="_blank" class="flex-center support-logo">
        <img alt="Supported by Red Hat" src="/themes/osdc/assets/img/l_supported-by-redhat-white.svg" title="Supported by Red Hat" width="125" height="56" class="support-logo__image">
    </a>

    <button id="toggle-search" aria-label="Toggle Search" class="button--plain toggle-search">
        <i class="icon-search"></i>
    </button>
    <nav role="navigation" aria-labelledby="block-useraccountmenu-menu" id="block-useraccountmenu" class="block block-menu navigation menu--account">
            
  <h2 class="visually-hidden" id="block-useraccountmenu-menu">User account menu</h2>
  

        
    
                    <ul class="account">
    
                            <li class="log-in account__item">
        <a href="/user/login?current=/node/70126" class="account__link" data-drupal-link-system-path="user/login">Log in</a>
                </li>
                            <li class="sign-up account__item">
        <a href="/user/register" class="account__link" data-drupal-link-system-path="user/register">Sign Up</a>
                </li>
                            <li class="facebook account__item">
        <a href="https://www.facebook.com/opensourceway" title="facebook" class="account__link">Facebook</a>
                </li>
                            <li class="twitter account__item">
        <a href="http://twitter.com/opensourceway" title="twitter" class="account__link">Twitter</a>
                </li>
                            <li class="rss account__item">
        <a href="/feed" title="RSS" class="account__link" data-drupal-link-system-path="rss.xml">RSS</a>
                </li>
            </ul>
    


  </nav>

  </div>
</div>

      <div class="region region-header">
    <div id="block-osdc-branding" class="block block-system block-system-branding-block">
  
    
    <div class="branding">
          <a href="/" rel="home" aria-label="Opensource.com" class="branding__logo">
        <img src="/themes/osdc/logo.svg" alt="Home"/>
      </a>
        <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" target="_blank" class="branding__supported-by">
      <img src="/themes/osdc/assets/img/l_supported-by-redhat-white.svg" width="125" height="56" class="branding__supported-by__image" alt="Supported by Red Hat">
    </a>
  </div>
  <div class="branding__slogan"></div>
</div>

  </div>

  </header>

    <div class="region region-main-nav">
    <nav role="navigation" aria-labelledby="block-mainnavigation-menu" id="block-mainnavigation" class="block block-menu navigation menu--main">
            
  <h2 class="visually-hidden" id="block-mainnavigation-menu">Main navigation</h2>
  

        
    
                    <ul class="main" id="main-menu">
    
                            <li class="main__item is-expanded">
        <a href="/" class="main__link" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item is-expanded">
        <a href="/tags/linux" class="main__link" data-drupal-link-system-path="taxonomy/term/6803">Linux</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/tags/command-line" class="main__link" data-drupal-link-system-path="taxonomy/term/5276">Command line</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/tags/kubernetes" class="main__link" data-drupal-link-system-path="taxonomy/term/9749">Kubernetes</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/tags/programming" class="main__link" data-drupal-link-system-path="taxonomy/term/7866">Programming</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/tags/go-programming-language" class="main__link" data-drupal-link-system-path="taxonomy/term/15746">Go</a>
                </li>
                            <li class="main__item">
        <a href="/tags/javascript" class="main__link" data-drupal-link-system-path="taxonomy/term/6609">JavaScript</a>
                </li>
                            <li class="main__item">
        <a href="/tags/python" class="main__link" data-drupal-link-system-path="taxonomy/term/7934">Python</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/tags/containers" class="main__link" data-drupal-link-system-path="taxonomy/term/9523">Containers</a>
                </li>
                            <li class="main__item">
        <a href="/tags/sysadmin" class="main__link" data-drupal-link-system-path="taxonomy/term/8596">Sysadmin</a>
                </li>
                            <li class="main__item">
        <a href="/tags/devops" class="main__link" data-drupal-link-system-path="taxonomy/term/9255">DevOps</a>
                </li>
                            <li class="main__item">
        <a href="/tags/gaming" class="main__link" data-drupal-link-system-path="taxonomy/term/6089">Gaming</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/tags/hardware" class="main__link" data-drupal-link-system-path="taxonomy/term/6284">Hardware</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/tags/3d-printing" class="main__link" data-drupal-link-system-path="taxonomy/term/4635">3D printing</a>
                </li>
                            <li class="main__item">
        <a href="/tags/arduino" class="main__link" data-drupal-link-system-path="taxonomy/term/4740">Arduino</a>
                </li>
                            <li class="main__item">
        <a href="/tags/raspberry-pi" class="main__link" data-drupal-link-system-path="taxonomy/term/7974">Raspberry Pi</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/tags/government" class="main__link" data-drupal-link-system-path="taxonomy/term/6211">Government</a>
                </li>
                            <li class="main__item">
        <a href="/tags/law" class="main__link" data-drupal-link-system-path="taxonomy/term/6744">Law</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/tags/open-organization" class="main__link" data-drupal-link-system-path="taxonomy/term/14761">Open Organization</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/open-organization/resources/open-org-definition" class="main__link" data-drupal-link-system-path="node/33506">What is an open organization?</a>
                </li>
                            <li class="main__item">
        <a href="/open-organization/resources/open-decision-framework" class="main__link" data-drupal-link-system-path="node/30866">What is an open decision?</a>
                </li>
            </ul>
    
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/resources" class="main__link" data-drupal-link-system-path="node/17752">Resources</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item is-expanded">
        <a href="/resources/what-open-source" class="main__link" data-drupal-link-system-path="node/17753">What is open source?</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/open-source-way" class="main__link" data-drupal-link-system-path="node/17730">The open source way</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/resources/projects-and-applications" class="main__link" data-drupal-link-system-path="node/17760">Projects and applications</a>
                </li>
                            <li class="main__item">
        <a href="/resources/organizations" class="main__link" data-drupal-link-system-path="node/17763">Organizations</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/resources/cloud" class="main__link" data-drupal-link-system-path="node/31366">Cloud technology</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/resources/what-ansible" class="main__link" data-drupal-link-system-path="node/56241">Ansible</a>
                </li>
                            <li class="main__item">
        <a href="/resources/big-data" class="main__link" data-drupal-link-system-path="node/21471">Big data</a>
                </li>
                            <li class="main__item">
        <a href="/resources/data-science" class="main__link" data-drupal-link-system-path="node/55831">Data science</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-docker" class="main__link" data-drupal-link-system-path="node/18438">Docker</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-git" class="main__link" data-drupal-link-system-path="node/29816">Git</a>
                </li>
                            <li class="main__item">
        <a href="/resources/internet-of-things" class="main__link" data-drupal-link-system-path="node/25831">Internet of things</a>
                </li>
                            <li class="main__item">
        <a href="/resources/java" class="main__link" data-drupal-link-system-path="node/38936">Java</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-kubernetes" class="main__link" data-drupal-link-system-path="node/27941">Kubernetes</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-are-linux-containers" class="main__link" data-drupal-link-system-path="node/29741">Linux containers</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-are-microservices" class="main__link" data-drupal-link-system-path="node/23541">Microservices</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-openstack" class="main__link" data-drupal-link-system-path="node/17870">OpenStack</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/resources/python" class="main__link" data-drupal-link-system-path="node/37296">Python</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/resources/python/gui-frameworks" class="main__link" data-drupal-link-system-path="node/28806">Python GUI frameworks</a>
                </li>
                            <li class="main__item">
        <a href="/resources/python/ides" class="main__link" data-drupal-link-system-path="node/24166">Python IDEs</a>
                </li>
                            <li class="main__item">
        <a href="/resources/python/template-libraries" class="main__link" data-drupal-link-system-path="node/44451">Python template libraries</a>
                </li>
                            <li class="main__item">
        <a href="/resources/python/web-scraper-crawler" class="main__link" data-drupal-link-system-path="node/39381">Python web scrapers</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-software-defined-networking" class="main__link" data-drupal-link-system-path="node/19276">Software defined networking</a>
                </li>
                            <li class="main__item">
        <a href="/resources/virtualization" class="main__link" data-drupal-link-system-path="node/36551">Virtualization</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/alternatives" class="main__link" data-drupal-link-system-path="node/30871">Open source alternatives</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/alternatives/adobe-acrobat" class="main__link" data-drupal-link-system-path="node/29486">Alternatives to Acrobat</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/autocad" class="main__link" data-drupal-link-system-path="node/29001">Alternatives to AutoCAD</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/dreamweaver" class="main__link" data-drupal-link-system-path="node/27646">Alternatives to Dreamweaver</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/gmail" class="main__link" data-drupal-link-system-path="node/22941">Alternatives to Gmail</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/matlab" class="main__link" data-drupal-link-system-path="node/29276">Alternatives to MATLAB</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/minecraft" class="main__link" data-drupal-link-system-path="node/22786">Alternatives to Minecraft</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/google-photos" class="main__link" data-drupal-link-system-path="node/27211">Alternatives to Google Photos</a>
                </li>
                            <li class="main__item">
        <a href="/life/12/6/design-without-debt-five-tools-for-designers" class="main__link" data-drupal-link-system-path="node/16365">Alternatives to Photoshop</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/skype" class="main__link" data-drupal-link-system-path="node/45576">Alternatives to Skype</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/slack" class="main__link" data-drupal-link-system-path="node/23286">Alternatives to Slack</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/trello" class="main__link" data-drupal-link-system-path="node/22546">Alternatives to Trello</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives" class="main__link" data-drupal-link-system-path="node/30871">More...</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/resources/linux" class="main__link" data-drupal-link-system-path="node/19796">Linux</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/downloads" class="main__link" data-drupal-link-system-path="downloads">Downloads</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/downloads/cheat-sheets" class="main__link" data-drupal-link-system-path="downloads/cheat-sheets">Cheat sheets</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/devops-guides" class="main__link" data-drupal-link-system-path="downloads/devops-guides">DevOps guides</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/programming-guides" class="main__link" data-drupal-link-system-path="downloads/programming-guides">Programming guides</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/sysadmin-guides" class="main__link" data-drupal-link-system-path="downloads/sysadmin-guides">Sysadmin guides</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/ebooks" class="main__link" data-drupal-link-system-path="downloads/ebooks">eBooks</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/open-source-yearbook" class="main__link" data-drupal-link-system-path="downloads/open-source-yearbook">Open Source Yearbook</a>
                </li>
                            <li class="main__item">
        <a href="/open-organization/resources/book-series" class="main__link" data-drupal-link-system-path="node/37936">Open Organization series</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/about" class="main__link" data-drupal-link-system-path="node/17734">Community</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item is-expanded">
        <a href="/about" class="main__link" data-drupal-link-system-path="node/17734">About Opensource.com</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/participate" class="main__link" data-drupal-link-system-path="node/17735">Welcome to the Opensource.com community</a>
                </li>
                            <li class="main__item">
        <a href="/team" class="main__link" data-drupal-link-system-path="node/17744">Meet the team</a>
                </li>
                            <li class="main__item">
        <a href="/user/register" class="main__link" data-drupal-link-system-path="user/register">Create an account</a>
                </li>
                            <li class="main__item">
        <a href="/code-of-conduct" class="main__link" data-drupal-link-system-path="node/17710">Rules for comments and discussions</a>
                </li>
                            <li class="main__item">
        <a href="/correspondent-program" class="main__link" data-drupal-link-system-path="node/17743">Correspondent Program</a>
                </li>
                            <li class="main__item">
        <a href="/faq" class="main__link" data-drupal-link-system-path="node/62466">Frequently Asked Questions</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/writers" class="main__link" data-drupal-link-system-path="node/18340">Contribute to Opensource.com</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/submission-style-guide" class="main__link" data-drupal-link-system-path="node/18705">Opensource.com style guide</a>
                </li>
                            <li class="main__item">
        <a href="/article/20/1/write-for-us" class="main__link" data-drupal-link-system-path="node/60351">Writing topics</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/contact" class="main__link" data-drupal-link-system-path="node/68921">Contact Us</a>
                </li>
            </ul>
    
                </li>
            </ul>
    


  </nav>
<div class="views-exposed-form block block-views block-views-exposed-filter-blockacquia-search-page" data-drupal-selector="views-exposed-form-acquia-search-page" id="block-exposedformacquia-searchpage">
  
    
      <form action="/site-search" method="get" id="views-exposed-form-acquia-search-page" accept-charset="UTF-8">
  <div class="form--inline clearfix">
  <div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-search form-item-search">
      <label for="edit-search">Search</label>
        <input placeholder="Search" data-drupal-selector="edit-search" type="text" id="edit-search" name="search" value="" size="30" maxlength="128" class="form-text" />

        </div>
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions"><input data-drupal-selector="edit-submit-acquia-search" type="submit" id="edit-submit-acquia-search" value="Search" class="button js-form-submit form-submit" />
</div>

</div>

</form>

  </div>


  </div>


  <main>
    <a id="main-content" tabindex="-1"></a>
    <div class="wrapper wrapper--870">
        <div class="region region-content">
    <div id="block-subscribetoourweeklynewsletterflyin" class="block subscribe-float hide block-block-content block-block-content53f83537-7483-486d-9cf3-65f15e0c01c2">
  <button id="subscribe-float-close" class="subscribe-float__close"><span>x</span></button>
  
  
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><h2 class="subscribe-float__title">Subscribe to our <span>newsletter</span>.</h2>
<p>Stay on top of the latest thoughts, strategies and insights from enterprising peers.</p>
<p><iframe frameborder="0" height="229" id="fkfkx" scrolling="no" title="Subscribe to our weekly newsletter" src="https://opensource.com/eloqua-embedded-email-capture-block-sticky.html?offer_id=70160000000QzXNAA0"></iframe></p>
</div>
      
  </div>

<div id="block-osdc-page-title" class="block block-core block-page-title-block">
  
    
      
  <h1 class="published page-title">
    <span class="field field--name-title field--type-string field--label-hidden">Learn Rust by debugging Rust</span>

      </h1>


  </div>
<div id="block-mainpagecontent" class="block block-system block-system-main-block">
  
    
      
<article class="node node--type-article node--promoted node--view-mode-full">

  
  <div class="article__subhead">Rustlings is an open source project by the Rust team that helps you learn Rust through the process of debugging.</div>

      <footer class="author__meta">
      <div class="author__submitted">
        <div class="author__list">
          By 
<article class="profile">
            <a href="/users/gkamathe" hreflang="en">Gaurav Kamathe</a>
      
<span class="user-attributes">(Correspondent, Red Hat)
</span>
</article>
 
        </div>
        <div class="author__meta-date-container">
                    <span class="author__meta-date">July 29, 2022</span>          <span class="author__date-pipe">|</span>
          <a href="#comments"><span class="author__comment-count">0 Comments </span></a>
          <span class="author__date-pipe">|</span>
          <pfe-readtime class="pf-global--FontSize--lg" for="#article_content" hidden>%t min read</pfe-readtime>

        </div>
      </div>
    </footer>
    <div id="article_content" class="author__content">

      <div class="layout layout--onecol">
    <div  class="layout__region layout__region--content">
      <div class="block block-layout-builder block-extra-field-blocknodearticlerate-vote-widget">
  
    
      <div data-drupal-selector="rate-node-70126" class="rate-widget-thumbs-up" title="Register or Login to like.">
    <div class="rate-thumbs-up-btn-up vote-pending">1 reader likes this</div>
    <div class="rate-score">1 reader likes this</div>
    
</div>

  </div>
<div class="block block-layout-builder block-extra-field-blocknodearticlecontent-moderation-control">
  
    
      
  </div>

    </div>
  </div>
  <div class="layout layout--onecol">
    <div  class="layout__region layout__region--content">
      <div class="block block-layout-builder block-field-blocknodearticlefield-lead-image">
  
    
      
            <div class="field field--name-field-lead-image field--type-entity-reference field--label-hidden field__item"><article class="media media--type-image media--view-mode-caption">
  
      
            <div class="field field--name-field-media-image field--type-image field--label-hidden field__item">  <img loading="lazy" src="/sites/default/files/lead-images/rust_programming_crab_sea.png" width="1040" height="585" alt="Ferris the crab under the sea, unofficial logo for Rust programming language" title="Ferris the crab under the sea, unofficial logo for Rust programming language" />

</div>
      
   <div class="field field--name-field-caption field--type-text-long field--label-hidden caption field__item"><span class="caption__byline">Image by: </span><p>Opensource.com</p>
</div>

  </article>
</div>
      
  </div>
<div class="block block-layout-builder block-field-blocknodearticlebody">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>In my previous <a href="https://opensource.com/article/22/6/rust-toolchain-rustup" target="_blank">article about rustup</a>, I showed you how to install the Rust toolchain. Well, what good is the toolchain if you won’t be using it to get more hands-on with Rust? Learning any language involves reading existing code and writing a lot of sample programs. That's a good way to become proficient in a language. However, there's a third way: debugging code.</p>
<p>Learning through debugging involves trying to compile a pre-written (buggy) sample program, understanding the errors generated by the compiler, fixing the sample code, and then re-compiling it. Repeat that process until the code successfully compiles and runs.</p>
<p><a href="https://github.com/rust-lang/rustlings" target="_blank">Rustlings</a> is an open source project by the Rust team that helps you learn Rust through the process of debugging. It also provides you with a lot of hints along the way. If you're a beginner to Rust and have either started or completed reading the Rust book, then rustlings is the ideal next step. Rustlings helps you apply what you've learned from the book, and move to working on bigger projects.</p>
<h2>Installing rustlings</h2>
<p>I'm using (and recommend) a Fedora machine to try rustlings, but any Linux distribution works. To install rustlings, you must download and run its install script. It's recommended that you do this as a normal user (not root) without any special privileges.</p>
<p>Remember, for you to be able to use rustlings, you need the Rust toolchain available on your system. If you don't have that already, please refer to my <a href="https://opensource.com/article/22/6/rust-toolchain-rustup" target="_blank">article on rustup</a>.</p>
<p>Once you're ready, download the installation script:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ curl <span class="re5">-L</span> https:<span class="sy0">//</span>raw.githubusercontent.com<span class="sy0">/</span>rust-lang<span class="sy0">/</span>rustlings<span class="sy0">/</span>main<span class="sy0">/</span>install.sh  <span class="sy0">&gt;</span> rustlings_install.sh<br />
$ <span class="kw2">file</span> rustlings_install.sh<br />
rustlings_install.sh: Bourne-Again shell script, ASCII text executable</div></div></pre><p>Inspect the script to learn what it does:</p>
<pre>
<span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw2">less</span> rustlings_install.sh</code></span></pre><p>And then run it to install:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">bash</span> rustlings_install.sh<br />
<span class="br0">[</span>...<span class="br0">]</span><br />
Installing <span class="sy0">/</span>home<span class="sy0">/</span>tux<span class="sy0">/</span>.cargo<span class="sy0">/</span>bin<span class="sy0">/</span>rustlings<br />
Installed package <span class="sy0">`</span>rustlings v4.8.0 <span class="br0">(</span><span class="sy0">/</span>home<span class="sy0">/</span>tux<span class="sy0">/</span>rustlings<span class="br0">)</span><span class="sy0">`</span> <span class="br0">(</span>executable <span class="sy0">`</span>rustlings<span class="sy0">`</span><span class="br0">)</span><br />
All <span class="kw1">done</span><span class="sy0">!</span></div></div></pre><p>Run 'rustlings' to get started.</p>
<h2>Rustlings exercises</h2>
<p>The installation provides you with the <code>rustlings</code> command. Run it along with the <code>--help</code> flag to see what options are available.</p>
<pre>
<span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span>rustlings <span class="re5">--help</span></code></span></pre><p>The installation script also clones the rustlings Git repository, and installs all the dependencies required to run the sample programs. You can view the sample programs within the exercises directory under <code>rustlings</code>:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw3">cd</span> rustlings<br />
$ <span class="kw3">pwd</span><br />
<span class="sy0">/</span>home<span class="sy0">/</span>tux<span class="sy0">/</span>rustlings<br />
$ <span class="kw2">ls</span><br />
AUTHORS.md  Cargo.toml        CONTRIBUTING.md  info.toml install.sh README.md  target Cargo.lock  CHANGELOG.md  exercises install.ps1  LICENSE src tests<br />
$ <span class="kw2">ls</span> <span class="re5">-m</span> exercises<span class="sy0">/</span><br />
advanced_errors, clippy, collections, conversions, enums, error_handling, functions, generics, <span class="kw1">if</span>, intro, macros, mod.rs, <br />
modules, move_semantics, option, primitive_types, quiz1.rs, quiz2.rs, quiz3.rs, quiz4.rs, README.md, <br />
standard_library_types, <span class="kw2">strings</span>, structs, tests, threads, traits, variables</div></div></pre><h2>List all exercises from the command line</h2>
<p>The <code>rustlings</code> command provides you with a <code>list</code> command which displays each sample program, its complete path, and the status (which defaults to <strong>pending</strong>.)</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ rustlings list<br />
Name         Path                                 Status<br />
intro1       exercises<span class="sy0">/</span>intro<span class="sy0">/</span>intro1.rs            Pending<br />
intro2       exercises<span class="sy0">/</span>intro<span class="sy0">/</span>intro2.rs            Pending<br />
variables1   exercises<span class="sy0">/</span>variables<span class="sy0">/</span>variables1.rs    Pending<br />
variables2   exercises<span class="sy0">/</span>variables<span class="sy0">/</span>variables2.rs    Pending<br />
variables3   exercises<span class="sy0">/</span>variables<span class="sy0">/</span>variables3.rs    Pending<br />
<span class="br0">[</span>...<span class="br0">]</span></div></div></pre><p>Near the end of the output, you're given a progress report so you can track your work.</p>
<pre>
<span class="geshifilter"><code class="bash geshifilter-bash">Progress: You completed <span class="nu0">0</span> <span class="sy0">/</span> <span class="nu0">84</span> exercises <span class="br0">(</span><span class="nu0">0.00</span> <span class="sy0">%</span><span class="br0">)</span>.</code></span></pre><h2>View sample programs</h2>
<p>The <code>rustings list</code> command shows you what programs are available, so at any time you can view the code of those programs by copying the complete paths into your terminal as an argument for the <a href="https://opensource.com/article/19/2/getting-started-cat-command" target="_blank">cat</a> or <a href="https://opensource.com/article/18/4/using-less-view-text-files-command-line" target="_blank">less</a> commands:</p>
<pre>
<span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw2">cat</span> exercises<span class="sy0">/</span>intro<span class="sy0">/</span>intro1.rs</code></span></pre><h2>Verify your programs</h2>
<p>Now you can start debugging programs. You can do that using the <code>verify</code> command. Notice that rustlings chooses the first program in the list (<code>intro1.rs</code>), tries to compile it, and succeeds:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ rustlings verify<br />
Progress: <span class="br0">[</span>-----------------------------------<span class="br0">]</span> <span class="nu0">0</span><span class="sy0">/</span><span class="nu0">84</span><br />
✅ Successfully ran exercises<span class="sy0">/</span>intro<span class="sy0">/</span>intro1.rs<span class="sy0">!</span><br />
<br />
You can keep working on this exercise,<br />
or jump into the next one by removing the <span class="sy0">`</span>I AM NOT DONE<span class="sy0">`</span> comment:<br />
<br />
 <span class="nu0">6</span> <span class="sy0">|</span>  <span class="sy0">//</span> Execute the <span class="kw3">command</span> <span class="sy0">`</span>rustlings hint intro1<span class="sy0">`</span> <span class="kw1">for</span> a hint.<br />
 <span class="nu0">7</span> <span class="sy0">|</span>  <br />
 <span class="nu0">8</span> <span class="sy0">|</span>  <span class="sy0">//</span> I AM NOT DONE<br />
 <span class="nu0">9</span> <span class="sy0">|</span></div></div></pre><p>As you can see from the output, even though the sample code compiles, there's work yet to be done. Each sample program has the following comment in its source file:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">grep</span> <span class="st0">"NOT DONE"</span> exercises<span class="sy0">/</span>intro<span class="sy0">/</span>intro1.rs<br />
<span class="sy0">//</span> I AM NOT DONE</div></div></pre><p>Although the compilation of the first program worked fine, rustlings won't move to the next program until you remove the <code>I AM NOT DONE</code> comment.</p>
<p></p><div class="embedded-resource-list callout-float-right">
            <div class="field field--name-title field--type-string field--label-hidden field__item">Programming and development</div>
      
      <div class="field field--name-links field--type-link field--label-hidden field__items">
              <div class="field__item"><a href="https://developers.redhat.com/?intcmp=7016000000127cYAAQ">Red Hat Developers Blog</a></div>
              <div class="field__item"><a href="https://opensource.com/downloads/cheat-sheets?intcmp=7016000000127cYAAQ">Programming cheat sheets</a></div>
              <div class="field__item"><a href="https://www.redhat.com/en/services/training/learning-subscription?intcmp=7016000000127cYAAQ">Try for free: Red Hat Learning Subscription</a></div>
              <div class="field__item"><a href="https://opensource.com/downloads/bash-programming-guide?intcmp=7016000000127cYAAQ">eBook: An introduction to programming with Bash</a></div>
              <div class="field__item"><a href="https://developers.redhat.com/cheat-sheets/bash-shell-cheat-sheet?intcmp=7016000000127cYAAQ">Bash shell scripting cheat sheet</a></div>
              <div class="field__item"><a href="https://developers.redhat.com/e-books/modernizing-enterprise-java?intcmp=7016000000127cYAAQ">eBook: Modernizing Enterprise Java</a></div>
          </div>
  </div>
<h2>Moving to the next exercise</h2>
<p>Once you have removed the comment from <code>intro1.rs</code>, you can move to the next exercise by running the <code>rustlings verify</code> command again. This time, you may notice that rustlings tries to compile the next program (<code>intro2.rs</code>) in the series, but runs into an error. You're expected to debug that issue, fix it, and then move forward. This is a critical step, allowing you to understand why Rust says a program has bugs.</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ rustlings verify<br />
Progress: <span class="br0">[</span><span class="sy0">&gt;</span>------------------------<span class="br0">]</span> <span class="nu0">1</span><span class="sy0">/</span><span class="nu0">84</span><br />
⚠️  Compiling of exercises<span class="sy0">/</span>intro<span class="sy0">/</span>intro2.rs failed<span class="sy0">!</span> Please try again. Here<span class="st_h">'s the output:<br />
error: 1 positional argument in format string, but no arguments were given<br />
 --&gt; exercises/intro/intro2.rs:8:21<br />
  |<br />
8 |         println!("Hello {}!");<br />
  |                         ^^<br />
<br />
error: aborting due to previous error</span></div></div></pre><h2>Getting a hint</h2>
<p>Rustlings has a handy <code>hint</code> argument, which tells you exactly what's wrong with the sample program, and how to fix it. You can think of it as an add-on help option, in addition to what the compiler error message tells you.</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ rustlings hint intro2<br />
Add an argument after the format string.</div></div></pre><p>Based on the above hint, fixing the program is easy. All you need to do is add an additional argument to the <code>println</code> statement. This diff should help you understand the changes:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash"><span class="sy0">&lt;</span> println<span class="sy0">!</span><span class="br0">(</span><span class="st0">"Hello {}!"</span>, <span class="st0">"world"</span><span class="br0">)</span>;<br />
<span class="re5">---</span><br />
<span class="sy0">&gt;</span> println<span class="sy0">!</span><span class="br0">(</span><span class="st0">"Hello {}!"</span><span class="br0">)</span>;</div></div></pre><p>Once you make that change, and removed the <code>NOT DONE</code> comment from the source code, you can run <code>rustlings verify</code> again to compile and run the code.</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ rustlings verify<br />
Progress: <span class="br0">[</span><span class="sy0">&gt;</span>-------------------------------------<span class="br0">]</span> <span class="nu0">1</span><span class="sy0">/</span><span class="nu0">84</span><br />
✅ Successfully ran exercises<span class="sy0">/</span>intro<span class="sy0">/</span>intro2.rs<span class="sy0">!</span></div></div></pre><h2>Track progress</h2>
<p>You aren't going to finish all of the exercises in a day, and it's easy to lose track of where you left off. You can run the <code>list</code> command to see the status of your work.</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ rustlings list<br />
Name         Path                                  Status<br />
intro1       exercises<span class="sy0">/</span>intro<span class="sy0">/</span>intro1.rs             Done   <br />
intro2       exercises<span class="sy0">/</span>intro<span class="sy0">/</span>intro2.rs             Done   <br />
variables1   exercises<span class="sy0">/</span>variables<span class="sy0">/</span>variables1.rs     Pending<br />
variables2   exercises<span class="sy0">/</span>variables<span class="sy0">/</span>variables2.rs     Pending<br />
variables3   exercises<span class="sy0">/</span>variables<span class="sy0">/</span>variables3.rs     Pending<br />
<span class="br0">[</span>...<span class="br0">]</span></div></div></pre><h2>Run specific exercises</h2>
<p>If you don't want to start from the beginning and skip a few exercises, rustlings allows you to focus on specific exercises using the <code>rustlings run</code> command. This runs a specific program without requiring the previous lesson to be verified. For example:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ rustlings run intro2<br />
Hello world<span class="sy0">!</span><br />
✅ Successfully ran exercises<span class="sy0">/</span>intro<span class="sy0">/</span>intro2.rs<br />
$ rustlings run variables1</div></div></pre><p>Typing exercise names can become tedious, but rustlings provides you with a handy <code>next</code> command so you can move to the next exercise in the series.</p>
<pre>
<span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span>rustlings run next</code></span></pre><h2>Alternative watch command</h2>
<p>If you don't want to keep typing <code>verify</code> after each modification you make, you can run the <code>watch</code> command in a terminal window, and then keep modifying the source code to fix issues. The <code>watch</code> command detects these modifications, and keeps re-compiling the program to see whether the issue has been fixed.</p>
<pre>
<span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span>rustlings <span class="kw2">watch</span></code></span></pre><h2>Learn by debugging</h2>
<p>The Rust compiler is known to provide very meaningful error messages, which helps you understand issues in your code. This usually leads to faster debugging. Rustlings is a great way to practice Rust, to get used to reading error messages, and understand the Rust language. Check out the recent features of Rustlings 5.0.0 on <a href="https://github.com/rust-lang/rustlings/releases/tag/5.0.0" target="_blank">GitHub</a>.</p>
<p><strong>[ Practice programming with Rust. Download our <a href="https://opensource.com/downloads/rust-cheat-sheet" target="_blank">Rust cheat sheet</a>. ]</strong></p>
</div>
      
  </div>
<div class="block block-layout-builder block-field-blocknodearticlefield-listicle-title">
  
    
      
            <div class="hidden field field--name-field-listicle-title field--type-string field--label-hidden field__item">What to read next</div>
      
  </div>
<div class="block block-layout-builder block-field-blocknodearticlefield-tags">
  
    
      
  <div class="field field--name-field-tags field--type-entity-reference field--label-inline clearfix">
    <div class="field__label">Tags</div>
          <div class="field__items">
              <div class="field__item"><a href="/tags/rust" hreflang="en">Rust</a></div>
          <div class="field__item"><a href="/tags/programming" hreflang="en">Programming</a></div>
              </div>
      </div>

  </div>
<div class="views-element-container author-block block block-views block-views-blockauthor-info-author-info">
  <div class="author-block__wrapper">
  
    
      <div><div class="view view-author-info view-id-author_info view-display-id-author_info js-view-dom-id-421e8c3dc27929a9b6017afd8b58633605502055d7918a1f29bdeebef33a4db2">
  
    
      
      <div class="view-content">
          <div class="views-row"><div class="views-field views-field-field-display-name"><div class="field-content"><a href="/users/gkamathe" hreflang="en">Gaurav Kamathe</a></div></div><div class="views-field views-field-field-user-picture"><div class="field-content">  <img src="/sites/default/files/styles/150x150/public/pictures/pic1_0.png?itok=dDmgIQTi" width="150" height="150" loading="lazy" class="image-style-_50x150" />


</div></div><div class="views-field views-field-field-user-about"><span class="field-content">Seasoned Software Engineering professional.
Primary interests are Security, Linux, Malware.
Loves working on the command-line.
Interested in low-level software and understanding how things work.
Opinions expressed here are my own and not that of my employer
</span></div><div class="views-field views-field-nothing"><span class="field-content"><a href="/users/gkamathe">More about me</a></span></div></div>

    </div>
  
      
          </div>
</div>

    </div>
</div>


<div class="views-element-container author-block block block-views block-views-blockauthor-info-block-1">
  <div class="author-block__wrapper plain">
  
    
      <div><div class="view view-author-info view-id-author_info view-display-id-block_1 js-view-dom-id-f0df95d08498a38ede0c1db287d90f1ed6a4ccc83515a288840736fb6137cd12">
  
    
      
  
      
          </div>
</div>

    </div>
</div>


<div class="block block-layout-builder block-field-blocknodearticlefield-comments">
  
    
      <section id='comments'  class="field field--name-field-comments field--type-comment field--label-hidden comment-wrapper">
  

  <div class="comments__count">
                  <div class="login"><a href="/user/register?absolute=1">Register</a> or <a href="/user/login?current=/node/70126&amp;absolute=1">Login</a> to post a comment.</div>
  </div>

  
  
</section>

  </div>
<div class="views-element-container related-articles block block-views block-views-blockrelated-articles-related-articles">
  
      <h2 class="related-articles__title">Related Content</h2>
    
      <div><div class="view view-related-articles view-id-related_articles view-display-id-related_articles js-view-dom-id-2f454baa2ab261d9f8c39e938138f95142787567f92f442c8f7a72ac1c8e0ac5">
  
    
      
      <div class="view-content">
          <div class="views-row"><div class="views-field views-field-field-lead-image"><div class="field-content">  <a href="/article/22/6/rust-toolchain-rustup" hreflang="en"><img src="/sites/default/files/styles/222x125/public/lead-images/tools_hardware_purple.png?itok=wf-JBwrN" width="222" height="125" alt="Tools illustration" title="Tools illustration" loading="lazy" class="image-style-_22x125" />

</a>
</div></div><div class="views-field views-field-title"><span class="field-content"><a href="/article/22/6/rust-toolchain-rustup" hreflang="en">Manage your Rust toolchain using rustup</a></span></div></div>
    <div class="views-row"><div class="views-field views-field-field-lead-image"><div class="field-content">  <a href="/article/22/1/rust-cheat-sheet" hreflang="und"><img src="/sites/default/files/styles/222x125/public/lead-images/coverimage_cheat_sheet.png?itok=mBYwSlG_" width="222" height="125" alt="Blender Hotkey Cheat Sheet" title="Blender Hotkey Cheat Sheet" loading="lazy" class="image-style-_22x125" />

</a>
</div></div><div class="views-field views-field-title"><span class="field-content"><a href="/article/22/1/rust-cheat-sheet" hreflang="und">Learn Rust in 2022</a></span></div></div>
    <div class="views-row"><div class="views-field views-field-field-lead-image"><div class="field-content">  <a href="/article/21/10/rust-embedded-development" hreflang="und"><img src="/sites/default/files/styles/222x125/public/lead-images/rust_programming_crab_sea.png?itok=W-6ic-Ka" width="222" height="125" alt="Ferris the crab under the sea, unofficial logo for Rust programming language" title="Ferris the crab under the sea, unofficial logo for Rust programming language" loading="lazy" class="image-style-_22x125" />

</a>
</div></div><div class="views-field views-field-title"><span class="field-content"><a href="/article/21/10/rust-embedded-development" hreflang="und">Use Rust for embedded development</a></span></div></div>

    </div>
  
          </div>
</div>

  </div>

<div class="block block-layout-builder block-field-blocknodearticlefield-default-license">
  
    
      
            <div class="field field--name-field-default-license field--type-list-string field--label-hidden field__item"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" src="/themes/osdc/assets/img/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a>This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License.</div>
      
  </div>

    </div>
  </div>

  </div>
</article>




  </div>
<div id="block-socialmediashareicons" class="block block-osdc-system block-osdc-social-block">
  
    
      <div><a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A//red.ht/3v4HNH8&amp;title=Learn%20Rust%20by%20debugging%20Rust&amp;summary=Rustlings%20is%20an%20open%20source%20project%20by%20the%20Rust%20team%20that%20helps%20you%20learn%20Rust%20through%20the%20process%20of%20debugging.&amp;source=Opensource.com" class="linkedin-icon">LinkedIn</a><a href="https://twitter.com/intent/tweet?text=Learn%20Rust%20by%20debugging%20Rust%20https%3A//red.ht/3v4HNH8%20via%20%40opensourceway%20by%20%40kamatheg&amp;related=opensourceway%2Ckamatheg" class="twitter-icon">Twitter</a><a href="https://www.facebook.com/sharer.php?u=https%3A//red.ht/3v4HNH8" class="facebook-icon">Facebook</a><a href="https://api.whatsapp.com/send?text=Learn%20Rust%20by%20debugging%20Rust%20%7C%20Opensource.com%20https%3A//red.ht/3v4HNH8" class="whatsapp-icon">WhatsApp</a><a href="mailto:?subject=Learn%20Rust%20by%20debugging%20Rust%20%7C%20OpenSource.com&amp;body=https%3A//red.ht/3v4HNH8" class="email-icon">Email</a><a href="https://www.reddit.com/submit?url=https%3A//red.ht/3v4HNH8&amp;title=Learn%20Rust%20by%20debugging%20Rust%20%7C%20OpenSource.com" class="reddit-icon">Reddit</a><pfe-modal><button slot="pfe-modal--trigger" class="mastodon-icon"><span class="screen-reader-text">Mastodon</span></button><div id="mastodon-container"></div></pfe-modal><form id="mastodon-form" class="mastodon-form" data-drupal-selector="mastodon-form" action="/article/22/7/learn-rust-rustlings" method="post" accept-charset="UTF-8">
  <div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-mastodon-url form-item-mastodon-url">
      <label for="edit-mastodon-url">Location of your Mastodon instance:</label>
        <input data-drupal-selector="edit-mastodon-url" type="text" id="edit-mastodon-url" name="mastodon_url" value="" size="60" maxlength="128" class="form-text" />

        </div>
<input autocomplete="off" data-drupal-selector="form-epgncqw3eabq6-zafaoe-0ha4-jlrfxw7cuu4jelvu" type="hidden" name="form_build_id" value="form-EPGncQW3eABq6-ZAFAOE_-0ha4-jLRfxW7CUU4JelvU" />
<input data-drupal-selector="edit-mastodon-form" type="hidden" name="form_id" value="mastodon_form" />
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions"><input data-query="?url=https://red.ht/3v4HNH8&amp;text=Learn Rust by debugging Rust | OpenSource.com" data-drupal-selector="edit-submit" type="submit" id="edit-submit" name="op" value="Toot" class="button button--primary js-form-submit form-submit" />
</div>

</form>
</div>

  </div>

<div id="subscribe-cta" class="subscribe-cta block block-block-content block-block-contente8c82e66-7bc7-4c25-9c7c-f7bbdcb3c2d3">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><div class="cta__text-and-form">
<div class="cta__text">
<h2 class="cta__title">Subscribe to our weekly newsletter</h2>
</div>
<div class="cta__form">
<iframe class="eloqua-embedded-bottom" frameborder="0" height="192" id="fkfkx" scrolling="no" src="https://opensource.com/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></div>
<p><a href="https://www.redhat.com/footer/privacy-policy.html" target="_blank">Privacy Statement</a></p>
</div>
</div>
      
  </div>


  </div>

    </div>
  </main>

      <footer class="global_footer">
      <div class="wrapper">
          <div class="region region-left-footer">
    <div id="block-aboutthissitefooter" class="block block-block-content block-block-content1d00183d-1f84-4ed3-9367-c632014cd322">
  
      <h2>About This Site</h2>
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>
<p><a href="https://opensource.com/">Opensource.com</a> aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
<p>A note on advertising: Opensource.com does not sell advertising on the site or in any of its newsletters.</p>
</div>
      
  </div>

  </div>

          <div class="region region-right-footer">
    <div id="block-connectfooter" class="block block-block-content block-block-content04a63217-9bba-49ac-9d2c-b2eb30fb8526">
  
      <h2>Contact</h2>
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p class="footer-twitter"><a href="https://twitter.com/OpenSourceWay" target="_blank">Follow us @opensource.com on Twitter</a></p>
<p class="footer-facebook"><a href="https://www.facebook.com/opensourceway" target="_blank">Like Opensource.com on Facebook</a></p>
<p class="footer-youtube"><a href="http://www.youtube.com/opensourceway" target="_blank">Watch us at Opensource.com</a></p>
<p class="footer-mastodon"><a href="https://fosstodon.org/@osdc">Follow us on Mastodon</a></p>
<p class="footer-rss"><a href="https://opensource.com/feed">RSS Feed</a></p>
</div>
      
  </div>
<div id="block-sitebranding" class="block block-system block-system-branding-block">
  
    
    <div class="branding">
          <a href="/" rel="home" aria-label="" class="branding__logo">
        <img src="/themes/osdc/logo.svg" alt="Home"/>
      </a>
      </div>
</div>

  </div>

          <div class="region region-copyright">
    <div id="block-copyrightfooter" class="block block-block-content block-block-contentc0a744a4-2740-4f8a-a693-ee8d7cb5ff86">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>Copyright ©<span id="copyright-year">2021</span> Red Hat, Inc.</p>
</div>
      
  </div>
<nav role="navigation" aria-labelledby="block-legal-menu" id="block-legal" class="block block-menu navigation menu--legal">
            
  <h2 class="visually-hidden" id="block-legal-menu">Legal</h2>
  

        
              <ul class="menu">
                    <li class="menu-item">
        <a href="/privacy-policy" data-drupal-link-system-path="node/17705">Privacy Policy</a>
              </li>
                <li class="menu-item">
        <a href="/legal" data-drupal-link-system-path="legal">Terms of use</a>
              </li>
                <li class="menu-item">
        <a href="/contact" data-drupal-link-system-path="node/68921">Contact</a>
              </li>
        </ul>
  


  </nav>

  </div>

      </div>
    </footer>
  
</div>
  </div>

    
    <script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/70126","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ajaxPageState":{"libraries":"classy\/base,classy\/messages,classy\/node,codesnippet\/codesnippet.highlightjs,codesnippet\/codesnippet.style.vs,core\/normalize,geshifilter\/geshifilter,layout_discovery\/onecol,osdc\/author-block,osdc\/author-meta,osdc\/global,osdc\/poll,osdc\/related-content,osdc\/search,osdc\/social-shares,osdc\/subscribe-float,poll\/drupal.poll-links,rate\/thumbs-up,system\/base,views\/views.module","theme":"osdc","theme_token":null},"ajaxTrustedUrl":{"form_action_p_pvdeGsVG5zNF_XLGPTvYSKCf43t8qZYSwcfZl2uzM":true,"\/site-search":true},"user":{"uid":0,"permissionsHash":"af4858ad1c65186ac44e3cbfc73c8006e4259986d4e743bd7f73e117f9447519"}}</script>
<script src="/sites/default/files/js/js_husSYrzUWeiB1ynd2OR98yjZPlgHRjVEgB-r5u7Eihc.js"></script>
<script src="/themes/osdc/node_modules/%40patternfly/pfe-readtime/dist/pfe-readtime.min.js?rfqt0k" type="module"></script>
<script src="/sites/default/files/js/js_BFaDpbcHG59nVAH3cj-Hr9GgoAwTXjTzni2UpwOaR2A.js"></script>

  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"NRJS-6128485344987227876","applicationID":"1384502491","transactionName":"NlJbMERZV0FXBURbDA8YeAdCUVZcGSJCRxMAW2UKWVxcbnUJXkYRDltVAURkd11SA2ZbBhZ0VgpCSlZeWgNCH10XXlwT","queueTime":0,"applicationTime":385,"atts":"GhVYRgxDRE8=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
