<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html class="no-js"  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema# schema: http://schema.org/"><!--<![endif]-->

<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
  <meta charset="utf-8" /><script type="text/javascript">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</script>
<link href="https://opensource.com/rss.xml" rel="alternate" type="application/rss+xml" title="Opensource.com RSS" />
<link rel="shortcut icon" href="https://opensource.com/sites/all/themes/opensource/favicon.ico" type="image/vnd.microsoft.icon" />
<script src="https://www.google.com/recaptcha/api.js?hl=en" async="async" defer="defer"></script>
<meta name="description" content="Learn how to use some of the lesser-known features of gdb to inspect and fix your code." />
<meta name="rating" content="general" />
<meta name="referrer" content="no-referrer" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://opensource.com/article/19/9/tips-gnu-debugger" />
<link rel="shortlink" href="https://opensource.com/node/56066" />
<meta name="revisit-after" content="1 day" />
<meta property="og:site_name" content="Opensource.com" />
<meta property="og:url" content="https://opensource.com/article/19/9/tips-gnu-debugger" />
<meta property="og:type" content="article" />
<meta property="og:title" content="5 tips for GNU Debugger" />
<meta property="og:description" content="The GNU Debugger (gdb) is an invaluable tool for inspecting running processes and fixing problems while you&#039;re developing programs. You can set breakpoints at specific locations (by function name, line number, and so on), enable and disable those breakpoints, display and alter variable values, and do all the standard things you would expect any debugger to do. But it has many other features you might not have experimented with. Here are five for you to try." />
<meta property="og:image" content="https://opensource.com/sites/default/files/lead-images/bug_software_issue_tracking_computer_screen.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@opensourceway" />
<meta name="twitter:creator" content="@" />
<meta name="twitter:title" content="5 tips for GNU Debugger" />
<meta name="twitter:description" content="The GNU Debugger (gdb) is an invaluable tool for inspecting running processes and fixing problems while you&#039;re developing programs. You can set breakpoints at specific locations (by function name, line number, and so on), enable and disable those breakpoints, display and alter variable values, and do all the standard things you would expect any debugger to do. But it has many other features you might not have experimented with. Here are five for you to try." />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/lead-images/bug_software_issue_tracking_computer_screen.jpg" />
  <title>5 tips for GNU Debugger | Opensource.com</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_rPk7Et6wjNyH7pw3qgw9a85Yiqd9m38Ov-4hY99oyhM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_vamxBRmWk2Q7fxdiL4tDdJ_YjZN5fmFXzhYuV4x6kIk.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_1HAxiQy0ym2_Wq8hTu-6qsXiyLz9C2U7glSaTTu6UTk.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_v0CtiJaVnDK75UyA4_mnXJcPqXTFFDc4Qj3KIXRXBJU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_PxsPpITToy8ZnO0bJDA1TEC6bbFpGTfSWr2ZP8LuFYo.css" media="all" />
  <script src="/sites/all/themes/opensource/js/use-typekit.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  <script src="https://opensource.com/sites/default/files/js/js_0RyHJ63yYLuaWsodCPCgSD8dcTIA0dqcDf8-7c2XdBw.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_R9xDkoIXbrDQhdBhQ3W4GF5TzHxKYFK0UB8wjqE0DbE.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_tBWHhFjU_NjWsmd07Hrx5ScmFu-4-PJD_GwzNMH3UwA.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_VQpdyHm5xCOVZuJDT1qsHx0ol1ROIpb8g515ZxRqX4o.js"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-33294138-1", {"cookieDomain":".opensource.com"});ga("send", "pageview");</script>
<script src="https://opensource.com/sites/default/files/js/js_rVcPYhZ5_LfvT-dWbCnRngMcccEhwUaw2iNYx0yXj_Q.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_KbByFnBctcQt9juhHXNabaQDr4mJAc1OExQYJ-HcyXk.js"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-56066 node-type-article region-content section-article page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<header class="header" id="header" role="banner">

    
    <div class="header-banner">
      <div class="header-banner__inner">
                  <div class="header__name-and-slogan" id="name-and-slogan">
                          <div class="header__site-name" id="site-name">
                <a href="/" title="Home" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/logo.svg" onerror="this.src='/sites/all/themes/opensource/logo.png';this.onerror=null;" /></a>
                <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" title="Home" class="header__sponsor-link" rel="home"><img alt="RedHat" src="/sites/all/themes/opensource/images/redhat-logo.svg" onerror="this.src='/sites/all/themes/opensource/images/redhat-logo.png';this.onerror=null;"/></a>
              </div>
            
                      </div>
                <nav class="desktop-user-links">
            <div class="header__region region region-header">
    <div id="block-menu-block-1" class="block block-menu-block first last odd" role="navigation">

      
  <div class="menu-block-wrapper menu-block-1 menu-name-user-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-195"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1179"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul></div>

</div>
  </div>
        </nav>
      </div>
    </div>

    <div class="sf-nav">
      <div class="sf-nav__inner">
          <div class="js-mobile-header-buttons region region-navigation-top">
    <div id="block-os-solr-search-form" class="block block-os-solr-search first odd">

      
  <form action="/article/19/9/tips-gnu-debugger" method="post" id="os-search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search">
  <label class="element-invisible" for="edit-search">Search </label>
 <input title="Enter the terms you wish to search for." placeholder="Search opensource.com" type="text" id="edit-search" name="search" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="GO" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-f-dzpn_pmo_Rqbl2DTJwrp4IWtnzT7xmxkvuAtu3Ncs" />
<input type="hidden" name="form_id" value="os_search_block_form" />
</div>
</div></form>
</div>
<div id="block-superfish-1" class="block block-superfish even">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-default sf-total-items-5 sf-parent-items-5 sf-single-items-0"><li id="menu-1906-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-10 sf-parent-children-4 sf-single-children-6 menuparent"><a href="/" title="" class="sf-depth-1 menuparent">Articles</a><ul><li id="menu-12341-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/containers" title="" class="sf-depth-2">Containers</a></li><li id="menu-12416-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/devops" title="" class="sf-depth-2">DevOps</a></li><li id="menu-12346-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/tags/gaming" title="" class="sf-depth-2">Gaming</a></li><li id="menu-17776-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/tags/government" title="" class="sf-depth-2">Government</a></li><li id="menu-12351-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/hardware" title="" class="sf-depth-2 menuparent">Hardware</a><ul><li id="menu-12376-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/3d-printing" title="" class="sf-depth-3">3D printing</a></li><li id="menu-12386-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/arduino" title="" class="sf-depth-3">Arduino</a></li><li id="menu-12381-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/raspberry-pi" title="" class="sf-depth-3">Raspberry Pi</a></li></ul></li><li id="menu-1946-1" class="middle even sf-item-6 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/tags/law" title="" class="sf-depth-2 menuparent">Law</a><ul><li id="menu-12391-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/licensing" title="" class="sf-depth-3">Licensing</a></li><li id="menu-12396-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/patents" title="" class="sf-depth-3">Patents</a></li></ul></li><li id="menu-12356-1" class="middle odd sf-item-7 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/tags/linux" title="" class="sf-depth-2 menuparent">Linux</a><ul><li id="menu-19831-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/command-line" title="" class="sf-depth-3">Command line</a></li></ul></li><li id="menu-12361-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="/tags/openstack" title="" class="sf-depth-2">OpenStack</a></li><li id="menu-12366-1" class="middle odd sf-item-9 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/programming" title="" class="sf-depth-2 menuparent">Programming</a><ul><li id="menu-17771-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/go" title="" class="sf-depth-3">Go</a></li><li id="menu-12411-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/javascript" title="" class="sf-depth-3">JavaScript</a></li><li id="menu-12406-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/python" title="" class="sf-depth-3">Python</a></li></ul></li><li id="menu-12371-1" class="last even sf-item-10 sf-depth-2 sf-no-children"><a href="/tags/sysadmin" title="" class="sf-depth-2">SysAdmin</a></li></ul></li><li id="menu-1921-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-6 sf-parent-children-3 sf-single-children-3 menuparent"><a href="/resources" title="" class="sf-depth-1 menuparent">Resources</a><ul><li id="menu-19841-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/resources/what-open-source" title="" class="sf-depth-2 menuparent">What is open source?</a><ul><li id="menu-1991-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-source-way" class="sf-depth-3">The open source way</a></li></ul></li><li id="menu-2016-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/projects-and-applications" title="" class="sf-depth-2">Projects and applications</a></li><li id="menu-2021-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/resources/organizations" title="" class="sf-depth-2">Organizations</a></li><li id="menu-5556-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-13 sf-parent-children-1 sf-single-children-12 menuparent"><a href="/resources/cloud" title="" class="sf-depth-2 menuparent">Cloud technology</a><ul><li id="menu-5576-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/resources/big-data" title="" class="sf-depth-3">Big data</a></li><li id="menu-19861-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/data-science" title="" class="sf-depth-3">Data science</a></li><li id="menu-5566-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/resources/what-docker" title="" class="sf-depth-3">Docker</a></li><li id="menu-19926-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/resources/what-is-git" title="" class="sf-depth-3">Git</a></li><li id="menu-5591-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/internet-of-things" title="" class="sf-depth-3">Internet of things</a></li><li id="menu-19921-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/resources/java" title="" class="sf-depth-3">Java</a></li><li id="menu-5596-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/resources/what-is-kubernetes" title="" class="sf-depth-3">Kubernetes</a></li><li id="menu-5571-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/resources/what-are-linux-containers" title="" class="sf-depth-3">Linux containers</a></li><li id="menu-5586-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/resources/what-are-microservices" title="" class="sf-depth-3">Microservices</a></li><li id="menu-5561-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/resources/what-is-openstack" title="" class="sf-depth-3">OpenStack</a></li><li id="menu-19836-1" class="middle odd sf-item-11 sf-depth-3 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/resources/python" title="" class="sf-depth-3 menuparent">Python</a><ul><li id="menu-19866-1" class="first odd sf-item-1 sf-depth-4 sf-no-children"><a href="/resources/python/gui-frameworks" title="" class="sf-depth-4">Python GUI frameworks</a></li><li id="menu-19871-1" class="middle even sf-item-2 sf-depth-4 sf-no-children"><a href="/resources/python/ides" title="" class="sf-depth-4">Python IDEs</a></li><li id="menu-19881-1" class="middle odd sf-item-3 sf-depth-4 sf-no-children"><a href="/resources/python/template-libraries" title="" class="sf-depth-4">Python template libraries</a></li><li id="menu-19876-1" class="last even sf-item-4 sf-depth-4 sf-no-children"><a href="/resources/python/web-scraper-crawler" title="" class="sf-depth-4">Python web scrapers</a></li></ul></li><li id="menu-5581-1" class="middle even sf-item-12 sf-depth-3 sf-no-children"><a href="/resources/what-is-software-defined-networking" title="" class="sf-depth-3">Software defined networking</a></li><li id="menu-12601-1" class="last odd sf-item-13 sf-depth-3 sf-no-children"><a href="/resources/virtualization" title="" class="sf-depth-3">Virtualization</a></li></ul></li><li id="menu-2036-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-11 sf-parent-children-0 sf-single-children-11 menuparent"><a href="/alternatives" title="" class="sf-depth-2 menuparent">Open source alternatives</a><ul><li id="menu-4646-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/alternatives/adobe-acrobat" class="sf-depth-3">Alternatives to Acrobat</a></li><li id="menu-4656-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/alternatives/autocad" class="sf-depth-3">Alternatives to AutoCAD</a></li><li id="menu-4636-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/alternatives/dreamweaver" class="sf-depth-3">Alternatives to Dreamweaver</a></li><li id="menu-5506-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/alternatives/gmail" class="sf-depth-3">Alternatives to Gmail</a></li><li id="menu-5551-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/alternatives/matlab" class="sf-depth-3">Alternatives to MATLAB</a></li><li id="menu-5501-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/alternatives/minecraft" class="sf-depth-3">Alternatives to Minecraft</a></li><li id="menu-4651-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/alternatives/picasa" class="sf-depth-3">Alternatives to Picasa</a></li><li id="menu-4661-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/alternatives/microsoft-publisher" class="sf-depth-3">Alternatives to Publisher</a></li><li id="menu-5511-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/alternatives/slack" class="sf-depth-3">Alternatives to Slack</a></li><li id="menu-4641-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/alternatives/trello" class="sf-depth-3">Alternatives to Trello</a></li><li id="menu-5546-1" class="last odd sf-item-11 sf-depth-3 sf-no-children"><a href="/alternatives" title="" class="sf-depth-3">More...</a></li></ul></li><li id="menu-19886-1" class="last even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/linux" title="" class="sf-depth-2">Linux</a></li></ul></li><li id="menu-19666-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-6 sf-parent-children-6 sf-single-children-0 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-1 menuparent">Downloads</a><ul><li id="menu-19406-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-16 sf-parent-children-0 sf-single-children-16 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Cheat sheets</a><ul><li id="menu-19651-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-awk-features" class="sf-depth-3">AWK cheat sheet</a></li><li id="menu-18641-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/blender-hotkey-cheat-sheet" class="sf-depth-3">Blender cheat sheet</a></li><li id="menu-18856-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/downloads/freedos-commands-cheat-sheet" class="sf-depth-3">FreeDOS cheat sheet</a></li><li id="menu-19721-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/content/cheat-sheet-gimp" class="sf-depth-3">GIMP cheat sheet</a></li><li id="menu-19696-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-gnome-3" class="sf-depth-3">GNOME cheat sheet</a></li><li id="menu-18661-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/downloads/groff-macros-cheat-sheet" class="sf-depth-3">Groff macros cheat sheet</a></li><li id="menu-19731-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/downloads/go-cheat-sheet" class="sf-depth-3">Go cheat sheet</a></li><li id="menu-19716-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-i3-window-manager-keybinding" class="sf-depth-3">i3 window manager cheat sheet</a></li><li id="menu-19781-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/downloads/inkscape-cheat-sheet" class="sf-depth-3">Inkscape Cheat Sheet</a></li><li id="menu-16886-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/irc-cheat-sheet" class="sf-depth-3">IRC cheat sheet</a></li><li id="menu-19301-1" class="middle odd sf-item-11 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-networking" class="sf-depth-3">Networking cheat sheet</a></li><li id="menu-18636-1" class="middle even sf-item-12 sf-depth-3 sf-no-children"><a href="/downloads/pandoc-cheat-sheet" class="sf-depth-3">Pandoc cheat sheet</a></li><li id="menu-19711-1" class="middle odd sf-item-13 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-python-37-beginners" class="sf-depth-3">Python 3.7 cheat sheet</a></li><li id="menu-19726-1" class="middle even sf-item-14 sf-depth-3 sf-no-children"><a href="/downloads/getting-started-raspberry-pi-cheat-sheet" class="sf-depth-3">Raspberry Pi cheat sheet</a></li><li id="menu-19691-1" class="middle odd sf-item-15 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-selinux" class="sf-depth-3">SELinux cheat sheet</a></li><li id="menu-18591-1" class="last even sf-item-16 sf-depth-3 sf-no-children"><a href="/downloads/advanced-ssh-cheat-sheet" class="sf-depth-3">SSH cheat sheet</a></li></ul></li><li id="menu-12466-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/yearbook/2017" title="" class="sf-depth-2 menuparent">Open Source Yearbook</a><ul><li id="menu-19681-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/yearbook/2015" title="" class="sf-depth-3">2015</a></li><li id="menu-19676-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/yearbook/2016" title="" class="sf-depth-3">2016</a></li><li id="menu-19671-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/yearbook/2017" title="" class="sf-depth-3">2017</a></li><li id="menu-19786-1" class="last even sf-item-4 sf-depth-3 sf-no-children"><a href="/yearbook/2018" title="" class="sf-depth-3">2018</a></li></ul></li><li id="menu-19906-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Programming guides</a><ul><li id="menu-19891-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/7-essential-pypi-libraries" title="" class="sf-depth-3">7 essential PyPI libraries</a></li></ul></li><li id="menu-19911-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">DevOps guides</a><ul><li id="menu-19806-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/devops-transformation" class="sf-depth-3">Starting a DevOps transformation</a></li><li id="menu-19776-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/small-scale-scrum" class="sf-depth-3">Introduction to Small Scale Scrum</a></li><li id="menu-19771-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/downloads/devsecops" class="sf-depth-3">Getting started with DevSecOps</a></li><li id="menu-19701-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/downloads/devops-monitoring-guide" class="sf-depth-3">DevOps monitoring tools guide</a></li><li id="menu-19686-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/devops-hiring-guide" class="sf-depth-3">DevOps hiring guide</a></li></ul></li><li id="menu-19916-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Sysadmin guides</a><ul><li id="menu-19801-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="https://opensource.com/downloads/ansible-quickstart" title="" class="sf-depth-3">Ansible Automation for Sysadmins</a></li><li id="menu-19706-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/containers-primer" class="sf-depth-3">Containers primer</a></li></ul></li><li id="menu-19901-1" class="last even sf-item-6 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">E-books</a><ul><li id="menu-19896-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/kubernetes-dump-truck" title="" class="sf-depth-3">Kubernetes is a dump truck</a></li></ul></li></ul></li><li id="menu-4691-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-5 sf-parent-children-2 sf-single-children-3 menuparent"><a href="/about" class="sf-depth-1 menuparent">About</a><ul><li id="menu-12516-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-7 sf-parent-children-0 sf-single-children-7 menuparent"><a href="/participate" class="sf-depth-2 menuparent">Join us</a><ul><li id="menu-12521-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/user/register" title="" class="sf-depth-3">Register</a></li><li id="menu-12526-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/rules-comments-and-discussions" class="sf-depth-3">Rules for comments and discussions</a></li><li id="menu-17781-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/devops-team" class="sf-depth-3">Contribute to DevOps resources</a></li><li id="menu-12531-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/community-moderator-program" class="sf-depth-3">Community Moderator program</a></li><li id="menu-12581-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/contributor-club" title="" class="sf-depth-3">Contributor Club</a></li><li id="menu-12541-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/points-and-badges" class="sf-depth-3">Points and badges</a></li><li id="menu-17766-1" class="last odd sf-item-7 sf-depth-3 sf-no-children"><a href="/delete-account" title="" class="sf-depth-3">Delete your account</a></li></ul></li><li id="menu-1966-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-6 sf-parent-children-0 sf-single-children-6 menuparent"><a href="/writers" title="" class="sf-depth-2 menuparent">For writers</a><ul><li id="menu-17761-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/how-submit-article" class="sf-depth-3">Write for us</a></li><li id="menu-12546-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/editorial-calendar" title="" class="sf-depth-3">Editorial calendar</a></li><li id="menu-12586-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/article/19/1/write-for-us" title="" class="sf-depth-3">Writing topics</a></li><li id="menu-2041-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/submission-style-guide" class="sf-depth-3">Article submission and style guide</a></li><li id="menu-4616-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/promoting-articles" class="sf-depth-3">Tips for promoting your Opensource.com article</a></li><li id="menu-12556-1" class="last even sf-item-6 sf-depth-3 sf-no-children"><a href="/writer-testimonials" class="sf-depth-3">Writer testimonials</a></li></ul></li><li id="menu-1971-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/opensourcecom-team" class="sf-depth-2">Meet the team</a></li><li id="menu-2006-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/press-kit" class="sf-depth-2">Press kit</a></li><li id="menu-2001-1" class="last odd sf-item-5 sf-depth-2 sf-no-children"><a href="/contact" title="" class="sf-depth-2">Contact</a></li></ul></li><li id="menu-2136-1" class="last odd sf-item-5 sf-depth-1 sf-total-children-5 sf-parent-children-3 sf-single-children-2 menuparent"><a href="/open-organization" title="" class="sf-depth-1 menuparent">Open Organization</a><ul><li id="menu-12471-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="sf-depth-2">What is an open organization?</a></li><li id="menu-15056-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-maturity-model" title="" class="sf-depth-2">How open is your organization?</a></li><li id="menu-15051-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-6 sf-parent-children-0 sf-single-children-6 menuparent"><a href="/open-organization/resources/book-series" title="" class="sf-depth-2 menuparent">Book series</a><ul><li id="menu-16906-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/field-guide" title="" class="sf-depth-3">Field Guide</a></li><li id="menu-16891-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/leaders-manual" class="sf-depth-3">Leaders Manual</a></li><li id="menu-16896-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/culture-change" title="" class="sf-depth-3">Guide to IT Culture Change</a></li><li id="menu-19856-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/educators-guide" class="sf-depth-3">Guide for Educators</a></li><li id="menu-17796-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/workbook" title="" class="sf-depth-3">Workbook</a></li><li id="menu-18656-1" class="last even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/organize-innovation" title="" class="sf-depth-3">Organize for Innovation</a></li></ul></li><li id="menu-2146-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-8 sf-parent-children-0 sf-single-children-8 menuparent"><a href="/open-organization/resources" title="" class="sf-depth-2 menuparent">Resources</a><ul><li id="menu-2181-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/what-open-organization" title="" class="sf-depth-3">What is The Open Organization?</a></li><li id="menu-12421-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-decision-framework" title="" class="sf-depth-3">What is the Open Decision Framework?</a></li><li id="menu-2151-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/guides" title="" class="sf-depth-3">Discussion guide download</a></li><li id="menu-17821-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/newsletter" class="sf-depth-3">Newsletter sign-up</a></li><li id="menu-2246-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/faq" title="" class="sf-depth-3">Open Org FAQs</a></li><li id="menu-4606-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/twitter-chats" title="" class="sf-depth-3">Twitter chats</a></li><li id="menu-3201-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/open-organization/resources/reading-list" title="" class="sf-depth-3">Reading list</a></li><li id="menu-2256-1" class="last even sf-item-8 sf-depth-3 sf-no-children"><a href="/open-organization/resources/2015-book-club" title="" class="sf-depth-3">Book club</a></li></ul></li><li id="menu-3166-1" class="last odd sf-item-5 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/open-organization/resources/ambassadors-program" title="" class="sf-depth-2 menuparent">Ambassadors program</a><ul><li id="menu-2691-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/meet-ambassadors" title="" class="sf-depth-3">Meet the ambassadors</a></li></ul></li></ul></li></ul>
</div>
<div id="block-system-user-menu" class="block block-system block-menu odd" role="navigation">

      
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul>
</div>
<div id="block-menu-block-2" class="block block-menu-block last even" role="navigation">

      
  <div class="menu-block-wrapper menu-block-2 menu-name-menu-social-links parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-13171"><a href="http://twitter.com/opensourceway" title="twitter" class="menu__link">Twitter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-13176"><a href="https://www.facebook.com/opensourceway" title="facebook" class="menu__link">Facebook</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-13166"><a href="/feed" title="feed" class="menu__link">Feed</a></li>
</ul></div>

</div>
  </div>

        <div class="mobile--menu-region">
            <div class="region region-navigation">
    <div id="block-system-main-menu" class="block block-system block-menu first last odd" role="navigation">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/" title="" class="menu__link">Articles</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/containers" title="" class="menu__link">Containers</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/devops" title="" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/gaming" title="" class="menu__link">Gaming</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/government" title="" class="menu__link">Government</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/hardware" title="" class="menu__link">Hardware</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/3d-printing" title="" class="menu__link">3D printing</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/arduino" title="" class="menu__link">Arduino</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/raspberry-pi" title="" class="menu__link">Raspberry Pi</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/law" title="" class="menu__link">Law</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/linux" title="" class="menu__link">Linux</a><ul class="menu"><li class="menu__item is-leaf first last leaf"><a href="/tags/command-line" title="" class="menu__link">Command line</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/tags/openstack" title="" class="menu__link">OpenStack</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/programming" title="" class="menu__link">Programming</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/go" title="" class="menu__link">Go</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/javascript" title="" class="menu__link">JavaScript</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/python" title="" class="menu__link">Python</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/tags/sysadmin" title="" class="menu__link">SysAdmin</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-collapsed first collapsed"><a href="/resources/what-open-source" title="" class="menu__link">What is open source?</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/projects-and-applications" title="" class="menu__link">Projects and applications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/organizations" title="" class="menu__link">Organizations</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/resources/cloud" title="" class="menu__link">Cloud technology</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/alternatives" title="" class="menu__link">Open source alternatives</a></li>
<li class="menu__item is-leaf last leaf"><a href="/resources/linux" title="" class="menu__link">Linux</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/downloads/cheat-sheets" title="" class="menu__link">Downloads</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/about" class="menu__link">About</a></li>
<li class="menu__item is-expanded last expanded"><a href="/open-organization" title="" class="menu__link">Open Organization</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="menu__link">What is an open organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-org-maturity-model" title="" class="menu__link">How open is your organization?</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/open-organization/resources/book-series" title="" class="menu__link">Book series</a></li>
<li class="menu__item is-expanded expanded"><a href="/open-organization/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/what-open-organization" title="" class="menu__link">What is The Open Organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-decision-framework" title="" class="menu__link">What is the Open Decision Framework?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/guides" title="" class="menu__link">Discussion guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/newsletter" class="menu__link">Newsletter sign-up</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/faq" title="" class="menu__link">Open Org FAQs</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/twitter-chats" title="" class="menu__link">Twitter chats</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/reading-list" title="" class="menu__link">Reading list</a></li>
<li class="menu__item is-leaf last leaf"><a href="/open-organization/resources/2015-book-club" title="" class="menu__link">Book club</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/open-organization/resources/ambassadors-program" title="" class="menu__link">Ambassadors program</a></li>
</ul></li>
</ul>
</div>
  </div>
        </div>
      </div>
    </div>

</header>

<div id="page">

      <div id="main">
        <div class="pre-content">
                                                </div>
        <div id="content" class="column" role="main">
                              <a id="main-content"></a>
                                <h1 class="page__title title" id="page-title">5 tips for GNU Debugger | Opensource.com</h1>
                              



<div class="panel-display os-article clearfix os-article--with-image " id="article-template">

      <div class="os-article__top">
      <div class="os-article__top-inner">
        <div class="panel-pane pane-node-title"  >
  
      
  
  <h1>5 tips for GNU Debugger</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-article-subhead"  >
  
      
  
  <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden">
    <div class="field-items">
          <h2>Learn how to use some of the lesser-known features of gdb to inspect and fix your code.</h2>
      </div>
</div>

  
  </div>
<div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__date">27 Sep 2019</span>
<span class="byline__author-name"><a href="/users/twaugh" title="View user profile." class="username" xml:lang="" about="/users/twaugh" typeof="sioc:UserAccount" property="foaf:name" datatype="">Tim Waugh <span class="content-moderator">(Red Hat)</span></a>&nbsp;<span class="byline__feed"><a href="/user/73016/feed">Feed</a></span>
</span>
<span class="byline__social"><span class="byline__voting-widget"><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-8b20a84f15e294466c77ab6b888f541b rate-node-56066-1-1" id="rate-node-56066-1-1"><div class="rate-info">12</div><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/19/9/tips-gnu-debugger?rate=SCIXViCSJC-PQUJMpUDRlH5Gd87cBFICd6snnUAfqac" title="up">up</a></div></span>
</span>
</div>
  
  </div>
      </div>
    </div>
  
      <div class="os-article__image">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/bug_software_issue_tracking_computer_screen.jpg?itok=6qfIHR5y"><img class="image-full-size" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/bug_software_issue_tracking_computer_screen.jpg?itok=6qfIHR5y" width="520" height="292" alt="Bug tracking magnifying glass on computer screen" title="Bug tracking magnifying glass on computer screen" /></div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-file-field-file-image-caption"  >
  
      
  
  <div class="field field-name-field-file-image-caption field-type-text-long field-label-inline clearfix"><div class="field-label">Image credits :&nbsp;</div><div class="field-items"><div class="field-item even">Pixabay, testbytes, CC0
</div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__left">
      <div class="panel-pane pane-block pane-bean-email-capture widget-block widget-block__left"  >
      <div class="target-band-never-show-button">x</div>
        <h2 class="pane-title">
      Subscribe now    </h2>
    
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/email-capture" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe frameborder="0" height="100" id="fkfkx" scrolling="no" src="/eloqua-embedded-email-capture-block.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="250"></iframe></p>
</div></div></div>  </div>
</div>

  
  </div>
    </div>
  
  
      <div class="os-article__middle">
      <div class="panel-pane pane-entity-field pane-node-body"  >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:articleBody content:encoded"><p>The <a href="https://www.gnu.org/software/gdb/" target="_blank">GNU Debugger</a> (gdb) is an invaluable tool for inspecting running processes and fixing problems while you're developing programs.</p>

<p>You can set breakpoints at specific locations (by function name, line number, and so on), enable and disable those breakpoints, display and alter variable values, and do all the standard things you would expect any debugger to do. But it has many other features you might not have experimented with. Here are five for you to try.</p>

<h2 id="conditional-breakpoints">Conditional breakpoints</h2>

<p>Setting a breakpoint is one of the first things you'll learn to do with the GNU Debugger. The program stops when it reaches a breakpoint, and you can run gdb commands to inspect it or change variables before allowing the program to continue.</p>

<p>For example, you might know that an often-called function crashes sometimes, but only when it gets a certain parameter value. You could set a breakpoint at the start of that function and run the program. The function parameters are shown each time it hits the breakpoint, and if the parameter value that triggers the crash is not supplied, you can continue until the function is called again. When the troublesome parameter triggers a crash, you can step through the code to see what's wrong.</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash"><span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> <span class="kw3">break</span> sometimes_crashes<br />
Breakpoint <span class="nu0">1</span> at 0x40110e: <span class="kw2">file</span> prog.c, line <span class="nu0">5</span>.<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> run<br />
<span class="br0">&#91;</span>...<span class="br0">&#93;</span><br />
Breakpoint <span class="nu0">1</span>, sometimes_crashes <span class="br0">&#40;</span><span class="re2">f</span>=0x7fffffffd1bc<span class="br0">&#41;</span> at prog.c:<span class="nu0">5</span><br />
<span class="nu0">5</span> &nbsp; &nbsp; &nbsp;fprintf<span class="br0">&#40;</span>stderr,<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> <span class="kw3">continue</span><br />
Breakpoint <span class="nu0">1</span>, sometimes_crashes <span class="br0">&#40;</span><span class="re2">f</span>=0x7fffffffd1bc<span class="br0">&#41;</span> at prog.c:<span class="nu0">5</span><br />
<span class="nu0">5</span> &nbsp; &nbsp; &nbsp;fprintf<span class="br0">&#40;</span>stderr,<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> <span class="kw3">continue</span></div></div></pre>

<p>To make this more repeatable, you could count how many times the function is called before the specific call you are interested in, and set a counter on that breakpoint (for example, "continue 30" to make it ignore the next 29 times it reaches the breakpoint).</p>

<p>But where breakpoints get really powerful is in their ability to evaluate expressions at runtime, which allows you to automate this kind of testing. Enter: conditional breakpoints.</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash"><span class="kw3">break</span> <span class="br0">&#91;</span>LOCATION<span class="br0">&#93;</span> <span class="kw1">if</span> CONDITION<br />
<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> <span class="kw3">break</span> sometimes_crashes <span class="kw1">if</span> <span class="sy0">!</span>f<br />
Breakpoint <span class="nu0">1</span> at 0x401132: <span class="kw2">file</span> prog.c, line <span class="nu0">5</span>.<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> run<br />
<span class="br0">&#91;</span>...<span class="br0">&#93;</span><br />
Breakpoint <span class="nu0">1</span>, sometimes_crashes <span class="br0">&#40;</span><span class="re2">f</span>=0x0<span class="br0">&#41;</span> at prog.c:<span class="nu0">5</span><br />
<span class="nu0">5</span> &nbsp; &nbsp; &nbsp;fprintf<span class="br0">&#40;</span>stderr,<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span></div></div></pre>

<p>Instead of having gdb ask what to do every time the function is called, a conditional breakpoint allows you to make gdb stop at that location only when a particular expression evaluates as true. If the execution reaches the conditional breakpoint location, but the expression evaluates as false, the <div id="more-linux-resources" class="embedded-callout-menu callout-float-right"><div class="view view-related-content-callout view-id-related_content_callout view-display-id-article_block view-dom-id-1ba44b0f64ce1a9695d9f97d7fe10196">
            <div class="view-header">
      More Linux resources    </div>
  
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">      
  <div class="views-field views-field-field-related-content-link">        <div class="field-content"><div class="item-list"><ul><li class="first"><a href="https://opensource.com/resources/what-is-linux?intcmp=70160000000h1jYAAQ&amp;utm_source=intcallout&amp;utm_campaign=linuxcontent">What is Linux?</a></li>
<li><a href="https://opensource.com/resources/what-are-linux-containers?intcmp=70160000000h1jYAAQ&amp;utm_source=intcallout&amp;utm_campaign=linuxcontent">What are Linux containers?</a></li>
<li><a href="https://developers.redhat.com/cheat-sheets/advanced-linux-commands/?intcmp=70160000000h1jYAAQ&amp;utm_source=intcallout&amp;utm_campaign=linuxcontent">Advanced Linux commands cheat sheet</a></li>
<li><a href="https://developers.redhat.com/promotions/linux-cheatsheet/?intcmp=70160000000h1jYAAQ&amp;utm_source=intcallout&amp;utm_campaign=linuxcontent">Linux commands cheat sheet</a></li>
<li><a href="https://opensource.com/downloads/cheat-sheet-selinux?intcmp=70160000000h1jYAAQ&amp;utm_source=intcallout&amp;utm_campaign=linuxcontent">SELinux cheat sheet</a></li>
<li><a href="https://opensource.com/downloads/cheat-sheet-networking?intcmp=70160000000h1jYAAQ&amp;utm_source=intcallout&amp;utm_campaign=linuxcontent">Linux networking cheat sheet</a></li>
<li class="last"><a href="https://opensource.com/tags/linux?intcmp=70160000000h1jYAAQ&amp;utm_source=intcallout&amp;utm_campaign=linuxcontent">Our latest Linux articles</a></li>
</ul></div></div>  </div>  </div>    </div>
  
  
  
  
  
  
</div></div>debugger automatically lets the program continue without asking the user what to do.</p>

<h2 id="breakpoint-commands">Breakpoint commands</h2>

<p>An even more sophisticated feature of breakpoints in the GNU Debugger is the ability to script a response to reaching a breakpoint. Breakpoint commands allow you to write a list of GNU Debugger commands to run whenever it reaches a breakpoint.</p>

<p>We can use this to work around the bug we already know about in the <strong>sometimes_crashes</strong> function and make it return from that function harmlessly when it provides a null pointer.</p>

<p>We can use <strong>silent</strong> as the first line to get more control over the output. Without this, the stack frame will be displayed each time the breakpoint is hit, even before our breakpoint commands run.</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash"><span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> <span class="kw3">break</span> sometimes_crashes<br />
Breakpoint <span class="nu0">1</span> at 0x401132: <span class="kw2">file</span> prog.c, line <span class="nu0">5</span>.<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> commands <span class="nu0">1</span><br />
Type commands <span class="kw1">for</span> breakpoint<span class="br0">&#40;</span>s<span class="br0">&#41;</span> <span class="nu0">1</span>, one per line.<br />
End with a line saying just <span class="st0">&quot;end&quot;</span>.<br />
<span class="sy0">&gt;</span>silent<br />
<span class="sy0">&gt;</span><span class="kw1">if</span> <span class="sy0">!</span>f<br />
&nbsp;<span class="sy0">&gt;</span>frame<br />
&nbsp;<span class="sy0">&gt;</span><span class="kw3">printf</span> <span class="st0">&quot;Skipping call<span class="es1">\n</span>&quot;</span><br />
&nbsp;<span class="sy0">&gt;</span><span class="kw3">return</span> <span class="nu0">0</span><br />
&nbsp;<span class="sy0">&gt;</span><span class="kw3">continue</span><br />
&nbsp;<span class="sy0">&gt;</span>end<br />
<span class="sy0">&gt;</span><span class="kw3">printf</span> <span class="st0">&quot;Continuing<span class="es1">\n</span>&quot;</span><br />
<span class="sy0">&gt;</span><span class="kw3">continue</span><br />
<span class="sy0">&gt;</span>end<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> run<br />
Starting program: <span class="sy0">/</span>home<span class="sy0">/</span>twaugh<span class="sy0">/</span>Documents<span class="sy0">/</span>GDB<span class="sy0">/</span>prog<br />
warning: Loadable section <span class="st0">&quot;.note.gnu.property&quot;</span> outside of ELF segments<br />
Continuing<br />
Continuing<br />
Continuing<br />
<span class="co0">#0 &nbsp;sometimes_crashes (f=0x0) at prog.c:5</span><br />
<span class="nu0">5</span> &nbsp; &nbsp; &nbsp;fprintf<span class="br0">&#40;</span>stderr,<br />
Skipping call<br />
<span class="br0">&#91;</span>Inferior <span class="nu0">1</span> <span class="br0">&#40;</span>process <span class="nu0">9373</span><span class="br0">&#41;</span> exited normally<span class="br0">&#93;</span><br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> </div></div></pre>

<h2 id="dump-binary-memory">Dump binary memory</h2>

<p>GNU Debugger has built-in support for examining memory using the <strong>x</strong> command in various formats, including octal, hexadecimal, and so on. But I like to see two formats side by side: hexadecimal bytes on the left, and ASCII characters represented by those same bytes on the right.</p>

<p>When I want to view the contents of a file byte-by-byte, I often use <strong>hexdump -C</strong> (hexdump comes from the <a href="https://en.wikipedia.org/wiki/Util-linux" target="_blank">util-linux</a> package). Here is gdb's <strong>x</strong> command displaying hexadecimal bytes:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash"><span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> x<span class="sy0">/</span>33xb mydata<br />
0x404040 <span class="sy0">&lt;</span>mydata<span class="sy0">&gt;</span>: &nbsp; &nbsp;0x02 &nbsp; &nbsp;0x01 &nbsp; &nbsp;0x00 &nbsp; &nbsp;0x02 &nbsp; &nbsp;0x00 &nbsp; &nbsp;0x00 &nbsp; &nbsp;0x00 &nbsp; &nbsp;0x01<br />
0x404048 <span class="sy0">&lt;</span>mydata+<span class="nu0">8</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;0x01 &nbsp; &nbsp;0x47 &nbsp; &nbsp;0x00 &nbsp; &nbsp;0x12 &nbsp; &nbsp;0x61 &nbsp; &nbsp;0x74 &nbsp; &nbsp;0x74 &nbsp; &nbsp;0x72<br />
0x404050 <span class="sy0">&lt;</span>mydata+<span class="nu0">16</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;0x69 &nbsp; &nbsp;0x62 &nbsp; &nbsp;0x75 &nbsp; &nbsp;0x74 &nbsp; &nbsp;0x65 &nbsp; &nbsp;0x73 &nbsp; &nbsp;0x2d &nbsp; &nbsp;0x63<br />
0x404058 <span class="sy0">&lt;</span>mydata+<span class="nu0">24</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;0x68 &nbsp; &nbsp;0x61 &nbsp; &nbsp;0x72 &nbsp; &nbsp;0x73 &nbsp; &nbsp;0x65 &nbsp; &nbsp;0x75 &nbsp; &nbsp;0x00 &nbsp; &nbsp;0x05<br />
0x404060 <span class="sy0">&lt;</span>mydata+<span class="nu0">32</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;0x00</div></div></pre>

<p>What if you could teach gdb to display memory just like hexdump does? You can, and in fact, you can use this method for any format you prefer.</p>

<p>By combining the <strong>dump</strong> command to store the bytes in a file, the <strong>shell</strong> command to run hexdump on the file, and the <strong>define</strong> command, we can make our own new <strong>hexdump</strong> command to use hexdump to display the contents of memory.</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash"><span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> define <span class="kw2">hexdump</span><br />
Type commands <span class="kw1">for</span> definition of <span class="st0">&quot;hexdump&quot;</span>.<br />
End with a line saying just <span class="st0">&quot;end&quot;</span>.<br />
<span class="sy0">&gt;</span>dump binary memory <span class="sy0">/</span>tmp<span class="sy0">/</span>dump.bin <span class="re1">$arg0</span> <span class="re1">$arg0</span>+<span class="re1">$arg1</span><br />
<span class="sy0">&gt;</span>shell <span class="kw2">hexdump</span> <span class="re5">-C</span> <span class="sy0">/</span>tmp<span class="sy0">/</span>dump.bin<br />
<span class="sy0">&gt;</span>end</div></div></pre>

<p>Those commands can even go in the <strong>~/.gdbinit</strong> file to define the hexdump command permanently. Here it is in action:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash"><span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> <span class="kw2">hexdump</span> mydata sizeof<span class="br0">&#40;</span>mydata<span class="br0">&#41;</span><br />
00000000 &nbsp;02 01 00 02 00 00 00 01 &nbsp;01 <span class="nu0">47</span> 00 <span class="nu0">12</span> <span class="nu0">61</span> <span class="nu0">74</span> <span class="nu0">74</span> <span class="nu0">72</span> &nbsp;<span class="sy0">|</span>.........G..attr<span class="sy0">|</span><br />
00000010 &nbsp;<span class="nu0">69</span> <span class="nu0">62</span> <span class="nu0">75</span> <span class="nu0">74</span> <span class="nu0">65</span> <span class="nu0">73</span> 2d <span class="nu0">63</span> &nbsp;<span class="nu0">68</span> <span class="nu0">61</span> <span class="nu0">72</span> <span class="nu0">73</span> <span class="nu0">65</span> <span class="nu0">75</span> 00 05 &nbsp;<span class="sy0">|</span>ibutes-charseu..<span class="sy0">|</span><br />
00000020 &nbsp;00 &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;<span class="sy0">|</span>.<span class="sy0">|</span><br />
00000021</div></div></pre>

<h2 id="inline-disassembly">Inline disassembly</h2>

<p>Sometimes you want to understand more about what happened leading up to a crash, and the source code is not enough. You want to see what's going on at the CPU instruction level.</p>

<p>The <strong>disassemble</strong> command lets you see the CPU instructions that implement a function. But sometimes the output can be hard to follow. Usually, I want to see what instructions correspond to a certain section of source code in the function. To achieve this, use the <strong>/s</strong> modifier to include source code lines with the disassembly.</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash"><span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> disassemble<span class="sy0">/</span>s main<br />
Dump of assembler code <span class="kw1">for</span> <span class="kw1">function</span> main:<br />
prog.c:<br />
<span class="nu0">11</span> &nbsp; &nbsp;<span class="br0">&#123;</span><br />
&nbsp; &nbsp;0x0000000000401158 <span class="sy0">&lt;</span>+<span class="nu0">0</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;push &nbsp; <span class="sy0">%</span>rbp<br />
&nbsp; &nbsp;0x0000000000401159 <span class="sy0">&lt;</span>+<span class="nu0">1</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;mov&nbsp; &nbsp; &nbsp; <span class="sy0">%</span>rsp,<span class="sy0">%</span>rbp<br />
&nbsp; &nbsp;0x000000000040115c <span class="sy0">&lt;</span>+<span class="nu0">4</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;sub&nbsp; &nbsp; &nbsp; <span class="re4">$0</span>x10,<span class="sy0">%</span>rsp<br />
<br />
<span class="nu0">12</span> &nbsp; &nbsp;&nbsp; int n = <span class="nu0">0</span>;<br />
&nbsp; &nbsp;0x0000000000401160 <span class="sy0">&lt;</span>+<span class="nu0">8</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;movl &nbsp; <span class="re4">$0</span>x0,-0x4<span class="br0">&#40;</span><span class="sy0">%</span>rbp<span class="br0">&#41;</span><br />
<br />
<span class="nu0">13</span> &nbsp; &nbsp;&nbsp; sometimes_crashes<span class="br0">&#40;</span><span class="sy0">&amp;</span>n<span class="br0">&#41;</span>;<br />
&nbsp; &nbsp;0x0000000000401167 <span class="sy0">&lt;</span>+<span class="nu0">15</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;lea &nbsp; &nbsp; -0x4<span class="br0">&#40;</span><span class="sy0">%</span>rbp<span class="br0">&#41;</span>,<span class="sy0">%</span>rax<br />
&nbsp; &nbsp;0x000000000040116b <span class="sy0">&lt;</span>+<span class="nu0">19</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;mov &nbsp; &nbsp; <span class="sy0">%</span>rax,<span class="sy0">%</span>rdi<br />
&nbsp; &nbsp;0x000000000040116e <span class="sy0">&lt;</span>+<span class="nu0">22</span><span class="sy0">&gt;</span>: &nbsp; &nbsp;callq &nbsp;0x401126 <span class="sy0">&lt;</span>sometimes_crashes<span class="sy0">&gt;</span><br />
<span class="br0">&#91;</span>...snipped...<span class="br0">&#93;</span></div></div></pre>

<p>This, along with <strong>info registers</strong> to see the current values of all the CPU registers and commands like <strong>stepi</strong> to step one instruction at a time, allow you to have a much more detailed understanding of the program.</p>

<h2 id="reverse-debug">Reverse debug</h2>

<p>Sometimes you wish you could turn back time. Imagine you've hit a watchpoint on a variable. A watchpoint is like a breakpoint, but instead of being set at a location in the program, it is set on an expression (using the <strong>watch</strong> command). Whenever the value of the expression changes, execution stops, and the debugger takes control.</p>

<p>So imagine you've hit this watchpoint, and the memory used by a variable has changed value. This can turn out to be caused by something that occurred much earlier; for example, the memory was freed and is now being re-used. But when and why was it freed?</p>

<p>The GNU Debugger can solve even this problem because you can run your program in reverse!</p>

<p>It achieves this by carefully recording the state of the program at each step so that it can restore previously recorded states, giving the illusion of time flowing backward.</p>

<p>To enable this state recording, use the <strong>target record-full</strong> command. Then you can use impossible-sounding commands, such as:</p>

<ul><li><strong>reverse-step</strong>, which rewinds to the previous source line</li>
	<li><strong>reverse-next</strong>, which rewinds to the previous source line, stepping backward over function calls</li>
	<li><strong>reverse-finish</strong>, which rewinds to the point when the current function was about to be called</li>
	<li><strong>reverse-continue</strong>, which rewinds to the previous state in the program that would (now) trigger a breakpoint (or anything else that causes it to stop)</li>
</ul><p>Here is an example of reverse debugging in action:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash"><span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> b main<br />
Breakpoint <span class="nu0">1</span> at 0x401160: <span class="kw2">file</span> prog.c, line <span class="nu0">12</span>.<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> r<br />
Starting program: <span class="sy0">/</span>home<span class="sy0">/</span>twaugh<span class="sy0">/</span>Documents<span class="sy0">/</span>GDB<span class="sy0">/</span>prog<br />
<span class="br0">&#91;</span>...<span class="br0">&#93;</span><br />
<br />
Breakpoint <span class="nu0">1</span>, main <span class="br0">&#40;</span><span class="br0">&#41;</span> at prog.c:<span class="nu0">12</span><br />
<span class="nu0">12</span> &nbsp; &nbsp;&nbsp; int n = <span class="nu0">0</span>;<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> target record-full<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> c<br />
Continuing.<br />
<br />
Program received signal SIGSEGV, Segmentation fault.<br />
0x0000000000401154 <span class="kw1">in</span> sometimes_crashes <span class="br0">&#40;</span><span class="re2">f</span>=0x0<span class="br0">&#41;</span> at prog.c:<span class="nu0">7</span><br />
<span class="nu0">7</span> &nbsp; &nbsp; &nbsp;<span class="kw3">return</span> <span class="sy0">*</span>f;<br />
<span class="br0">&#40;</span><span class="kw2">gdb</span><span class="br0">&#41;</span> reverse-finish<br />
Run back to call of <span class="co0">#0 &nbsp;0x0000000000401154 in sometimes_crashes (f=0x0)</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; at prog.c:<span class="nu0">7</span><br />
0x0000000000401190 <span class="kw1">in</span> main <span class="br0">&#40;</span><span class="br0">&#41;</span> at prog.c:<span class="nu0">16</span><br />
<span class="nu0">16</span> &nbsp; &nbsp;&nbsp; sometimes_crashes<span class="br0">&#40;</span><span class="nu0">0</span><span class="br0">&#41;</span>;</div></div></pre>

<p>These are just a handful of useful things the GNU Debugger can do. There are many more to discover. Which hidden, little-known, or just plain amazing feature of gdb is your favorite? Please share it in the comments.</p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-listacles-panel-pane-1"  >
  
      
  
  <div class="view view-listacles view-id-listacles view-display-id-panel_pane_1 view-dom-id-9009deb59c77735248558d68ad23d635">
        
  
  
      <div class="view-content">
              
  <div class="views-field views-field-field-listacles">        <div class="field-content">
<div class="panelizer-view-mode node node-teaser-listacles node-article node-55231 node-promoted node-promoted">
        
<div class="panel-display teaser clearfix " >

  <div class="teaser__first">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/find-file-linux-code_magnifying_glass_zero.png?itok=4fKV-W3T"><a href="/article/19/8/dig-binary-files-hexdump"><img class="teaser-wide" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/find-file-linux-code_magnifying_glass_zero.png?itok=4fKV-W3T" width="249" height="140" alt="Magnifying glass on code" title="Magnifying glass on code" /></a></div></div></div>
  
  </div>
  </div>

  <div class="teaser__second">
    <h2 class="teaser__title"><div class="panel-pane pane-node-title"  >
  
      
  
  <a href="/article/19/8/dig-binary-files-hexdump">How Hexdump works</a>
  
  </div>
</h2>
    <div class="teaser__body"><div class="panel-pane pane-token pane-node-field-article-subhead"  >
  
      
  
  Hexdump helps you investigate the contents of binary files. Learn how hexdump works.
  
  </div>
</div>
    <div class="teaser__byline"><div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__author-name"><a href="/users/seth" title="View user profile." class="username" xml:lang="" about="/users/seth" typeof="sioc:UserAccount" property="foaf:name" datatype="">Seth Kenlon <span class="content-moderator">(Red Hat)</span></a></span>
</div>
  
  </div>
</div>
  </div>

</div>
</div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-tags"  >
  
        <h2 class="pane-title">
      Topics    </h2>
    
  
  <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:keywords"><a href="/tags/tools" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Tools</a></div><div class="field-item odd" rel="schema:keywords"><a href="/tags/linux" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Linux</a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-author-info-panel-pane-1"  >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-72b20ea5ef8134567c6d9baae2900ed4">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><a href="/users/twaugh"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/pictures/russellcotes-cropped.jpg?itok=Rinycza5" width="100" height="100" alt="" /></a></div>
<div class="authorbio__content">
  <span class="authorbio__name">Tim Waugh</span> - <span class="authorbio__about">Tim Waugh leads the team managing the tools used to build container images for Red Hat products. Having joined Red Hat in 1999 he has been writing free software for over twenty years. He enjoys learning things like magic and shorthand.
</span>
  <div class="authorbio__more-link"><a href="/users/twaugh">More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-content-article-contributions"  >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block"  >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__bottom">
      <div class="panel-pane pane-views-panes pane-related-articles-panel-pane-1"  >
  
        <h2 class="pane-title">
      Recommended reading    </h2>
    
  
  <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 related-content view-dom-id-6b5bb2b6cb8e0959c72230ce8b27be16">
        
  
  
      <div id="related-content-footer" class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/9/mirror-android-screen-guiscrcpy"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/code_computer_laptop_hack_work.png?itok=efQMUmxr" width="315" height="177" alt="Coding on a computer" title="Coding on a computer" /><br />
Mirror your Android screen on your computer with Guiscrcpy</a></span>  </div>  </div>  <div class="views-row views-row-2 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/9/linux-chgrp-and-newgrp-commands"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/community-penguins-osdc-lead.png?itok=V4UlQPGG" width="315" height="177" alt="Penguins walking on the beach " title="Penguins walking on the beach " /><br />
Introduction to the Linux chgrp and newgrp commands</a></span>  </div>  </div>  <div class="views-row views-row-3 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/9/last-time-used-windows"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/window-windows.png?itok=RWQlDQVI" width="315" height="177" alt="2 windows with brown frames on a white exterior wall" title="2 windows with brown frames on a white exterior wall" /><br />
When was the last time you used Windows?</a></span>  </div>  </div>  <div class="views-row views-row-4 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/9/linux-mainframes-part-2"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/car-penguin-drive-linux-yellow.png?itok=cTuiVl_j" width="315" height="177" alt="Penguin driving a car with a yellow background" title="Penguin driving a car with a yellow background" /><br />
Linux on the mainframe: Then and now</a></span>  </div>  </div>  <div class="views-row views-row-5 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/9/adding-plugins-zsh"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/build_structure_tech_program_code_construction.png?itok=PXWT1UKZ" width="315" height="177" alt="Someone wearing a hardhat and carrying code " title="Someone wearing a hardhat and carrying code " /><br />
Adding themes and plugins to Zsh</a></span>  </div>  </div>  <div class="views-row views-row-6 views-row-even views-row-last">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/9/getting-started-zsh"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/bash_command_line.png?itok=x7w7dExA" width="314" height="177" alt="bash logo on green background" title="bash logo on green background" /><br />
Getting started with Zsh</a></span>  </div>  </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
    </div>
  
      <div class="os-article__footer">
      <div class="panel-pane pane-node-comment-form"  >
  
        <h2 class="pane-title">
      Comment now    </h2>
    
  
  <form class="comment-form user-info-from-cookie" action="/article/19/9/tips-gnu-debugger#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div id="edit-login-register" class="form-item form-type-item">
 <a href="/user/login?destination=node/56066">Login or Register</a> to earn points for your comments.
</div>
<div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<input type="hidden" name="form_build_id" value="form-Ql9rROi60yt554IfHAgoPhFidM7Jg05tNwWDQFh5_Mk" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="honeypot_time" value="1569628346|SEgyUdInpGwM387u50CLL5EaKzdtQ8B_ZjiObobFP5Q" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/legal">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><fieldset class="captcha form-wrapper"><legend><span class="fieldset-legend">CAPTCHA</span></legend><div class="fieldset-wrapper"><div class="fieldset-description">This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.</div><input type="hidden" name="captcha_sid" value="218184826" />
<input type="hidden" name="captcha_token" value="210ba1d6ffc25bc165d7a4ad225de68b" />
<input type="hidden" name="captcha_response" value="Google no captcha" />
<div class="g-recaptcha" data-sitekey="6LdyKzYUAAAAAIwIfHYM0eXeqI_HRmLhM-Msg6nM" data-theme="light" data-type="image"></div></div></fieldset>
<div class="website-url-textfield"><div class="form-item form-type-textfield form-item-website-url">
  <label for="edit-website-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-website-url" name="website-url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div></div></form>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-default-license"  >
  
      
  
  <div class="field field-name-field-default-license field-type-text field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:license"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" style="border-width:0" src="/sites/all/themes/opensource/images/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a></div></div></div>
  
  </div>
    </div>
  
</div>
                  </div>


        
        
      </div>

        <div class="region region-pre-footer">
    <div id="block-os-common-components-footer-call-to-action" class="block block-os-common-components first last odd">

      
  
<div class="fieldable-panels-pane cta cta--green-on-blue cta--no-link">

  <div class="cta__content cta__content--no-link">
            <h2 class="cta__title">Subscribe to our weekly newsletter</h2>
<div class="field field-name-field-cta-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><iframe class="eloqua-embedded-bottom" frameborder="0" height="50" id="fkfkx" scrolling="no" src="/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></p>

<p>Get the highlights in your inbox every week.</p>
</div></div></div>  </div>

</div>


</div>
  </div>

        <div class="region region-footer-nav">
    <div id="block-bean-social-media" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/social-media" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><span>Find us:</span> 
</p>
<ul>
<li><a class="footer-twitter" href="https://twitter.com/OpenSourceWay" title="Twitter">Twitter</a></li>
<li><a class="footer-facebook" href="https://www.facebook.com/opensourceway" title="Facebook">Facebook</a></li>
<li><a class="footer-youtube" href="http://www.youtube.com/opensourceway" title="Youtube">Youtube</a></li>
<li><a class="footer-mastodon" href="https://fosstodon.org/@osdc" title="">Mastodon</a></li>
<li><a class="footer-irc" href="/join-us-irc" title="IRC">IRC</a></li>
<li><a class="footer-feed" href="/feed" title="RSS">RSS</a></li>
</ul>
</div></div></div>  </div>
</div>

</div>
<div id="block-menu-menu-footer" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Footer</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/legal" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact" class="menu__link">Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="/opensourcecom-team" title="" class="menu__link">Meet the Team</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://opensource.org/" title="" class="menu__link">Visit opensource.org</a></li>
</ul>
</div>
  </div>

        <footer id="footer" class="region region-footer">
    <div id="block-bean-copyrigt-block" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/copyrigt-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>For more discussion on open source and the role of the CIO in the enterprise, join us at <a href="https://enterprisersproject.com">The EnterprisersProject.com</a>.</p>

<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>

<p>Opensource.com aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>

<p>Copyright ©2019 Red Hat, Inc.</p>
</div></div></div>  </div>
</div>

</div>
<div id="block-bean-footer-logo" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/footer-logo" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><img src="/sites/all/themes/opensource/images/footer_logo.svg" /></p>
</div></div></div>  </div>
</div>

</div>
  </footer>

    </div>

    
      <div class="region region-os-social">
    <div id="block-os-social-os-social-share" class="block block-os-social first last odd">

      
  <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://opensource.com/article/19/9/tips-gnu-debugger">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <a class="a2a_button_mastodon a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <a class="a2a_button_mastodon a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div>
</div>
  </div>
    <div class="region region-page-bottom">
    <!-- begin Google Remarketing --><img height="1" width="1" style="border-style:none;display:block;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" onerror="this.src='/sites/all/themes/opensource/images/1x1.png';this.onerror=null" /><!-- end Google Remarketing -->  </div>
<script src="https://opensource.com/sites/default/files/js/js_29qYXJz8NLGg8Aomg-RZPjJcj9yEdEst1BMZ9gZbs-4.js"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script src="https://opensource.com/sites/default/files/js/js_skcw_uw28w93NamnwquPyMMZNIyaa2eQ6iAc5B_1jjA.js"></script>
<script>var a2a_config = a2a_config || {};
              a2a_config.callbacks = a2a_config.callbacks || [];
a2a_config.templates = {
    twitter: "5 tips for GNU Debugger https://red.ht/2nuCQqR via @opensourceway"
};</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"65779638","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkgHX1xuW1BXU1YEF2pWCVxcbkBYXEVuEQRSXQ==","queueTime":0,"applicationTime":367,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
