<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html class="no-js"  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema# schema: http://schema.org/"><!--<![endif]-->

<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
  <meta charset="utf-8" /><script type="text/javascript">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</script>
<link href="https://opensource.com/rss.xml" rel="alternate" type="application/rss+xml" title="Opensource.com RSS" />
<link rel="shortcut icon" href="https://opensource.com/sites/all/themes/opensource/favicon.ico" type="image/vnd.microsoft.icon" />
<script src="https://www.google.com/recaptcha/api.js?hl=en" async="async" defer="defer"></script>
<meta name="description" content="Try this script the next time you give a presentation to prevent making typos in front of a live audience." />
<meta name="rating" content="general" />
<meta name="referrer" content="no-referrer" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://opensource.com/article/20/2/live-demo-script" />
<link rel="shortlink" href="https://opensource.com/node/60831" />
<meta name="revisit-after" content="1 day" />
<meta property="og:site_name" content="Opensource.com" />
<meta property="og:url" content="https://opensource.com/article/20/2/live-demo-script" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Automate your live demos with this shell script" />
<meta property="og:description" content="I gave a talk about multi-architecture container images at LISA19 in October that included a lengthy live demo. Rather than writing out 30+ commands and risking typos, I decided to automate the demo with a shell script." />
<meta property="og:image" content="https://opensource.com/sites/default/files/lead-images/laptop_screen_desk_work_chat_text.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@opensourceway" />
<meta name="twitter:creator" content="@thedoh" />
<meta name="twitter:title" content="Automate your live demos with this shell script" />
<meta name="twitter:description" content="I gave a talk about multi-architecture container images at LISA19 in October that included a lengthy live demo. Rather than writing out 30+ commands and risking typos, I decided to automate the demo with a shell script." />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/lead-images/laptop_screen_desk_work_chat_text.png" />
  <title>Automate your live demos with this shell script | Opensource.com</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_rPk7Et6wjNyH7pw3qgw9a85Yiqd9m38Ov-4hY99oyhM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_vamxBRmWk2Q7fxdiL4tDdJ_YjZN5fmFXzhYuV4x6kIk.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_1HAxiQy0ym2_Wq8hTu-6qsXiyLz9C2U7glSaTTu6UTk.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_O7Hj1nQ3cC1S63duyZZiYmu20VaG7TSHDXU_g_WuSag.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_PxsPpITToy8ZnO0bJDA1TEC6bbFpGTfSWr2ZP8LuFYo.css" media="all" />
  <script src="/sites/all/themes/opensource/js/use-typekit.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  <script src="https://opensource.com/sites/default/files/js/js_0RyHJ63yYLuaWsodCPCgSD8dcTIA0dqcDf8-7c2XdBw.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_R9xDkoIXbrDQhdBhQ3W4GF5TzHxKYFK0UB8wjqE0DbE.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_tBWHhFjU_NjWsmd07Hrx5ScmFu-4-PJD_GwzNMH3UwA.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_VQpdyHm5xCOVZuJDT1qsHx0ol1ROIpb8g515ZxRqX4o.js"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-33294138-1", {"cookieDomain":".opensource.com"});ga("send", "pageview");</script>
<script src="https://opensource.com/sites/default/files/js/js_rVcPYhZ5_LfvT-dWbCnRngMcccEhwUaw2iNYx0yXj_Q.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_KbByFnBctcQt9juhHXNabaQDr4mJAc1OExQYJ-HcyXk.js"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-60831 node-type-article region-content section-article page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<header class="header" id="header" role="banner">

    
    <div class="header-banner">
      <div class="header-banner__inner">
                  <div class="header__name-and-slogan" id="name-and-slogan">
                          <div class="header__site-name" id="site-name">
                <a href="/article/20/1/10-year-anniversary" title="Celebrating 10 years of Opensource.com" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/logo-10yr-anniversary.svg" onerror="this.src='/sites/all/themes/opensource/logo-10yr-anniversary.png';this.onerror=null;" /></a>
                <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" title="Home" class="header__sponsor-link" rel="home"><img alt="RedHat" src="/sites/all/themes/opensource/images/redhat-logo.svg" onerror="this.src='/sites/all/themes/opensource/images/redhat-logo.png';this.onerror=null;"/></a>
              </div>
            
                      </div>
                <nav class="desktop-user-links">
            <div class="header__region region region-header">
    <div id="block-menu-block-1" class="block block-menu-block first last odd" role="navigation">

      
  <div class="menu-block-wrapper menu-block-1 menu-name-user-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-195"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1179"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul></div>

</div>
  </div>
        </nav>
      </div>
    </div>

    <div class="sf-nav">
      <div class="sf-nav__inner">
          <div class="js-mobile-header-buttons region region-navigation-top">
    <div id="block-os-solr-search-form" class="block block-os-solr-search first odd">

      
  <form action="/article/20/2/live-demo-script" method="post" id="os-search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search">
  <label class="element-invisible" for="edit-search">Search </label>
 <input title="Enter the terms you wish to search for." placeholder="Search opensource.com" type="text" id="edit-search" name="search" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="GO" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-GCV8zWzAGa3rSI2mBNdSvx9jTMSpjznBqIfWYLzf40M" />
<input type="hidden" name="form_id" value="os_search_block_form" />
</div>
</div></form>
</div>
<div id="block-superfish-1" class="block block-superfish even">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-default sf-total-items-5 sf-parent-items-5 sf-single-items-0"><li id="menu-1906-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-11 sf-parent-children-4 sf-single-children-7 menuparent"><a href="/" title="" class="sf-depth-1 menuparent">Articles</a><ul><li id="menu-12341-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/containers" title="" class="sf-depth-2">Containers</a></li><li id="menu-12416-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/devops" title="" class="sf-depth-2">DevOps</a></li><li id="menu-12346-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/tags/gaming" title="" class="sf-depth-2">Gaming</a></li><li id="menu-17776-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/tags/government" title="" class="sf-depth-2">Government</a></li><li id="menu-12351-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/hardware" title="" class="sf-depth-2 menuparent">Hardware</a><ul><li id="menu-12376-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/3d-printing" title="" class="sf-depth-3">3D printing</a></li><li id="menu-12386-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/arduino" title="" class="sf-depth-3">Arduino</a></li><li id="menu-12381-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/raspberry-pi" title="" class="sf-depth-3">Raspberry Pi</a></li></ul></li><li id="menu-27341-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="https://opensource.com/tags/kubernetes" title="" class="sf-depth-2">Kubernetes</a></li><li id="menu-1946-1" class="middle odd sf-item-7 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/tags/law" title="" class="sf-depth-2 menuparent">Law</a><ul><li id="menu-12391-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/licensing" title="" class="sf-depth-3">Licensing</a></li><li id="menu-12396-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/patents" title="" class="sf-depth-3">Patents</a></li></ul></li><li id="menu-12356-1" class="middle even sf-item-8 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/tags/linux" title="" class="sf-depth-2 menuparent">Linux</a><ul><li id="menu-19831-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/command-line" title="" class="sf-depth-3">Command line</a></li></ul></li><li id="menu-12361-1" class="middle odd sf-item-9 sf-depth-2 sf-no-children"><a href="/tags/openstack" title="" class="sf-depth-2">OpenStack</a></li><li id="menu-12366-1" class="middle even sf-item-10 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/programming" title="" class="sf-depth-2 menuparent">Programming</a><ul><li id="menu-17771-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/go" title="" class="sf-depth-3">Go</a></li><li id="menu-12411-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/javascript" title="" class="sf-depth-3">JavaScript</a></li><li id="menu-12406-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/python" title="" class="sf-depth-3">Python</a></li></ul></li><li id="menu-12371-1" class="last odd sf-item-11 sf-depth-2 sf-no-children"><a href="/tags/sysadmin" title="" class="sf-depth-2">SysAdmin</a></li></ul></li><li id="menu-1921-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-6 sf-parent-children-3 sf-single-children-3 menuparent"><a href="/resources" title="" class="sf-depth-1 menuparent">Resources</a><ul><li id="menu-19841-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/resources/what-open-source" title="" class="sf-depth-2 menuparent">What is open source?</a><ul><li id="menu-1991-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-source-way" class="sf-depth-3">The open source way</a></li></ul></li><li id="menu-2016-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/projects-and-applications" title="" class="sf-depth-2">Projects and applications</a></li><li id="menu-2021-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/resources/organizations" title="" class="sf-depth-2">Organizations</a></li><li id="menu-5556-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-14 sf-parent-children-1 sf-single-children-13 menuparent"><a href="/resources/cloud" title="" class="sf-depth-2 menuparent">Cloud technology</a><ul><li id="menu-27201-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/resources/what-ansible" title="" class="sf-depth-3">Ansible</a></li><li id="menu-5576-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/big-data" title="" class="sf-depth-3">Big data</a></li><li id="menu-19861-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/resources/data-science" title="" class="sf-depth-3">Data science</a></li><li id="menu-5566-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/resources/what-docker" title="" class="sf-depth-3">Docker</a></li><li id="menu-19926-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/what-is-git" class="sf-depth-3">Git</a></li><li id="menu-5591-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/resources/internet-of-things" title="" class="sf-depth-3">Internet of things</a></li><li id="menu-19921-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/resources/java" title="" class="sf-depth-3">Java</a></li><li id="menu-5596-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/resources/what-is-kubernetes" title="" class="sf-depth-3">Kubernetes</a></li><li id="menu-5571-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/resources/what-are-linux-containers" title="" class="sf-depth-3">Linux containers</a></li><li id="menu-5586-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/resources/what-are-microservices" title="" class="sf-depth-3">Microservices</a></li><li id="menu-5561-1" class="middle odd sf-item-11 sf-depth-3 sf-no-children"><a href="/resources/what-is-openstack" title="" class="sf-depth-3">OpenStack</a></li><li id="menu-19836-1" class="middle even sf-item-12 sf-depth-3 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/resources/python" title="" class="sf-depth-3 menuparent">Python</a><ul><li id="menu-19866-1" class="first odd sf-item-1 sf-depth-4 sf-no-children"><a href="/resources/python/gui-frameworks" class="sf-depth-4">Python GUI frameworks</a></li><li id="menu-19871-1" class="middle even sf-item-2 sf-depth-4 sf-no-children"><a href="/resources/python/ides" class="sf-depth-4">Python IDEs</a></li><li id="menu-19881-1" class="middle odd sf-item-3 sf-depth-4 sf-no-children"><a href="/resources/python/template-libraries" title="" class="sf-depth-4">Python template libraries</a></li><li id="menu-19876-1" class="last even sf-item-4 sf-depth-4 sf-no-children"><a href="/resources/python/web-scraper-crawler" title="" class="sf-depth-4">Python web scrapers</a></li></ul></li><li id="menu-5581-1" class="middle odd sf-item-13 sf-depth-3 sf-no-children"><a href="/resources/what-is-software-defined-networking" title="" class="sf-depth-3">Software defined networking</a></li><li id="menu-12601-1" class="last even sf-item-14 sf-depth-3 sf-no-children"><a href="/resources/virtualization" title="" class="sf-depth-3">Virtualization</a></li></ul></li><li id="menu-2036-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-12 sf-parent-children-0 sf-single-children-12 menuparent"><a href="/alternatives" title="" class="sf-depth-2 menuparent">Open source alternatives</a><ul><li id="menu-4646-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/alternatives/adobe-acrobat" class="sf-depth-3">Alternatives to Acrobat</a></li><li id="menu-4656-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/alternatives/autocad" class="sf-depth-3">Alternatives to AutoCAD</a></li><li id="menu-4636-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/alternatives/dreamweaver" class="sf-depth-3">Alternatives to Dreamweaver</a></li><li id="menu-5506-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/alternatives/gmail" class="sf-depth-3">Alternatives to Gmail</a></li><li id="menu-5551-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/alternatives/matlab" class="sf-depth-3">Alternatives to MATLAB</a></li><li id="menu-5501-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/alternatives/minecraft" class="sf-depth-3">Alternatives to Minecraft</a></li><li id="menu-4651-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/alternatives/picasa" class="sf-depth-3">Alternatives to Google Photos</a></li><li id="menu-27351-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/life/12/6/design-without-debt-five-tools-for-designers" title="" class="sf-depth-3">Alternatives to Photoshop</a></li><li id="menu-4661-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/alternatives/microsoft-publisher" class="sf-depth-3">Alternatives to Publisher</a></li><li id="menu-5511-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/alternatives/slack" class="sf-depth-3">Alternatives to Slack</a></li><li id="menu-4641-1" class="middle odd sf-item-11 sf-depth-3 sf-no-children"><a href="/alternatives/trello" class="sf-depth-3">Alternatives to Trello</a></li><li id="menu-5546-1" class="last even sf-item-12 sf-depth-3 sf-no-children"><a href="/alternatives" title="" class="sf-depth-3">More...</a></li></ul></li><li id="menu-19886-1" class="last even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/linux" title="" class="sf-depth-2">Linux</a></li></ul></li><li id="menu-19666-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-6 sf-parent-children-6 sf-single-children-0 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-1 menuparent">Downloads</a><ul><li id="menu-19406-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-23 sf-parent-children-0 sf-single-children-23 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Cheat sheets</a><ul><li id="menu-19651-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-awk-features" class="sf-depth-3">AWK cheat sheet</a></li><li id="menu-27241-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/bash-cheat-sheet" class="sf-depth-3">Bash cheat sheet</a></li><li id="menu-18641-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/downloads/blender-hotkey-cheat-sheet" class="sf-depth-3">Blender cheat sheet</a></li><li id="menu-27336-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/downloads/emacs-cheat-sheet" class="sf-depth-3">Emacs cheat sheet</a></li><li id="menu-18856-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/freedos-commands-cheat-sheet" class="sf-depth-3">FreeDOS cheat sheet</a></li><li id="menu-19721-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/content/cheat-sheet-gimp" class="sf-depth-3">GIMP cheat sheet</a></li><li id="menu-19696-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-gnome-3" class="sf-depth-3">GNOME cheat sheet</a></li><li id="menu-18661-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/downloads/groff-macros-cheat-sheet" class="sf-depth-3">Groff macros cheat sheet</a></li><li id="menu-19731-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/downloads/go-cheat-sheet" class="sf-depth-3">Go cheat sheet</a></li><li id="menu-19716-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-i3-window-manager-keybinding" class="sf-depth-3">i3 window manager cheat sheet</a></li><li id="menu-19781-1" class="middle odd sf-item-11 sf-depth-3 sf-no-children"><a href="/downloads/inkscape-cheat-sheet" class="sf-depth-3">Inkscape Cheat Sheet</a></li><li id="menu-16886-1" class="middle even sf-item-12 sf-depth-3 sf-no-children"><a href="/irc-cheat-sheet" class="sf-depth-3">IRC cheat sheet</a></li><li id="menu-27271-1" class="middle odd sf-item-13 sf-depth-3 sf-no-children"><a href="/downloads/java-cheat-sheet" class="sf-depth-3">Java cheat sheet</a></li><li id="menu-27246-1" class="middle even sf-item-14 sf-depth-3 sf-no-children"><a href="/downloads/linux-common-commands-cheat-sheet" class="sf-depth-3">Linux common commands cheat sheet</a></li><li id="menu-27216-1" class="middle odd sf-item-15 sf-depth-3 sf-no-children"><a href="/downloads/linux-permissions-cheat-sheet" class="sf-depth-3">Linux user permissions cheat sheet</a></li><li id="menu-27256-1" class="middle even sf-item-16 sf-depth-3 sf-no-children"><a href="/downloads/microservices-cheat-sheet" class="sf-depth-3">Microservices cheat sheet</a></li><li id="menu-19301-1" class="middle odd sf-item-17 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-networking" class="sf-depth-3">Networking cheat sheet</a></li><li id="menu-18636-1" class="middle even sf-item-18 sf-depth-3 sf-no-children"><a href="/downloads/pandoc-cheat-sheet" class="sf-depth-3">Pandoc cheat sheet</a></li><li id="menu-27261-1" class="middle odd sf-item-19 sf-depth-3 sf-no-children"><a href="/downloads/pip-cheat-sheet" class="sf-depth-3">pip cheat sheet</a></li><li id="menu-19711-1" class="middle even sf-item-20 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-python-37-beginners" class="sf-depth-3">Python 3.7 cheat sheet</a></li><li id="menu-19726-1" class="middle odd sf-item-21 sf-depth-3 sf-no-children"><a href="/downloads/getting-started-raspberry-pi-cheat-sheet" class="sf-depth-3">Raspberry Pi cheat sheet</a></li><li id="menu-19691-1" class="middle even sf-item-22 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-selinux" class="sf-depth-3">SELinux cheat sheet</a></li><li id="menu-18591-1" class="last odd sf-item-23 sf-depth-3 sf-no-children"><a href="/downloads/advanced-ssh-cheat-sheet" class="sf-depth-3">SSH cheat sheet</a></li></ul></li><li id="menu-12466-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/yearbook/2017" title="" class="sf-depth-2 menuparent">Open Source Yearbook</a><ul><li id="menu-19681-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/yearbook/2015" title="" class="sf-depth-3">2015</a></li><li id="menu-19676-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/yearbook/2016" title="" class="sf-depth-3">2016</a></li><li id="menu-19671-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/yearbook/2017" title="" class="sf-depth-3">2017</a></li><li id="menu-19786-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/yearbook/2018" title="" class="sf-depth-3">2018</a></li><li id="menu-27346-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/2019-yearbook-special-edition" title="" class="sf-depth-3">2019 Special Edition</a></li></ul></li><li id="menu-19906-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Programming guides</a><ul><li id="menu-19891-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/7-essential-pypi-libraries" title="" class="sf-depth-3">7 essential PyPI libraries</a></li></ul></li><li id="menu-19911-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">DevOps guides</a><ul><li id="menu-19806-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/devops-transformation" class="sf-depth-3">Starting a DevOps transformation</a></li><li id="menu-19776-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/small-scale-scrum" class="sf-depth-3">Introduction to Small Scale Scrum</a></li><li id="menu-19771-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/downloads/devsecops" class="sf-depth-3">Getting started with DevSecOps</a></li><li id="menu-19701-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/downloads/devops-monitoring-guide" class="sf-depth-3">DevOps monitoring tools guide</a></li><li id="menu-19686-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/devops-hiring-guide" class="sf-depth-3">DevOps hiring guide</a></li></ul></li><li id="menu-19916-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Sysadmin guides</a><ul><li id="menu-19801-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="https://opensource.com/downloads/ansible-quickstart" title="" class="sf-depth-3">Ansible Automation for Sysadmins</a></li><li id="menu-19706-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/containers-primer" class="sf-depth-3">Containers primer</a></li></ul></li><li id="menu-19901-1" class="last even sf-item-6 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">eBooks</a><ul><li id="menu-19896-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/getting-started-kubernetes-ebook" class="sf-depth-3">Getting started with Kubernetes</a></li><li id="menu-27276-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/guide-inter-process-communication-linux" class="sf-depth-3">Inter-process communication in Linux</a></li><li id="menu-27321-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/downloads/collaboration-tools-ebook" class="sf-depth-3">5 open source collaboration tools</a></li><li id="menu-27311-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/downloads/organization-tools" class="sf-depth-3">6 open source tools for staying organized</a></li><li id="menu-27316-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/desktop-tools" class="sf-depth-3">7 open source desktop tools</a></li></ul></li></ul></li><li id="menu-4691-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-5 sf-parent-children-2 sf-single-children-3 menuparent"><a href="/about" class="sf-depth-1 menuparent">About</a><ul><li id="menu-12516-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-7 sf-parent-children-0 sf-single-children-7 menuparent"><a href="/participate" class="sf-depth-2 menuparent">Join us</a><ul><li id="menu-12521-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/user/register" title="" class="sf-depth-3">Register</a></li><li id="menu-12526-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/rules-comments-and-discussions" class="sf-depth-3">Rules for comments and discussions</a></li><li id="menu-17781-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/devops-team" class="sf-depth-3">Contribute to DevOps resources</a></li><li id="menu-12531-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/correspondent-program" class="sf-depth-3">Correspondent Program</a></li><li id="menu-12581-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/contributor-club" title="" class="sf-depth-3">Contributor Club</a></li><li id="menu-12541-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/points-and-badges" class="sf-depth-3">Points and badges</a></li><li id="menu-17766-1" class="last odd sf-item-7 sf-depth-3 sf-no-children"><a href="/delete-account" title="" class="sf-depth-3">Delete your account</a></li></ul></li><li id="menu-1966-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-6 sf-parent-children-0 sf-single-children-6 menuparent"><a href="/writers" title="" class="sf-depth-2 menuparent">For writers</a><ul><li id="menu-17761-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/how-submit-article" class="sf-depth-3">Write for us</a></li><li id="menu-12546-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/editorial-calendar" title="" class="sf-depth-3">Editorial calendar</a></li><li id="menu-12586-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/article/20/1/write-for-us" title="" class="sf-depth-3">Writing topics</a></li><li id="menu-2041-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/submission-style-guide" class="sf-depth-3">Article submission and style guide</a></li><li id="menu-4616-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/promoting-articles" class="sf-depth-3">Tips for promoting your Opensource.com article</a></li><li id="menu-12556-1" class="last even sf-item-6 sf-depth-3 sf-no-children"><a href="/writer-testimonials" class="sf-depth-3">Writer testimonials</a></li></ul></li><li id="menu-1971-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/opensourcecom-team" class="sf-depth-2">Meet the team</a></li><li id="menu-2006-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/press-kit" class="sf-depth-2">Press kit</a></li><li id="menu-2001-1" class="last odd sf-item-5 sf-depth-2 sf-no-children"><a href="/contact" title="" class="sf-depth-2">Contact</a></li></ul></li><li id="menu-2136-1" class="last odd sf-item-5 sf-depth-1 sf-total-children-4 sf-parent-children-3 sf-single-children-1 menuparent"><a href="/open-organization" title="" class="sf-depth-1 menuparent">Open Organization</a><ul><li id="menu-27251-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://opensource.com/open-organization/start" title="" class="sf-depth-2">Get started</a></li><li id="menu-15051-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-6 sf-parent-children-0 sf-single-children-6 menuparent"><a href="/open-organization/resources/book-series" title="" class="sf-depth-2 menuparent">Book series</a><ul><li id="menu-16906-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/field-guide" title="" class="sf-depth-3">Field Guide</a></li><li id="menu-16891-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/leaders-manual" class="sf-depth-3">Leaders Manual</a></li><li id="menu-16896-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/culture-change" title="" class="sf-depth-3">Guide to IT Culture Change</a></li><li id="menu-19856-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/educators-guide" class="sf-depth-3">Guide for Educators</a></li><li id="menu-17796-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/workbook" title="" class="sf-depth-3">Workbook</a></li><li id="menu-18656-1" class="last even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/organize-innovation" title="" class="sf-depth-3">Organize for Innovation</a></li></ul></li><li id="menu-2146-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/open-organization/resources" title="" class="sf-depth-2 menuparent">Resources</a><ul><li id="menu-12471-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="sf-depth-3">What is an open organization?</a></li><li id="menu-15056-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-org-maturity-model" title="" class="sf-depth-3">How open is your organization?</a></li><li id="menu-12421-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-decision-framework" title="" class="sf-depth-3">What is an open decision?</a></li><li id="menu-2151-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/guides" title="" class="sf-depth-3">Discussion Guides</a></li><li id="menu-17821-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/newsletter" title="" class="sf-depth-3">Newsletter</a></li></ul></li><li id="menu-3166-1" class="last even sf-item-4 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/open-organization/resources/ambassadors-program" title="" class="sf-depth-2 menuparent">Ambassadors community</a><ul><li id="menu-2691-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/meet-ambassadors" title="" class="sf-depth-3">Meet the ambassadors</a></li></ul></li></ul></li></ul>
</div>
<div id="block-system-user-menu" class="block block-system block-menu odd" role="navigation">

      
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul>
</div>
<div id="block-menu-block-2" class="block block-menu-block last even" role="navigation">

      
  <div class="menu-block-wrapper menu-block-2 menu-name-menu-social-links parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-13171"><a href="http://twitter.com/opensourceway" title="twitter" class="menu__link">Twitter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-13176"><a href="https://www.facebook.com/opensourceway" title="facebook" class="menu__link">Facebook</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-13166"><a href="/feed" title="feed" class="menu__link">Feed</a></li>
</ul></div>

</div>
  </div>

        <div class="mobile--menu-region">
            <div class="region region-navigation">
    <div id="block-system-main-menu" class="block block-system block-menu first last odd" role="navigation">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/" title="" class="menu__link">Articles</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/containers" title="" class="menu__link">Containers</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/devops" title="" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/gaming" title="" class="menu__link">Gaming</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/government" title="" class="menu__link">Government</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/hardware" title="" class="menu__link">Hardware</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/3d-printing" title="" class="menu__link">3D printing</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/arduino" title="" class="menu__link">Arduino</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/raspberry-pi" title="" class="menu__link">Raspberry Pi</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="https://opensource.com/tags/kubernetes" title="" class="menu__link">Kubernetes</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/law" title="" class="menu__link">Law</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/linux" title="" class="menu__link">Linux</a><ul class="menu"><li class="menu__item is-leaf first last leaf"><a href="/tags/command-line" title="" class="menu__link">Command line</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/tags/openstack" title="" class="menu__link">OpenStack</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/programming" title="" class="menu__link">Programming</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/go" title="" class="menu__link">Go</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/javascript" title="" class="menu__link">JavaScript</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/python" title="" class="menu__link">Python</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/tags/sysadmin" title="" class="menu__link">SysAdmin</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-collapsed first collapsed"><a href="/resources/what-open-source" title="" class="menu__link">What is open source?</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/projects-and-applications" title="" class="menu__link">Projects and applications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/organizations" title="" class="menu__link">Organizations</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/resources/cloud" title="" class="menu__link">Cloud technology</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/alternatives" title="" class="menu__link">Open source alternatives</a></li>
<li class="menu__item is-leaf last leaf"><a href="/resources/linux" title="" class="menu__link">Linux</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/downloads/cheat-sheets" title="" class="menu__link">Downloads</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/about" class="menu__link">About</a></li>
<li class="menu__item is-expanded last expanded"><a href="/open-organization" title="" class="menu__link">Open Organization</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://opensource.com/open-organization/start" title="" class="menu__link">Get started</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/open-organization/resources/book-series" title="" class="menu__link">Book series</a></li>
<li class="menu__item is-expanded expanded"><a href="/open-organization/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="menu__link">What is an open organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-org-maturity-model" title="" class="menu__link">How open is your organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-decision-framework" title="" class="menu__link">What is an open decision?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/guides" title="" class="menu__link">Discussion Guides</a></li>
<li class="menu__item is-leaf last leaf"><a href="/open-organization/resources/newsletter" title="" class="menu__link">Newsletter</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/open-organization/resources/ambassadors-program" title="" class="menu__link">Ambassadors community</a></li>
</ul></li>
</ul>
</div>
  </div>
        </div>
      </div>
    </div>

</header>

<div id="page">

      <div id="main">
        <div class="pre-content">
                                                </div>
        <div id="content" class="column" role="main">
                              <a id="main-content"></a>
                                <h1 class="page__title title" id="page-title">Automate your live demos with this shell script | Opensource.com</h1>
                              



<div class="panel-display os-article clearfix os-article--with-image " id="article-template">

      <div class="os-article__top">
      <div class="os-article__top-inner">
        <div class="panel-pane pane-node-title"  >
  
      
  
  <h1>Automate your live demos with this shell script</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-article-subhead"  >
  
      
  
  <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden">
    <div class="field-items">
          <h2>Try this script the next time you give a presentation to prevent making typos in front of a live audience.</h2>
      </div>
</div>

  
  </div>
<div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__date">11 Feb 2020</span>
<span class="byline__author-name"><a href="/users/lisa" title="View user profile." class="username" xml:lang="" about="/users/lisa" typeof="sioc:UserAccount" property="foaf:name" datatype="">Lisa Seelye <span class="content-moderator">(Red Hat)</span></a>&nbsp;<span class="byline__feed"><a href="/user/348561/feed">Feed</a></span>
</span>
<span class="byline__social"><span class="byline__voting-widget"><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-d9f6772a3e537facae9c231c640d5e90 rate-node-60831-1-1" id="rate-node-60831-1-1"><div class="rate-info">8</div><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/20/2/live-demo-script?rate=9aozn0gWXCdMNwPxE0gcgISV4v5l-SkNtTVBH67z3aI" title="up">up</a></div></span>
</span>
</div>
  
  </div>
      </div>
    </div>
  
      <div class="os-article__image">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/laptop_screen_desk_work_chat_text.png?itok=UXqIDRDD"><img class="image-full-size" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/laptop_screen_desk_work_chat_text.png?itok=UXqIDRDD" width="520" height="292" alt="Person using a laptop" title="Person using a laptop" /></div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__left">
      <div class="panel-pane pane-block pane-bean-email-capture widget-block widget-block__left"  >
      <div class="target-band-never-show-button">x</div>
        <h2 class="pane-title">
      Subscribe now    </h2>
    
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/email-capture" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe frameborder="0" height="100" id="fkfkx" scrolling="no" src="/eloqua-embedded-email-capture-block.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="250"></iframe></p>
</div></div></div>  </div>
</div>

  
  </div>
    </div>
  
  
      <div class="os-article__middle">
      <div class="panel-pane pane-entity-field pane-node-body"  >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:articleBody content:encoded"><p>I gave a talk about <a href="https://www.usenix.org/conference/lisa19/presentation/seelye" target="_blank">multi-architecture container images</a> at <a href="https://www.usenix.org/conference/lisa19" target="_blank">LISA19</a> in October that included a lengthy live demo. Rather than writing out 30+ commands and risking typos, I decided to automate the demo with a shell script.</p>

<p>The script mimics what appears as input/output and runs the real commands in the background, pausing at various points so I can narrate what is going on. I'm very pleased with how the script turned out and the effect on stage. The script and supporting materials for my presentation are available on <a href="https://github.com/lisa/lisa19-containers" target="_blank">GitHub</a> under an Apache 2.0 license.</p>

<h2 id="the-script">The script</h2>

<pre><div class="geshifilter"><div class="bash geshifilter-bash"><span class="co0">#!/bin/bash</span><br />
<br />
<span class="kw1">set</span> <span class="re5">-e</span><br />
<br />
<span class="re2">IMG</span>=thedoh<span class="sy0">/</span>lisa19<br />
<span class="re2">REGISTRY</span>=docker.io<br />
<span class="re2">VERSION</span>=19.10.1<br />
<br />
<span class="co0"># Plan B with GCR:</span><br />
<span class="co0">#IMG=dulcet-iterator-213018</span><br />
<span class="co0">#REGISTRY=us.gcr.io</span><br />
<span class="co0">#VERSION=19.10.1</span><br />
<br />
<br />
pause<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; <span class="kw3">local</span> <span class="re2">step</span>=<span class="st0">&quot;<span class="es3">${1}</span>&quot;</span><br />
&nbsp; ps1<br />
&nbsp; <span class="kw3">echo</span> <span class="re5">-n</span> <span class="st0">&quot;# Next step: <span class="es3">${step}</span>&quot;</span><br />
&nbsp; <span class="kw2">read</span><br />
<span class="br0">&#125;</span><br />
<br />
ps1<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; <span class="kw3">echo</span> <span class="re5">-ne</span> <span class="st0">&quot;\033[01;32m<span class="es3">${USER}</span>@<span class="es4">$(hostname -s)</span> \033[01;34m<span class="es4">$(basename $(pwd)</span>) <span class="es1">\$</span> \033[00m&quot;</span><br />
<span class="br0">&#125;</span><br />
<br />
echocmd<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; <span class="kw3">echo</span> <span class="st0">&quot;<span class="es4">$(ps1)</span>$@&quot;</span><br />
<span class="br0">&#125;</span><br />
<br />
docmd<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; echocmd $<span class="sy0">@</span><br />
&nbsp; $<span class="sy0">@</span><br />
<span class="br0">&#125;</span><br />
<br />
step0<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; <span class="kw3">local</span> <span class="re2">registry</span>=<span class="st0">&quot;<span class="es3">${1}</span>&quot;</span> <span class="re2">img</span>=<span class="st0">&quot;<span class="es3">${2}</span>&quot;</span> <span class="re2">version</span>=<span class="st0">&quot;<span class="es3">${3}</span>&quot;</span><br />
&nbsp; <span class="co0"># Mindful of tokens in ~/.docker/config.json</span><br />
&nbsp; docmd <span class="kw2">grep</span> experimental ~<span class="sy0">/</span>.docker<span class="sy0">/</span>config.json<br />
&nbsp; <br />
&nbsp; docmd <span class="kw3">cd</span> ~<span class="sy0">/</span>go<span class="sy0">/</span>src<span class="sy0">/</span>github.com<span class="sy0">/</span>lisa<span class="sy0">/</span>lisa19-containers<br />
&nbsp; <br />
&nbsp; pause <span class="st0">&quot;This is what we'll be building&quot;</span><br />
&nbsp; docmd <span class="kw3">export</span> <span class="re2">REGISTRY</span>=<span class="co1">${registry}</span><br />
&nbsp; docmd <span class="kw3">export</span> <span class="re2">IMG</span>=<span class="co1">${img}</span><br />
&nbsp; docmd <span class="kw3">export</span> <span class="re2">VERSION</span>=<span class="co1">${version}</span><br />
&nbsp; docmd <span class="kw2">make</span> <span class="re2">REGISTRY</span>=<span class="co1">${registry}</span> <span class="re2">IMG</span>=<span class="co1">${img}</span> <span class="re2">VERSION</span>=<span class="co1">${version}</span> clean<br />
<span class="br0">&#125;</span><br />
<br />
step1<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; <span class="kw3">local</span> <span class="re2">registry</span>=<span class="st0">&quot;<span class="es3">${1}</span>&quot;</span> <span class="re2">img</span>=<span class="st0">&quot;<span class="es3">${2}</span>&quot;</span> <span class="re2">version</span>=<span class="st0">&quot;<span class="es3">${3}</span>&quot;</span><br />
&nbsp; <br />
&nbsp; docmd docker build <span class="re5">--no-cache</span> <span class="re5">--platform</span>=linux<span class="sy0">/</span>amd64 <span class="re5">--build-arg</span>=<span class="re2">GOARCH</span>=amd64 <span class="re5">-t</span> <span class="co1">${REGISTRY}</span><span class="sy0">/</span><span class="co1">${IMG}</span>:amd64-<span class="co1">${VERSION}</span> .<br />
&nbsp; pause <span class="st0">&quot;ARM64 image next&quot;</span><br />
&nbsp; docmd docker build <span class="re5">--no-cache</span> <span class="re5">--platform</span>=linux<span class="sy0">/</span>arm64 <span class="re5">--build-arg</span>=<span class="re2">GOARCH</span>=arm64 <span class="re5">-t</span> <span class="co1">${REGISTRY}</span><span class="sy0">/</span><span class="co1">${IMG}</span>:arm64-<span class="co1">${VERSION}</span> . <br />
<span class="br0">&#125;</span><br />
<br />
step2<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; <span class="kw3">local</span> <span class="re2">registry</span>=<span class="st0">&quot;<span class="es3">${1}</span>&quot;</span> <span class="re2">img</span>=<span class="st0">&quot;<span class="es3">${2}</span>&quot;</span> <span class="re2">version</span>=<span class="st0">&quot;<span class="es3">${3}</span>&quot;</span> <span class="re2">origpwd</span>=$<span class="br0">&#40;</span><span class="kw3">pwd</span><span class="br0">&#41;</span> <span class="re2">savedir</span>=$<span class="br0">&#40;</span><span class="kw2">mktemp</span> -d<span class="br0">&#41;</span> <span class="re2">jsontemp</span>=$<span class="br0">&#40;</span><span class="kw2">mktemp</span> <span class="re5">-t</span> XXXXX<span class="br0">&#41;</span><br />
&nbsp; <span class="kw2">chmod</span> <span class="nu0">700</span> <span class="re1">$jsontemp</span> <span class="re1">$savedir</span><br />
&nbsp; <span class="co0"># Set our way back home and get ready to fix our arm64 image to amd64.</span><br />
&nbsp; echocmd <span class="st_h">'origpwd=$(pwd)'</span><br />
&nbsp; echocmd <span class="st_h">'savedir=$(mktemp -d)'</span><br />
&nbsp; echocmd <span class="st0">&quot;mkdir -p <span class="es1">\$</span>savedir/change&quot;</span><br />
&nbsp; <span class="kw2">mkdir</span> <span class="re5">-p</span> <span class="re1">$savedir</span><span class="sy0">/</span>change <span class="sy0">&amp;&gt;/</span>dev<span class="sy0">/</span>null<br />
&nbsp; echocmd <span class="st0">&quot;docker save <span class="es3">${REGISTRY}</span>/<span class="es3">${IMG}</span>:arm64-<span class="es3">${VERSION}</span> 2&gt;/dev/null 1&gt; <span class="es1">\$</span>savedir/image.tar&quot;</span><br />
&nbsp; docker save <span class="co1">${REGISTRY}</span><span class="sy0">/</span><span class="co1">${IMG}</span>:arm64-<span class="co1">${VERSION}</span> <span class="nu0">2</span><span class="sy0">&gt;/</span>dev<span class="sy0">/</span>null <span class="nu0">1</span><span class="sy0">&gt;</span> <span class="re1">$savedir</span><span class="sy0">/</span>image.tar<br />
&nbsp; pause <span class="st0">&quot;untar the image to access its metadata&quot;</span><br />
&nbsp; <br />
&nbsp; echocmd <span class="st0">&quot;cd <span class="es1">\$</span>savedir/change&quot;</span><br />
&nbsp; <span class="kw3">cd</span> <span class="re1">$savedir</span><span class="sy0">/</span>change<br />
&nbsp; echocmd <span class="kw2">tar</span> xf \<span class="re1">$savedir</span><span class="sy0">/</span>image.tar<br />
&nbsp; <span class="kw2">tar</span> xf <span class="re1">$savedir</span><span class="sy0">/</span>image.tar<br />
&nbsp; docmd <span class="kw2">ls</span> <span class="re5">-l</span><br />
&nbsp; <br />
&nbsp; pause <span class="st0">&quot;find the JSON config file&quot;</span><br />
&nbsp; echocmd <span class="st_h">'jsonfile=$(jq -r &quot;.[0].Config&quot; manifest.json)'</span><br />
&nbsp; <span class="re2">jsonfile</span>=$<span class="br0">&#40;</span>jq <span class="re5">-r</span> <span class="st0">&quot;.[0].Config&quot;</span> manifest.json<span class="br0">&#41;</span><br />
&nbsp; <br />
&nbsp; pause <span class="st0">&quot;notice the original metadata says amd64&quot;</span><br />
&nbsp; echocmd jq <span class="st_h">'{architecture: .architecture, ID: .config.Image}'</span> \<span class="re1">$jsonfile</span><br />
&nbsp; jq <span class="st_h">'{architecture: .architecture, ID: .config.Image}'</span> <span class="re1">$jsonfile</span><br />
&nbsp; <br />
&nbsp; pause <span class="st0">&quot;Change from amd64 to arm64 using a temp file&quot;</span><br />
&nbsp; echocmd <span class="st0">&quot;jq '.architecture = <span class="es1">\&quot;</span>arm64<span class="es1">\&quot;</span>' <span class="es1">\$</span>jsonfile &gt; <span class="es1">\$</span>jsontemp&quot;</span><br />
&nbsp; jq <span class="st_h">'.architecture = &quot;arm64&quot;'</span> <span class="re1">$jsonfile</span> <span class="sy0">&gt;</span> <span class="re1">$jsontemp</span><br />
&nbsp; echocmd <span class="sy0">/</span>bin<span class="sy0">/</span><span class="kw2">mv</span> <span class="re5">-f</span> <span class="re5">--</span> \<span class="re1">$jsontemp</span> \<span class="re1">$jsonfile</span><br />
&nbsp; <span class="sy0">/</span>bin<span class="sy0">/</span><span class="kw2">mv</span> <span class="re5">-f</span> <span class="re5">--</span> <span class="re1">$jsontemp</span> <span class="re1">$jsonfile</span><br />
<br />
&nbsp; pause <span class="st0">&quot;Check to make sure the config JSON file says arm64 now&quot;</span><br />
&nbsp; echocmd jq <span class="st_h">'{architecture: .architecture, ID: .config.Image}'</span> \<span class="re1">$jsonfile</span><br />
&nbsp; jq <span class="st_h">'{architecture: .architecture, ID: .config.Image}'</span> <span class="re1">$jsonfile</span><br />
&nbsp; <br />
&nbsp; pause <span class="st0">&quot;delete the image with the incorrect metadata&quot;</span><br />
&nbsp; docmd docker rmi <span class="co1">${REGISTRY}</span><span class="sy0">/</span><span class="co1">${IMG}</span>:arm64-<span class="co1">${VERSION}</span><br />
&nbsp; <br />
&nbsp; pause <span class="st0">&quot;Re-compress the ARM64 image and load it back into Docker, then clean up the temp space&quot;</span><br />
&nbsp; echocmd <span class="st_h">'tar cf - * | docker load'</span><br />
&nbsp; <span class="kw2">tar</span> cf - <span class="sy0">*</span> <span class="sy0">|</span> docker load<br />
<br />
&nbsp; docmd <span class="kw3">cd</span> <span class="re1">$origpwd</span><br />
&nbsp; echocmd <span class="st0">&quot;/bin/rm -rf -- <span class="es1">\$</span>savedir&quot;</span><br />
&nbsp; <span class="sy0">/</span>bin<span class="sy0">/</span><span class="kw2">rm</span> <span class="re5">-rf</span> <span class="re5">--</span> <span class="re1">$savedir</span> <span class="sy0">&amp;&gt;/</span>dev<span class="sy0">/</span>null<br />
<span class="br0">&#125;</span><br />
<br />
step3<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; <span class="kw3">local</span> <span class="re2">registry</span>=<span class="st0">&quot;<span class="es3">${1}</span>&quot;</span> <span class="re2">img</span>=<span class="st0">&quot;<span class="es3">${2}</span>&quot;</span> <span class="re2">version</span>=<span class="st0">&quot;<span class="es3">${3}</span>&quot;</span><br />
&nbsp; docmd docker push <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:amd64-<span class="co1">${version}</span><br />
&nbsp; pause <span class="st0">&quot;push ARM64 image to <span class="es3">${registry}</span>&quot;</span><br />
&nbsp; docmd docker push <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:arm64-<span class="co1">${version}</span><br />
<span class="br0">&#125;</span><br />
<br />
step4<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; <span class="kw3">local</span> <span class="re2">registry</span>=<span class="st0">&quot;<span class="es3">${1}</span>&quot;</span> <span class="re2">img</span>=<span class="st0">&quot;<span class="es3">${2}</span>&quot;</span> <span class="re2">version</span>=<span class="st0">&quot;<span class="es3">${3}</span>&quot;</span><br />
&nbsp; docmd docker manifest create <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:<span class="co1">${version}</span> <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:arm64-<span class="co1">${version}</span> <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:amd64-<span class="co1">${version}</span><br />
&nbsp; <br />
&nbsp; pause <span class="st0">&quot;add a reference to the amd64 image to the manifest list&quot;</span><br />
&nbsp; docmd docker manifest annotate <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:<span class="co1">${version}</span> <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:amd64-<span class="co1">${version}</span> <span class="re5">--os</span> linux <span class="re5">--arch</span> amd64<br />
&nbsp; pause <span class="st0">&quot;now add arm64&quot;</span><br />
&nbsp; docmd docker manifest annotate <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:<span class="co1">${version}</span> <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:arm64-<span class="co1">${version}</span> <span class="re5">--os</span> linux <span class="re5">--arch</span> arm64<br />
<span class="br0">&#125;</span><br />
<br />
step5<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; <span class="kw3">local</span> <span class="re2">registry</span>=<span class="st0">&quot;<span class="es3">${1}</span>&quot;</span> <span class="re2">img</span>=<span class="st0">&quot;<span class="es3">${2}</span>&quot;</span> <span class="re2">version</span>=<span class="st0">&quot;<span class="es3">${3}</span>&quot;</span><br />
&nbsp; docmd docker manifest push <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:<span class="co1">${version}</span><br />
<span class="br0">&#125;</span><br />
<br />
<br />
step6<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="br0">&#123;</span><br />
&nbsp; <span class="kw3">local</span> <span class="re2">registry</span>=<span class="st0">&quot;<span class="es3">${1}</span>&quot;</span> <span class="re2">img</span>=<span class="st0">&quot;<span class="es3">${2}</span>&quot;</span> <span class="re2">version</span>=<span class="st0">&quot;<span class="es3">${3}</span>&quot;</span><br />
&nbsp; docmd <span class="kw2">make</span> <span class="re2">REGISTRY</span>=<span class="co1">${registry}</span> <span class="re2">IMG</span>=<span class="co1">${img}</span> <span class="re2">VERSION</span>=<span class="co1">${version}</span> clean<br />
&nbsp; <br />
&nbsp; pause <span class="st0">&quot;ask docker.io if <span class="es3">${img}</span>:<span class="es3">${version}</span> has a linux/amd64 manifest, and run it&quot;</span><br />
&nbsp; docmd docker pull <span class="re5">--platform</span> linux<span class="sy0">/</span>amd64 <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:<span class="co1">${version}</span><br />
&nbsp; docmd docker run <span class="re5">--rm</span> <span class="re5">-i</span> <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:<span class="co1">${version}</span><br />
&nbsp; <br />
&nbsp; pause <span class="st0">&quot;clean slate again&quot;</span><br />
&nbsp; docmd <span class="kw2">make</span> <span class="re2">REGISTRY</span>=<span class="co1">${registry}</span> <span class="re2">IMG</span>=<span class="co1">${img}</span> <span class="re2">VERSION</span>=<span class="co1">${version}</span> clean<br />
&nbsp; <br />
&nbsp; pause <span class="st0">&quot;now repeat for linux/arm64 and see what it gives us&quot;</span><br />
&nbsp; docmd docker pull <span class="re5">--platform</span> linux<span class="sy0">/</span>arm64 <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:<span class="co1">${version}</span><br />
&nbsp; <span class="kw1">set</span> +e<br />
&nbsp; docmd docker run <span class="re5">--rm</span> <span class="re5">-i</span> <span class="co1">${registry}</span><span class="sy0">/</span><span class="co1">${img}</span>:<span class="co1">${version}</span><br />
&nbsp; <span class="kw1">set</span> <span class="re5">-e</span><br />
&nbsp; <span class="kw1">if</span> <span class="br0">&#91;</span><span class="br0">&#91;</span> $<span class="br0">&#40;</span><span class="kw2">uname</span> -s<span class="br0">&#41;</span> == <span class="st0">&quot;Darwin&quot;</span> <span class="br0">&#93;</span><span class="br0">&#93;</span>; <span class="kw1">then</span><br />
&nbsp; &nbsp; pause <span class="st0">&quot;note about Docker on Mac and binfmt_misc: binfmt_misc lets a mac run arm64 binaries in the Docker VM&quot;</span><br />
&nbsp; <span class="kw1">fi</span><br />
<span class="br0">&#125;</span><br />
<br />
pause <span class="st0">&quot;initial setup&quot;</span><br />
step0 <span class="co1">${REGISTRY}</span> <span class="co1">${IMG}</span> <span class="co1">${VERSION}</span><br />
pause <span class="st0">&quot;1 build constituent images&quot;</span><br />
step1 <span class="co1">${REGISTRY}</span> <span class="co1">${IMG}</span> <span class="co1">${VERSION}</span><br />
<br />
pause <span class="st0">&quot;2 fix ARM64 metadata&quot;</span><br />
step2 <span class="co1">${REGISTRY}</span> <span class="co1">${IMG}</span> <span class="co1">${VERSION}</span><br />
<br />
pause <span class="st0">&quot;3 push constituent images up to docker.io&quot;</span><br />
step3 <span class="co1">${REGISTRY}</span> <span class="co1">${IMG}</span> <span class="co1">${VERSION}</span><br />
<br />
pause <span class="st0">&quot;4 build the manifest list for the image&quot;</span><br />
step4 <span class="co1">${REGISTRY}</span> <span class="co1">${IMG}</span> <span class="co1">${VERSION}</span><br />
<br />
pause <span class="st0">&quot;5 Push the manifest list to docker.io&quot;</span><br />
step5 <span class="co1">${REGISTRY}</span> <span class="co1">${IMG}</span> <span class="co1">${VERSION}</span><br />
<br />
pause <span class="st0">&quot;6 clean slate, and validate the list-based image&quot;</span><br />
step6 <span class="co1">${REGISTRY}</span> <span class="co1">${IMG}</span> <span class="co1">${VERSION}</span><br />
<br />
docmd <span class="kw3">echo</span> <span class="st_h">'Manual steps all done!'</span><br />
<span class="kw2">make</span> <span class="re2">REGISTRY</span>=<span class="co1">${REGISTRY}</span> <span class="re2">IMG</span>=<span class="co1">${IMG}</span> <span class="re2">VERSION</span>=<span class="co1">${VERSION}</span> clean <span class="sy0">&amp;&gt;/</span>dev<span class="sy0">/</span>null</div></div></pre>

<p> </p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-listacles-panel-pane-1"  >
  
      
  
  <div class="view view-listacles view-id-listacles view-display-id-panel_pane_1 view-dom-id-6d60a3fdac74ea96d9927f820f2418b0">
        
  
  
      <div class="view-content">
              
  <div class="views-field views-field-field-listacles">        <div class="field-content">
<div class="panelizer-view-mode node node-teaser-listacles node-article node-37801 node-promoted node-promoted">
        
<div class="panel-display teaser clearfix " >

  <div class="teaser__first">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/OSDC_Internet_Cables_520x292_0614_RD.png?itok=9mLQWQos"><a href="/article/17/7/squid-proxy"><img class="teaser-wide" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/OSDC_Internet_Cables_520x292_0614_RD.png?itok=9mLQWQos" width="249" height="140" alt="Open source network cable" title="Open source network cable" /></a></div></div></div>
  
  </div>
  </div>

  <div class="teaser__second">
    <h2 class="teaser__title"><div class="panel-pane pane-node-title"  >
  
      
  
  <a href="/article/17/7/squid-proxy">How to live demo a web app with lousy internet</a>
  
  </div>
</h2>
    <div class="teaser__body"><div class="panel-pane pane-token pane-node-field-article-subhead"  >
  
      
  
  Squid HTTP proxy enables you to run a software demonstration, no matter how good or bad your internet connection.
  
  </div>
</div>
    <div class="teaser__byline"><div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__author-name"><a href="/users/preaction" title="View user profile." class="username" xml:lang="" about="/users/preaction" typeof="sioc:UserAccount" property="foaf:name" datatype="">Doug Bell</a></span>
</div>
  
  </div>
</div>
  </div>

</div>
</div>
</div>  </div>          
  <div class="views-field views-field-field-listacles">        <div class="field-content">
<div class="panelizer-view-mode node node-teaser-listacles node-article node-54941 node-promoted node-promoted">
        
<div class="panel-display teaser clearfix " >

  <div class="teaser__first">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/video_editing_folder_music_wave_play.png?itok=HnTi4SkM"><a href="/article/19/7/live-demo-perfect-or-broken"><img class="teaser-wide" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/video_editing_folder_music_wave_play.png?itok=HnTi4SkM" width="248" height="140" alt="video editing dashboard" title="video editing dashboard" /></a></div></div></div>
  
  </div>
  </div>

  <div class="teaser__second">
    <h2 class="teaser__title"><div class="panel-pane pane-node-title"  >
  
      
  
  <a href="/article/19/7/live-demo-perfect-or-broken">Do you prefer a live demo to be perfect or broken?</a>
  
  </div>
</h2>
    <div class="teaser__body"><div class="panel-pane pane-token pane-node-field-article-subhead"  >
  
      
  
  Do you learn more from flawless demos or ones the presenter de-bugs in real-time? Let us know by answering our poll.
  
  </div>
</div>
    <div class="teaser__byline"><div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__author-name"><a href="/users/lmaffeo" title="View user profile." class="username" xml:lang="" about="/users/lmaffeo" typeof="sioc:UserAccount" property="foaf:name" datatype="">Lauren Maffeo <span class="content-moderator">(Correspondent)</span></a></span>
</div>
  
  </div>
</div>
  </div>

</div>
</div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-tags"  >
  
        <h2 class="pane-title">
      Topics    </h2>
    
  
  <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:keywords"><a href="/tags/scripting" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Scripting</a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-author-info-panel-pane-1"  >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-a0214210e96c4589467b92c225b1bd16">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><a href="/users/lisa"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/pictures/2019.jpg?itok=ZA7r42tD" width="100" height="100" alt="" /></a></div>
<div class="authorbio__content">
  <span class="authorbio__name">Lisa Seelye</span> - <span class="authorbio__about">Lisa is a long time Linux user, former Gentoo developer (2003-2007). She is a lifelong gamer, which lead her to spend time in the video game industry and write one of the early API libraries for Eve Online (a video game involving the serious business of Internet space ships). Melding her experience as a long-time Linux systems administrator with software development experience, she is a Senior Site Reliability Engineer at Red Hat, focusing her time on OpenShift Dedicated (a hosted Kubernetes...</span>
  <div class="authorbio__more-link"><a href="/users/lisa">More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-content-article-contributions"  >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block"  >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__bottom">
      <div class="panel-pane pane-views-panes pane-related-articles-panel-pane-1"  >
  
        <h2 class="pane-title">
      Recommended reading    </h2>
    
  
  <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 related-content view-dom-id-e77a2550814dbe16ffc401e15e3f3d51">
        
  
  
      <div id="related-content-footer" class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/2/kubernetes-scanner"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/ship_captain_devops_kubernetes_steer.png?itok=UMTY3fyH" width="315" height="177" alt="Ship captain sailing the Kubernetes seas" title="Ship captain sailing the Kubernetes seas" /><br />
Scan Kubernetes for errors with KRAWL</a></span>  </div>  </div>  <div class="views-row views-row-2 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/1/logtool-root-cause-identification"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/search_find_code_python_programming.png?itok=id5zgy6o" width="314" height="177" alt="Searching for code" title="Searching for code" /><br />
Use this Python script to find bugs in your Overcloud</a></span>  </div>  </div>  <div class="views-row views-row-3 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/1/automating-helm-deployments-bash"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/laptop_screen_desk_work_chat_text.png?itok=hBYci--3" width="315" height="177" alt="Person using a laptop" title="Person using a laptop" /><br />
Automating Helm deployments with Bash</a></span>  </div>  </div>  <div class="views-row views-row-4 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/1/bash-scripts-git"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/rh_003588_01_rd3os.combacktoschoolseriesk12_rh_021x_0.png?itok=u6tyN-U4" width="315" height="177" alt="Digital hand surrounding by objects, bike, light bulb, graphs" title="Digital hand surrounding by objects, bike, light bulb, graphs" /><br />
6 handy Bash scripts for Git</a></span>  </div>  </div>  <div class="views-row views-row-5 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/1/setv-bash-function"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/code_computer_laptop_hack_work.png?itok=efQMUmxr" width="315" height="177" alt="Coding on a computer" title="Coding on a computer" /><br />
setV: A Bash function to maintain Python virtual environments</a></span>  </div>  </div>  <div class="views-row views-row-6 views-row-even views-row-last">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/1/create-save-run-rsync-configurations"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/coffee_tea_laptop_computer_work_desk.png?itok=cilyeaUf" width="315" height="177" alt="Person drinking a hat drink at the computer" title="Person drinking a hat drink at the computer" /><br />
Use this script to create, save, and run different rsync configurations via named profiles</a></span>  </div>  </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
    </div>
  
      <div class="os-article__footer">
      <div class="panel-pane pane-node-comment-form"  >
  
        <h2 class="pane-title">
      Comment now    </h2>
    
  
  <form class="comment-form user-info-from-cookie" action="/article/20/2/live-demo-script#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div id="edit-login-register" class="form-item form-type-item">
 <a href="/user/login?destination=node/60831">Login or Register</a> to earn points for your comments.
</div>
<div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<input type="hidden" name="form_build_id" value="form-5dzbAuW8lKzT50uh7EZO9T9hs2cjbVXLALF2DyhCCuY" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="honeypot_time" value="1581438548|cu0jZ2LO19zOsN9r8n_OcTHXhU46PdiyWhHR-xDI_PM" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/legal">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><fieldset class="captcha form-wrapper"><legend><span class="fieldset-legend">CAPTCHA</span></legend><div class="fieldset-wrapper"><div class="fieldset-description">This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.</div><input type="hidden" name="captcha_sid" value="258673521" />
<input type="hidden" name="captcha_token" value="1ae3a5918d686e1a19dfbdc2ea8bcc7e" />
<input type="hidden" name="captcha_response" value="Google no captcha" />
<div class="g-recaptcha" data-sitekey="6LdyKzYUAAAAAIwIfHYM0eXeqI_HRmLhM-Msg6nM" data-theme="light" data-type="image"></div></div></fieldset>
<div class="website-url-textfield"><div class="form-item form-type-textfield form-item-website-url">
  <label for="edit-website-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-website-url" name="website-url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div></div></form>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-default-license"  >
  
      
  
  <div class="field field-name-field-default-license field-type-text field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:license"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" style="border-width:0" src="/sites/all/themes/opensource/images/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a></div></div></div>
  
  </div>
    </div>
  
</div>
                  </div>


        
        
      </div>

        <div class="region region-pre-footer">
    <div id="block-os-common-components-footer-call-to-action" class="block block-os-common-components first last odd">

      
  
<div class="fieldable-panels-pane cta cta--green-on-blue cta--no-link">

  <div class="cta__content cta__content--no-link">
            <h2 class="cta__title">Subscribe to our weekly newsletter</h2>
<div class="field field-name-field-cta-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><iframe class="eloqua-embedded-bottom" frameborder="0" height="50" id="fkfkx" scrolling="no" src="/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></p>

<p>Get the highlights in your inbox every week.</p>
</div></div></div>  </div>

</div>


</div>
  </div>

        <div class="region region-footer-nav">
    <div id="block-bean-social-media" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/social-media" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><span>Find us:</span> 
</p>
<ul>
<li><a class="footer-twitter" href="https://twitter.com/OpenSourceWay" title="Twitter">Twitter</a></li>
<li><a class="footer-facebook" href="https://www.facebook.com/opensourceway" title="Facebook">Facebook</a></li>
<li><a class="footer-youtube" href="http://www.youtube.com/opensourceway" title="Youtube">Youtube</a></li>
<li><a class="footer-mastodon" href="https://fosstodon.org/@osdc" title="">Mastodon</a></li>
<li><a class="footer-irc" href="/join-us-irc" title="IRC">IRC</a></li>
<li><a class="footer-feed" href="/feed" title="RSS">RSS</a></li>
</ul>
</div></div></div>  </div>
</div>

</div>
<div id="block-menu-menu-footer" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Footer</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/legal" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact" class="menu__link">Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="/opensourcecom-team" title="" class="menu__link">Meet the Team</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://opensource.org/" title="" class="menu__link">Visit opensource.org</a></li>
</ul>
</div>
  </div>

        <footer id="footer" class="region region-footer">
    <div id="block-bean-copyrigt-block" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/copyrigt-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>For more discussion on open source and the role of the CIO in the enterprise, join us at <a href="https://enterprisersproject.com">The EnterprisersProject.com</a>.</p>

<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>

<p>Opensource.com aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>

<p>Copyright ©2019 Red Hat, Inc.</p>
</div></div></div>  </div>
</div>

</div>
<div id="block-bean-footer-logo" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/footer-logo" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><img src="/sites/all/themes/opensource/images/footer_logo.svg" /></p>
</div></div></div>  </div>
</div>

</div>
  </footer>

    </div>

    
      <div class="region region-os-social">
    <div id="block-os-social-os-social-share" class="block block-os-social first last odd">

      
  <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://opensource.com/article/20/2/live-demo-script">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <a class="a2a_button_mastodon a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <a class="a2a_button_mastodon a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div>
</div>
  </div>
    <div class="region region-page-bottom">
    <!-- begin Google Remarketing --><img height="1" width="1" style="border-style:none;display:block;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" onerror="this.src='/sites/all/themes/opensource/images/1x1.png';this.onerror=null" /><!-- end Google Remarketing -->  </div>
<script src="https://opensource.com/sites/default/files/js/js_29qYXJz8NLGg8Aomg-RZPjJcj9yEdEst1BMZ9gZbs-4.js"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script src="https://opensource.com/sites/default/files/js/js_skcw_uw28w93NamnwquPyMMZNIyaa2eQ6iAc5B_1jjA.js"></script>
<script>var a2a_config = a2a_config || {};
              a2a_config.callbacks = a2a_config.callbacks || [];
a2a_config.templates = {
    twitter: "Automate your live demos with this shell script https://red.ht/398C2dL via @opensourceway by @thedoh"
};</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"65779638","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkgHX1xuW1BXU1YEF2pWCVxcbkBYXEVuEQRSXQ==","queueTime":0,"applicationTime":592,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
