<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html class="no-js"  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema# schema: http://schema.org/"><!--<![endif]-->

<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
  <meta charset="utf-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1039.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<link rel="shortcut icon" href="https://opensource.com/sites/all/themes/opensource/favicon.ico" type="image/vnd.microsoft.icon" />
<link href="https://opensource.com/rss.xml" rel="alternate" title="Opensource.com RSS" />
<meta name="description" content="Did you forget to insert probe points in your code? No problem. Learn how to insert them dynamically with uprobe and kprobe." />
<meta name="rating" content="general" />
<meta name="referrer" content="no-referrer" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://opensource.com/article/17/7/dynamic-tracing-linux-user-and-kernel-space" />
<link rel="shortlink" href="https://opensource.com/node/37426" />
<meta name="revisit-after" content="1 day" />
<meta property="og:site_name" content="Opensource.com" />
<meta property="og:url" content="https://opensource.com/article/17/7/dynamic-tracing-linux-user-and-kernel-space" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Dynamic tracing in Linux user and kernel space" />
<meta property="og:description" content="Did you forget to insert probe points in your code? No problem. Learn how to insert them dynamically with uprobe and kprobe." />
<meta property="og:image" content="https://opensource.com/sites/default/files/images/business/colors-colorful-box-rectangle.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@opensourceway" />
<meta name="twitter:creator" content="@pratyushanand80" />
<meta name="twitter:title" content="Dynamic tracing in Linux user and kernel space" />
<meta name="twitter:description" content="Did you forget to insert probe points in your code? No problem. Learn how to insert them dynamically with uprobe and kprobe." />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/images/business/colors-colorful-box-rectangle.png" />
  <title>Dynamic tracing in Linux user and kernel space | Opensource.com</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_Rdur8XVJnPlTNehlWLFbY-WXVG0stXacIOxyox8i_wE.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_iYIQ5yoCGsXhB9L0PJ6L5T9CwnfFU_DHQNK9fZjR0P4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_SOTzSrOZeHcRiX_YMozRv03ObZ1j8sWNndoHvmLk8d4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_ueKO8sJFsb_-PcC-qGG3exlUb_4unHYQQyOmMPIM_B8.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans.css?oso6s1" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold.css?oso6s1" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-italic.css?oso6s1" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold-italic.css?oso6s1" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_wigS70piKQxAQ-PhuV0Kv5yYuTDEoD4yq0VyEj5L7HY.css" media="all" />
  <script src="https://use.typekit.net/elz3yuz.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  <script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js?v=1.7.2"></script>
<script src="https://opensource.com/misc/jquery.once.js?v=1.2"></script>
<script src="https://opensource.com/misc/drupal.js?oso6s1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.core.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.widget.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/media.core.js?v=7.x-2.0-rc12"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.tabs.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.accordion.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.button.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.mouse.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.draggable.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.position.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.resizable.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.dialog.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/better-autocomplete/jquery.better-autocomplete.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/util/json2.js?v=7.x-2.0-rc12"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/util/ba-debug.min.js?v=7.x-2.0-rc12"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/external/jquery.cookie.js?v=67fb34f6a866c40d0570"></script>
<script src="https://opensource.com/misc/form.js?v=7.52"></script>
<script src="https://opensource.com/sites/all/modules/contrib/comment_notify/comment_notify.js?oso6s1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_admin/panopoly-admin.js?oso6s1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_magic/panopoly-magic.js?oso6s1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_theme/js/panopoly-accordion.js?oso6s1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/caption_filter/js/caption-filter.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/loginlogout/loginlogout.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/modules/custom/os_events/os_events.js?oso6s1"></script>
<script src="//static.addtoany.com/menu/page.js"></script>
<script src="https://opensource.com/sites/all/modules/contrib/pollanon/js/jquery.cookie.min.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/pollanon/js/pollanon.pack.js?oso6s1"></script>
<script src="https://opensource.com/misc/collapse.js?v=7.52"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/js/linkit.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/js/linkit.dialog.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/editors/ckeditor/linkitDialog.js?v=7.2"></script>
<script src="https://opensource.com/misc/textarea.js?v=7.52"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/media.popups.js?v=7.x-2.0-rc12"></script>
<script src="https://opensource.com/modules/filter/filter.js?oso6s1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/modules/media_wysiwyg/js/media_wysiwyg.filter.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/mollom/mollom.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/rate/rate.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/google_analytics/googleanalytics.js?oso6s1"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-33294138-1", {"cookieDomain":".opensource.com"});ga("send", "pageview");</script>
<script src="https://opensource.com/sites/all/libraries/superfish/jquery.hoverIntent.minified.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/sftouchscreen.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/supposition.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/superfish.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/supersubs.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/superfish/superfish.js?oso6s1"></script>
<script src="https://opensource.com/sites/all/themes/opensource/js/script.js?oso6s1"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-37426 node-type-article region-content section-article page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<header class="header" id="header" role="banner">

    
    <div class="header-banner">
      <div class="header-banner__inner">
                  <div class="header__name-and-slogan" id="name-and-slogan">
                          <div class="header__site-name" id="site-name">
                <a href="/" title="Home" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/logo.svg" onerror="this.src='/sites/all/themes/opensource/logo.png';this.onerror=null;" /></a>
                <a href="http://www.redhat.com/en?intcmp=701600000011l7VAAQ" title="Home" class="header__sponsor-link" rel="home"><img alt="RedHat" src="/sites/all/themes/opensource/images/redhat-logo.svg" onerror="this.src='/sites/all/themes/opensource/images/redhat-logo.png';this.onerror=null;"/></a>
              </div>
            
                      </div>
                <nav class="desktop-user-links">
            <div class="header__region region region-header">
    <div id="block-menu-block-1" class="block block-menu-block first last odd" role="navigation">

      
  <div class="menu-block-wrapper menu-block-1 menu-name-user-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-195"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1179"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul></div>

</div>
  </div>
        </nav>
      </div>
    </div>

    <div class="sf-nav">
      <div class="sf-nav__inner">
          <div class="js-mobile-header-buttons region region-navigation-top">
    <div id="block-search-form" class="block block-search first odd" role="search">

      
  <form action="/article/17/7/dynamic-tracing-linux-user-and-kernel-space" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." placeholder="Search opensource.com" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="GO" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-MH5CrPoXQon7njahfybXZrApXHeb15YXSPeaM_Fl5lc" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>
</div>
<div id="block-superfish-1" class="block block-superfish even">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-default sf-total-items-5 sf-parent-items-5 sf-single-items-0"><li id="menu-1906-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-8 sf-parent-children-4 sf-single-children-4 menuparent"><a href="/" title="" class="sf-depth-1 menuparent">Articles</a><ul><li id="menu-12341-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/containers" title="" class="sf-depth-2">Containers</a></li><li id="menu-12346-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/gaming" title="" class="sf-depth-2">Gaming</a></li><li id="menu-12351-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/hardware" title="" class="sf-depth-2 menuparent">Hardware</a><ul><li id="menu-12376-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/3d-printing" title="" class="sf-depth-3">3D printing</a></li><li id="menu-12386-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/arduino" title="" class="sf-depth-3">Arduino</a></li><li id="menu-12381-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/raspberry-pi" title="" class="sf-depth-3">Raspberry Pi</a></li></ul></li><li id="menu-1946-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/tags/law" title="" class="sf-depth-2 menuparent">Law</a><ul><li id="menu-12391-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/licensing" title="" class="sf-depth-3">Licensing</a></li><li id="menu-12396-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/patents" title="" class="sf-depth-3">Patents</a></li></ul></li><li id="menu-12356-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/tags/linux" title="" class="sf-depth-2">Linux</a></li><li id="menu-12361-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/tags/openstack" title="" class="sf-depth-2">OpenStack</a></li><li id="menu-12366-1" class="middle odd sf-item-7 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/programming" title="" class="sf-depth-2 menuparent">Programming</a><ul><li id="menu-12411-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/javascript" title="" class="sf-depth-3">JavaScript</a></li><li id="menu-12401-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/perl" title="" class="sf-depth-3">Perl</a></li><li id="menu-12406-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/python" title="" class="sf-depth-3">Python</a></li></ul></li><li id="menu-12371-1" class="last even sf-item-8 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/tags/sysadmin" title="" class="sf-depth-2 menuparent">SysAdmin</a><ul><li id="menu-12416-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/devops" title="" class="sf-depth-3">DevOps</a></li></ul></li></ul></li><li id="menu-1921-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-7 sf-parent-children-2 sf-single-children-5 menuparent"><a href="/resources" title="" class="sf-depth-1 menuparent">Resources</a><ul><li id="menu-2016-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/resources/projects-and-applications" title="" class="sf-depth-2">Projects and applications</a></li><li id="menu-2026-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/conferences-and-events-monthly" title="" class="sf-depth-2">Conferences and events</a></li><li id="menu-2021-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/resources/organizations" title="" class="sf-depth-2">Organizations</a></li><li id="menu-5556-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-9 sf-parent-children-0 sf-single-children-9 menuparent"><a href="/resources/cloud" title="" class="sf-depth-2 menuparent">The open source cloud</a><ul><li id="menu-5576-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/resources/big-data" title="" class="sf-depth-3">Big data</a></li><li id="menu-5566-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/what-docker" title="" class="sf-depth-3">Docker</a></li><li id="menu-5591-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/resources/internet-of-things" title="" class="sf-depth-3">Internet of things</a></li><li id="menu-5596-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/resources/what-is-kubernetes" title="" class="sf-depth-3">Kubernetes</a></li><li id="menu-5571-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/what-are-linux-containers" title="" class="sf-depth-3">Linux containers</a></li><li id="menu-5586-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/resources/what-are-microservices" title="" class="sf-depth-3">Microservices</a></li><li id="menu-5561-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/resources/what-is-openstack" title="" class="sf-depth-3">OpenStack</a></li><li id="menu-5581-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/resources/what-is-software-defined-networking" title="" class="sf-depth-3">Software defined networking</a></li><li id="menu-12601-1" class="last odd sf-item-9 sf-depth-3 sf-no-children"><a href="/resources/virtualization" title="" class="sf-depth-3">Virtualization</a></li></ul></li><li id="menu-2036-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-11 sf-parent-children-0 sf-single-children-11 menuparent"><a href="/alternatives" title="" class="sf-depth-2 menuparent">Open source alternatives</a><ul><li id="menu-4646-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/alternatives/adobe-acrobat" class="sf-depth-3">Alternatives to Acrobat</a></li><li id="menu-4656-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/alternatives/autocad" class="sf-depth-3">Alternatives to AutoCAD</a></li><li id="menu-4636-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/alternatives/dreamweaver" class="sf-depth-3">Alternatives to Dreamweaver</a></li><li id="menu-5506-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/alternatives/gmail" class="sf-depth-3">Alternatives to Gmail</a></li><li id="menu-5551-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/alternatives/matlab" class="sf-depth-3">Alternatives to MATLAB</a></li><li id="menu-5501-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/alternatives/minecraft" class="sf-depth-3">Alternatives to Minecraft</a></li><li id="menu-4651-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/alternatives/picasa" class="sf-depth-3">Alternatives to Picasa</a></li><li id="menu-4661-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/alternatives/microsoft-publisher" class="sf-depth-3">Alternatives to Publisher</a></li><li id="menu-5511-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/alternatives/slack" class="sf-depth-3">Alternatives to Slack</a></li><li id="menu-4641-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/alternatives/trello" class="sf-depth-3">Alternatives to Trello</a></li><li id="menu-5546-1" class="last odd sf-item-11 sf-depth-3 sf-no-children"><a href="/alternatives" title="" class="sf-depth-3">More...</a></li></ul></li><li id="menu-2011-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/ebooks" title="" class="sf-depth-2">eBooks</a></li><li id="menu-12466-1" class="last odd sf-item-7 sf-depth-2 sf-no-children"><a href="/yearbook/2016" title="" class="sf-depth-2">Open Source Yearbook</a></li></ul></li><li id="menu-4691-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/about" class="sf-depth-1 menuparent">About</a><ul><li id="menu-1991-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-source-way" class="sf-depth-2">The Open Source Way</a></li><li id="menu-1971-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/opensourcecom-team" class="sf-depth-2">Meet the team</a></li><li id="menu-2006-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/press-kit" class="sf-depth-2">Press kit</a></li><li id="menu-2001-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/contact" title="" class="sf-depth-2">Contact</a></li></ul></li><li id="menu-12511-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-6 sf-parent-children-2 sf-single-children-4 menuparent"><a href="/tags/opensourcecom-community" title="" class="sf-depth-1 menuparent">Community</a><ul><li id="menu-12516-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/participate" class="sf-depth-2 menuparent">Join the community</a><ul><li id="menu-12521-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/user/register" title="" class="sf-depth-3">Register</a></li><li id="menu-12526-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="https://opensource.com/rules-comments-and-discussions" title="" class="sf-depth-3">Rules for comments and discussions</a></li><li id="menu-12531-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="https://opensource.com/community-moderator-program" title="" class="sf-depth-3">Community Moderator program</a></li><li id="menu-12541-1" class="last even sf-item-4 sf-depth-3 sf-no-children"><a href="https://opensource.com/points-and-badges" title="" class="sf-depth-3">Points and badges</a></li></ul></li><li id="menu-12546-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="https://opensource.com/resources/editorial-calendar" title="" class="sf-depth-2">Editorial calendar</a></li><li id="menu-12551-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="https://opensource.com/how-submit-article" title="" class="sf-depth-2">Submit your story</a></li><li id="menu-12556-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="https://opensource.com/writer-testimonials" title="" class="sf-depth-2">Writer testimonials</a></li><li id="menu-1966-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/writers" class="sf-depth-2 menuparent">Guides for writers</a><ul><li id="menu-2041-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/submission-style-guide" class="sf-depth-3">Article submission and style guide</a></li><li id="menu-4616-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/promoting-articles" class="sf-depth-3">Tips for promoting your Opensource.com article</a></li><li id="menu-12586-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="https://opensource.com/community/16/8/editorial-writing-topics" title="" class="sf-depth-3">Writing topics</a></li></ul></li><li id="menu-12581-1" class="last even sf-item-6 sf-depth-2 sf-no-children"><a href="https://opensource.com/resources/contributor-club" title="" class="sf-depth-2">Contributor Club</a></li></ul></li><li id="menu-2136-1" class="last odd sf-item-5 sf-depth-1 sf-total-children-7 sf-parent-children-2 sf-single-children-5 menuparent"><a href="/open-organization" title="" class="sf-depth-1 menuparent">The Open Org</a><ul><li id="menu-12471-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="sf-depth-2">What is an open organization?</a></li><li id="menu-2181-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/open-organization/resources/what-open-organization" title="" class="sf-depth-2">What is The Open Organization?</a></li><li id="menu-12421-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-decision-framework" title="" class="sf-depth-2">What is the Open Decision Framework?</a></li><li id="menu-4606-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/open-organization/resources/twitter-chats" title="" class="sf-depth-2">Twitter chats</a></li><li id="menu-2246-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/open-organization/resources/faq" title="" class="sf-depth-2">Open Org FAQs</a></li><li id="menu-2146-1" class="middle even sf-item-6 sf-depth-2 sf-total-children-8 sf-parent-children-0 sf-single-children-8 menuparent"><a href="/open-organization/resources" title="" class="sf-depth-2 menuparent">Resources</a><ul><li id="menu-12606-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/culture-change" class="sf-depth-3">Guide to IT Culture Change download</a></li><li id="menu-12456-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/leaders-manual" title="Download the Open Organization Leaders Manual" class="sf-depth-3">Leaders Manual download</a></li><li id="menu-4631-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/catalyst-in-chief" class="sf-depth-3">Catalyst in Chief download</a></li><li id="menu-3206-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/field-guide" class="sf-depth-3">Field guide download</a></li><li id="menu-2271-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/chapter1" title="" class="sf-depth-3">Chapter download</a></li><li id="menu-2151-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/guides" title="" class="sf-depth-3">Discussion guide download</a></li><li id="menu-3201-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/open-organization/resources/reading-list" title="" class="sf-depth-3">Reading list</a></li><li id="menu-2256-1" class="last even sf-item-8 sf-depth-3 sf-no-children"><a href="/open-organization/resources/2015-book-club" title="" class="sf-depth-3">Book club</a></li></ul></li><li id="menu-3166-1" class="last odd sf-item-7 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/open-organization/resources/ambassadors-program" title="" class="sf-depth-2 menuparent">Ambassadors program</a><ul><li id="menu-2691-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/meet-ambassadors" title="" class="sf-depth-3">Meet the ambassadors</a></li></ul></li></ul></li></ul>
</div>
<div id="block-system-user-menu" class="block block-system block-menu odd" role="navigation">

      
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul>
</div>
<div id="block-menu-block-2" class="block block-menu-block last even" role="navigation">

      
  <div class="menu-block-wrapper menu-block-2 menu-name-menu-social-links parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-13171"><a href="http://twitter.com/opensourceway" title="twitter" class="menu__link">Twitter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-13176"><a href="https://www.facebook.com/opensourceway" title="facebook" class="menu__link">Facebook</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-13166"><a href="/feed" title="feed" class="menu__link">Feed</a></li>
</ul></div>

</div>
  </div>

        <div class="mobile--menu-region">
            <div class="region region-navigation">
    <div id="block-system-main-menu" class="block block-system block-menu first last odd" role="navigation">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/" title="" class="menu__link">Articles</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/containers" title="" class="menu__link">Containers</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/gaming" title="" class="menu__link">Gaming</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/hardware" title="" class="menu__link">Hardware</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/3d-printing" title="" class="menu__link">3D printing</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/arduino" title="" class="menu__link">Arduino</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/raspberry-pi" title="" class="menu__link">Raspberry Pi</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/law" title="" class="menu__link">Law</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/linux" title="" class="menu__link">Linux</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/openstack" title="" class="menu__link">OpenStack</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/programming" title="" class="menu__link">Programming</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/javascript" title="" class="menu__link">JavaScript</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/perl" title="" class="menu__link">Perl</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/python" title="" class="menu__link">Python</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded"><a href="/tags/sysadmin" title="" class="menu__link">SysAdmin</a><ul class="menu"><li class="menu__item is-leaf first last leaf"><a href="/tags/devops" title="" class="menu__link">DevOps</a></li>
</ul></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/projects-and-applications" title="" class="menu__link">Projects and applications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/conferences-and-events-monthly" title="" class="menu__link">Conferences and events</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/organizations" title="" class="menu__link">Organizations</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/resources/cloud" title="" class="menu__link">The open source cloud</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/alternatives" title="" class="menu__link">Open source alternatives</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/ebooks" title="" class="menu__link">eBooks</a></li>
<li class="menu__item is-leaf last leaf"><a href="/yearbook/2016" title="" class="menu__link">Open Source Yearbook</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/about" class="menu__link">About</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/opensourcecom-community" title="" class="menu__link">Community</a></li>
<li class="menu__item is-expanded last expanded"><a href="/open-organization" title="" class="menu__link">The Open Org</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="menu__link">What is an open organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/what-open-organization" title="" class="menu__link">What is The Open Organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-decision-framework" title="" class="menu__link">What is the Open Decision Framework?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/twitter-chats" title="" class="menu__link">Twitter chats</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/faq" title="" class="menu__link">Open Org FAQs</a></li>
<li class="menu__item is-expanded expanded"><a href="/open-organization/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/culture-change" class="menu__link">Guide to IT Culture Change download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/leaders-manual" title="Download the Open Organization Leaders Manual" class="menu__link">Leaders Manual download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/catalyst-in-chief" class="menu__link">Catalyst in Chief download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/field-guide" class="menu__link">Field guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/chapter1" title="" class="menu__link">Chapter download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/guides" title="" class="menu__link">Discussion guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/reading-list" title="" class="menu__link">Reading list</a></li>
<li class="menu__item is-leaf last leaf"><a href="/open-organization/resources/2015-book-club" title="" class="menu__link">Book club</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/open-organization/resources/ambassadors-program" title="" class="menu__link">Ambassadors program</a></li>
</ul></li>
</ul>
</div>
  </div>
        </div>
      </div>
    </div>

</header>

<div id="page">

      <div id="main">
        <div class="pre-content">
                                                </div>
        <div id="content" class="column" role="main">
                              <a id="main-content"></a>
                                <h1 class="page__title title" id="page-title">Dynamic tracing in Linux user and kernel space</h1>
                              



<div class="panel-display os-article clearfix os-article--with-image " id="article-template">

      <div class="os-article__top">
      <div class="os-article__top-inner">
        <div class="panel-pane pane-node-title" >
  
      
  
  <h1>Dynamic tracing in Linux user and kernel space</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-article-subhead" >
  
      
  
  <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden">
    <div class="field-items">
          <h2>Did you forget to insert probe points in your code? No problem. Learn how to insert them dynamically with uprobe and kprobe.</h2>
      </div>
</div>

  
  </div>
<div class="panel-pane pane-os-article-byline" >
  
      
  
  <div class="byline"><span class="byline__thumbnail"><img class="byline-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/byline_thumbnail/public/pictures/dsc02750.jpg?itok=lNEX8B-6" width="50" height="50" alt="" title="Pratyush Anand" /></span>
<span class="byline__date">06 Jul 2017</span>
<span class="byline__author"><a href="/users/pratyushanand" title="View user profile." class="username" xml:lang="" about="/users/pratyushanand" typeof="sioc:UserAccount" property="foaf:name" datatype="">Pratyush Anand <span class="redhat-employee">(Red Hat)</span></a>&nbsp;<span class="byline__feed"><a href="/user/143191/feed">Feed</a></span>
</span>
<span class="byline__social"><span class="byline__voting-widget"><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-a43f76997c8a04ce7adf2e386ce32bc5 rate-node-37426-1-1" id="rate-node-37426-1-1"><div class="rate-info">3</div><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/17/7/dynamic-tracing-linux-user-and-kernel-space?rate=oV4L6viwGWO8mlFe9O9KuBIJGy4ik0eiFQMAuKDmfkE" title="up">up</a></div></span>
</span>
</div>
  
  </div>
      </div>
    </div>
  
      <div class="os-article__image">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image" >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/image-full-size/public/images/business/colors-colorful-box-rectangle.png?itok=mjaGyXHI"><img class="image-full-size" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/image-full-size/public/images/business/colors-colorful-box-rectangle.png?itok=mjaGyXHI" width="520" height="292" alt="Dynamic tracing in Linux user and kernel space" title="Dynamic tracing in Linux user and kernel space" /></div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-file-field-file-image-caption" >
  
      
  
  <div class="field field-name-field-file-image-caption field-type-text-long field-label-inline clearfix"><div class="field-label">Image by :&nbsp;</div><div class="field-items"><div class="field-item even"><p><a href="https://www.flickr.com/photos/internetarchivebookimages/14597795260/in/photolist-oeXvXb-hPSQLm-oeUM2H-hW1T6S-hXA7k4-oumVDq-ocd4ZC-5QyMBE-i6rStz-6rhyvN-5QuACV-hTKzZh-5QusTp-i33K73-bFbtPG-i6S3hp-i6rmCo-hTLxQe-5tW3NG-ovhqZn-ownQgU-dk3D2q-hYr6E7-6noGX2-jYYYri-id2WB1-hY4Lzf-rgGR7X-i9rYzc-osDB3W-4jy9dq-hTvspL-odYRjt-obKKWq-i15f1Y-5QuCU2-c86b2o-hSKedH-iasYwZ-ouLPXV-idr3FN-i9r9Cm-hXqwjY-odd32R-btbcHB-odmxvq-i6eU1p-hVLBzE-hTTBZn-hLdgbb" target="_blank">Internet Archive Book Images</a>. Modified by Opensource.com. <a href="https://creativecommons.org/licenses/by-sa/4.0/" target="_blank">CC BY-SA 4.0</a></p>
</div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__middle">
      <div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:articleBody content:encoded"><p>Have you ever been in a situation where you realize that you didn't insert <b>debug print</b> at a few points in your code, so now you won't know if your CPU hits a particular line of code for execution until you recompile the code with debug statements? Don't worry, there's an easier solution. Basically, you need to insert dynamic probe points at different locations of your source code assembly instructions.</p>
<p>For advanced users, kernel <a href="https://www.kernel.org/doc/Documentation/trace/" target="_blank">documentation/trace</a> and <strong><a href="http://man7.org/linux/man-pages/man1/perf.1.html " target="_blank">man perf</a></strong> provide a lot of information about different types of kernels and user space tracing mechanisms; however, average users just want a few simple steps and an example to get started quickly. That's where this article will help.</p>
<p><div class="embedded-callout-menu callout-float-right"><div class="view view-related-content-callout view-id-related_content_callout view-display-id-article_block view-dom-id-8c984f4dc3ff47542a4156e75d74d3bb">
            <div class="view-header">
      <p>Programming and development</p>
    </div>
  
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">      
  <div class="views-field views-field-field-related-content-link">        <div class="field-content"><div class="item-list"><ul><li class="first"><a href="https://opensource.com/tags/python?src=programming_resource_menu1">New Python content</a></li>
<li><a href="https://opensource.com/tags/javascript?src=programming_resource_menu2">Our latest JavaScript articles</a></li>
<li><a href="https://opensource.com/tags/perl?src=programming_resource_menu3">Recent Perl posts</a></li>
<li class="last"><a href="https://developers.redhat.com/?intcmp=7016000000127cYAAQ&amp;src=programming_resource_menu4">Red Hat Developers Blog</a></li>
</ul></div></div>  </div>  </div>    </div>
  
  
  
  
  
  
</div></div></p>
<p>Let's start with definitions.</p>
<h3>Probe point</h3>
<p>A probe point is a debug statement that helps explore execution characteristics of software (i.e., the execution flow and state of software data structure at the moment a probe statement executes). <b><a href="https://en.wikipedia.org/wiki/Printk" target="_blank">printk</a></b> is the simplest form of probe statement and one of the fundamental tools used by developers for kernel hacking.</p>
<h3>Static vs. dynamic probing</h3>
<p>Because it requires recompilation of source code, <b>printk</b> insertion is a static probing method. There are many other static tracepoints at important locations in the kernel code that can be enabled or disabled dynamically. The Linux kernel has a few frameworks that can help a developer probe either the kernel or user space application without recompiling the source code. <b><a href="https://www.kernel.org/doc/Documentation/trace/kprobetrace.txt" target="_blank">Kprobe</a></b> is one such dynamic method of inserting probe points within kernel code, and <b><a href="https://www.kernel.org/doc/Documentation/trace/uprobetracer.txt" target="_blank">uprobe</a></b> does so within a user application.</p>
<h2>Tracing user space using uprobe</h2>
<p>An uprobe tracepoint can be inserted into any user space code by using either the <strong>sysfs</strong> interface or the <a href="https://perf.wiki.kernel.org/index.php/Main_Page" target="_blank"><strong>perf</strong> tool</a>.</p>
<h3>Inserting uprobe using the sysfs interface</h3>
<p>Consider the following simple test code with no print statements in which we want to insert a probe at some instruction:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="br0">&#91;</span><span class="kw3">source</span>,c<span class="br0">&#93;</span>
.test.c</pre></div></pre><pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="co0">#include &lt;stdio.h&gt;</span>
<span class="co0">#include &lt;stdlib.h&gt;</span>
<span class="co0">#include &lt;unistd.h&gt;</span>
&nbsp;
static int func_1_cnt;
static int func_2_cnt;
&nbsp;
static void func_1<span class="br0">&#40;</span>void<span class="br0">&#41;</span>
<span class="br0">&#123;</span>
	func_1_cnt++;
<span class="br0">&#125;</span>
&nbsp;
static void func_2<span class="br0">&#40;</span>void<span class="br0">&#41;</span>
<span class="br0">&#123;</span>
	func_2_cnt++;
<span class="br0">&#125;</span>
&nbsp;
int main<span class="br0">&#40;</span>int argc, void <span class="sy0">**</span>argv<span class="br0">&#41;</span>
<span class="br0">&#123;</span>
	int number;
&nbsp;
	<span class="kw1">while</span><span class="br0">&#40;</span><span class="nu0">1</span><span class="br0">&#41;</span> <span class="br0">&#123;</span>
		<span class="kw2">sleep</span><span class="br0">&#40;</span><span class="nu0">1</span><span class="br0">&#41;</span>;
		number = rand<span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="sy0">%</span> <span class="nu0">10</span>;
		<span class="kw1">if</span> <span class="br0">&#40;</span>number <span class="sy0">&lt;</span> <span class="nu0">5</span><span class="br0">&#41;</span>
			func_2<span class="br0">&#40;</span><span class="br0">&#41;</span>;
		<span class="kw1">else</span>
			func_1<span class="br0">&#40;</span><span class="br0">&#41;</span>;
	<span class="br0">&#125;</span>
<span class="br0">&#125;</span></pre></div></pre><p>Compile the code and find the instruction addresses you want to probe:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="co0"># gcc -o test test.c</span>
<span class="co0"># objdump -d test</span></pre></div></pre><p>Let's say we have the following object code on the ARM64 platform:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash">0000000000400620 <span class="sy0">&lt;</span>func_1<span class="sy0">&gt;</span>:
  <span class="nu0">400620</span>:	<span class="nu0">90000080</span> 	adrp	x0, <span class="nu0">410000</span> <span class="sy0">&lt;</span>__FRAME_END__+0xf6f8<span class="sy0">&gt;</span>
  <span class="nu0">400624</span>:	912d4000 	add	x0, x0, <span class="co0">#0xb50</span>
  <span class="nu0">400628</span>:	b9400000 	ldr	w0, <span class="br0">&#91;</span>x0<span class="br0">&#93;</span>
  40062c:	<span class="nu0">11000401</span> 	add	w1, w0, <span class="co0">#0x1</span>
  <span class="nu0">400630</span>:	<span class="nu0">90000080</span> 	adrp	x0, <span class="nu0">410000</span> <span class="sy0">&lt;</span>__FRAME_END__+0xf6f8<span class="sy0">&gt;</span>
  <span class="nu0">400634</span>:	912d4000 	add	x0, x0, <span class="co0">#0xb50</span>
  <span class="nu0">400638</span>:	b9000001 	str	w1, <span class="br0">&#91;</span>x0<span class="br0">&#93;</span>
  40063c:	d65f03c0 	ret
&nbsp;
0000000000400640 <span class="sy0">&lt;</span>func_2<span class="sy0">&gt;</span>:
  <span class="nu0">400640</span>:	<span class="nu0">90000080</span> 	adrp	x0, <span class="nu0">410000</span> <span class="sy0">&lt;</span>__FRAME_END__+0xf6f8<span class="sy0">&gt;</span>
  <span class="nu0">400644</span>:	912d5000 	add	x0, x0, <span class="co0">#0xb54</span>
  <span class="nu0">400648</span>:	b9400000 	ldr	w0, <span class="br0">&#91;</span>x0<span class="br0">&#93;</span>
  40064c:	<span class="nu0">11000401</span> 	add	w1, w0, <span class="co0">#0x1</span>
  <span class="nu0">400650</span>:	<span class="nu0">90000080</span> 	adrp	x0, <span class="nu0">410000</span> <span class="sy0">&lt;</span>__FRAME_END__+0xf6f8<span class="sy0">&gt;</span>
  <span class="nu0">400654</span>:	912d5000 	add	x0, x0, <span class="co0">#0xb54</span>
  <span class="nu0">400658</span>:	b9000001 	str	w1, <span class="br0">&#91;</span>x0<span class="br0">&#93;</span>
  40065c:	d65f03c0 	ret</pre></div></pre><p>and we want to insert a probe at offset <b>0x620</b> and <b>0x644</b>. Execute the following commands:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="co0"># echo 'p:func_2_entry test:0x620' &gt; /sys/kernel/debug/tracing/uprobe_events</span>
<span class="co0"># echo 'p:func_1_entry test:0x644' &gt;&gt; /sys/kernel/debug/tracing/uprobe_events</span>
<span class="co0"># echo 1 &gt; /sys/kernel/debug/tracing/events/uprobes/enable</span>
<span class="co0"># ./test&amp;</span></pre></div></pre><p>In the first and second second echo statement above, <b>p</b> tells us that it is a <em>simple probe</em>. (A probe can be either <em>simple</em> or <em>return</em>.) <b>func_n_entry</b> is the name we see in the trace output. <b>Name</b> is an optional field; if it is not provided, we should expect a name like <b>p_test_0x644</b>. <b>test</b> is the executable binary in which we want to insert the probe. If <b>test</b> is not in the current directory, we need to specify <b>path_to_test/test</b>. The <b>0x620</b> or <b>0x640</b> is the instruction offset from the start of the program. Please note <b>&gt;&gt;</b> in the second echo statement, as we want to add one more probe. So, when we enable uprobe tracing after inserting probe points in the first two commands, it will enable all the uprobe events when we write to <b>events/uprobes/enable</b>. We can enable individual events, as well, by writing to the specific event file created in the <b>events</b> directory. Once the probe points have been inserted and enabled, we can see a trace entry whenever the probed instruction is executed.</p>
<p>Read the trace file to see the output:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="co0"># cat /sys/kernel/debug/tracing/trace</span>
<span class="co0"># tracer: nop</span>
<span class="co0">#</span>
<span class="co0"># entries-in-buffer/entries-written: 8/8   #P:8</span>
<span class="co0">#</span>
<span class="co0">#                              _-----=&gt; irqs-off</span>
<span class="co0">#                             / _----=&gt; need-resched</span>
<span class="co0">#                            | / _---=&gt; hardirq/softirq</span>
<span class="co0">#                            || / _--=&gt; preempt-depth</span>
<span class="co0">#                            ||| /     delay</span>
<span class="co0">#           TASK-PID   CPU#  ||||    TIMESTAMP  FUNCTION</span>
<span class="co0">#              | |       |   ||||       |         |</span>
            test-<span class="nu0">2788</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">1740.674740</span>: func_1_entry: <span class="br0">&#40;</span>0x400644<span class="br0">&#41;</span>
            test-<span class="nu0">2788</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">1741.674854</span>: func_1_entry: <span class="br0">&#40;</span>0x400644<span class="br0">&#41;</span>
            test-<span class="nu0">2788</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">1742.674949</span>: func_2_entry: <span class="br0">&#40;</span>0x400620<span class="br0">&#41;</span>
            test-<span class="nu0">2788</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">1743.675065</span>: func_2_entry: <span class="br0">&#40;</span>0x400620<span class="br0">&#41;</span>
            test-<span class="nu0">2788</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">1744.675158</span>: func_1_entry: <span class="br0">&#40;</span>0x400644<span class="br0">&#41;</span>
            test-<span class="nu0">2788</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">1745.675273</span>: func_1_entry: <span class="br0">&#40;</span>0x400644<span class="br0">&#41;</span>
            test-<span class="nu0">2788</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">1746.675390</span>: func_2_entry: <span class="br0">&#40;</span>0x400620<span class="br0">&#41;</span>
            test-<span class="nu0">2788</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">1747.675503</span>: func_2_entry: <span class="br0">&#40;</span>0x400620<span class="br0">&#41;</span></pre></div></pre><p>We can see what task was done by what CPU and at what time it executed the probed instruction.</p>
<p>A <em>return probe</em> can also be inserted into any instruction. This will log an entry when the function with that instruction is returned:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="co0"># echo 0 &gt; /sys/kernel/debug/tracing/events/uprobes/enable</span>
<span class="co0"># echo 'r:func_2_exit test:0x620' &gt;&gt; /sys/kernel/debug/tracing/uprobe_events</span>
<span class="co0"># echo 'r:func_1_exit test:0x644' &gt;&gt; /sys/kernel/debug/tracing/uprobe_events</span>
<span class="co0"># echo 1 &gt; /sys/kernel/debug/tracing/events/uprobes/enable</span></pre></div></pre><p>Here we use <b>r</b> instead of <b>p</b>, and all the other parameters are the same. Note that we need to disable uprobe events if we want to insert a new probe point:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash">            test-<span class="nu0">3009</span>  <span class="br0">&#91;</span>002<span class="br0">&#93;</span> ....  <span class="nu0">4813.852674</span>: func_1_entry: <span class="br0">&#40;</span>0x400644<span class="br0">&#41;</span>
            test-<span class="nu0">3009</span>  <span class="br0">&#91;</span>002<span class="br0">&#93;</span> ....  <span class="nu0">4813.852691</span>: func_1_exit: <span class="br0">&#40;</span>0x4006b0 <span class="sy0">&lt;</span>- 0x400644<span class="br0">&#41;</span>
            test-<span class="nu0">3009</span>  <span class="br0">&#91;</span>002<span class="br0">&#93;</span> ....  <span class="nu0">4814.852805</span>: func_2_entry: <span class="br0">&#40;</span>0x400620<span class="br0">&#41;</span>
            test-<span class="nu0">3009</span>  <span class="br0">&#91;</span>002<span class="br0">&#93;</span> ....  <span class="nu0">4814.852807</span>: func_2_exit: <span class="br0">&#40;</span>0x4006b8 <span class="sy0">&lt;</span>- 0x400620<span class="br0">&#41;</span>
            test-<span class="nu0">3009</span>  <span class="br0">&#91;</span>002<span class="br0">&#93;</span> ....  <span class="nu0">4815.852920</span>: func_2_entry: <span class="br0">&#40;</span>0x400620<span class="br0">&#41;</span>
            test-<span class="nu0">3009</span>  <span class="br0">&#91;</span>002<span class="br0">&#93;</span> ....  <span class="nu0">4815.852921</span>: func_2_exit: <span class="br0">&#40;</span>0x4006b8 <span class="sy0">&lt;</span>- 0x400620<span class="br0">&#41;</span></pre></div></pre><p>The log above tells us <b>func_1</b> returned to the address <b>0x4006b0</b> at timestamp <b>4813.852691</b>.</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="co0"># echo 0 &gt; /sys/kernel/debug/tracing/events/uprobes/enable</span>
<span class="co0"># echo 'p:func_2_entry test:0x630' &gt; /sys/kernel/debug/tracing/uprobe_events count=%x1</span>
<span class="co0"># echo 1 &gt; /sys/kernel/debug/tracing/events/uprobes/enable</span>
<span class="co0"># echo &gt; /sys/kernel/debug/tracing/trace</span>
<span class="co0"># ./test&amp;</span></pre></div></pre><p>Here we are printing the value of <b>ARM64 x1 register</b> as <b>count=</b> when the instruction at offset <b>0x630</b> is executed.</p>
<p>The output would look like this:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash">            test-<span class="nu0">3095</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">7918.629728</span>: func_2_entry: <span class="br0">&#40;</span>0x400630<span class="br0">&#41;</span> <span class="re2">count</span>=0x1
            test-<span class="nu0">3095</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">7919.629884</span>: func_2_entry: <span class="br0">&#40;</span>0x400630<span class="br0">&#41;</span> <span class="re2">count</span>=0x2
            test-<span class="nu0">3095</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">7920.629988</span>: func_2_entry: <span class="br0">&#40;</span>0x400630<span class="br0">&#41;</span> <span class="re2">count</span>=0x3
            test-<span class="nu0">3095</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">7922.630272</span>: func_2_entry: <span class="br0">&#40;</span>0x400630<span class="br0">&#41;</span> <span class="re2">count</span>=0x4
            test-<span class="nu0">3095</span>  <span class="br0">&#91;</span>003<span class="br0">&#93;</span> ....  <span class="nu0">7923.630429</span>: func_2_entry: <span class="br0">&#40;</span>0x400630<span class="br0">&#41;</span> <span class="re2">count</span>=0x5</pre></div></pre><h3>Inserting uprobe using perf</h3>
<p>Always finding the offset of an instruction or function where a probe needs to be inserted is cumbersome, and it's even more complicated to know the name of a CPU register assigned to any local variable. <b>perf</b> is a useful tool to help prepare and insert uprobe into any line in source code.</p>
<p>Besides <b>perf</b>, there are a few other tools, such as <b>SystemTap</b>, <b>DTrace</b>, and <b>LTTng</b>, that can be used for kernel and user space tracing; however, <b>perf</b> is fully coupled with the kernel, so it's favored by kernel developers.</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="co0"># gcc -g -o test test.c</span>
<span class="co0"># perf probe -x ./test func_2_entry=func_2</span>
<span class="co0"># perf probe -x ./test func_2_exit=func_2%return</span>
<span class="co0"># perf probe -x ./test test_15=test.c:15</span>
<span class="co0"># perf probe -x ./test test_25=test.c:25 number</span>
<span class="co0"># perf record -e probe_test:func_2_entry -e probe_test:func_2_exit -e probe_test:test_15  -e probe_test:test_25 ./test</span></pre></div></pre><p>As the above example shows, we can insert a probe point directly into the function start and return, a specific line number of the source file, etc. You can get a local variable printed. You can have many other options, like all the instances of a function calling (see <b><a href="http://man7.org/linux/man-pages/man1/perf-probe.1.html" target="_blank">man perf probe</a></b> for details). <b>perf probe</b> is used to create a probe point event, then those events can be probed using <b>perf record</b> while executing a <b>./test</b> executable. When we create a <b>perf probe</b> point, we can have other recording options like <b>perf stat</b>, and we can have many post-analysis options like <b>perf script</b> or <b>perf report</b>.</p>
<p>Using <b>perf script</b>, our output for the above example looks like:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="co0"># perf script</span>
            <span class="kw3">test</span>  <span class="nu0">2741</span> <span class="br0">&#91;</span>002<span class="br0">&#93;</span>   <span class="nu0">427.584681</span>: probe_test:test_25: <span class="br0">&#40;</span>4006a0<span class="br0">&#41;</span> <span class="re2">number</span>=<span class="nu0">3</span>
            <span class="kw3">test</span>  <span class="nu0">2741</span> <span class="br0">&#91;</span>002<span class="br0">&#93;</span>   <span class="nu0">427.584717</span>: probe_test:test_15: <span class="br0">&#40;</span><span class="nu0">400640</span><span class="br0">&#41;</span>
            <span class="kw3">test</span>  <span class="nu0">2741</span> <span class="br0">&#91;</span>002<span class="br0">&#93;</span>   <span class="nu0">428.584861</span>: probe_test:test_25: <span class="br0">&#40;</span>4006a0<span class="br0">&#41;</span> <span class="re2">number</span>=<span class="nu0">6</span>
            <span class="kw3">test</span>  <span class="nu0">2741</span> <span class="br0">&#91;</span>002<span class="br0">&#93;</span>   <span class="nu0">428.584872</span>: probe_test:func_2_entry: <span class="br0">&#40;</span><span class="nu0">400620</span><span class="br0">&#41;</span>
            <span class="kw3">test</span>  <span class="nu0">2741</span> <span class="br0">&#91;</span>002<span class="br0">&#93;</span>   <span class="nu0">428.584881</span>: probe_test:func_2_exit: <span class="br0">&#40;</span><span class="nu0">400620</span> <span class="sy0">&lt;</span>- 4006b8<span class="br0">&#41;</span>
            <span class="kw3">test</span>  <span class="nu0">2741</span> <span class="br0">&#91;</span>002<span class="br0">&#93;</span>   <span class="nu0">429.585012</span>: probe_test:test_25: <span class="br0">&#40;</span>4006a0<span class="br0">&#41;</span> <span class="re2">number</span>=<span class="nu0">7</span>
            <span class="kw3">test</span>  <span class="nu0">2741</span> <span class="br0">&#91;</span>002<span class="br0">&#93;</span>   <span class="nu0">429.585021</span>: probe_test:func_2_entry: <span class="br0">&#40;</span><span class="nu0">400620</span><span class="br0">&#41;</span>
            <span class="kw3">test</span>  <span class="nu0">2741</span> <span class="br0">&#91;</span>002<span class="br0">&#93;</span>   <span class="nu0">429.585025</span>: probe_test:func_2_exit: <span class="br0">&#40;</span><span class="nu0">400620</span> <span class="sy0">&lt;</span>- 4006b8<span class="br0">&#41;</span></pre></div></pre><h2>Tracing kernel space using kprobe</h2>
<p>As with uprobe, either the <strong>sysfs </strong>interface or the <strong>perf </strong>tool can be used to insert a kprobe tracepoint into kernel code.</p>
<h3>Inserting kprobe using the sysfs interface</h3>
<p>We can insert kprobe within <em>most</em> of the symbols in <b>/proc/kallsyms</b>; other symbols have been blacklisted in the kernel. A kprobe insertion into the <b>kprobe_events</b> file for the symbols that aren't compatible with a kprobe insertion should result in a write error. A probe can be inserted at some offset from the symbol base, as well. Like uprobe, we can also trace the return of a function using <b><a href="https://www.kernel.org/doc/Documentation/kprobes.txt" target="_blank">kretprobe</a></b>. The value of a local variable can also be printed in trace output.</p>
<p>This example explains how to do that:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash">; disable all events, just to insure that we see only kprobe output <span class="kw1">in</span> trace.
<span class="co0"># echo 0 &gt; /sys/kernel/debug/tracing/events/enable</span>
; disable kprobe events <span class="kw1">until</span> probe points are inseted.
<span class="co0"># echo 0 &gt; /sys/kernel/debug/tracing/events/kprobes/enable</span>
; <span class="kw2">clear</span> out all the events from kprobe_events, to insure that we see output <span class="kw1">for</span>
; only those <span class="kw1">for</span> <span class="kw2">which</span> we have enabled 
<span class="co0"># echo &gt; /sys/kernel/debug/tracing/kprobe_events</span>
; insert probe point at kfree
<span class="co0"># echo &quot;p kfree&quot; &gt;&gt; /sys/kernel/debug/tracing/kprobe_events</span>
; insert probe point at kfree+0x10 with name kfree_probe_10
<span class="co0"># echo &quot;p:kree_probe_10 kfree+0x10&quot; &gt;&gt; /sys/kernel/debug/tracing/kprobe_events</span>
; insert probe point at kfree <span class="kw3">return</span>
<span class="co0"># echo &quot;r:kfree_probe kfree&quot; &gt;&gt; /sys/kernel/debug/tracing/kprobe_events</span>
; <span class="kw3">enable</span> kprobe events <span class="kw1">until</span> probe points are inseted.
<span class="co0"># echo 1 &gt; /sys/kernel/debug/tracing/events/kprobes/enable</span></pre></div></pre><pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="br0">&#91;</span>root<span class="sy0">@</span>pratyush ~<span class="br0">&#93;</span><span class="co0"># more /sys/kernel/debug/tracing/trace</span>
<span class="co0"># tracer: nop</span>
<span class="co0">#</span>
<span class="co0"># entries-in-buffer/entries-written: 9037/9037   #P:8</span>
<span class="co0">#</span>
<span class="co0">#                              _-----=&gt; irqs-off</span>
<span class="co0">#                             / _----=&gt; need-resched</span>
<span class="co0">#                            | / _---=&gt; hardirq/softirq</span>
<span class="co0">#                            || / _--=&gt; preempt-depth</span>
<span class="co0">#                            ||| /     delay</span>
<span class="co0">#           TASK-PID   CPU#  ||||    TIMESTAMP  FUNCTION</span>
<span class="co0">#              | |       |   ||||       |         |</span>
            sshd-<span class="nu0">2189</span>  <span class="br0">&#91;</span>002<span class="br0">&#93;</span> dn..  <span class="nu0">1908.930731</span>: kree_probe: <span class="br0">&#40;</span>__audit_syscall_exit+0x194<span class="sy0">/</span>0x218 <span class="sy0">&lt;</span>- kfree<span class="br0">&#41;</span>
            sshd-<span class="nu0">2189</span>  <span class="br0">&#91;</span>002<span class="br0">&#93;</span> d...  <span class="nu0">1908.930744</span>: p_kfree_0: <span class="br0">&#40;</span>kfree+0x0<span class="sy0">/</span>0x214<span class="br0">&#41;</span>
            sshd-<span class="nu0">2189</span>  <span class="br0">&#91;</span>002<span class="br0">&#93;</span> d...  <span class="nu0">1908.930746</span>: kree_probe_10: <span class="br0">&#40;</span>kfree+0x10<span class="sy0">/</span>0x214<span class="br0">&#41;</span></pre></div></pre><h3>Inserting kprobe using perf</h3>
<p>As with uprobe, we can use <strong>perf </strong>to insert a kprobe within the kernel code. We can insert a probe point directly into the function start and return, the specific line number of the source file, etc. We can either provide <b>vmlinux</b> to the <b>-k</b> option, or we can provide the kernel source code path to the <b>-s</b> option:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="co0"># perf probe -k vmlinux kfree_entry=kfree</span>
<span class="co0"># perf probe -k vmlinux kfree_exit=kfree%return</span>
<span class="co0"># perf probe -s ./  kfree_mid=mm/slub.c:3408 x</span>
<span class="co0"># perf record -e probe:kfree_entry -e probe:kfree_exit -e probe:kfree_mid sleep 10</span></pre></div></pre><p>Using a <b>perf script</b>, we see this output for the above example:</p>
<pre>
<div class="geshifilter"><pre class="bash geshifilter-bash"><span class="co0"># perf script</span>
           <span class="kw2">sleep</span>  <span class="nu0">2379</span> <span class="br0">&#91;</span>001<span class="br0">&#93;</span>  <span class="nu0">2702.291224</span>: probe:kfree_entry: <span class="br0">&#40;</span>fffffe0000201944<span class="br0">&#41;</span>
           <span class="kw2">sleep</span>  <span class="nu0">2379</span> <span class="br0">&#91;</span>001<span class="br0">&#93;</span>  <span class="nu0">2702.291229</span>: probe:kfree_mid: <span class="br0">&#40;</span>fffffe0000201978<span class="br0">&#41;</span> <span class="re2">x</span>=0x0
           <span class="kw2">sleep</span>  <span class="nu0">2379</span> <span class="br0">&#91;</span>001<span class="br0">&#93;</span>  <span class="nu0">2702.291231</span>: probe:kfree_exit: <span class="br0">&#40;</span>fffffe0000201944 <span class="sy0">&lt;</span>- fffffe000019f67c<span class="br0">&#41;</span>
           <span class="kw2">sleep</span>  <span class="nu0">2379</span> <span class="br0">&#91;</span>001<span class="br0">&#93;</span>  <span class="nu0">2702.291241</span>: probe:kfree_entry: <span class="br0">&#40;</span>fffffe0000201944<span class="br0">&#41;</span>
           <span class="kw2">sleep</span>  <span class="nu0">2379</span> <span class="br0">&#91;</span>001<span class="br0">&#93;</span>  <span class="nu0">2702.291242</span>: probe:kfree_mid: <span class="br0">&#40;</span>fffffe0000201978<span class="br0">&#41;</span> <span class="re2">x</span>=0xfffffe01db8f6000
           <span class="kw2">sleep</span>  <span class="nu0">2379</span> <span class="br0">&#91;</span>001<span class="br0">&#93;</span>  <span class="nu0">2702.291243</span>: probe:kfree_exit: <span class="br0">&#40;</span>fffffe0000201944 <span class="sy0">&lt;</span>- fffffe000019f67c<span class="br0">&#41;</span>
           <span class="kw2">sleep</span>  <span class="nu0">2379</span> <span class="br0">&#91;</span>001<span class="br0">&#93;</span>  <span class="nu0">2702.291249</span>: probe:kfree_entry: <span class="br0">&#40;</span>fffffe0000201944<span class="br0">&#41;</span>
           <span class="kw2">sleep</span>  <span class="nu0">2379</span> <span class="br0">&#91;</span>001<span class="br0">&#93;</span>  <span class="nu0">2702.291250</span>: probe:kfree_mid: <span class="br0">&#40;</span>fffffe0000201978<span class="br0">&#41;</span> <span class="re2">x</span>=0xfffffe01db8f6000
           <span class="kw2">sleep</span>  <span class="nu0">2379</span> <span class="br0">&#91;</span>001<span class="br0">&#93;</span>  <span class="nu0">2702.291251</span>: probe:kfree_exit: <span class="br0">&#40;</span>fffffe0000201944 <span class="sy0">&lt;</span>- fffffe000019f67c<span class="br0">&#41;</span></pre></div></pre><p>I hope that this tutorial has explained how to hack your executable code and insert a couple of probe points into them. Happy tracing!</p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-tags" >
  
        <h2 class="pane-title">Topics</h2>
    
  
  <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:keywords"><a href="/tags/linux" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Linux</a></div><div class="field-item odd" rel="schema:keywords"><a href="/tags/programming" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Programming</a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-author-info-panel-pane-1" >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-932b7fd8698573ce2db1d0c183a5f672">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/pictures/dsc02750.jpg?itok=MNCfslm9" width="100" height="100" alt="" /></div>
<div class="authorbio__content">
  <span class="authorbio__name">Pratyush Anand</span> - <span class="authorbio__about">Pratyush is working with Red Hat as a Linux Kernel Generalist. Primarily, he takes care of several kexec/kdump issues being faced by Red Hat product and upstream. He also handles other kernel debugging/tracing/performance issues around Red Hat supported ARM64 platforms. Apart from Linux Kernel, he has also contributed in upstream kexec-tools and makedumpfile project. He is an open source enthusiast and delivers volunteer lectures in educational institutes for the promotion of FOSS.
</span>
  <div class="authorbio__more-link"><a href="/users/pratyushanand">More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-article-contributions" >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block" >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__bottom">
      <div class="panel-pane pane-views-panes pane-related-articles-panel-pane-1" >
  
        <h2 class="pane-title">Recommended reading</h2>
    
  
  <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 related-content view-dom-id-7490f55d08e9cf1942a2009feae08864">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/7/coderdojo-raspberry-pi"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/people_remote_teams_world.png?itok=H4VB1aBc" width="315" height="177" alt="CoderDojo merges with the Raspberry Pi Foundation" title="CoderDojo merges with the Raspberry Pi Foundation" /><br />
CoderDojo merges with the Raspberry Pi Foundation</a></span>  </div>  </div>  <div class="views-row views-row-2 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/7/nodered-raspberrypi-hardware"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/hardware_hammer_sign.jpg?itok=2bwlk-WL" width="315" height="177" alt="No coding required: Node-RED on a Raspberry Pi" title="No coding required: Node-RED on a Raspberry Pi" /><br />
No coding required: Node-RED on a Raspberry Pi</a></span>  </div>  </div>  <div class="views-row views-row-3 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/7/two-great-uses-cp-command"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/car-penguin-drive-linux-yellow.png?itok=HWYet17F" width="315" height="177" alt="Two great uses for the cp command" title="Two great uses for the cp command" /><br />
Two great uses for the cp command</a></span>  </div>  </div>  <div class="views-row views-row-4 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/7/brewing-beer-python-and-raspberry-pi"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/beer-drink-sample-sampler.png?itok=Yk5ZiADC" width="315" height="177" alt="Brewing beer with Linux, Python, and Raspberry Pi" title="Brewing beer with Linux, Python, and Raspberry Pi" /><br />
Brewing beer with Linux, Python, and Raspberry Pi</a></span>  </div>  </div>  <div class="views-row views-row-5 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/6/vox-pupuli"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/world_remote_teams.png?itok=bcOVkygU" width="315" height="177" alt="Building Puppet&#039;s unofficial forge community" title="Building Puppet&#039;s unofficial forge community" /><br />
Building Puppet&#039;s unofficial forge community</a></span>  </div>  </div>  <div class="views-row views-row-6 views-row-even views-row-last">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/6/clipboard-managers"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/resume_career_document_general.png?itok=bnXnLmaI" width="315" height="177" alt="6 Linux clipboard managers to boost your productivity" title="6 Linux clipboard managers to boost your productivity" /><br />
6 Linux clipboard managers to boost your productivity</a></span>  </div>  </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
    </div>
  
      <div class="os-article__footer">
      <div class="panel-pane pane-node-comment-form" >
  
        <h2 class="pane-title">Comment now</h2>
    
  
  <form class="comment-form user-info-from-cookie" action="/article/17/7/dynamic-tracing-linux-user-and-kernel-space#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div id="edit-login-register" class="form-item form-type-item">
 <a href="/user/login?destination=node/37426">Login or Register</a> to earn points for your comments.
</div>
<div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<input type="hidden" name="form_build_id" value="form--3sXAt8oRvY5e_8auT4BwK9BU3dcD6yz14VvyxLBxJ0" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/legal">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><input class="mollom-content-id" type="hidden" name="mollom[contentId]" value="" />
<input class="mollom-captcha-id" type="hidden" name="mollom[captchaId]" value="170706715d425b193a" />
<div class="form-item form-type-textfield form-item-mollom-captcha">
  <label for="edit-mollom-captcha">Verification <span class="form-required" title="This field is required.">*</span></label>
 <span class="field-prefix">
<span class="mollom-captcha-container">
  <span class="mollom-image-captcha-instructions">Type the characters you see in the picture; if you can't read them, submit the form and a new image will be generated. Not case sensitive.&nbsp;&nbsp;<a href="#" class="mollom-switch-captcha mollom-audio-captcha">Switch to audio verification.</a></span>
  <a href="javascript:void(0);" class="mollom-refresh-captcha mollom-refresh-image"><img typeof="foaf:Image" src="https://opensource.com/sites/all/modules/contrib/mollom/images/refresh.png" alt="Refresh" /></a>
  <span class="mollom-captcha-content mollom-image-captcha"><img typeof="foaf:Image" src="https://rest-production.mollom.com:443/v1/captcha/170706715d425b193a.png" alt="Type the characters you see in this picture." /></span>
</span>
</span> <input title="Enter the characters from the verification above." type="text" id="edit-mollom-captcha" name="mollom[captcha]" value="" size="10" maxlength="128" class="form-text required" />
</div>
<div style="display: none;"><div class="form-item form-type-textfield form-item-mollom-homepage">
  <label for="edit-mollom-homepage">Home page </label>
 <input autocomplete="off" type="text" id="edit-mollom-homepage" name="mollom[homepage]" value="" size="60" maxlength="128" class="form-text" />
</div>
</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div></div></form>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-default-license" >
  
      
  
  <div class="field field-name-field-default-license field-type-text field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:license"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" style="border-width:0" src="/sites/all/themes/opensource/images/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a></div></div></div>
  
  </div>
    </div>
  
</div>
                  </div>


        
        
      </div>

        <div class="region region-pre-footer">
    <div id="block-os-common-components-footer-call-to-action" class="block block-os-common-components first last odd">

      
  
<div class="fieldable-panels-pane cta cta--green-on-blue cta--no-link">

  <div class="cta__content cta__content--no-link">
            <h2 class="cta__title">Sign up for Opensource.com news</h2>
<div class="field field-name-field-cta-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><iframe frameborder="0" height="50" id="fkfkx" scrolling="no" src="/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></p>
</div></div></div>  </div>

</div>


</div>
  </div>

        <div class="region region-footer-nav">
    <div id="block-bean-social-media" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/social-media" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><span>Find us:</span> 
</p>
<ul>
<li><a class="footer-twitter" href="https://twitter.com/OpenSourceWay" title="Twitter">Twitter</a></li>
<li><a class="footer-facebook" href="https://www.facebook.com/opensourceway" title="Facebook">Facebook</a></li>
<li><a class="footer-gplus" href="https://plus.google.com/108750398488318674353" title="Google Plus">Google Plus</a></li>
<li><a class="footer-instagram" href="https://www.instagram.com/opensourceway/" title="Instagram">Instagram</a></li>
<li><a class="footer-youtube" href="http://www.youtube.com/opensourceway" title="Youtube">Youtube</a></li>
<li><a class="footer-linkedin" href="https://www.linkedin.com/grps/Open-Source-Professionals-Advocates-2769297" title="LinkedIn">LinkedIn</a></li>
<li><a class="footer-flickr" href="http://www.flickr.com/photos/opensourceway" title="Flickr">Flickr</a></li>
<li><a class="footer-feed" href="https://opensource.com/feed" title="RSS">RSS</a></li>
</ul>
</div></div></div>  </div>
</div>

</div>
<div id="block-menu-menu-footer" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Footer</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/legal" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact" class="menu__link">Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="/opensourcecom-team" title="" class="menu__link">Meet the Team</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://opensource.org/" title="" class="menu__link">Visit opensource.org</a></li>
</ul>
</div>
  </div>

        <footer id="footer" class="region region-footer">
    <div id="block-bean-copyrigt-block" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/copyrigt-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>For more discussion on open source and the role of the CIO in the enterprise, join us at <a href="http://enterprisersproject.com">The EnterprisersProject.com</a>.</p>
<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>
<p>Opensource.com aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Shadowman logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div></div></div>  </div>
</div>

</div>
<div id="block-bean-footer-logo" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/footer-logo" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><img src="/sites/all/themes/opensource/images/footer_logo.svg" /></p>
</div></div></div>  </div>
</div>

</div>
  </footer>

    </div>

    
      <div class="region region-os-social">
    <div id="block-os-social-os-social-share" class="block block-os-social first last odd">

      
  <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div>
</div>
  </div>
    <div class="region region-page-bottom">
    <!-- begin Google Remarketing --><img height="1" width="1" style="border-style:none;display:block;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" onerror="this.src='/sites/all/themes/opensource/images/1x1.png';this.onerror=null" /><!-- end Google Remarketing -->  </div>
<script src="https://opensource.com/sites/all/modules/contrib/media_ckeditor/js/plugins/media/library.js?oso6s1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_widgets/panopoly-widgets.js?oso6s1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_widgets/jquery-ui-tabs-rotate.js?oso6s1"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script>var a2a_config = a2a_config || {};
a2a_config.templates = {
    twitter: "Dynamic tracing in Linux user and kernel space http://red.ht/2srbWhi via @opensourceway by @pratyushanand80"
};</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"65779638","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkgHX1xuW1BXU1YEF2pWCVxcbkBYXEVuEQRSXQ==","queueTime":0,"applicationTime":627,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
