<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html class="no-js"  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema# schema: http://schema.org/"><!--<![endif]-->

<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
  <meta charset="utf-8" /><script type="text/javascript">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</script>
<link href="https://opensource.com/rss.xml" rel="alternate" type="application/rss+xml" title="Opensource.com RSS" />
<link rel="shortcut icon" href="https://opensource.com/sites/all/themes/opensource/favicon.ico" type="image/vnd.microsoft.icon" />
<script src="https://www.google.com/recaptcha/api.js?hl=en" async="async" defer="defer"></script>
<meta name="description" content="Automatically perform a set of actions on multiple files with for loops and find commands." />
<meta name="rating" content="general" />
<meta name="referrer" content="no-referrer" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://opensource.com/article/19/6/how-write-loop-bash" />
<link rel="shortlink" href="https://opensource.com/node/54341" />
<meta name="revisit-after" content="1 day" />
<meta property="og:site_name" content="Opensource.com" />
<meta property="og:url" content="https://opensource.com/article/19/6/how-write-loop-bash" />
<meta property="og:type" content="article" />
<meta property="og:title" content="How to write a loop in Bash" />
<meta property="og:description" content="Automatically perform a set of actions on multiple files with for loops and find commands." />
<meta property="og:image" content="https://opensource.com/sites/default/files/lead-images/bash_command_line.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@opensourceway" />
<meta name="twitter:creator" content="@" />
<meta name="twitter:title" content="How to write a loop in Bash" />
<meta name="twitter:description" content="Automatically perform a set of actions on multiple files with for loops and find commands." />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/lead-images/bash_command_line.png" />
  <title>How to write a loop in Bash | Opensource.com</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_rPk7Et6wjNyH7pw3qgw9a85Yiqd9m38Ov-4hY99oyhM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_qbWV8z-nAv7aqUsFySyOpWtipkPMMxfzR6T74v1M4_w.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_Uu_s7pgbnx6qMiEV7Qx4ofdg-AR2NOxZL0-UcApa2KI.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_NRb2PYryOMEugaEfXSAvlO-UgHQ5VxMgLRuDt52Y1DU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_PxsPpITToy8ZnO0bJDA1TEC6bbFpGTfSWr2ZP8LuFYo.css" media="all" />
  <script src="/sites/all/themes/opensource/js/use-typekit.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  <script src="https://opensource.com/sites/default/files/js/js_0RyHJ63yYLuaWsodCPCgSD8dcTIA0dqcDf8-7c2XdBw.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_R9xDkoIXbrDQhdBhQ3W4GF5TzHxKYFK0UB8wjqE0DbE.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_tBWHhFjU_NjWsmd07Hrx5ScmFu-4-PJD_GwzNMH3UwA.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_v2jwWn2vdJrAHHKMo-mOmfxmpVY6cfKDhZutjy4hfgQ.js"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-33294138-1", {"cookieDomain":".opensource.com"});ga("send", "pageview");</script>
<script src="https://opensource.com/sites/default/files/js/js_rVcPYhZ5_LfvT-dWbCnRngMcccEhwUaw2iNYx0yXj_Q.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_KbByFnBctcQt9juhHXNabaQDr4mJAc1OExQYJ-HcyXk.js"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-54341 node-type-article region-content section-article page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<header class="header" id="header" role="banner">

    
    <div class="header-banner">
      <div class="header-banner__inner">
                  <div class="header__name-and-slogan" id="name-and-slogan">
                          <div class="header__site-name" id="site-name">
                <a href="/" title="Home" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/logo.svg" onerror="this.src='/sites/all/themes/opensource/logo.png';this.onerror=null;" /></a>
                <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" title="Home" class="header__sponsor-link" rel="home"><img alt="RedHat" src="/sites/all/themes/opensource/images/redhat-logo.svg" onerror="this.src='/sites/all/themes/opensource/images/redhat-logo.png';this.onerror=null;"/></a>
              </div>
            
                      </div>
                <nav class="desktop-user-links">
            <div class="header__region region region-header">
    <div id="block-menu-block-1" class="block block-menu-block first last odd" role="navigation">

      
  <div class="menu-block-wrapper menu-block-1 menu-name-user-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-195"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1179"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul></div>

</div>
  </div>
        </nav>
      </div>
    </div>

    <div class="sf-nav">
      <div class="sf-nav__inner">
          <div class="js-mobile-header-buttons region region-navigation-top">
    <div id="block-os-solr-search-form" class="block block-os-solr-search first odd">

      
  <form action="/article/19/6/how-write-loop-bash" method="post" id="os-search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search">
  <label class="element-invisible" for="edit-search">Search </label>
 <input title="Enter the terms you wish to search for." placeholder="Search opensource.com" type="text" id="edit-search" name="search" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="GO" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-0U2vQy0ebVri0RacF1XqvYc9EGCaaxo_q_1Dpv9Q3cA" />
<input type="hidden" name="form_id" value="os_search_block_form" />
</div>
</div></form>
</div>
<div id="block-superfish-1" class="block block-superfish even">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-default sf-total-items-5 sf-parent-items-5 sf-single-items-0"><li id="menu-1906-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-10 sf-parent-children-3 sf-single-children-7 menuparent"><a href="/" title="" class="sf-depth-1 menuparent">Articles</a><ul><li id="menu-12341-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/containers" title="" class="sf-depth-2">Containers</a></li><li id="menu-12416-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/devops" title="" class="sf-depth-2">DevOps</a></li><li id="menu-12346-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/tags/gaming" title="" class="sf-depth-2">Gaming</a></li><li id="menu-17776-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/tags/government" title="" class="sf-depth-2">Government</a></li><li id="menu-12351-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/hardware" title="" class="sf-depth-2 menuparent">Hardware</a><ul><li id="menu-12376-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/3d-printing" title="" class="sf-depth-3">3D printing</a></li><li id="menu-12386-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/arduino" title="" class="sf-depth-3">Arduino</a></li><li id="menu-12381-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/raspberry-pi" title="" class="sf-depth-3">Raspberry Pi</a></li></ul></li><li id="menu-1946-1" class="middle even sf-item-6 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/tags/law" title="" class="sf-depth-2 menuparent">Law</a><ul><li id="menu-12391-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/licensing" title="" class="sf-depth-3">Licensing</a></li><li id="menu-12396-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/patents" title="" class="sf-depth-3">Patents</a></li></ul></li><li id="menu-12356-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/tags/linux" title="" class="sf-depth-2">Linux</a></li><li id="menu-12361-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="/tags/openstack" title="" class="sf-depth-2">OpenStack</a></li><li id="menu-12366-1" class="middle odd sf-item-9 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/programming" title="" class="sf-depth-2 menuparent">Programming</a><ul><li id="menu-17771-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/go" title="" class="sf-depth-3">Go</a></li><li id="menu-12411-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/javascript" title="" class="sf-depth-3">JavaScript</a></li><li id="menu-12406-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/python" title="" class="sf-depth-3">Python</a></li></ul></li><li id="menu-12371-1" class="last even sf-item-10 sf-depth-2 sf-no-children"><a href="/tags/sysadmin" title="" class="sf-depth-2">SysAdmin</a></li></ul></li><li id="menu-1921-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-5 sf-parent-children-2 sf-single-children-3 menuparent"><a href="/resources" title="" class="sf-depth-1 menuparent">Resources</a><ul><li id="menu-2016-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/resources/projects-and-applications" title="" class="sf-depth-2">Projects and applications</a></li><li id="menu-2021-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/organizations" title="" class="sf-depth-2">Organizations</a></li><li id="menu-1991-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/open-source-way" class="sf-depth-2">The open source way</a></li><li id="menu-5556-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-9 sf-parent-children-0 sf-single-children-9 menuparent"><a href="/resources/cloud" title="" class="sf-depth-2 menuparent">Cloud technology</a><ul><li id="menu-5576-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/resources/big-data" title="" class="sf-depth-3">Big data</a></li><li id="menu-5566-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/what-docker" title="" class="sf-depth-3">Docker</a></li><li id="menu-5591-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/resources/internet-of-things" title="" class="sf-depth-3">Internet of things</a></li><li id="menu-5596-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/resources/what-is-kubernetes" title="" class="sf-depth-3">Kubernetes</a></li><li id="menu-5571-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/what-are-linux-containers" title="" class="sf-depth-3">Linux containers</a></li><li id="menu-5586-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/resources/what-are-microservices" title="" class="sf-depth-3">Microservices</a></li><li id="menu-5561-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/resources/what-is-openstack" title="" class="sf-depth-3">OpenStack</a></li><li id="menu-5581-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/resources/what-is-software-defined-networking" title="" class="sf-depth-3">Software defined networking</a></li><li id="menu-12601-1" class="last odd sf-item-9 sf-depth-3 sf-no-children"><a href="/resources/virtualization" title="" class="sf-depth-3">Virtualization</a></li></ul></li><li id="menu-2036-1" class="last odd sf-item-5 sf-depth-2 sf-total-children-11 sf-parent-children-0 sf-single-children-11 menuparent"><a href="/alternatives" title="" class="sf-depth-2 menuparent">Open source alternatives</a><ul><li id="menu-4646-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/alternatives/adobe-acrobat" class="sf-depth-3">Alternatives to Acrobat</a></li><li id="menu-4656-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/alternatives/autocad" class="sf-depth-3">Alternatives to AutoCAD</a></li><li id="menu-4636-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/alternatives/dreamweaver" class="sf-depth-3">Alternatives to Dreamweaver</a></li><li id="menu-5506-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/alternatives/gmail" class="sf-depth-3">Alternatives to Gmail</a></li><li id="menu-5551-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/alternatives/matlab" class="sf-depth-3">Alternatives to MATLAB</a></li><li id="menu-5501-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/alternatives/minecraft" class="sf-depth-3">Alternatives to Minecraft</a></li><li id="menu-4651-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/alternatives/picasa" class="sf-depth-3">Alternatives to Picasa</a></li><li id="menu-4661-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/alternatives/microsoft-publisher" class="sf-depth-3">Alternatives to Publisher</a></li><li id="menu-5511-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/alternatives/slack" class="sf-depth-3">Alternatives to Slack</a></li><li id="menu-4641-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/alternatives/trello" class="sf-depth-3">Alternatives to Trello</a></li><li id="menu-5546-1" class="last odd sf-item-11 sf-depth-3 sf-no-children"><a href="/alternatives" title="" class="sf-depth-3">More...</a></li></ul></li></ul></li><li id="menu-19666-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-9 sf-parent-children-2 sf-single-children-7 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-1 menuparent">Downloads</a><ul><li id="menu-19406-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-16 sf-parent-children-0 sf-single-children-16 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Cheat sheets</a><ul><li id="menu-19651-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-awk-features" class="sf-depth-3">AWK cheat sheet</a></li><li id="menu-18641-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/blender-hotkey-cheat-sheet" class="sf-depth-3">Blender cheat sheet</a></li><li id="menu-18856-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/downloads/freedos-commands-cheat-sheet" class="sf-depth-3">FreeDOS cheat sheet</a></li><li id="menu-19721-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/content/cheat-sheet-gimp" class="sf-depth-3">GIMP cheat sheet</a></li><li id="menu-19696-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-gnome-3" class="sf-depth-3">GNOME cheat sheet</a></li><li id="menu-18661-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/downloads/groff-macros-cheat-sheet" class="sf-depth-3">Groff macros cheat sheet</a></li><li id="menu-19731-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/downloads/go-cheat-sheet" class="sf-depth-3">Go cheat sheet</a></li><li id="menu-19716-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-i3-window-manager-keybinding" class="sf-depth-3">i3 window manager cheat sheet</a></li><li id="menu-19781-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/downloads/inkscape-cheat-sheet" class="sf-depth-3">Inkscape Cheat Sheet</a></li><li id="menu-16886-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/irc-cheat-sheet" class="sf-depth-3">IRC cheat sheet</a></li><li id="menu-19301-1" class="middle odd sf-item-11 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-networking" class="sf-depth-3">Networking cheat sheet</a></li><li id="menu-18636-1" class="middle even sf-item-12 sf-depth-3 sf-no-children"><a href="/downloads/pandoc-cheat-sheet" class="sf-depth-3">Pandoc cheat sheet</a></li><li id="menu-19711-1" class="middle odd sf-item-13 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-python-37-beginners" class="sf-depth-3">Python 3.7 cheat sheet</a></li><li id="menu-19726-1" class="middle even sf-item-14 sf-depth-3 sf-no-children"><a href="/downloads/getting-started-raspberry-pi-cheat-sheet" class="sf-depth-3">Raspberry Pi cheat sheet</a></li><li id="menu-19691-1" class="middle odd sf-item-15 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-selinux" class="sf-depth-3">SELinux cheat sheet</a></li><li id="menu-18591-1" class="last even sf-item-16 sf-depth-3 sf-no-children"><a href="/downloads/advanced-ssh-cheat-sheet" class="sf-depth-3">SSH cheat sheet</a></li></ul></li><li id="menu-12466-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/yearbook/2017" title="" class="sf-depth-2 menuparent">Open Source Yearbook</a><ul><li id="menu-19681-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/yearbook/2015" title="" class="sf-depth-3">2015</a></li><li id="menu-19676-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/yearbook/2016" title="" class="sf-depth-3">2016</a></li><li id="menu-19671-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/yearbook/2017" title="" class="sf-depth-3">2017</a></li><li id="menu-19786-1" class="last even sf-item-4 sf-depth-3 sf-no-children"><a href="/yearbook/2018" title="" class="sf-depth-3">2018</a></li></ul></li><li id="menu-19801-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="https://opensource.com/downloads/ansible-quickstart" title="" class="sf-depth-2">Ansible Automation for Sysadmins</a></li><li id="menu-19706-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/downloads/containers-primer" class="sf-depth-2">Containers primer</a></li><li id="menu-19686-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/downloads/devops-hiring-guide" class="sf-depth-2">DevOps hiring guide</a></li><li id="menu-19701-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/downloads/devops-monitoring-guide" class="sf-depth-2">DevOps monitoring tools guide</a></li><li id="menu-19771-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/downloads/devsecops" title="" class="sf-depth-2">Getting started with DevSecOps</a></li><li id="menu-19776-1" class="middle even sf-item-8 sf-depth-2 sf-no-children"><a href="/downloads/small-scale-scrum" class="sf-depth-2">Introduction to Small Scale Scrum</a></li><li id="menu-19806-1" class="last odd sf-item-9 sf-depth-2 sf-no-children"><a href="/downloads/devops-transformation" title="" class="sf-depth-2">Starting a DevOps transformation</a></li></ul></li><li id="menu-4691-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-5 sf-parent-children-2 sf-single-children-3 menuparent"><a href="/about" class="sf-depth-1 menuparent">About</a><ul><li id="menu-12516-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-7 sf-parent-children-0 sf-single-children-7 menuparent"><a href="/participate" class="sf-depth-2 menuparent">Our community</a><ul><li id="menu-12521-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/user/register" title="" class="sf-depth-3">Register</a></li><li id="menu-12526-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/rules-comments-and-discussions" class="sf-depth-3">Rules for comments and discussions</a></li><li id="menu-17781-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/devops-team" class="sf-depth-3">Contribute to DevOps resources</a></li><li id="menu-12531-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/community-moderator-program" class="sf-depth-3">Community Moderator program</a></li><li id="menu-12581-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/contributor-club" title="" class="sf-depth-3">Contributor Club</a></li><li id="menu-12541-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/points-and-badges" class="sf-depth-3">Points and badges</a></li><li id="menu-17766-1" class="last odd sf-item-7 sf-depth-3 sf-no-children"><a href="/delete-account" title="" class="sf-depth-3">Delete your account</a></li></ul></li><li id="menu-1966-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-6 sf-parent-children-0 sf-single-children-6 menuparent"><a href="/writers" title="" class="sf-depth-2 menuparent">For writers</a><ul><li id="menu-17761-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/how-submit-article" class="sf-depth-3">Write for us</a></li><li id="menu-12546-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/editorial-calendar" title="" class="sf-depth-3">Editorial calendar</a></li><li id="menu-12586-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/article/19/1/write-for-us" title="" class="sf-depth-3">Writing topics</a></li><li id="menu-2041-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/submission-style-guide" class="sf-depth-3">Article submission and style guide</a></li><li id="menu-4616-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/promoting-articles" class="sf-depth-3">Tips for promoting your Opensource.com article</a></li><li id="menu-12556-1" class="last even sf-item-6 sf-depth-3 sf-no-children"><a href="/writer-testimonials" class="sf-depth-3">Writer testimonials</a></li></ul></li><li id="menu-1971-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/opensourcecom-team" class="sf-depth-2">Meet the team</a></li><li id="menu-2006-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/press-kit" class="sf-depth-2">Press kit</a></li><li id="menu-2001-1" class="last odd sf-item-5 sf-depth-2 sf-no-children"><a href="/contact" title="" class="sf-depth-2">Contact</a></li></ul></li><li id="menu-2136-1" class="last odd sf-item-5 sf-depth-1 sf-total-children-5 sf-parent-children-3 sf-single-children-2 menuparent"><a href="/open-organization" title="" class="sf-depth-1 menuparent">The Open Org</a><ul><li id="menu-12471-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="sf-depth-2">What is an open organization?</a></li><li id="menu-15056-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-maturity-model" title="" class="sf-depth-2">How open is your organization?</a></li><li id="menu-15051-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/open-organization/resources/book-series" title="" class="sf-depth-2 menuparent">Book series</a><ul><li id="menu-18656-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/organize-innovation" class="sf-depth-3">Organize for Innovation download</a></li><li id="menu-17796-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/workbook" class="sf-depth-3">Open Organization Workbook download</a></li><li id="menu-16896-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/culture-change" class="sf-depth-3">Guide to IT Culture Change download</a></li><li id="menu-16891-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/leaders-manual" class="sf-depth-3">Leaders Manual download</a></li><li id="menu-16906-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/field-guide" class="sf-depth-3">Field guide download</a></li></ul></li><li id="menu-2146-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-8 sf-parent-children-0 sf-single-children-8 menuparent"><a href="/open-organization/resources" title="" class="sf-depth-2 menuparent">Resources</a><ul><li id="menu-2181-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/what-open-organization" title="" class="sf-depth-3">What is The Open Organization?</a></li><li id="menu-12421-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-decision-framework" title="" class="sf-depth-3">What is the Open Decision Framework?</a></li><li id="menu-2151-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/guides" title="" class="sf-depth-3">Discussion guide download</a></li><li id="menu-17821-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/newsletter" class="sf-depth-3">Newsletter sign-up</a></li><li id="menu-2246-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/faq" title="" class="sf-depth-3">Open Org FAQs</a></li><li id="menu-4606-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/twitter-chats" title="" class="sf-depth-3">Twitter chats</a></li><li id="menu-3201-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/open-organization/resources/reading-list" title="" class="sf-depth-3">Reading list</a></li><li id="menu-2256-1" class="last even sf-item-8 sf-depth-3 sf-no-children"><a href="/open-organization/resources/2015-book-club" title="" class="sf-depth-3">Book club</a></li></ul></li><li id="menu-3166-1" class="last odd sf-item-5 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/open-organization/resources/ambassadors-program" title="" class="sf-depth-2 menuparent">Ambassadors program</a><ul><li id="menu-2691-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/meet-ambassadors" title="" class="sf-depth-3">Meet the ambassadors</a></li></ul></li></ul></li></ul>
</div>
<div id="block-system-user-menu" class="block block-system block-menu odd" role="navigation">

      
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul>
</div>
<div id="block-menu-block-2" class="block block-menu-block last even" role="navigation">

      
  <div class="menu-block-wrapper menu-block-2 menu-name-menu-social-links parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-13171"><a href="http://twitter.com/opensourceway" title="twitter" class="menu__link">Twitter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-13176"><a href="https://www.facebook.com/opensourceway" title="facebook" class="menu__link">Facebook</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-13166"><a href="/feed" title="feed" class="menu__link">Feed</a></li>
</ul></div>

</div>
  </div>

        <div class="mobile--menu-region">
            <div class="region region-navigation">
    <div id="block-system-main-menu" class="block block-system block-menu first last odd" role="navigation">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/" title="" class="menu__link">Articles</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/containers" title="" class="menu__link">Containers</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/devops" title="" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/gaming" title="" class="menu__link">Gaming</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/government" title="" class="menu__link">Government</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/hardware" title="" class="menu__link">Hardware</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/3d-printing" title="" class="menu__link">3D printing</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/arduino" title="" class="menu__link">Arduino</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/raspberry-pi" title="" class="menu__link">Raspberry Pi</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/law" title="" class="menu__link">Law</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/linux" title="" class="menu__link">Linux</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/openstack" title="" class="menu__link">OpenStack</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/programming" title="" class="menu__link">Programming</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/go" title="" class="menu__link">Go</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/javascript" title="" class="menu__link">JavaScript</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/python" title="" class="menu__link">Python</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/tags/sysadmin" title="" class="menu__link">SysAdmin</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/projects-and-applications" title="" class="menu__link">Projects and applications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/organizations" title="" class="menu__link">Organizations</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-source-way" class="menu__link">The open source way</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/resources/cloud" title="" class="menu__link">Cloud technology</a></li>
<li class="menu__item is-collapsed last collapsed"><a href="/alternatives" title="" class="menu__link">Open source alternatives</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/downloads/cheat-sheets" title="" class="menu__link">Downloads</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/about" class="menu__link">About</a></li>
<li class="menu__item is-expanded last expanded"><a href="/open-organization" title="" class="menu__link">The Open Org</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="menu__link">What is an open organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-org-maturity-model" title="" class="menu__link">How open is your organization?</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/open-organization/resources/book-series" title="" class="menu__link">Book series</a></li>
<li class="menu__item is-expanded expanded"><a href="/open-organization/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/what-open-organization" title="" class="menu__link">What is The Open Organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-decision-framework" title="" class="menu__link">What is the Open Decision Framework?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/guides" title="" class="menu__link">Discussion guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/newsletter" class="menu__link">Newsletter sign-up</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/faq" title="" class="menu__link">Open Org FAQs</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/twitter-chats" title="" class="menu__link">Twitter chats</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/reading-list" title="" class="menu__link">Reading list</a></li>
<li class="menu__item is-leaf last leaf"><a href="/open-organization/resources/2015-book-club" title="" class="menu__link">Book club</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/open-organization/resources/ambassadors-program" title="" class="menu__link">Ambassadors program</a></li>
</ul></li>
</ul>
</div>
  </div>
        </div>
      </div>
    </div>

</header>

<div id="page">

      <div id="main">
        <div class="pre-content">
                                                </div>
        <div id="content" class="column" role="main">
                              <a id="main-content"></a>
                                <h1 class="page__title title" id="page-title">How to write a loop in Bash</h1>
                              



<div class="panel-display os-article clearfix os-article--with-image " id="article-template">

      <div class="os-article__top">
      <div class="os-article__top-inner">
        <div class="panel-pane pane-node-title"  >
  
      
  
  <h1>How to write a loop in Bash</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-article-subhead"  >
  
      
  
  <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden">
    <div class="field-items">
          <h2>Automatically perform a set of actions on multiple files with for loops and find commands.</h2>
      </div>
</div>

  
  </div>
<div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__date">12 Jun 2019</span>
<span class="byline__author-name"><a href="/users/seth" title="View user profile." class="username" xml:lang="" about="/users/seth" typeof="sioc:UserAccount" property="foaf:name" datatype="">Seth Kenlon <span class="content-moderator">(Red Hat)</span></a>&nbsp;<span class="byline__feed"><a href="/user/15261/feed">Feed</a></span>
</span>
<span class="byline__social"><span class="byline__voting-widget"><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-d2cf20fa3a131c7f02e6a756acc178c0 rate-node-54341-1-1" id="rate-node-54341-1-1"><div class="rate-info">9</div><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/19/6/how-write-loop-bash?rate=RYDIPRd2Prmz2nTeDT7F-iAOinRIYX6pCv0m6x-yrpE" title="up">up</a></div></span>
</span>
<span class="byline__comment-count"><a href="#comments">6 comments</a></span>
</div>
  
  </div>
      </div>
    </div>
  
      <div class="os-article__image">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/bash_command_line.png?itok=k4z94W2U"><img class="image-full-size" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/bash_command_line.png?itok=k4z94W2U" width="518" height="292" alt="bash logo on green background" title="bash logo on green background" /></div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-file-field-file-image-caption"  >
  
      
  
  <div class="field field-name-field-file-image-caption field-type-text-long field-label-inline clearfix"><div class="field-label">Image by :&nbsp;</div><div class="field-items"><div class="field-item even"><p>opensource.com</p>
</div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__left">
      <div class="panel-pane pane-block pane-bean-email-capture widget-block widget-block__left"  >
      <div class="target-band-never-show-button">x</div>
        <h2 class="pane-title">
      Get the newsletter    </h2>
    
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/email-capture" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p class="eloqua-email-capture-text">Join the 85,000 open source advocates who receive our giveaway alerts and article roundups.</p>

<p><iframe frameborder="0" height="100" id="fkfkx" scrolling="no" src="/eloqua-embedded-email-capture-block.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="250"></iframe></p>
</div></div></div>  </div>
</div>

  
  </div>
    </div>
  
  
      <div class="os-article__middle">
      <div class="panel-pane pane-entity-field pane-node-body"  >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:articleBody content:encoded"><p>A common reason people want to learn the Unix shell is to unlock the power of batch processing. If you want to perform some set of actions on many files, one of the ways to do that is by constructing a command that iterates over those files. In programming terminology, this is called <em>execution control, </em>and one of the most common examples of it is the <strong>for</strong> loop.</p>

<p>A <strong>for</strong> loop is a recipe detailing what actions you want your computer to take <em>for</em> each data object (such as a file) you specify.</p>

<h2 id="the-classic-for-loop">The classic for loop</h2>

<p><div id="the-linux-terminal" class="embedded-callout-menu callout-float-right"><div class="view view-related-content-callout view-id-related_content_callout view-display-id-article_block view-dom-id-91e20402700c32f60f3328bf829d5958">
            <div class="view-header">
      The Linux Terminal    </div>
  
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">      
  <div class="views-field views-field-field-related-content-link">        <div class="field-content"><div class="item-list"><ul><li class="first"><a href="https://opensource.com/life/17/10/top-terminal-emulators?intcmp=7016000000127cYAAQ">Top 7 terminal emulators for Linux</a></li>
<li><a href="https://opensource.com/article/17/2/command-line-tools-data-analysis-linux?intcmp=7016000000127cYAAQ">10 command-line tools for data analysis in Linux</a></li>
<li><a href="https://opensource.com/downloads/advanced-ssh-cheat-sheet?intcmp=7016000000127cYAAQ">Download Now: SSH cheat sheet</a></li>
<li class="last"><a href="https://developers.redhat.com/cheat-sheets/advanced-linux-commands/?intcmp=7016000000127cYAAQ">Advanced Linux commands cheat sheet</a></li>
</ul></div></div>  </div>  </div>    </div>
  
  
  
  
  
  
</div></div>An easy loop to try is one that analyzes a collection of files. This probably isn't a useful loop on its own, but it's a safe way to prove to yourself that you have the ability to handle each file in a directory individually. First, create a simple test environment by creating a directory and placing some copies of some files into it. Any file will do initially, but later examples require graphic files (such as JPEG, PNG, or similar). You can create the folder and copy files into it using a file manager or in the terminal:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">mkdir</span> example<br />
&nbsp; &nbsp; &nbsp; &nbsp; $ <span class="kw2">cp</span> ~<span class="sy0">/</span>Pictures<span class="sy0">/</span>vacation<span class="sy0">/*</span>.<span class="br0">&#123;</span>png,jpg<span class="br0">&#125;</span> example</div></div></pre>

<p>Change directory to your new folder, then list the files in it to confirm that your test environment is what you expect:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw3">cd</span> example<br />
$ <span class="kw2">ls</span> <span class="re5">-1</span><br />
cat.jpg<br />
design_maori.png<br />
otago.jpg<br />
waterfall.png</div></div></pre>

<p>The syntax to loop through each file individually in a loop is: create a variable (<strong>f</strong> for file, for example). Then define the data set you want the variable to cycle through. In this case, cycle through all files in the current directory using the <strong>*</strong> wildcard character (the <strong>*</strong> wildcard matches <em>everything</em>). Then terminate this introductory clause with a semicolon (<strong>;</strong>).</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw1">for</span> f <span class="kw1">in</span> <span class="sy0">*</span> ;</code></span></pre>

<p>Depending on your preference, you can choose to press <strong>Return</strong> here. The shell won't try to execute the loop until it is syntactically complete.</p>

<p>Next, define what you want to happen with each iteration of the loop. For simplicity, use the <strong>file</strong> command to get a little bit of data about each file, represented by the <strong>f</strong> variable (but prepended with a <strong>$</strong> to tell the shell to swap out the value of the variable for whatever the variable currently contains):</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="kw1">do</span> <span class="kw2">file</span> <span class="re1">$f</span> ;</code></span></pre>

<p>Terminate the clause with another semi-colon and close the loop:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="kw1">done</span></code></span></pre>

<p>Press <strong>Return</strong> to start the shell cycling through <em>everything</em> in the current directory. The <strong>for</strong> loop assigns each file, one by one, to the variable <strong>f</strong> and runs your command:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw1">for</span> f <span class="kw1">in</span> <span class="sy0">*</span> ; <span class="kw1">do</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="sy0">&gt;</span> <span class="kw2">file</span> <span class="re1">$f</span> ;<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="sy0">&gt;</span> <span class="kw1">done</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; cat.jpg: JPEG image data, EXIF standard <span class="nu0">2.2</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; design_maori.png: PNG image data, <span class="nu0">4608</span> x <span class="nu0">2592</span>, <span class="nu0">8</span>-bit<span class="sy0">/</span>color RGB, non-interlaced<br />
&nbsp; &nbsp; &nbsp; &nbsp; otago.jpg: JPEG image data, EXIF standard <span class="nu0">2.2</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; waterfall.png: PNG image data, <span class="nu0">4608</span> x <span class="nu0">2592</span>, <span class="nu0">8</span>-bit<span class="sy0">/</span>color RGB, non-interlaced</div></div></pre>

<p>You can also write it this way:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw1">for</span> f <span class="kw1">in</span> <span class="sy0">*</span>; <span class="kw1">do</span> <span class="kw2">file</span> <span class="re1">$f</span>; <span class="kw1">done</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; cat.jpg: JPEG image data, EXIF standard <span class="nu0">2.2</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; design_maori.png: PNG image data, <span class="nu0">4608</span> x <span class="nu0">2592</span>, <span class="nu0">8</span>-bit<span class="sy0">/</span>color RGB, non-interlaced<br />
&nbsp; &nbsp; &nbsp; &nbsp; otago.jpg: JPEG image data, EXIF standard <span class="nu0">2.2</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; waterfall.png: PNG image data, <span class="nu0">4608</span> x <span class="nu0">2592</span>, <span class="nu0">8</span>-bit<span class="sy0">/</span>color RGB, non-interlaced</div></div></pre>

<p>Both the multi-line and single-line formats are the same to your shell and produce the exact same results.</p>

<h2 id="a-practical-example">A practical example</h2>

<p>Here's a practical example of how a loop can be useful for everyday computing. Assume you have a collection of vacation photos you want to send to friends. Your photo files are huge, making them too large to email and inconvenient to upload to your <a href="http://nextcloud.com" target="_blank">photo-sharing service</a>. You want to create smaller web-versions of your photos, but you have 100 photos and don't want to spend the time reducing each photo, one by one.</p>

<p>First, install the <strong>ImageMagick</strong> command using your package manager on Linux, BSD, or Mac. For instance, on Fedora and RHEL:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw2">sudo</span> dnf <span class="kw2">install</span> ImageMagick</code></span></pre>

<p>On Ubuntu or Debian:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw2">sudo</span> apt <span class="kw2">install</span> ImageMagick</code></span></pre>

<p>On BSD, use <strong>ports</strong> or <a href="http://pkgsrc.org" target="_blank">pkgsrc</a>. On Mac, use <a href="http://brew.sh" target="_blank">Homebrew</a> or <a href="https://www.macports.org" target="_blank">MacPorts</a>.</p>

<p>Once you install ImageMagick, you have a set of new commands to operate on photos.</p>

<p>Create a destination directory for the files you're about to create:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw2">mkdir</span> tmp</code></span></pre>

<p>To reduce each photo to 33% of its original size, try this loop:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw1">for</span> f <span class="kw1">in</span> <span class="sy0">*</span> ; <span class="kw1">do</span> convert <span class="re1">$f</span> <span class="re5">-scale</span> <span class="nu0">33</span><span class="sy0">%</span> tmp<span class="sy0">/</span><span class="re1">$f</span> ; <span class="kw1">done</span></code></span></pre>

<p>Then look in the <strong>tmp</strong> folder to see your scaled photos.</p>

<p>You can use any number of commands within a loop, so if you need to perform complex actions on a batch of files, you can place your whole workflow between the <strong>do</strong> and <strong>done</strong> statements of a <strong>for</strong> loop. For example, suppose you want to copy each processed photo straight to a shared photo directory on your web host and remove the photo file from your local system:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw1">for</span> f <span class="kw1">in</span> <span class="sy0">*</span> ; <span class="kw1">do</span> <br />
&nbsp; &nbsp; convert <span class="re1">$f</span> <span class="re5">-scale</span> <span class="nu0">33</span><span class="sy0">%</span> tmp<span class="sy0">/</span><span class="re1">$f</span><br />
&nbsp; &nbsp; <span class="kw2">scp</span> <span class="re5">-i</span> seth_web tmp<span class="sy0">/</span><span class="re1">$f</span> seth<span class="sy0">@</span>example.com:~<span class="sy0">/</span>public_html <br />
&nbsp; &nbsp; trash tmp<span class="sy0">/</span><span class="re1">$f</span> ;<br />
&nbsp; <span class="kw1">done</span></div></div></pre>

<p>For each file processed by the <strong>for</strong> loop, your computer automatically runs three commands. This means if you process just 10 photos this way, you save yourself 30 commands and probably at least as many minutes.</p>

<h2 id="limiting-your-loop">Limiting your loop</h2>

<p>A loop doesn't always have to look at every file. You might want to process only the JPEG files in your example directory:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw1">for</span> f <span class="kw1">in</span> <span class="sy0">*</span>.jpg ; <span class="kw1">do</span> convert <span class="re1">$f</span> <span class="re5">-scale</span> <span class="nu0">33</span><span class="sy0">%</span> tmp<span class="sy0">/</span><span class="re1">$f</span> ; <span class="kw1">done</span><br />
$ <span class="kw2">ls</span> <span class="re5">-m</span> tmp<br />
cat.jpg, otago.jpg</div></div></pre>

<p>Or, instead of processing files, you may need to repeat an action a specific number of times. A <strong>for</strong> loop's variable is defined by whatever data you provide it, so you can create a loop that iterates over numbers instead of files:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw1">for</span> n <span class="kw1">in</span> <span class="br0">&#123;</span><span class="nu0">0</span>..<span class="nu0">4</span><span class="br0">&#125;</span>; <span class="kw1">do</span> <span class="kw3">echo</span> <span class="re1">$n</span> ; <span class="kw1">done</span><br />
<span class="nu0">0</span><br />
<span class="nu0">1</span><br />
<span class="nu0">2</span><br />
<span class="nu0">3</span><br />
<span class="nu0">4</span></div></div></pre>

<h2 id="more-looping">More looping</h2>

<p>You now know enough to create your own loops. Until you're comfortable with looping, use them on <em>copies</em> of the files you want to process and, as often as possible, use commands with built-in safeguards to prevent you from clobbering your data and making irreparable mistakes, like accidentally renaming an entire directory of files to the same name, each overwriting the other.</p>

<p>For advanced <strong>for</strong> loop topics, read on.</p>

<h2 id="not-all-shells-are-bash">Not all shells are Bash</h2>

<p>The <strong>for</strong> keyword is built into the Bash shell. Many similar shells use the same keyword and syntax, but some shells, like <a href="https://en.wikipedia.org/wiki/Tcsh" target="_blank">tcsh</a>, use a different keyword, like <strong>foreach</strong>, instead.</p>

<p>In tcsh, the syntax is similar in spirit but more strict than Bash. In the following code sample, do not type the string <strong>foreach?</strong> in lines 2 and 3. It is a secondary prompt alerting you that you are still in the process of building your loop.</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ foreach f <span class="br0">&#40;</span><span class="sy0">*</span><span class="br0">&#41;</span><br />
foreach? <span class="kw2">file</span> <span class="re1">$f</span><br />
foreach? end<br />
cat.jpg: JPEG image data, EXIF standard <span class="nu0">2.2</span><br />
design_maori.png: PNG image data, <span class="nu0">4608</span> x <span class="nu0">2592</span>, <span class="nu0">8</span>-bit<span class="sy0">/</span>color RGB, non-interlaced<br />
otago.jpg: JPEG image data, EXIF standard <span class="nu0">2.2</span><br />
waterfall.png: PNG image data, <span class="nu0">4608</span> x <span class="nu0">2592</span>, <span class="nu0">8</span>-bit<span class="sy0">/</span>color RGB, non-interlaced</div></div></pre>

<p>In tcsh, both <strong>foreach</strong> and <strong>end</strong> must appear alone on separate lines, so you cannot create a <strong>for</strong> loop on one line as you can with Bash and similar shells.</p>

<h2 id="for-loops-with-the-find-command">For loops with the find command</h2>

<p>In theory, you could find a shell that doesn't provide a <strong>for</strong> loop function, or you may just prefer to use a different command with added features.</p>

<p>The <strong>find</strong> command is another way to implement the functionality of a <strong>for</strong> loop, as it offers several ways to define the scope of which files to include in your loop as well as options for <a href="https://opensource.com/article/18/5/gnu-parallel">Parallel</a> processing.</p>

<p>The <strong>find</strong> command is meant to help you find files on your hard drives. Its syntax is simple: you provide the path of the location you want to search, and <strong>find</strong> finds all files and directories:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">find</span> . <br />
.<br />
.<span class="sy0">/</span>cat.jpg<br />
.<span class="sy0">/</span>design_maori.png<br />
.<span class="sy0">/</span>otago.jpg<br />
.<span class="sy0">/</span>waterfall.png</div></div></pre>

<p>You can filter the search results by adding some portion of the name:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">find</span> . <span class="re5">-name</span> <span class="st0">&quot;*jpg&quot;</span><br />
.<span class="sy0">/</span>cat.jpg<br />
.<span class="sy0">/</span>otago.jpg</div></div></pre>

<p>The great thing about <strong>find</strong> is that each file it finds can be fed into a loop using the <strong>-exec</strong> flag. For instance, to scale down only the PNG photos in your example directory:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">find</span> . <span class="re5">-name</span> <span class="st0">&quot;*png&quot;</span> <span class="re5">-exec</span> convert <span class="br0">&#123;</span><span class="br0">&#125;</span> <span class="re5">-scale</span> <span class="nu0">33</span><span class="sy0">%</span> tmp<span class="sy0">/</span><span class="br0">&#123;</span><span class="br0">&#125;</span> \;<br />
$ <span class="kw2">ls</span> <span class="re5">-m</span> tmp<br />
design_maori.png, waterfall.png</div></div></pre>

<p>In the <strong>-exec</strong> clause, the bracket characters <strong>{}</strong> stand in for whatever item <strong>find</strong> is processing (in other words, any file ending in PNG that has been located, one at a time). The <strong>-exec</strong> clause must be terminated with a semicolon, but Bash usually tries to use the semicolon for itself. You "escape" the semicolon with a backslash (<strong>\;</strong>) so that <strong>find</strong> knows to treat that semicolon as its terminating character.</p>

<p>The <strong>find</strong> command is very good at what it does, and it can be too good sometimes. For instance, if you reuse it to find PNG files for another photo process, you will get a few errors:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">find</span> . <span class="re5">-name</span> <span class="st0">&quot;*png&quot;</span> <span class="re5">-exec</span> convert <span class="br0">&#123;</span><span class="br0">&#125;</span> <span class="re5">-flip</span> <span class="re5">-flop</span> tmp<span class="sy0">/</span><span class="br0">&#123;</span><span class="br0">&#125;</span> \;&nbsp; &nbsp; <br />
convert: unable to open image <span class="sy0">`</span>tmp<span class="sy0">/</span>.<span class="sy0">/</span>tmp<span class="sy0">/</span>design_maori.png<span class="st_h">':<br />
No such file or directory @ error/blob.c/OpenBlob/2643.<br />
...</span></div></div></pre>

<p>It seems that <strong>find</strong> has located all the PNG files—not only the ones in your current directory (<strong>.</strong>) but also those that you processed before and placed in your <strong>tmp</strong> subdirectory. In some cases, you may want <strong>find</strong> to search the current directory plus all other directories within it (and all directories in <em>those</em>). It can be a powerful recursive processing tool, especially in complex file structures (like directories of music artists containing directories of albums filled with music files), but you can limit this with the <strong>-maxdepth</strong> option.</p>

<p>To find only PNG files in the current directory (excluding subdirectories):</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw2">find</span> . <span class="re5">-maxdepth</span> <span class="nu0">1</span> <span class="re5">-name</span> <span class="st0">&quot;*png&quot;</span></code></span></pre>

<p>To find and process files in the current directory plus an additional level of subdirectories, increment the maximum depth by 1:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw2">find</span> . <span class="re5">-maxdepth</span> <span class="nu0">2</span> <span class="re5">-name</span> <span class="st0">&quot;*png&quot;</span></code></span></pre>

<p>Its default is to descend into all subdirectories.</p>

<h2 id="looping-for-fun-and-profit">Looping for fun and profit</h2>

<p>The more you use loops, the more time and effort you save, and the bigger the tasks you can tackle. You're just one user, but with a well-thought-out loop, you can make your computer do the hard work.</p>

<p>You can and should treat looping like any other command, keeping it close at hand for when you need to repeat a single action or two on several files. However, it's also a legitimate gateway to serious programming, so if you have to accomplish a complex task on any number of files, take a moment out of your day to plan out your workflow. If you can achieve your goal on one file, then wrapping that repeatable process in a <strong>for</strong> loop is relatively simple, and the only "programming" required is an understanding of how variables work and enough organization to separate unprocessed from processed files. With a little practice, you can move from a Linux user to a Linux user who knows how to write a loop, so get out there and make your computer work for you!</p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-listacles-panel-pane-1"  >
  
      
  
  <div class="view view-listacles view-id-listacles view-display-id-panel_pane_1 view-dom-id-8f6ab7d66c4f44fa6eba276e1e83f27a">
        
  
  
      <div class="view-content">
              
  <div class="views-field views-field-field-listacles">        <div class="field-content"></div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-tags"  >
  
        <h2 class="pane-title">
      Topics    </h2>
    
  
  <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:keywords"><a href="/tags/bash" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Bash</a></div><div class="field-item odd" rel="schema:keywords"><a href="/tags/command-line" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Command line</a></div><div class="field-item even" rel="schema:keywords"><a href="/tags/linux" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Linux</a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-author-info-panel-pane-1"  >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-1c09d0a5772edb67aac25a620522ed3d">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><a href="/users/seth"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/penguinmedallion200x200.png?itok=ROQSR50J" width="100" height="100" alt="image from https://openclipart.org/detail/196235/penguin-profile-medalion" /></a></div>
<div class="authorbio__content">
  <span class="authorbio__name">Seth Kenlon</span> - <span class="authorbio__about">Seth Kenlon is an independent multimedia artist, free culture advocate, and UNIX geek. He has worked in the <a href="http://www.imdb.com/name/nm1244992" rel="nofollow">film</a> and <a href="http://people.redhat.com/skenlon" rel="nofollow">computing</a> industry, often at the same time. He is one of the maintainers of the Slackware-based multimedia production project, <a href="http://slackermedia.info">http://slackermedia.info</a>
</span>
  <div class="authorbio__more-link"><a href="/users/seth">More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-content-article-contributions"  >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block"  >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__bottom">
      <div class="panel-pane pane-views-panes pane-related-articles-panel-pane-1"  >
  
        <h2 class="pane-title">
      Recommended reading    </h2>
    
  
  <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 related-content view-dom-id-3cd410ab1b0f54c05e0bdbed78ead980">
        
  
  
      <div id="related-content-footer" class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/6/what-linux-user"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/linux_penguin_green.png?itok=GeutroCl" width="315" height="177" /><br />
What is a Linux user?</a></span>  </div>  </div>  <div class="views-row views-row-2 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/6/tmux-terminal-joy"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/linux_keyboard_desktop.png?itok=RlzHnXX3" width="315" height="177" alt="Linux keys on the keyboard for a desktop computer" title="Linux keys on the keyboard for a desktop computer" /><br />
How tmux sparks joy in your Linux terminal</a></span>  </div>  </div>  <div class="views-row views-row-3 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/6/create-centos-homelab-hour"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/metrics_data_dashboard_system_computer_analytics.png?itok=CR7DSXPK" width="314" height="177" alt="metrics and data shown on a computer screen" title="metrics and data shown on a computer screen" /><br />
 Create a CentOS homelab in an hour</a></span>  </div>  </div>  <div class="views-row views-row-4 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/5/dual-booting-windows-linux-uefi"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/linux_keyboard_desktop.png?itok=RlzHnXX3" width="315" height="177" alt="Linux keys on the keyboard for a desktop computer" title="Linux keys on the keyboard for a desktop computer" /><br />
Dual booting Windows and Linux using UEFI</a></span>  </div>  </div>  <div class="views-row views-row-5 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/5/set-static-network-connection-linux"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/terminal_command_linux_desktop_code.jpg?itok=_IipN0pY" width="315" height="177" alt="Terminal command prompt on orange background" title="Terminal command prompt on orange background" /><br />
Set up a static network connection in Linux</a></span>  </div>  </div>  <div class="views-row views-row-6 views-row-even views-row-last">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/19/5/gnome-boxes-remote-access-capabilities"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/mesh_networking_dots_connected.png?itok=J4r1QvjR" width="315" height="177" alt="Mesh networking connected dots" title="Mesh networking connected dots" /><br />
How to use GNOME Boxes&#039; remote access capabilities</a></span>  </div>  </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
    </div>
  
      <div class="os-article__footer">
      <div class="panel-pane pane-node-comments"  id="comments" >
  
        <h2 class="pane-title">
      6 Comments    </h2>
    
  
  <a id="comment-178111"></a>
<div class="comment first odd clearfix" about="/comment/178111#comment-178111" typeof="sioc:Post sioct:Comment">

  <div class="user-picture-badges">
    <img class="comment-avatar" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/comment_avatar/public/pictures/goncasousa.jpg?itok=dgj9KpF4" width="50" height="50" alt="GoncaSousa" title="GoncaSousa" />      </div>

  
  <div class="submitted">
    <span property="dc:date dc:created" content="2019-06-12T04:30:14-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/goncasousa" class="username">Gonca Sousa</a> on 12 Jun 2019</span>    <a href="/comment/178111#comment-178111" class="permalink" rel="bookmark">Permalink</a>      </div>

  <div class="content">
    <span rel="sioc:reply_of" resource="/article/19/6/how-write-loop-bash" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>great</p>
</div></div></div>      </div>

  <div class="comment__meta">
    <ul class="links inline"><li class="comment-reply first last"><a href="/comment/reply/54341/178111">reply</a></li>
</ul>    <div class="vud-widget vud-widget-upanddown" id="widget-comment-178111">
  <div class="up-score clear-block">
                    <div class="up-active" title="Vote up!"></div>
          <div class="element-invisible">Vote up!</div>
              <span class="up-current-score">0</span>
  </div>

  </div>
  </div>
</div>
<a id="comment-178126"></a>
<div class="comment even clearfix" about="/comment/178126#comment-178126" typeof="sioc:Post sioct:Comment">

  <div class="user-picture-badges">
    <img class="comment-avatar" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/comment_avatar/public/pictures/fav.png?itok=b7fDynSS" width="50" height="50" alt="howtopamm" title="howtopamm" />      </div>

  
  <div class="submitted">
    <span property="dc:date dc:created" content="2019-06-12T10:40:34-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/howtopamm" class="username">howtopam</a> on 12 Jun 2019</span>    <a href="/comment/178126#comment-178126" class="permalink" rel="bookmark">Permalink</a>      </div>

  <div class="content">
    <span rel="sioc:reply_of" resource="/article/19/6/how-write-loop-bash" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>Great little tutorial. People enjoy small bits of valuable information. This "for loop" statement can be very helpful to increase productivity when used in correct coding scenarios. Thanks for the lesson Gonca Sousa.</p>
</div></div></div>      </div>

  <div class="comment__meta">
    <ul class="links inline"><li class="comment-reply first last"><a href="/comment/reply/54341/178126">reply</a></li>
</ul>    <div class="vud-widget vud-widget-upanddown" id="widget-comment-178126">
  <div class="up-score clear-block">
                    <div class="up-active" title="Vote up!"></div>
          <div class="element-invisible">Vote up!</div>
              <span class="up-current-score">0</span>
  </div>

  </div>
  </div>
</div>

<div class="indented"><a id="comment-178131"></a>
<div class="comment odd clearfix" about="/comment/178131#comment-178131" typeof="sioc:Post sioct:Comment">

  <div class="user-picture-badges">
    <img class="comment-avatar" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/comment_avatar/public/pictures/fav.png?itok=b7fDynSS" width="50" height="50" alt="howtopamm" title="howtopamm" />      </div>

  
  <div class="submitted">
    <span property="dc:date dc:created" content="2019-06-12T10:50:58-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/howtopamm" class="username">howtopam</a> on 12 Jun 2019</span>    <a href="/comment/178131#comment-178131" class="permalink" rel="bookmark">Permalink</a>      </div>

  <div class="content">
    <span rel="sioc:reply_of" resource="/article/19/6/how-write-loop-bash" class="rdf-meta element-hidden"></span><span rel="sioc:reply_of" resource="/comment/178126#comment-178126" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>My mistake and apology @Seth Kenlon. You are the author and I quoted Gonca Sousa in my thanks for the lesson statement in the above comment. Sorry Seth Kenlon and to Gonca Sousa as well for the incorrect credit. howtopam</p>
</div></div></div>      </div>

  <div class="comment__meta">
    <ul class="links inline"><li class="comment-reply first last"><a href="/comment/reply/54341/178131">reply</a></li>
</ul>    <div class="vud-widget vud-widget-upanddown" id="widget-comment-178131">
  <div class="up-score clear-block">
                    <div class="up-active" title="Vote up!"></div>
          <div class="element-invisible">Vote up!</div>
              <span class="up-current-score">0</span>
  </div>

  </div>
  </div>
</div>

<div class="indented"><a id="comment-178141"></a>
<div class="comment comment-by-node-author even clearfix" about="/comment/178141#comment-178141" typeof="sioc:Post sioct:Comment">

  <div class="user-picture-badges">
    <img class="comment-avatar" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/comment_avatar/public/penguinmedallion200x200.png?itok=g0KVUVcw" width="50" height="50" alt="sethkenlon" title="sethkenlon" />      </div>

  
  <div class="submitted">
    <span property="dc:date dc:created" content="2019-06-12T14:00:20-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/seth" class="username">Seth Kenlon</a> on 12 Jun 2019</span>    <a href="/comment/178141#comment-178141" class="permalink" rel="bookmark">Permalink</a>      </div>

  <div class="content">
    <span rel="sioc:reply_of" resource="/article/19/6/how-write-loop-bash" class="rdf-meta element-hidden"></span><span rel="sioc:reply_of" resource="/comment/178131#comment-178131" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>Thanks for reading my article and for the comment!</p>
</div></div></div>      </div>

  <div class="comment__meta">
    <ul class="links inline"><li class="comment-reply first last"><a href="/comment/reply/54341/178141">reply</a></li>
</ul>    <div class="vud-widget vud-widget-upanddown" id="widget-comment-178141">
  <div class="up-score clear-block">
                    <div class="up-active" title="Vote up!"></div>
          <div class="element-invisible">Vote up!</div>
              <span class="up-current-score">0</span>
  </div>

  </div>
  </div>
</div>
</div></div><a id="comment-178146"></a>
<div class="comment odd clearfix" about="/comment/178146#comment-178146" typeof="sioc:Post sioct:Comment">

  <div class="user-picture-badges">
    <img class="comment-avatar" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/comment_avatar/public/osdc_default_avatar.png?itok=pk-4pxZV" width="50" height="50" alt="wavesailor" title="wavesailor" />      </div>

  
  <div class="submitted">
    <span property="dc:date dc:created" content="2019-06-12T14:17:43-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/wavesailor" class="username">JJ</a> on 12 Jun 2019</span>    <a href="/comment/178146#comment-178146" class="permalink" rel="bookmark">Permalink</a>      </div>

  <div class="content">
    <span rel="sioc:reply_of" resource="/article/19/6/how-write-loop-bash" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>Great article - Nice to learn about the `file` command and the `covert` in addition to learning about looping. Thx</p>
</div></div></div>      </div>

  <div class="comment__meta">
    <ul class="links inline"><li class="comment-reply first last"><a href="/comment/reply/54341/178146">reply</a></li>
</ul>    <div class="vud-widget vud-widget-upanddown" id="widget-comment-178146">
  <div class="up-score clear-block">
                    <div class="up-active" title="Vote up!"></div>
          <div class="element-invisible">Vote up!</div>
              <span class="up-current-score">0</span>
  </div>

  </div>
  </div>
</div>

<div class="indented"><a id="comment-178151"></a>
<div class="comment comment-by-node-author last even clearfix" about="/comment/178151#comment-178151" typeof="sioc:Post sioct:Comment">

  <div class="user-picture-badges">
    <img class="comment-avatar" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/comment_avatar/public/penguinmedallion200x200.png?itok=g0KVUVcw" width="50" height="50" alt="sethkenlon" title="sethkenlon" />      </div>

  
  <div class="submitted">
    <span property="dc:date dc:created" content="2019-06-12T15:05:43-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/seth" class="username">Seth Kenlon</a> on 12 Jun 2019</span>    <a href="/comment/178151#comment-178151" class="permalink" rel="bookmark">Permalink</a>      </div>

  <div class="content">
    <span rel="sioc:reply_of" resource="/article/19/6/how-write-loop-bash" class="rdf-meta element-hidden"></span><span rel="sioc:reply_of" resource="/comment/178146#comment-178146" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>The ``convert`` command from ImageMagick is one of those things I use a heck of a lot more than I think I realise. I think I'd just give up on computers if I had to open every image I resize or convert from one format to another in a GUI, one at a time.</p>
<p>Thanks for reading, JJ, and thanks for the comment!</p>
</div></div></div>      </div>

  <div class="comment__meta">
    <ul class="links inline"><li class="comment-reply first last"><a href="/comment/reply/54341/178151">reply</a></li>
</ul>    <div class="vud-widget vud-widget-upanddown" id="widget-comment-178151">
  <div class="up-score clear-block">
                    <div class="up-active" title="Vote up!"></div>
          <div class="element-invisible">Vote up!</div>
              <span class="up-current-score">0</span>
  </div>

  </div>
  </div>
</div>
</div>
  
  </div>
<div class="panel-pane pane-node-comment-form"  >
  
        <h2 class="pane-title">
      Comment now    </h2>
    
  
  <form class="comment-form user-info-from-cookie" action="/article/19/6/how-write-loop-bash#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div id="edit-login-register" class="form-item form-type-item">
 <a href="/user/login?destination=node/54341">Login or Register</a> to earn points for your comments.
</div>
<div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<input type="hidden" name="form_build_id" value="form--VvRtwtLWnPLCQnIKGSNKmdo7gPAjvp_qX1fD9oyLFs" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="honeypot_time" value="1560401690|T5oMSVYMGqB4zRIIKvIsaT8IBGaKU-xAKb-pvKd_bHA" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/legal">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><fieldset class="captcha form-wrapper"><legend><span class="fieldset-legend">CAPTCHA</span></legend><div class="fieldset-wrapper"><div class="fieldset-description">This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.</div><input type="hidden" name="captcha_sid" value="192345976" />
<input type="hidden" name="captcha_token" value="1c518be9b51f4316c34b556429a2d55c" />
<input type="hidden" name="captcha_response" value="Google no captcha" />
<div class="g-recaptcha" data-sitekey="6LdyKzYUAAAAAIwIfHYM0eXeqI_HRmLhM-Msg6nM" data-theme="light" data-type="image"></div></div></fieldset>
<div class="website-url-textfield"><div class="form-item form-type-textfield form-item-website-url">
  <label for="edit-website-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-website-url" name="website-url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div></div></form>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-default-license"  >
  
      
  
  <div class="field field-name-field-default-license field-type-text field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:license"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" style="border-width:0" src="/sites/all/themes/opensource/images/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a></div></div></div>
  
  </div>
    </div>
  
</div>
                  </div>


        
        
      </div>

        <div class="region region-pre-footer">
    <div id="block-os-common-components-footer-call-to-action" class="block block-os-common-components first last odd">

      
  
<div class="fieldable-panels-pane cta cta--green-on-blue cta--no-link">

  <div class="cta__content cta__content--no-link">
            <h2 class="cta__title">Our best content, delivered to your inbox</h2>
<div class="field field-name-field-cta-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><iframe class="eloqua-embedded-bottom" frameborder="0" height="50" id="fkfkx" scrolling="no" src="/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></p>

<p>Sign up to receive our open source highlights email, giveaway alerts, and more.</p>
</div></div></div>  </div>

</div>


</div>
  </div>

        <div class="region region-footer-nav">
    <div id="block-bean-social-media" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/social-media" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><span>Find us:</span> 
</p>
<ul>
<li><a class="footer-twitter" href="https://twitter.com/OpenSourceWay" title="Twitter">Twitter</a></li>
<li><a class="footer-facebook" href="https://www.facebook.com/opensourceway" title="Facebook">Facebook</a></li>
<li><a class="footer-youtube" href="http://www.youtube.com/opensourceway" title="Youtube">Youtube</a></li>
<!--<li><a class="footer-mastadon" href="https://fosstodon.org/@osdc" title="">Mastadon</a></li> --><li><a class="footer-irc" href="/join-us-irc" title="IRC">IRC</a></li>
<li><a class="footer-feed" href="/feed" title="RSS">RSS</a></li>
</ul>
</div></div></div>  </div>
</div>

</div>
<div id="block-menu-menu-footer" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Footer</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/legal" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact" class="menu__link">Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="/opensourcecom-team" title="" class="menu__link">Meet the Team</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://opensource.org/" title="" class="menu__link">Visit opensource.org</a></li>
</ul>
</div>
  </div>

        <footer id="footer" class="region region-footer">
    <div id="block-bean-copyrigt-block" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/copyrigt-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>For more discussion on open source and the role of the CIO in the enterprise, join us at <a href="https://enterprisersproject.com">The EnterprisersProject.com</a>.</p>

<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>

<p>Opensource.com aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>

<p>Copyright ©2019 Red Hat, Inc.</p>
</div></div></div>  </div>
</div>

</div>
<div id="block-bean-footer-logo" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/footer-logo" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><img src="/sites/all/themes/opensource/images/footer_logo.svg" /></p>
</div></div></div>  </div>
</div>

</div>
  </footer>

    </div>

    
      <div class="region region-os-social">
    <div id="block-os-social-os-social-share" class="block block-os-social first last odd">

      
  <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://opensource.com/article/19/6/how-write-loop-bash">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div>
</div>
  </div>
    <div class="region region-page-bottom">
    <!-- begin Google Remarketing --><img height="1" width="1" style="border-style:none;display:block;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" onerror="this.src='/sites/all/themes/opensource/images/1x1.png';this.onerror=null" /><!-- end Google Remarketing -->  </div>
<script src="https://opensource.com/sites/default/files/js/js_29qYXJz8NLGg8Aomg-RZPjJcj9yEdEst1BMZ9gZbs-4.js"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script src="https://opensource.com/sites/default/files/js/js_skcw_uw28w93NamnwquPyMMZNIyaa2eQ6iAc5B_1jjA.js"></script>
<script>var a2a_config = a2a_config || {};
              a2a_config.callbacks = a2a_config.callbacks || [];
a2a_config.templates = {
    twitter: "How to write a loop in Bash https://red.ht/2Zefgwo via @opensourceway"
};</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"65779638","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkgHX1xuW1BXU1YEF2pWCVxcbkBYXEVuEQRSXQ==","queueTime":0,"applicationTime":383,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
