<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html class="no-js"  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema# schema: http://schema.org/"><!--<![endif]-->

<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
  <meta charset="utf-8" /><script type="text/javascript">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</script>
<link href="https://opensource.com/rss.xml" rel="alternate" type="application/rss+xml" title="Opensource.com RSS" />
<link rel="shortcut icon" href="https://opensource.com/sites/all/themes/opensource/favicon.ico" type="image/vnd.microsoft.icon" />
<script src="https://www.google.com/recaptcha/api.js?hl=en" async="async" defer="defer"></script>
<meta name="description" content="ZeroMQ makes for a fast and resilient messaging library to gather data and share between multiple languages." />
<meta name="rating" content="general" />
<meta name="referrer" content="no-referrer" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://opensource.com/article/20/3/zeromq-c-python" />
<link rel="shortlink" href="https://opensource.com/node/61401" />
<meta name="revisit-after" content="1 day" />
<meta property="og:site_name" content="Opensource.com" />
<meta property="og:url" content="https://opensource.com/article/20/3/zeromq-c-python" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Share data between C and Python with this messaging library" />
<meta property="og:description" content="I&#039;ve had moments as a software engineer when I&#039;m asked to do a task that sends shivers down my spine. One such moment was when I had to write an interface between some new hardware infrastructure that requires C and a cloud infrastructure, which is primarily Python." />
<meta property="og:image" content="https://opensource.com/sites/default/files/lead-images/email_chat_communication_message.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@opensourceway" />
<meta name="twitter:creator" content="@cl_fontana" />
<meta name="twitter:title" content="Share data between C and Python with this messaging library" />
<meta name="twitter:description" content="I&#039;ve had moments as a software engineer when I&#039;m asked to do a task that sends shivers down my spine. One such moment was when I had to write an interface between some new hardware infrastructure that requires C and a cloud infrastructure, which is primarily Python." />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/lead-images/email_chat_communication_message.png" />
  <title>Share data between C and Python with this messaging library | Opensource.com</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_rPk7Et6wjNyH7pw3qgw9a85Yiqd9m38Ov-4hY99oyhM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_qbWV8z-nAv7aqUsFySyOpWtipkPMMxfzR6T74v1M4_w.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_1Q9A4axkPRKF-HjzCsVwYOSCecYMhuSJ5GUQC0BjtTM.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_N1z17xGWvLWKP2odF5Li8hbDu6NOl0RA6dFcNmmYNj4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_PxsPpITToy8ZnO0bJDA1TEC6bbFpGTfSWr2ZP8LuFYo.css" media="all" />
  <script src="/sites/all/themes/opensource/js/use-typekit.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  <script src="https://opensource.com/sites/default/files/js/js_0RyHJ63yYLuaWsodCPCgSD8dcTIA0dqcDf8-7c2XdBw.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_R9xDkoIXbrDQhdBhQ3W4GF5TzHxKYFK0UB8wjqE0DbE.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_tBWHhFjU_NjWsmd07Hrx5ScmFu-4-PJD_GwzNMH3UwA.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_v2jwWn2vdJrAHHKMo-mOmfxmpVY6cfKDhZutjy4hfgQ.js"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-33294138-1", {"cookieDomain":".opensource.com"});ga("send", "pageview");</script>
<script src="https://opensource.com/sites/default/files/js/js_rVcPYhZ5_LfvT-dWbCnRngMcccEhwUaw2iNYx0yXj_Q.js"></script>
<script src="https://opensource.com/sites/default/files/js/js_KbByFnBctcQt9juhHXNabaQDr4mJAc1OExQYJ-HcyXk.js"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-61401 node-type-article region-content section-article page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<header class="header" id="header" role="banner">

    
    <div class="header-banner">
      <div class="header-banner__inner">
                  <div class="header__name-and-slogan" id="name-and-slogan">
                          <div class="header__site-name" id="site-name">
                <div class="header__anniversary-logo">
                  <a href="https://opensource.com/" title="Celebrating 10 years of Opensource.com" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/opensource-text.svg" onerror="this.src='/sites/all/themes/opensource/opensource-text.png';this.onerror=null;" class="header__anniversary-logo__text" /></a>
                  <a href="/article/20/1/10-year-anniversary" title="Celebrating 10 years of Opensource.com" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/opensource-banner.svg" onerror="this.src='/sites/all/themes/opensource/opensource-banner.png';this.onerror=null;" class="header__anniversary-logo__banner" /></a>
                </div>
                <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" title="Home" class="header__sponsor-link" rel="home"><img alt="RedHat" src="/sites/all/themes/opensource/images/redhat-logo.svg" onerror="this.src='/sites/all/themes/opensource/images/redhat-logo.png';this.onerror=null;"/></a>
              </div>
            
                      </div>
                <nav class="desktop-user-links">
            <div class="header__region region region-header">
    <div id="block-menu-block-1" class="block block-menu-block first last odd" role="navigation">

      
  <div class="menu-block-wrapper menu-block-1 menu-name-user-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-195"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1179"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul></div>

</div>
  </div>
        </nav>
      </div>
    </div>

    <div class="sf-nav">
      <div class="sf-nav__inner">
          <div class="js-mobile-header-buttons region region-navigation-top">
    <div id="block-os-solr-search-form" class="block block-os-solr-search first odd">

      
  <form action="/article/20/3/zeromq-c-python" method="post" id="os-search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search">
  <label class="element-invisible" for="edit-search">Search </label>
 <input title="Enter the terms you wish to search for." placeholder="Search opensource.com" type="text" id="edit-search" name="search" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="GO" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-fKIbF9MGHb3VM-oxq8dfkG66HXXnQBMwczPiFHHuw0A" />
<input type="hidden" name="form_id" value="os_search_block_form" />
</div>
</div></form>
</div>
<div id="block-superfish-1" class="block block-superfish even">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-default sf-total-items-5 sf-parent-items-5 sf-single-items-0"><li id="menu-1906-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-11 sf-parent-children-4 sf-single-children-7 menuparent"><a href="/" title="" class="sf-depth-1 menuparent">Articles</a><ul><li id="menu-12341-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/containers" title="" class="sf-depth-2">Containers</a></li><li id="menu-12416-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/devops" title="" class="sf-depth-2">DevOps</a></li><li id="menu-12346-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/tags/gaming" title="" class="sf-depth-2">Gaming</a></li><li id="menu-17776-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/tags/government" title="" class="sf-depth-2">Government</a></li><li id="menu-12351-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/hardware" title="" class="sf-depth-2 menuparent">Hardware</a><ul><li id="menu-12376-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/3d-printing" title="" class="sf-depth-3">3D printing</a></li><li id="menu-12386-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/arduino" title="" class="sf-depth-3">Arduino</a></li><li id="menu-12381-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/raspberry-pi" title="" class="sf-depth-3">Raspberry Pi</a></li></ul></li><li id="menu-27341-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="https://opensource.com/tags/kubernetes" title="" class="sf-depth-2">Kubernetes</a></li><li id="menu-1946-1" class="middle odd sf-item-7 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/tags/law" title="" class="sf-depth-2 menuparent">Law</a><ul><li id="menu-12391-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/licensing" title="" class="sf-depth-3">Licensing</a></li><li id="menu-12396-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/patents" title="" class="sf-depth-3">Patents</a></li></ul></li><li id="menu-12356-1" class="middle even sf-item-8 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/tags/linux" title="" class="sf-depth-2 menuparent">Linux</a><ul><li id="menu-19831-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/command-line" title="" class="sf-depth-3">Command line</a></li></ul></li><li id="menu-12361-1" class="middle odd sf-item-9 sf-depth-2 sf-no-children"><a href="/tags/openstack" title="" class="sf-depth-2">OpenStack</a></li><li id="menu-12366-1" class="middle even sf-item-10 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/programming" title="" class="sf-depth-2 menuparent">Programming</a><ul><li id="menu-17771-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/go" title="" class="sf-depth-3">Go</a></li><li id="menu-12411-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/javascript" title="" class="sf-depth-3">JavaScript</a></li><li id="menu-12406-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/python" title="" class="sf-depth-3">Python</a></li></ul></li><li id="menu-12371-1" class="last odd sf-item-11 sf-depth-2 sf-no-children"><a href="/tags/sysadmin" title="" class="sf-depth-2">SysAdmin</a></li></ul></li><li id="menu-1921-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-6 sf-parent-children-3 sf-single-children-3 menuparent"><a href="/resources" title="" class="sf-depth-1 menuparent">Resources</a><ul><li id="menu-19841-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/resources/what-open-source" title="" class="sf-depth-2 menuparent">What is open source?</a><ul><li id="menu-1991-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-source-way" class="sf-depth-3">The open source way</a></li></ul></li><li id="menu-2016-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/projects-and-applications" title="" class="sf-depth-2">Projects and applications</a></li><li id="menu-2021-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/resources/organizations" title="" class="sf-depth-2">Organizations</a></li><li id="menu-5556-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-14 sf-parent-children-1 sf-single-children-13 menuparent"><a href="/resources/cloud" title="" class="sf-depth-2 menuparent">Cloud technology</a><ul><li id="menu-27201-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/resources/what-ansible" title="" class="sf-depth-3">Ansible</a></li><li id="menu-5576-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/big-data" title="" class="sf-depth-3">Big data</a></li><li id="menu-19861-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/resources/data-science" title="" class="sf-depth-3">Data science</a></li><li id="menu-5566-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/resources/what-docker" title="" class="sf-depth-3">Docker</a></li><li id="menu-19926-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/what-is-git" class="sf-depth-3">Git</a></li><li id="menu-5591-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/resources/internet-of-things" title="" class="sf-depth-3">Internet of things</a></li><li id="menu-19921-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/resources/java" title="" class="sf-depth-3">Java</a></li><li id="menu-5596-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/resources/what-is-kubernetes" title="" class="sf-depth-3">Kubernetes</a></li><li id="menu-5571-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/resources/what-are-linux-containers" title="" class="sf-depth-3">Linux containers</a></li><li id="menu-5586-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/resources/what-are-microservices" title="" class="sf-depth-3">Microservices</a></li><li id="menu-5561-1" class="middle odd sf-item-11 sf-depth-3 sf-no-children"><a href="/resources/what-is-openstack" title="" class="sf-depth-3">OpenStack</a></li><li id="menu-19836-1" class="middle even sf-item-12 sf-depth-3 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/resources/python" title="" class="sf-depth-3 menuparent">Python</a><ul><li id="menu-19866-1" class="first odd sf-item-1 sf-depth-4 sf-no-children"><a href="/resources/python/gui-frameworks" class="sf-depth-4">Python GUI frameworks</a></li><li id="menu-19871-1" class="middle even sf-item-2 sf-depth-4 sf-no-children"><a href="/resources/python/ides" class="sf-depth-4">Python IDEs</a></li><li id="menu-19881-1" class="middle odd sf-item-3 sf-depth-4 sf-no-children"><a href="/resources/python/template-libraries" title="" class="sf-depth-4">Python template libraries</a></li><li id="menu-19876-1" class="last even sf-item-4 sf-depth-4 sf-no-children"><a href="/resources/python/web-scraper-crawler" title="" class="sf-depth-4">Python web scrapers</a></li></ul></li><li id="menu-5581-1" class="middle odd sf-item-13 sf-depth-3 sf-no-children"><a href="/resources/what-is-software-defined-networking" title="" class="sf-depth-3">Software defined networking</a></li><li id="menu-12601-1" class="last even sf-item-14 sf-depth-3 sf-no-children"><a href="/resources/virtualization" title="" class="sf-depth-3">Virtualization</a></li></ul></li><li id="menu-2036-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-13 sf-parent-children-0 sf-single-children-13 menuparent"><a href="/alternatives" title="" class="sf-depth-2 menuparent">Open source alternatives</a><ul><li id="menu-4646-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/alternatives/adobe-acrobat" class="sf-depth-3">Alternatives to Acrobat</a></li><li id="menu-4656-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/alternatives/autocad" class="sf-depth-3">Alternatives to AutoCAD</a></li><li id="menu-4636-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/alternatives/dreamweaver" class="sf-depth-3">Alternatives to Dreamweaver</a></li><li id="menu-5506-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/alternatives/gmail" class="sf-depth-3">Alternatives to Gmail</a></li><li id="menu-5551-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/alternatives/matlab" class="sf-depth-3">Alternatives to MATLAB</a></li><li id="menu-5501-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/alternatives/minecraft" class="sf-depth-3">Alternatives to Minecraft</a></li><li id="menu-4651-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/alternatives/google-photos" class="sf-depth-3">Alternatives to Google Photos</a></li><li id="menu-27351-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/life/12/6/design-without-debt-five-tools-for-designers" title="" class="sf-depth-3">Alternatives to Photoshop</a></li><li id="menu-4661-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/alternatives/microsoft-publisher" class="sf-depth-3">Alternatives to Publisher</a></li><li id="menu-27371-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/alternatives/skype" title="" class="sf-depth-3">Alternatives to Skype</a></li><li id="menu-5511-1" class="middle odd sf-item-11 sf-depth-3 sf-no-children"><a href="/alternatives/slack" class="sf-depth-3">Alternatives to Slack</a></li><li id="menu-4641-1" class="middle even sf-item-12 sf-depth-3 sf-no-children"><a href="/alternatives/trello" class="sf-depth-3">Alternatives to Trello</a></li><li id="menu-5546-1" class="last odd sf-item-13 sf-depth-3 sf-no-children"><a href="/alternatives" title="" class="sf-depth-3">More...</a></li></ul></li><li id="menu-19886-1" class="last even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/linux" title="" class="sf-depth-2">Linux</a></li></ul></li><li id="menu-19666-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-6 sf-parent-children-6 sf-single-children-0 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-1 menuparent">Downloads</a><ul><li id="menu-19406-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-24 sf-parent-children-0 sf-single-children-24 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Cheat sheets</a><ul><li id="menu-19651-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-awk-features" class="sf-depth-3">AWK cheat sheet</a></li><li id="menu-27241-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/bash-cheat-sheet" class="sf-depth-3">Bash cheat sheet</a></li><li id="menu-18641-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/downloads/blender-hotkey-cheat-sheet" class="sf-depth-3">Blender cheat sheet</a></li><li id="menu-27336-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/downloads/emacs-cheat-sheet" class="sf-depth-3">Emacs cheat sheet</a></li><li id="menu-27356-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/firewall-cheat-sheet" class="sf-depth-3">Firewall Cheat Sheet</a></li><li id="menu-18856-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/downloads/freedos-commands-cheat-sheet" class="sf-depth-3">FreeDOS cheat sheet</a></li><li id="menu-19721-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/content/cheat-sheet-gimp" class="sf-depth-3">GIMP cheat sheet</a></li><li id="menu-19696-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-gnome-3" class="sf-depth-3">GNOME cheat sheet</a></li><li id="menu-18661-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/downloads/groff-macros-cheat-sheet" class="sf-depth-3">Groff macros cheat sheet</a></li><li id="menu-19731-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/downloads/go-cheat-sheet" class="sf-depth-3">Go cheat sheet</a></li><li id="menu-19716-1" class="middle odd sf-item-11 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-i3-window-manager-keybinding" class="sf-depth-3">i3 window manager cheat sheet</a></li><li id="menu-19781-1" class="middle even sf-item-12 sf-depth-3 sf-no-children"><a href="/downloads/inkscape-cheat-sheet" class="sf-depth-3">Inkscape Cheat Sheet</a></li><li id="menu-16886-1" class="middle odd sf-item-13 sf-depth-3 sf-no-children"><a href="/irc-cheat-sheet" class="sf-depth-3">IRC cheat sheet</a></li><li id="menu-27271-1" class="middle even sf-item-14 sf-depth-3 sf-no-children"><a href="/downloads/java-cheat-sheet" class="sf-depth-3">Java cheat sheet</a></li><li id="menu-27246-1" class="middle odd sf-item-15 sf-depth-3 sf-no-children"><a href="/downloads/linux-common-commands-cheat-sheet" class="sf-depth-3">Linux common commands cheat sheet</a></li><li id="menu-27216-1" class="middle even sf-item-16 sf-depth-3 sf-no-children"><a href="/downloads/linux-permissions-cheat-sheet" class="sf-depth-3">Linux user permissions cheat sheet</a></li><li id="menu-27256-1" class="middle odd sf-item-17 sf-depth-3 sf-no-children"><a href="/downloads/microservices-cheat-sheet" class="sf-depth-3">Microservices cheat sheet</a></li><li id="menu-19301-1" class="middle even sf-item-18 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-networking" class="sf-depth-3">Networking cheat sheet</a></li><li id="menu-18636-1" class="middle odd sf-item-19 sf-depth-3 sf-no-children"><a href="/downloads/pandoc-cheat-sheet" class="sf-depth-3">Pandoc cheat sheet</a></li><li id="menu-27261-1" class="middle even sf-item-20 sf-depth-3 sf-no-children"><a href="/downloads/pip-cheat-sheet" class="sf-depth-3">pip cheat sheet</a></li><li id="menu-19711-1" class="middle odd sf-item-21 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-python-37-beginners" class="sf-depth-3">Python 3.7 cheat sheet</a></li><li id="menu-19726-1" class="middle even sf-item-22 sf-depth-3 sf-no-children"><a href="/downloads/getting-started-raspberry-pi-cheat-sheet" class="sf-depth-3">Raspberry Pi cheat sheet</a></li><li id="menu-19691-1" class="middle odd sf-item-23 sf-depth-3 sf-no-children"><a href="/downloads/cheat-sheet-selinux" class="sf-depth-3">SELinux cheat sheet</a></li><li id="menu-18591-1" class="last even sf-item-24 sf-depth-3 sf-no-children"><a href="/downloads/advanced-ssh-cheat-sheet" class="sf-depth-3">SSH cheat sheet</a></li></ul></li><li id="menu-12466-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/yearbook/2017" title="" class="sf-depth-2 menuparent">Open Source Yearbook</a><ul><li id="menu-19681-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/yearbook/2015" title="" class="sf-depth-3">2015</a></li><li id="menu-19676-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/yearbook/2016" title="" class="sf-depth-3">2016</a></li><li id="menu-19671-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/yearbook/2017" title="" class="sf-depth-3">2017</a></li><li id="menu-19786-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/yearbook/2018" title="" class="sf-depth-3">2018</a></li><li id="menu-27346-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/2019-yearbook-special-edition" title="" class="sf-depth-3">2019 Special Edition</a></li></ul></li><li id="menu-19906-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Programming guides</a><ul><li id="menu-19891-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/7-essential-pypi-libraries" title="" class="sf-depth-3">7 essential PyPI libraries</a></li></ul></li><li id="menu-19911-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">DevOps guides</a><ul><li id="menu-19806-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/devops-transformation" class="sf-depth-3">Starting a DevOps transformation</a></li><li id="menu-19776-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/small-scale-scrum" class="sf-depth-3">Introduction to Small Scale Scrum</a></li><li id="menu-19771-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/downloads/devsecops" class="sf-depth-3">Getting started with DevSecOps</a></li><li id="menu-19701-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/downloads/devops-monitoring-guide" class="sf-depth-3">DevOps monitoring tools guide</a></li><li id="menu-19686-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/devops-hiring-guide" class="sf-depth-3">DevOps hiring guide</a></li></ul></li><li id="menu-19916-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">Sysadmin guides</a><ul><li id="menu-19801-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="https://opensource.com/downloads/ansible-quickstart" title="" class="sf-depth-3">Ansible Automation for Sysadmins</a></li><li id="menu-19706-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/containers-primer" class="sf-depth-3">Containers primer</a></li></ul></li><li id="menu-19901-1" class="last even sf-item-6 sf-depth-2 sf-total-children-6 sf-parent-children-0 sf-single-children-6 menuparent"><a href="/downloads/cheat-sheets" title="" class="sf-depth-2 menuparent">eBooks</a><ul><li id="menu-19896-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/downloads/getting-started-kubernetes-ebook" class="sf-depth-3">Getting started with Kubernetes</a></li><li id="menu-27276-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/downloads/guide-inter-process-communication-linux" class="sf-depth-3">Inter-process communication in Linux</a></li><li id="menu-27321-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/downloads/collaboration-tools-ebook" class="sf-depth-3">5 open source collaboration tools</a></li><li id="menu-27311-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/downloads/organization-tools" class="sf-depth-3">6 open source tools for staying organized</a></li><li id="menu-27316-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/downloads/desktop-tools" class="sf-depth-3">7 open source desktop tools</a></li><li id="menu-27366-1" class="last even sf-item-6 sf-depth-3 sf-no-children"><a href="/downloads/raspberry-pi-guide" class="sf-depth-3">Raspberry Pi: How to get started</a></li></ul></li></ul></li><li id="menu-4691-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-5 sf-parent-children-2 sf-single-children-3 menuparent"><a href="/about" class="sf-depth-1 menuparent">About</a><ul><li id="menu-12516-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-7 sf-parent-children-0 sf-single-children-7 menuparent"><a href="/participate" class="sf-depth-2 menuparent">Join us</a><ul><li id="menu-12521-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/user/register" title="" class="sf-depth-3">Register</a></li><li id="menu-12526-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/rules-comments-and-discussions" class="sf-depth-3">Rules for comments and discussions</a></li><li id="menu-17781-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/devops-team" class="sf-depth-3">Contribute to DevOps resources</a></li><li id="menu-12531-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/correspondent-program" class="sf-depth-3">Correspondent Program</a></li><li id="menu-12581-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/contributor-club" title="" class="sf-depth-3">Contributor Club</a></li><li id="menu-12541-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/points-and-badges" class="sf-depth-3">Points and badges</a></li><li id="menu-17766-1" class="last odd sf-item-7 sf-depth-3 sf-no-children"><a href="/delete-account" title="" class="sf-depth-3">Delete your account</a></li></ul></li><li id="menu-1966-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-6 sf-parent-children-0 sf-single-children-6 menuparent"><a href="/writers" title="" class="sf-depth-2 menuparent">For writers</a><ul><li id="menu-17761-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/how-submit-article" class="sf-depth-3">Write for us</a></li><li id="menu-12546-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/editorial-calendar" title="" class="sf-depth-3">Editorial calendar</a></li><li id="menu-12586-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/article/20/1/write-for-us" title="" class="sf-depth-3">Writing topics</a></li><li id="menu-2041-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/submission-style-guide" class="sf-depth-3">Article submission and style guide</a></li><li id="menu-4616-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/promoting-articles" class="sf-depth-3">Tips for promoting your Opensource.com article</a></li><li id="menu-12556-1" class="last even sf-item-6 sf-depth-3 sf-no-children"><a href="/writer-testimonials" class="sf-depth-3">Writer testimonials</a></li></ul></li><li id="menu-1971-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/opensourcecom-team" class="sf-depth-2">Meet the team</a></li><li id="menu-2006-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/press-kit" class="sf-depth-2">Press kit</a></li><li id="menu-2001-1" class="last odd sf-item-5 sf-depth-2 sf-no-children"><a href="/contact" title="" class="sf-depth-2">Contact</a></li></ul></li><li id="menu-2136-1" class="last odd sf-item-5 sf-depth-1 sf-total-children-4 sf-parent-children-3 sf-single-children-1 menuparent"><a href="/open-organization" title="" class="sf-depth-1 menuparent">Open Organization</a><ul><li id="menu-27251-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="https://opensource.com/open-organization/start" title="" class="sf-depth-2">Get started</a></li><li id="menu-15051-1" class="middle even sf-item-2 sf-depth-2 sf-total-children-6 sf-parent-children-0 sf-single-children-6 menuparent"><a href="/open-organization/resources/book-series" title="" class="sf-depth-2 menuparent">Book series</a><ul><li id="menu-16906-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/field-guide" title="" class="sf-depth-3">Field Guide</a></li><li id="menu-16891-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/leaders-manual" class="sf-depth-3">Leaders Manual</a></li><li id="menu-16896-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/culture-change" title="" class="sf-depth-3">Guide to IT Culture Change</a></li><li id="menu-19856-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/educators-guide" class="sf-depth-3">Guide for Educators</a></li><li id="menu-17796-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/workbook" title="" class="sf-depth-3">Workbook</a></li><li id="menu-18656-1" class="last even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/organize-innovation" title="" class="sf-depth-3">Organize for Innovation</a></li></ul></li><li id="menu-2146-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/open-organization/resources" title="" class="sf-depth-2 menuparent">Resources</a><ul><li id="menu-12471-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="sf-depth-3">What is an open organization?</a></li><li id="menu-15056-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-org-maturity-model" title="" class="sf-depth-3">How open is your organization?</a></li><li id="menu-12421-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-decision-framework" title="" class="sf-depth-3">What is an open decision?</a></li><li id="menu-2151-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/guides" title="" class="sf-depth-3">Discussion Guides</a></li><li id="menu-17821-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/newsletter" title="" class="sf-depth-3">Newsletter</a></li></ul></li><li id="menu-3166-1" class="last even sf-item-4 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/open-organization/resources/ambassadors-program" title="" class="sf-depth-2 menuparent">Ambassadors community</a><ul><li id="menu-2691-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/meet-ambassadors" title="" class="sf-depth-3">Meet the ambassadors</a></li></ul></li></ul></li></ul>
</div>
<div id="block-system-user-menu" class="block block-system block-menu odd" role="navigation">

      
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul>
</div>
<div id="block-menu-block-2" class="block block-menu-block last even" role="navigation">

      
  <div class="menu-block-wrapper menu-block-2 menu-name-menu-social-links parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-13171"><a href="http://twitter.com/opensourceway" title="twitter" class="menu__link">Twitter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-13176"><a href="https://www.facebook.com/opensourceway" title="facebook" class="menu__link">Facebook</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-13166"><a href="/feed" title="feed" class="menu__link">Feed</a></li>
</ul></div>

</div>
  </div>

        <div class="mobile--menu-region">
            <div class="region region-navigation">
    <div id="block-system-main-menu" class="block block-system block-menu first last odd" role="navigation">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/" title="" class="menu__link">Articles</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/containers" title="" class="menu__link">Containers</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/devops" title="" class="menu__link">DevOps</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/gaming" title="" class="menu__link">Gaming</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/government" title="" class="menu__link">Government</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/hardware" title="" class="menu__link">Hardware</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/3d-printing" title="" class="menu__link">3D printing</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/arduino" title="" class="menu__link">Arduino</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/raspberry-pi" title="" class="menu__link">Raspberry Pi</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="https://opensource.com/tags/kubernetes" title="" class="menu__link">Kubernetes</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/law" title="" class="menu__link">Law</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/linux" title="" class="menu__link">Linux</a><ul class="menu"><li class="menu__item is-leaf first last leaf"><a href="/tags/command-line" title="" class="menu__link">Command line</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/tags/openstack" title="" class="menu__link">OpenStack</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/programming" title="" class="menu__link">Programming</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/go" title="" class="menu__link">Go</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/javascript" title="" class="menu__link">JavaScript</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/python" title="" class="menu__link">Python</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/tags/sysadmin" title="" class="menu__link">SysAdmin</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-collapsed first collapsed"><a href="/resources/what-open-source" title="" class="menu__link">What is open source?</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/projects-and-applications" title="" class="menu__link">Projects and applications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/organizations" title="" class="menu__link">Organizations</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/resources/cloud" title="" class="menu__link">Cloud technology</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/alternatives" title="" class="menu__link">Open source alternatives</a></li>
<li class="menu__item is-leaf last leaf"><a href="/resources/linux" title="" class="menu__link">Linux</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/downloads/cheat-sheets" title="" class="menu__link">Downloads</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/about" class="menu__link">About</a></li>
<li class="menu__item is-expanded last expanded"><a href="/open-organization" title="" class="menu__link">Open Organization</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="https://opensource.com/open-organization/start" title="" class="menu__link">Get started</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/open-organization/resources/book-series" title="" class="menu__link">Book series</a></li>
<li class="menu__item is-expanded expanded"><a href="/open-organization/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="menu__link">What is an open organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-org-maturity-model" title="" class="menu__link">How open is your organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-decision-framework" title="" class="menu__link">What is an open decision?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/guides" title="" class="menu__link">Discussion Guides</a></li>
<li class="menu__item is-leaf last leaf"><a href="/open-organization/resources/newsletter" title="" class="menu__link">Newsletter</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/open-organization/resources/ambassadors-program" title="" class="menu__link">Ambassadors community</a></li>
</ul></li>
</ul>
</div>
  </div>
        </div>
      </div>
    </div>

</header>

<div id="page">

      <div id="main">
        <div class="pre-content">
                                                </div>
        <div id="content" class="column" role="main">
                              <a id="main-content"></a>
                                <h1 class="page__title title" id="page-title">Share data between C and Python with this messaging library | Opensource.com</h1>
                              



<div class="panel-display os-article clearfix os-article--with-image " id="article-template">

      <div class="os-article__top">
      <div class="os-article__top-inner">
        <div class="panel-pane pane-node-title"  >
  
      
  
  <h1>Share data between C and Python with this messaging library</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-article-subhead"  >
  
      
  
  <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden">
    <div class="field-items">
          <h2>ZeroMQ makes for a fast and resilient messaging library to gather data and share between multiple languages.</h2>
      </div>
</div>

  
  </div>
<div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__date">18 Mar 2020</span>
<span class="byline__author-name"><a href="/users/cristianofontana" title="View user profile." class="username" xml:lang="" about="/users/cristianofontana" typeof="sioc:UserAccount" property="foaf:name" datatype="">Cristiano L. Fontana</a>&nbsp;<span class="byline__feed"><a href="/user/348736/feed">Feed</a></span>
</span>
<span class="byline__social"><span class="byline__voting-widget"><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-0818b0e8e587f9fc155f15644d31e8da rate-node-61401-1-1" id="rate-node-61401-1-1"><div class="rate-info">14</div><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/20/3/zeromq-c-python?rate=zeIzr7QpV-FFCUvuFwFKUOlor7JdoMlXrBkjhcPtopg" title="up">up</a></div></span>
</span>
<span class="byline__comment-count"><a href="#comments">3 comments</a></span>
</div>
  
  </div>
      </div>
    </div>
  
      <div class="os-article__image">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/email_chat_communication_message.png?itok=LKjiLnQu"><img class="image-full-size" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/email_chat_communication_message.png?itok=LKjiLnQu" width="520" height="292" alt="Chat via email" title="Chat via email" /></div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__left">
      <div class="panel-pane pane-block pane-bean-email-capture widget-block widget-block__left"  >
      <div class="target-band-never-show-button">x</div>
        <h2 class="pane-title">
      Subscribe now    </h2>
    
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/email-capture" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p class="eloqua-email-capture-text">Get the highlights in your inbox every week.</p>

<p><iframe frameborder="0" height="100" id="fkfkx" scrolling="no" src="/eloqua-embedded-email-capture-block.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="250"></iframe></p>
</div></div></div>  </div>
</div>

  
  </div>
    </div>
  
  
      <div class="os-article__middle">
      <div class="panel-pane pane-entity-field pane-node-body"  >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:articleBody content:encoded"><p>I've had moments as a software engineer when I'm asked to do a task that sends shivers down my spine. One such moment was when I had to write an interface between some new hardware infrastructure that requires C and a cloud infrastructure, which is primarily Python.</p>

<p>One strategy could be to <a href="https://docs.python.org/3/extending/extending.html" target="_blank">write an extension in C</a>, which Python supports by design. A quick glance at the documentation shows this would mean writing a good amount of C. That can be good in some cases, but it's not what I prefer to do. Another strategy is to put the two tasks in separate processes and exchange messages between the two with the <a href="https://zeromq.org/" target="_blank">ZeroMQ messaging library</a>.</p>

<p>When I experienced this type of scenario before discovering ZeroMQ, I went through the extension-writing path. It was not that bad, but it is very time-consuming and convoluted. Nowadays, to avoid that, I subdivide a system into independent processes that exchange information through messages sent over <a href="https://en.wikipedia.org/wiki/Network_socket" target="_blank">communication sockets</a>. With this approach, several programming languages can coexist, and each process is simpler and thus easier to debug.</p>

<p>ZeroMQ provides an even easier process:</p>

<ol><li>Write a small shim in C that reads data from the hardware and sends whatever it finds as a message.</li>
	<li>Write a Python interface between the new and existing infrastructure.</li>
</ol><p>One of ZeroMQ's project's founders is <a href="https://en.wikipedia.org/wiki/Pieter_Hintjens" target="_blank">Pieter Hintjens</a>, a remarkable person with <a href="http://hintjens.com/" target="_blank">interesting views and writings</a>.</p>

<h2 id="prerequisites">Prerequisites</h2>

<p>For this tutorial, you will need:</p>

<ul><li>A C compiler (e.g., <a href="https://gcc.gnu.org/" target="_blank">GCC</a> or <a href="https://clang.llvm.org/" target="_blank">Clang</a>)</li>
	<li>The <a href="https://github.com/zeromq/libzmq#installation-of-binary-packages-" target="_blank"><strong>libzmq</strong> library</a></li>
	<li><a href="https://www.python.org/downloads/" target="_blank">Python 3</a></li>
	<li><a href="https://zeromq.org/languages/python/" target="_blank">ZeroMQ bindings</a> for python</li>
</ul><p>Install them on Fedora with:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span>dnf <span class="kw2">install</span> clang zeromq zeromq-devel python3 python3-zmq</code></span></pre>

<p>For Debian or Ubuntu:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw2">apt-get install</span> clang libzmq5 libzmq3-dev python3 python3-zmq</code></span></pre>

<p>If you run into any issues, refer to each project's installation instructions (which are linked above).</p>

<h2 id="writing-the-hardware-interfacing-library">Writing the hardware-interfacing library</h2>

<p>Since this is a hypothetical scenario, this tutorial will write a fictitious library with two functions:</p>

<ul><li><strong>fancyhw_init()</strong> to initiate the (hypothetical) hardware</li>
	<li><strong>fancyhw_read_val()</strong> to return a value read from the hardware</li>
</ul><p>Save the library's full source code to a file named <strong>libfancyhw.h</strong>:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="co2">#ifndef LIBFANCYHW_H</span><br />
<span class="co2">#define LIBFANCYHW_H</span><br />
<br />
<span class="co2">#include &lt;stdlib.h&gt;</span><br />
<span class="co2">#include &lt;stdint.h&gt;</span><br />
<br />
<span class="co1">// This is the fictitious hardware interfacing library</span><br />
<br />
<span class="kw4">void</span> fancyhw_init<span class="br0">&#40;</span><span class="kw4">unsigned</span> <span class="kw4">int</span> init_param<span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/srand.html"><span class="kw3">srand</span></a><span class="br0">&#40;</span>init_param<span class="br0">&#41;</span><span class="sy0">;</span><br />
<span class="br0">&#125;</span><br />
<br />
<span class="kw4">int16_t</span> fancyhw_read_val<span class="br0">&#40;</span><span class="kw4">void</span><span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; <span class="kw1">return</span> <span class="br0">&#40;</span><span class="kw4">int16_t</span><span class="br0">&#41;</span><a href="http://www.opengroup.org/onlinepubs/009695399/functions/rand.html"><span class="kw3">rand</span></a><span class="br0">&#40;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<span class="br0">&#125;</span><br />
<br />
<span class="co2">#endif</span></div></div></pre>

<p>This library can simulate the data you want to pass between languages, thanks to the random number generator.</p>

<h2 id="designing-a-c-interface">Designing a C interface</h2>

<p>The following will go step-by-step through writing the C interface—from including the libraries to managing the data transfer.</p>

<h3 id="libraries">Libraries</h3>

<p>Begin by loading the necessary libraries (the purpose of each library is in a comment in the code):</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="co1">// For printf()</span><br />
<span class="co2">#include &lt;stdio.h&gt;</span><br />
<span class="co1">// For EXIT_*</span><br />
<span class="co2">#include &lt;stdlib.h&gt;</span><br />
<span class="co1">// For memcpy()</span><br />
<span class="co2">#include &lt;string.h&gt;</span><br />
<span class="co1">// For sleep()</span><br />
<span class="co2">#include &lt;unistd.h&gt;</span><br />
<br />
<span class="co2">#include &lt;zmq.h&gt;</span><br />
<br />
<span class="co2">#include &quot;libfancyhw.h&quot;</span></div></div></pre>

<h3 id="significant-parameters">Significant parameters</h3>

<p>Define the <strong>main</strong> function and the significant parameters needed for the rest of the program:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="kw4">int</span> main<span class="br0">&#40;</span><span class="kw4">void</span><span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">unsigned</span> <span class="kw4">int</span> INIT_PARAM <span class="sy0">=</span> <span class="nu0">12345</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">unsigned</span> <span class="kw4">int</span> REPETITIONS <span class="sy0">=</span> <span class="nu0">10</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">unsigned</span> <span class="kw4">int</span> PACKET_SIZE <span class="sy0">=</span> <span class="nu0">16</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">char</span> <span class="sy0">*</span>TOPIC <span class="sy0">=</span> <span class="st0">&quot;fancyhw_data&quot;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; ...</div></div></pre>

<h3 id="initialization">Initialization</h3>

<p>Both libraries need some initialization. The fictitious one needs just one parameter:</p>

<pre><span class="geshifilter"><code class="c geshifilter-c">fancyhw_init<span class="br0">&#40;</span>INIT_PARAM<span class="br0">&#41;</span><span class="sy0">;</span></code></span></pre>

<p>The ZeroMQ library needs some real initialization. First, define a <strong>context</strong>—an object that manages all the sockets:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="kw4">void</span> <span class="sy0">*</span>context <span class="sy0">=</span> zmq_ctx_new<span class="br0">&#40;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
<span class="kw1">if</span> <span class="br0">&#40;</span><span class="sy0">!</span>context<span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;ERROR: ZeroMQ error occurred during zmq_ctx_new(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">return</span> EXIT_FAILURE<span class="sy0">;</span><br />
<span class="br0">&#125;</span></div></div></pre>

<p>Then define the socket used to deliver data. ZeroMQ supports several types of sockets, each with its application. Use a <strong>publish</strong> socket (also known as <strong>PUB</strong> socket), which can deliver copies of a message to multiple receivers. This approach enables you to attach several receivers that will all get the same messages. If there are no receivers, the messages will be discarded (i.e., they will not be queued). Do this with:</p>

<pre><span class="geshifilter"><code class="c geshifilter-c"><span class="kw4">void</span> <span class="sy0">*</span>data_socket <span class="sy0">=</span> zmq_socket<span class="br0">&#40;</span>context<span class="sy0">,</span> ZMQ_PUB<span class="br0">&#41;</span><span class="sy0">;</span></code></span></pre>

<p>The socket must be bound to an address so that the clients know where to connect. In this case, use the <a href="https://en.wikipedia.org/wiki/Transmission_Control_Protocol" target="_blank">TCP transport layer</a> (there are <a href="http://zguide.zeromq.org/page:all#Plugging-Sockets-into-the-Topology" target="_blank">other options</a>, but TCP is a good default choice):</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="kw4">const</span> <span class="kw4">int</span> rb <span class="sy0">=</span> zmq_bind<span class="br0">&#40;</span>data_socket<span class="sy0">,</span> <span class="st0">&quot;tcp://*:5555&quot;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
<span class="kw1">if</span> <span class="br0">&#40;</span>rb <span class="sy0">!=</span> <span class="nu0">0</span><span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;ERROR: ZeroMQ error occurred during zmq_ctx_new(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">return</span> EXIT_FAILURE<span class="sy0">;</span><br />
<span class="br0">&#125;</span></div></div></pre>

<p>Next, calculate some useful values that you will need later. Note <strong>TOPIC</strong> in the code below; <strong>PUB</strong> sockets need a topic to be associated with the messages they send. Topics can be used by the receivers to filter messages:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="kw4">const</span> <span class="kw4">size_t</span> topic_size <span class="sy0">=</span> <a href="http://www.opengroup.org/onlinepubs/009695399/functions/strlen.html"><span class="kw3">strlen</span></a><span class="br0">&#40;</span>TOPIC<span class="br0">&#41;</span><span class="sy0">;</span><br />
<span class="kw4">const</span> <span class="kw4">size_t</span> envelope_size <span class="sy0">=</span> topic_size <span class="sy0">+</span> <span class="nu0">1</span> <span class="sy0">+</span> PACKET_SIZE <span class="sy0">*</span> <span class="kw4">sizeof</span><span class="br0">&#40;</span><span class="kw4">int16_t</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
<a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;Topic: %s; topic size: %zu; Envelope size: %zu<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> TOPIC<span class="sy0">,</span> topic_size<span class="sy0">,</span> envelope_size<span class="br0">&#41;</span><span class="sy0">;</span></div></div></pre>

<h3 id="sending-messages">Sending messages</h3>

<p>Start a loop that sends <strong>REPETITIONS</strong> messages:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="kw1">for</span> <span class="br0">&#40;</span><span class="kw4">unsigned</span> <span class="kw4">int</span> i <span class="sy0">=</span> <span class="nu0">0</span><span class="sy0">;</span> i <span class="sy0">&lt;</span> REPETITIONS<span class="sy0">;</span> i<span class="sy0">++</span><span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; ...</div></div></pre>

<p>Before sending a message, fill a buffer of <strong>PACKET_SIZE</strong> values. The library provides signed integers of 16 bits. Since the dimension of an <strong>int</strong> in C is not defined, use an <strong>int</strong> with a specific width:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="kw4">int16_t</span> buffer<span class="br0">&#91;</span>PACKET_SIZE<span class="br0">&#93;</span><span class="sy0">;</span><br />
<br />
<span class="kw1">for</span> <span class="br0">&#40;</span><span class="kw4">unsigned</span> <span class="kw4">int</span> j <span class="sy0">=</span> <span class="nu0">0</span><span class="sy0">;</span> j <span class="sy0">&lt;</span> PACKET_SIZE<span class="sy0">;</span> j<span class="sy0">++</span><span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; buffer<span class="br0">&#91;</span>j<span class="br0">&#93;</span> <span class="sy0">=</span> fancyhw_read_val<span class="br0">&#40;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<span class="br0">&#125;</span><br />
<br />
<a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;Read %u data values<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> PACKET_SIZE<span class="br0">&#41;</span><span class="sy0">;</span></div></div></pre>

<p>The first step in message preparation and delivery is creating a ZeroMQ message and allocating the memory necessary for your message. This empty message is an envelope to store the data you will ship:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c">zmq_msg_t envelope<span class="sy0">;</span><br />
<br />
<span class="kw4">const</span> <span class="kw4">int</span> rmi <span class="sy0">=</span> zmq_msg_init_size<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="sy0">,</span> envelope_size<span class="br0">&#41;</span><span class="sy0">;</span><br />
<span class="kw1">if</span> <span class="br0">&#40;</span>rmi <span class="sy0">!=</span> <span class="nu0">0</span><span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;ERROR: ZeroMQ error occurred during zmq_msg_init_size(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; zmq_msg_close<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw2">break</span><span class="sy0">;</span><br />
<span class="br0">&#125;</span></div></div></pre>

<p>Now that the memory is allocated, store the data in the ZeroMQ message "envelope." The <strong>zmq_msg_data()</strong> function returns a pointer to the beginning of the buffer in the envelope. The first part is the topic, followed by a space, then the binary data. Add whitespace as a separator between the topic and the data. To move along the buffer, you have to play with casts and <a href="https://en.wikipedia.org/wiki/Pointer_%28computer_programming%29%23C_and_C++" target="_blank">pointer arithmetic</a>. (Thank you, C, for making things straightforward.) Do this with:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><a href="http://www.opengroup.org/onlinepubs/009695399/functions/memcpy.html"><span class="kw3">memcpy</span></a><span class="br0">&#40;</span>zmq_msg_data<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span><span class="sy0">,</span> TOPIC<span class="sy0">,</span> topic_size<span class="br0">&#41;</span><span class="sy0">;</span><br />
<a href="http://www.opengroup.org/onlinepubs/009695399/functions/memcpy.html"><span class="kw3">memcpy</span></a><span class="br0">&#40;</span><span class="br0">&#40;</span><span class="kw4">void</span><span class="sy0">*</span><span class="br0">&#41;</span><span class="br0">&#40;</span><span class="br0">&#40;</span><span class="kw4">char</span><span class="sy0">*</span><span class="br0">&#41;</span>zmq_msg_data<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span> <span class="sy0">+</span> topic_size<span class="br0">&#41;</span><span class="sy0">,</span> <span class="st0">&quot; &quot;</span><span class="sy0">,</span> <span class="nu0">1</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<a href="http://www.opengroup.org/onlinepubs/009695399/functions/memcpy.html"><span class="kw3">memcpy</span></a><span class="br0">&#40;</span><span class="br0">&#40;</span><span class="kw4">void</span><span class="sy0">*</span><span class="br0">&#41;</span><span class="br0">&#40;</span><span class="br0">&#40;</span><span class="kw4">char</span><span class="sy0">*</span><span class="br0">&#41;</span>zmq_msg_data<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span> <span class="sy0">+</span> <span class="nu0">1</span> <span class="sy0">+</span> topic_size<span class="br0">&#41;</span><span class="sy0">,</span> buffer<span class="sy0">,</span> PACKET_SIZE <span class="sy0">*</span> <span class="kw4">sizeof</span><span class="br0">&#40;</span><span class="kw4">int16_t</span><span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span></div></div></pre>

<p>Send the message through the <strong>data_socket</strong>:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="kw4">const</span> <span class="kw4">size_t</span> rs <span class="sy0">=</span> zmq_msg_send<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="sy0">,</span> data_socket<span class="sy0">,</span> <span class="nu0">0</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<span class="kw1">if</span> <span class="br0">&#40;</span>rs <span class="sy0">!=</span> envelope_size<span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;ERROR: ZeroMQ error occurred during zmq_msg_send(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; zmq_msg_close<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw2">break</span><span class="sy0">;</span><br />
<span class="br0">&#125;</span></div></div></pre>

<p>Make sure to dispose of the envelope after you use it:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c">zmq_msg_close<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
<a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;Message sent; i: %u, topic: %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> i<span class="sy0">,</span> TOPIC<span class="br0">&#41;</span><span class="sy0">;</span></div></div></pre>

<h3 id="clean-up">Clean it up</h3>

<p>Because C does not provide <a href="https://en.wikipedia.org/wiki/Garbage_collection_(computer_science)" target="_blank">garbage collection</a>, you have to tidy up. After you are done sending your messages, close the program with the clean-up needed to release the used memory:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="kw4">const</span> <span class="kw4">int</span> rc <span class="sy0">=</span> zmq_close<span class="br0">&#40;</span>data_socket<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
<span class="kw1">if</span> <span class="br0">&#40;</span>rc <span class="sy0">!=</span> <span class="nu0">0</span><span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;ERROR: ZeroMQ error occurred during zmq_close(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">return</span> EXIT_FAILURE<span class="sy0">;</span><br />
<span class="br0">&#125;</span><br />
<br />
<span class="kw4">const</span> <span class="kw4">int</span> rd <span class="sy0">=</span> zmq_ctx_destroy<span class="br0">&#40;</span>context<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
<span class="kw1">if</span> <span class="br0">&#40;</span>rd <span class="sy0">!=</span> <span class="nu0">0</span><span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;Error occurred during zmq_ctx_destroy(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">return</span> EXIT_FAILURE<span class="sy0">;</span><br />
<span class="br0">&#125;</span><br />
<br />
<span class="kw1">return</span> EXIT_SUCCESS<span class="sy0">;</span></div></div></pre>

<h3 id="the-entire-program">The entire C program</h3>

<p>Save the full interface library below to a local file called <strong>hw_interface.c</strong>:</p>

<pre><div class="geshifilter"><div class="c geshifilter-c"><span class="co1">// For printf()</span><br />
<span class="co2">#include &lt;stdio.h&gt;</span><br />
<span class="co1">// For EXIT_*</span><br />
<span class="co2">#include &lt;stdlib.h&gt;</span><br />
<span class="co1">// For memcpy()</span><br />
<span class="co2">#include &lt;string.h&gt;</span><br />
<span class="co1">// For sleep()</span><br />
<span class="co2">#include &lt;unistd.h&gt;</span><br />
<br />
<span class="co2">#include &lt;zmq.h&gt;</span><br />
<br />
<span class="co2">#include &quot;libfancyhw.h&quot;</span><br />
<br />
<span class="kw4">int</span> main<span class="br0">&#40;</span><span class="kw4">void</span><span class="br0">&#41;</span><br />
<span class="br0">&#123;</span><br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">unsigned</span> <span class="kw4">int</span> INIT_PARAM <span class="sy0">=</span> <span class="nu0">12345</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">unsigned</span> <span class="kw4">int</span> REPETITIONS <span class="sy0">=</span> <span class="nu0">10</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">unsigned</span> <span class="kw4">int</span> PACKET_SIZE <span class="sy0">=</span> <span class="nu0">16</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">char</span> <span class="sy0">*</span>TOPIC <span class="sy0">=</span> <span class="st0">&quot;fancyhw_data&quot;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; fancyhw_init<span class="br0">&#40;</span>INIT_PARAM<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw4">void</span> <span class="sy0">*</span>context <span class="sy0">=</span> zmq_ctx_new<span class="br0">&#40;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">if</span> <span class="br0">&#40;</span><span class="sy0">!</span>context<span class="br0">&#41;</span><br />
&nbsp; &nbsp; <span class="br0">&#123;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;ERROR: ZeroMQ error occurred during zmq_ctx_new(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">return</span> EXIT_FAILURE<span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="br0">&#125;</span><br />
<br />
&nbsp; &nbsp; <span class="kw4">void</span> <span class="sy0">*</span>data_socket <span class="sy0">=</span> zmq_socket<span class="br0">&#40;</span>context<span class="sy0">,</span> ZMQ_PUB<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">int</span> rb <span class="sy0">=</span> zmq_bind<span class="br0">&#40;</span>data_socket<span class="sy0">,</span> <span class="st0">&quot;tcp://*:5555&quot;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">if</span> <span class="br0">&#40;</span>rb <span class="sy0">!=</span> <span class="nu0">0</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; <span class="br0">&#123;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;ERROR: ZeroMQ error occurred during zmq_ctx_new(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">return</span> EXIT_FAILURE<span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="br0">&#125;</span><br />
<br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">size_t</span> topic_size <span class="sy0">=</span> <a href="http://www.opengroup.org/onlinepubs/009695399/functions/strlen.html"><span class="kw3">strlen</span></a><span class="br0">&#40;</span>TOPIC<span class="br0">&#41;</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">size_t</span> envelope_size <span class="sy0">=</span> topic_size <span class="sy0">+</span> <span class="nu0">1</span> <span class="sy0">+</span> PACKET_SIZE <span class="sy0">*</span> <span class="kw4">sizeof</span><span class="br0">&#40;</span><span class="kw4">int16_t</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;Topic: %s; topic size: %zu; Envelope size: %zu<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> TOPIC<span class="sy0">,</span> topic_size<span class="sy0">,</span> envelope_size<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">for</span> <span class="br0">&#40;</span><span class="kw4">unsigned</span> <span class="kw4">int</span> i <span class="sy0">=</span> <span class="nu0">0</span><span class="sy0">;</span> i <span class="sy0">&lt;</span> REPETITIONS<span class="sy0">;</span> i<span class="sy0">++</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; <span class="br0">&#123;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw4">int16_t</span> buffer<span class="br0">&#91;</span>PACKET_SIZE<span class="br0">&#93;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">for</span> <span class="br0">&#40;</span><span class="kw4">unsigned</span> <span class="kw4">int</span> j <span class="sy0">=</span> <span class="nu0">0</span><span class="sy0">;</span> j <span class="sy0">&lt;</span> PACKET_SIZE<span class="sy0">;</span> j<span class="sy0">++</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="br0">&#123;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; buffer<span class="br0">&#91;</span>j<span class="br0">&#93;</span> <span class="sy0">=</span> fancyhw_read_val<span class="br0">&#40;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="br0">&#125;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;Read %u data values<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> PACKET_SIZE<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; zmq_msg_t envelope<span class="sy0">;</span><br />
&nbsp; &nbsp; <br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">int</span> rmi <span class="sy0">=</span> zmq_msg_init_size<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="sy0">,</span> envelope_size<span class="br0">&#41;</span><span class="sy0">;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">if</span> <span class="br0">&#40;</span>rmi <span class="sy0">!=</span> <span class="nu0">0</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="br0">&#123;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;ERROR: ZeroMQ error occurred during zmq_msg_init_size(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; zmq_msg_close<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <span class="kw2">break</span><span class="sy0">;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="br0">&#125;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <br />
&nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/memcpy.html"><span class="kw3">memcpy</span></a><span class="br0">&#40;</span>zmq_msg_data<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span><span class="sy0">,</span> TOPIC<span class="sy0">,</span> topic_size<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/memcpy.html"><span class="kw3">memcpy</span></a><span class="br0">&#40;</span><span class="br0">&#40;</span><span class="kw4">void</span><span class="sy0">*</span><span class="br0">&#41;</span><span class="br0">&#40;</span><span class="br0">&#40;</span><span class="kw4">char</span><span class="sy0">*</span><span class="br0">&#41;</span>zmq_msg_data<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span> <span class="sy0">+</span> topic_size<span class="br0">&#41;</span><span class="sy0">,</span> <span class="st0">&quot; &quot;</span><span class="sy0">,</span> <span class="nu0">1</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/memcpy.html"><span class="kw3">memcpy</span></a><span class="br0">&#40;</span><span class="br0">&#40;</span><span class="kw4">void</span><span class="sy0">*</span><span class="br0">&#41;</span><span class="br0">&#40;</span><span class="br0">&#40;</span><span class="kw4">char</span><span class="sy0">*</span><span class="br0">&#41;</span>zmq_msg_data<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span> <span class="sy0">+</span> <span class="nu0">1</span> <span class="sy0">+</span> topic_size<span class="br0">&#41;</span><span class="sy0">,</span> buffer<span class="sy0">,</span> PACKET_SIZE <span class="sy0">*</span> <span class="kw4">sizeof</span><span class="br0">&#40;</span><span class="kw4">int16_t</span><span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">size_t</span> rs <span class="sy0">=</span> zmq_msg_send<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="sy0">,</span> data_socket<span class="sy0">,</span> <span class="nu0">0</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">if</span> <span class="br0">&#40;</span>rs <span class="sy0">!=</span> envelope_size<span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="br0">&#123;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;ERROR: ZeroMQ error occurred during zmq_msg_send(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; zmq_msg_close<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <span class="kw2">break</span><span class="sy0">;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="br0">&#125;</span><br />
&nbsp; &nbsp; <br />
&nbsp; &nbsp; &nbsp; &nbsp; zmq_msg_close<span class="br0">&#40;</span><span class="sy0">&amp;</span>envelope<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;Message sent; i: %u, topic: %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> i<span class="sy0">,</span> TOPIC<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; sleep<span class="br0">&#40;</span><span class="nu0">1</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="br0">&#125;</span><br />
<br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">int</span> rc <span class="sy0">=</span> zmq_close<span class="br0">&#40;</span>data_socket<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">if</span> <span class="br0">&#40;</span>rc <span class="sy0">!=</span> <span class="nu0">0</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; <span class="br0">&#123;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;ERROR: ZeroMQ error occurred during zmq_close(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">return</span> EXIT_FAILURE<span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="br0">&#125;</span><br />
<br />
&nbsp; &nbsp; <span class="kw4">const</span> <span class="kw4">int</span> rd <span class="sy0">=</span> zmq_ctx_destroy<span class="br0">&#40;</span>context<span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">if</span> <span class="br0">&#40;</span>rd <span class="sy0">!=</span> <span class="nu0">0</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; <span class="br0">&#123;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <a href="http://www.opengroup.org/onlinepubs/009695399/functions/printf.html"><span class="kw3">printf</span></a><span class="br0">&#40;</span><span class="st0">&quot;Error occurred during zmq_ctx_destroy(): %s<span class="es1">\n</span>&quot;</span><span class="sy0">,</span> zmq_strerror<span class="br0">&#40;</span>errno<span class="br0">&#41;</span><span class="br0">&#41;</span><span class="sy0">;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">return</span> EXIT_FAILURE<span class="sy0">;</span><br />
&nbsp; &nbsp; <span class="br0">&#125;</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">return</span> EXIT_SUCCESS<span class="sy0">;</span><br />
<span class="br0">&#125;</span></div></div></pre>

<p>Compile using the command:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span>clang <span class="re5">-std</span>=c99 -I. hw_interface.c <span class="re5">-lzmq</span> <span class="re5">-o</span> hw_interface</code></span></pre>

<p>If there are no compilation errors, you can run the interface. What's great is that ZeroMQ <strong>PUB</strong> sockets can run without any applications sending or retrieving data. That reduces complexity because there is no obligation in terms of which process needs to start first.</p>

<p>Run the interface:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ .<span class="sy0">/</span>hw_interface <br />
Topic: fancyhw_data; topic size: <span class="nu0">12</span>; Envelope size: <span class="nu0">45</span><br />
Read <span class="nu0">16</span> data values<br />
Message sent; i: <span class="nu0">0</span>, topic: fancyhw_data<br />
Read <span class="nu0">16</span> data values<br />
Message sent; i: <span class="nu0">1</span>, topic: fancyhw_data<br />
Read <span class="nu0">16</span> data values<br />
...<br />
...</div></div></pre>

<p>The output shows the data being sent through ZeroMQ. Now you need an application to read the data.</p>

<h2 id="write-a-python-data-processor">Write a Python data processor</h2>

<p>You are now ready to pass the data from C to a Python application.</p>

<h3 id="libraries-1">Libraries</h3>

<p>You need two libraries to help transfer data. First, you need ZeroMQ bindings in Python:</p>

<pre><span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span>python3 <span class="re5">-m</span> pip <span class="kw2">install</span> zmq</code></span></pre>

<p>The other is the <a href="https://docs.python.org/3/library/struct.html" target="_blank"><strong>struct</strong> library</a>, which decodes binary data. It's commonly available with the Python standard library, so there's no need to <strong>pip install</strong> it.</p>

<p>The first part of the Python program imports both of these libraries:</p>

<pre><div class="geshifilter"><div class="python geshifilter-python"><span class="kw1">import</span> zmq<br />
<span class="kw1">import</span> <span class="kw3">struct</span></div></div></pre>

<h3 id="significant-parameters-1">Significant parameters</h3>

<p>To use ZeroMQ, you must subscribe to the same topic used in the constant <strong>TOPIC</strong> above:</p>

<pre><div class="geshifilter"><div class="python geshifilter-python">topic <span class="sy0">=</span> <span class="st0">&quot;fancyhw_data&quot;</span>.<span class="me1">encode</span><span class="br0">&#40;</span><span class="st0">'ascii'</span><span class="br0">&#41;</span><br />
<br />
<span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;Reading messages with topic: {}&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>topic<span class="br0">&#41;</span><span class="br0">&#41;</span></div></div></pre>

<h3 id="initialization-1">Initialization</h3>

<p>Next, initialize the context and the socket. Use a <strong>subscribe</strong> socket (also known as a <strong>SUB</strong> socket), which is the natural partner of the <strong>PUB </strong>socket. The socket also needs to subscribe to the right topic:</p>

<pre><div class="geshifilter"><div class="python geshifilter-python"><span class="kw1">with</span> zmq.<span class="me1">Context</span><span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="kw1">as</span> context:<br />
&nbsp; &nbsp; <span class="kw3">socket</span> <span class="sy0">=</span> context.<span class="kw3">socket</span><span class="br0">&#40;</span>zmq.<span class="me1">SUB</span><span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; <span class="kw3">socket</span>.<span class="me1">connect</span><span class="br0">&#40;</span><span class="st0">&quot;tcp://127.0.0.1:5555&quot;</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; <span class="kw3">socket</span>.<span class="me1">setsockopt</span><span class="br0">&#40;</span>zmq.<span class="me1">SUBSCRIBE</span><span class="sy0">,</span> topic<span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; i <span class="sy0">=</span> <span class="nu0">0</span><br />
<br />
&nbsp; &nbsp; ...</div></div></pre>

<h3 id="receiving-messages">Receiving messages</h3>

<p>Start an infinite loop that waits for new messages to be delivered to the SUB socket. The loop will be closed if you press <strong>Ctrl+C</strong> or if an error occurs:</p>

<pre><div class="geshifilter"><div class="python geshifilter-python">&nbsp; &nbsp; <span class="kw1">try</span>:<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">while</span> <span class="kw2">True</span>:<br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; ... <span class="co1"># we will fill this in next</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">except</span> <span class="kw2">KeyboardInterrupt</span>:<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw3">socket</span>.<span class="me1">close</span><span class="br0">&#40;</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; <span class="kw1">except</span> <span class="kw2">Exception</span> <span class="kw1">as</span> error:<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;ERROR: {}&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>error<span class="br0">&#41;</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw3">socket</span>.<span class="me1">close</span><span class="br0">&#40;</span><span class="br0">&#41;</span></div></div></pre>

<p>The loop waits for new messages to arrive with the <strong>recv()</strong> method. Then it splits whatever is received at the first space to separate the topic from the content:</p>

<pre><span class="geshifilter"><code class="python geshifilter-python">binary_topic<span class="sy0">,</span> data_buffer <span class="sy0">=</span> <span class="kw3">socket</span>.<span class="me1">recv</span><span class="br0">&#40;</span><span class="br0">&#41;</span>.<span class="me1">split</span><span class="br0">&#40;</span>b<span class="st0">' '</span><span class="sy0">,</span> <span class="nu0">1</span><span class="br0">&#41;</span></code></span></pre>

<h3 id="decoding-messages">Decoding messages</h3>

<p>Python does yet not know that the topic is a string, so decode it using the standard ASCII encoding:</p>

<pre><div class="geshifilter"><div class="python geshifilter-python">topic <span class="sy0">=</span> binary_topic.<span class="me1">decode</span><span class="br0">&#40;</span>encoding <span class="sy0">=</span> <span class="st0">'ascii'</span><span class="br0">&#41;</span><br />
<br />
<span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;Message {:d}:&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>i<span class="br0">&#41;</span><span class="br0">&#41;</span><br />
<span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;<span class="es0">\t</span>topic: '{}'&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>topic<span class="br0">&#41;</span><span class="br0">&#41;</span></div></div></pre>

<p>The next step is to read the binary data using the <strong>struct</strong> library, which can convert shapeless binary blobs to significant values. First, calculate the number of values stored in the packet. This example uses 16-bit signed integers that correspond to an "h" in the <strong>struct</strong> <a href="https://docs.python.org/3/library/struct.html#format-characters" target="_blank">format</a>:</p>

<pre><div class="geshifilter"><div class="python geshifilter-python">packet_size <span class="sy0">=</span> <span class="kw2">len</span><span class="br0">&#40;</span>data_buffer<span class="br0">&#41;</span> // <span class="kw3">struct</span>.<span class="me1">calcsize</span><span class="br0">&#40;</span><span class="st0">&quot;h&quot;</span><span class="br0">&#41;</span><br />
<br />
<span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;<span class="es0">\t</span>packet size: {:d}&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>packet_size<span class="br0">&#41;</span><span class="br0">&#41;</span></div></div></pre>

<p>By knowing how many values are in the packet, you can define the format by preparing a string with the number of values and their types (e.g., "<strong>16h</strong>"):</p>

<pre><span class="geshifilter"><code class="python geshifilter-python">struct_format <span class="sy0">=</span> <span class="st0">&quot;{:d}h&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>packet_size<span class="br0">&#41;</span></code></span></pre>

<p>Convert that binary blob to a series of numbers that you can immediately print:</p>

<pre><div class="geshifilter"><div class="python geshifilter-python">data <span class="sy0">=</span> <span class="kw3">struct</span>.<span class="me1">unpack</span><span class="br0">&#40;</span>struct_format<span class="sy0">,</span> data_buffer<span class="br0">&#41;</span><br />
<br />
<span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;<span class="es0">\t</span>data: {}&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>data<span class="br0">&#41;</span><span class="br0">&#41;</span></div></div></pre>

<h3 id="the-full-python-program">The full Python program</h3>

<p>Here is the complete data receiver in Python:</p>

<pre><div class="geshifilter"><div class="python geshifilter-python"><span class="co1">#! /usr/bin/env python3</span><br />
<br />
<span class="kw1">import</span> zmq<br />
<span class="kw1">import</span> <span class="kw3">struct</span><br />
<br />
topic <span class="sy0">=</span> <span class="st0">&quot;fancyhw_data&quot;</span>.<span class="me1">encode</span><span class="br0">&#40;</span><span class="st0">'ascii'</span><span class="br0">&#41;</span><br />
<br />
<span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;Reading messages with topic: {}&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>topic<span class="br0">&#41;</span><span class="br0">&#41;</span><br />
<br />
<span class="kw1">with</span> zmq.<span class="me1">Context</span><span class="br0">&#40;</span><span class="br0">&#41;</span> <span class="kw1">as</span> context:<br />
&nbsp; &nbsp; <span class="kw3">socket</span> <span class="sy0">=</span> context.<span class="kw3">socket</span><span class="br0">&#40;</span>zmq.<span class="me1">SUB</span><span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; <span class="kw3">socket</span>.<span class="me1">connect</span><span class="br0">&#40;</span><span class="st0">&quot;tcp://127.0.0.1:5555&quot;</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; <span class="kw3">socket</span>.<span class="me1">setsockopt</span><span class="br0">&#40;</span>zmq.<span class="me1">SUBSCRIBE</span><span class="sy0">,</span> topic<span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; i <span class="sy0">=</span> <span class="nu0">0</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">try</span>:<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">while</span> <span class="kw2">True</span>:<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; binary_topic<span class="sy0">,</span> data_buffer <span class="sy0">=</span> <span class="kw3">socket</span>.<span class="me1">recv</span><span class="br0">&#40;</span><span class="br0">&#41;</span>.<span class="me1">split</span><span class="br0">&#40;</span>b<span class="st0">' '</span><span class="sy0">,</span> <span class="nu0">1</span><span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; topic <span class="sy0">=</span> binary_topic.<span class="me1">decode</span><span class="br0">&#40;</span>encoding <span class="sy0">=</span> <span class="st0">'ascii'</span><span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;Message {:d}:&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>i<span class="br0">&#41;</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;<span class="es0">\t</span>topic: '{}'&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>topic<span class="br0">&#41;</span><span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; packet_size <span class="sy0">=</span> <span class="kw2">len</span><span class="br0">&#40;</span>data_buffer<span class="br0">&#41;</span> // <span class="kw3">struct</span>.<span class="me1">calcsize</span><span class="br0">&#40;</span><span class="st0">&quot;h&quot;</span><span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;<span class="es0">\t</span>packet size: {:d}&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>packet_size<span class="br0">&#41;</span><span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; struct_format <span class="sy0">=</span> <span class="st0">&quot;{:d}h&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>packet_size<span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; data <span class="sy0">=</span> <span class="kw3">struct</span>.<span class="me1">unpack</span><span class="br0">&#40;</span>struct_format<span class="sy0">,</span> data_buffer<span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;<span class="es0">\t</span>data: {}&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>data<span class="br0">&#41;</span><span class="br0">&#41;</span><br />
<br />
&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; i +<span class="sy0">=</span> <span class="nu0">1</span><br />
<br />
&nbsp; &nbsp; <span class="kw1">except</span> <span class="kw2">KeyboardInterrupt</span>:<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw3">socket</span>.<span class="me1">close</span><span class="br0">&#40;</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; <span class="kw1">except</span> <span class="kw2">Exception</span> <span class="kw1">as</span> error:<br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw1">print</span><span class="br0">&#40;</span><span class="st0">&quot;ERROR: {}&quot;</span>.<span class="me1">format</span><span class="br0">&#40;</span>error<span class="br0">&#41;</span><span class="br0">&#41;</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; <span class="kw3">socket</span>.<span class="me1">close</span><span class="br0">&#40;</span><span class="br0">&#41;</span></div></div></pre>

<p>Save it to a file called <strong>online_analysis.py</strong>. Python does not need to be compiled, so you can run the program immediately.</p>

<p>Here is the output:</p>

<pre><div class="geshifilter"><div class="bash geshifilter-bash">$ .<span class="sy0">/</span>online_analysis.py <br />
Reading messages with topic: b<span class="st_h">'fancyhw_data'</span><br />
Message <span class="nu0">0</span>:<br />
&nbsp; &nbsp; &nbsp; &nbsp; topic: <span class="st_h">'fancyhw_data'</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; packet size: <span class="nu0">16</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; data: <span class="br0">&#40;</span><span class="nu0">20946</span>, -<span class="nu0">23616</span>, <span class="nu0">9865</span>, <span class="nu0">31416</span>, -<span class="nu0">15911</span>, -<span class="nu0">10845</span>, -<span class="nu0">5332</span>, <span class="nu0">25662</span>, <span class="nu0">10955</span>, -<span class="nu0">32501</span>, -<span class="nu0">18717</span>, -<span class="nu0">24490</span>, -<span class="nu0">16511</span>, -<span class="nu0">28861</span>, <span class="nu0">24205</span>, <span class="nu0">26568</span><span class="br0">&#41;</span><br />
Message <span class="nu0">1</span>:<br />
&nbsp; &nbsp; &nbsp; &nbsp; topic: <span class="st_h">'fancyhw_data'</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; packet size: <span class="nu0">16</span><br />
&nbsp; &nbsp; &nbsp; &nbsp; data: <span class="br0">&#40;</span><span class="nu0">12505</span>, <span class="nu0">31355</span>, <span class="nu0">14083</span>, -<span class="nu0">19654</span>, -<span class="nu0">9141</span>, <span class="nu0">14532</span>, -<span class="nu0">25591</span>, <span class="nu0">31203</span>, <span class="nu0">10428</span>, -<span class="nu0">25564</span>, -<span class="nu0">732</span>, -<span class="nu0">7979</span>, <span class="nu0">9529</span>, -<span class="nu0">27982</span>, <span class="nu0">29610</span>, <span class="nu0">30475</span><span class="br0">&#41;</span><br />
...<br />
...</div></div></pre>

<h2 id="conclusion">Conclusion</h2>

<p><div id="programming-and-development" class="embedded-callout-menu callout-float-right"><div class="view view-related-content-callout view-id-related_content_callout view-display-id-article_block view-dom-id-a29c2e96bfa812d2b36cc29cff772219">
            <div class="view-header">
      Programming and development    </div>
  
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">      
  <div class="views-field views-field-field-related-content-link">        <div class="field-content"><div class="item-list"><ul><li class="first"><a href="https://opensource.com/downloads/cheat-sheets?intcmp=7016000000127cYAAQ">Programming cheat sheets</a></li>
<li><a href="https://opensource.com/tags/python?src=programming_resource_menu1">New Python content</a></li>
<li><a href="https://opensource.com/tags/javascript?src=programming_resource_menu2">Our latest JavaScript articles</a></li>
<li><a href="https://opensource.com/tags/perl?src=programming_resource_menu3">Recent Perl posts</a></li>
<li class="last"><a href="https://developers.redhat.com/?intcmp=7016000000127cYAAQ&amp;src=programming_resource_menu4">Red Hat Developers Blog</a></li>
</ul></div></div>  </div>  </div>    </div>
  
  
  
  
  
  
</div></div>This tutorial describes an alternative way of gathering data from C-based hardware interfaces and providing it to Python-based infrastructures. You can take this data and analyze it or pass it off in any number of directions. It employs a messaging library to deliver data between a "gatherer" and an "analyzer" instead of having a monolithic piece of software that does everything.</p>

<p>This tutorial also increases what I call "software granularity." In other words, it subdivides the software into smaller units. One of the benefits of this strategy is the possibility of using different programming languages at the same time with minimal interfaces acting as shims between them.</p>

<p>In practice, this design allows software engineers to work both more collaboratively and independently. Different teams may work on different steps of the analysis, choosing the tool they prefer. Another benefit is the parallelism that comes for free since all the processes can run in parallel. The <a href="https://zeromq.org/" target="_blank">ZeroMQ messaging library</a> is a remarkable piece of software that makes all of this much easier.</p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-listacles-panel-pane-1"  >
  
      
  
  <div class="view view-listacles view-id-listacles view-display-id-panel_pane_1 view-dom-id-1d6e1f0fc19ae52713c307b438d76552">
        
  
  
      <div class="view-content">
              
  <div class="views-field views-field-field-listacles">        <div class="field-content">
<div class="panelizer-view-mode node node-teaser-listacles node-article node-60986 node-promoted node-promoted">
        
<div class="panel-display teaser clearfix " >

  <div class="teaser__first">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/metrics_data_dashboard_system_computer_analytics.png?itok=jqAPXpXC"><a href="/article/20/2/c-data-science"><img class="teaser-wide" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/metrics_data_dashboard_system_computer_analytics.png?itok=jqAPXpXC" width="248" height="140" alt="metrics and data shown on a computer screen" title="metrics and data shown on a computer screen" /></a></div></div></div>
  
  </div>
  </div>

  <div class="teaser__second">
    <h2 class="teaser__title"><div class="panel-pane pane-node-title"  >
  
      
  
  <a href="/article/20/2/c-data-science">Using C and C++ for data science</a>
  
  </div>
</h2>
    <div class="teaser__body"><div class="panel-pane pane-token pane-node-field-article-subhead"  >
  
      
  
  Let&#039;s work through a common data science task with C99 and C++11.
  
  </div>
</div>
    <div class="teaser__byline"><div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__author-name"><a href="/users/cristianofontana" title="View user profile." class="username" xml:lang="" about="/users/cristianofontana" typeof="sioc:UserAccount" property="foaf:name" datatype="">Cristiano L. Fontana</a></span>
</div>
  
  </div>
</div>
  </div>

</div>
</div>
</div>  </div>          
  <div class="views-field views-field-field-listacles">        <div class="field-content">
<div class="panelizer-view-mode node node-teaser-listacles node-article node-53871 node-promoted node-promoted">
        
<div class="panel-display teaser clearfix " >

  <div class="teaser__first">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image"  >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/dna_helix_science_genetics.png?itok=N9WzAk7R"><a href="/article/19/5/learn-python-r-data-science"><img class="teaser-wide" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/teaser-wide/public/lead-images/dna_helix_science_genetics.png?itok=N9WzAk7R" width="249" height="140" alt="DNA double helix" title="DNA double helix" /></a></div></div></div>
  
  </div>
  </div>

  <div class="teaser__second">
    <h2 class="teaser__title"><div class="panel-pane pane-node-title"  >
  
      
  
  <a href="/article/19/5/learn-python-r-data-science">100 ways to learn Python and R for data science</a>
  
  </div>
</h2>
    <div class="teaser__body"><div class="panel-pane pane-token pane-node-field-article-subhead"  >
  
      
  
  Want to learn data science? Find recommended courses in the Data Science Repo, a community-sourced directory of Python and R learning resources.
  
  </div>
</div>
    <div class="teaser__byline"><div class="panel-pane pane-os-content-article-byline"  >
  
      
  
  <div class="byline"><span class="byline__author-name"><a href="/users/chris-engelhardt" title="View user profile." class="username" xml:lang="" about="/users/chris-engelhardt" typeof="sioc:UserAccount" property="foaf:name" datatype="">Chris Engelhardt</a></span>
<span class="byline__author-name"><a href="/users/momiji15" title="View user profile." class="username" xml:lang="" about="/users/momiji15" typeof="sioc:UserAccount" property="foaf:name" datatype="">Dorris Scott</a></span>
<span class="byline__author-name"><a href="/users/asingh31" title="View user profile." class="username" xml:lang="" about="/users/asingh31" typeof="sioc:UserAccount" property="foaf:name" datatype="">Annu Singh</a></span>
</div>
  
  </div>
</div>
  </div>

</div>
</div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-tags"  >
  
        <h2 class="pane-title">
      Topics    </h2>
    
  
  <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:keywords"><a href="/tags/python" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Python</a></div><div class="field-item odd" rel="schema:keywords"><a href="/tags/programming" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Programming</a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-author-info-panel-pane-1"  >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-1e7a6d5f1e7ce69296f6256a14ca2901">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><a href="/users/cristianofontana"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/pictures/cristiano_fontana.jpg?itok=PT3ovTGY" width="100" height="100" alt="" /></a></div>
<div class="authorbio__content">
  <span class="authorbio__name">Cristiano L. Fontana</span> - <span class="authorbio__about">Cristiano L. Fontana is a researcher at the Physics and Astronomy Department "Galileo Galilei" of the University of Padova (Italy). He works in the applied physics field and teaches introductory physics at the medical school of the same university.
</span>
  <div class="authorbio__more-link"><a href="/users/cristianofontana">More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-content-article-contributions"  >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block"  >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__bottom">
      <div class="panel-pane pane-views-panes pane-related-articles-panel-pane-1"  >
  
        <h2 class="pane-title">
      Recommended reading    </h2>
    
  
  <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 related-content view-dom-id-225c2c82b4c2aeb505856d95a42963e7">
        
  
  
      <div id="related-content-footer" class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/3/treq-python"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/coffee_python.jpg?itok=KjLnj0yY" width="314" height="177" alt="Python in a coffee cup." title="Python in a coffee cup." /><br />
Get started using treq to make async calls in Python</a></span>  </div>  </div>  <div class="views-row views-row-2 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/3/ranger-file-navigator"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/features_solutions_command_data.png?itok=gtpjm2aw" width="314" height="177" alt="computer screen " title="computer screen " /><br />
How to use Ranger for navigating files from the command line</a></span>  </div>  </div>  <div class="views-row views-row-3 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/3/pip-linux-mac-windows"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/1980s-computer-yearbook.png?itok=mQIlrpw-" width="315" height="177" alt="Person typing on a 1980&#039;s computer" title="Person typing on a 1980&#039;s computer" /><br />
How to install pip to manage PyPI packages easily</a></span>  </div>  </div>  <div class="views-row views-row-4 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/2/logzero-python"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/getting_started_with_python.png?itok=4QHzsLy2" width="315" height="177" alt="Snake charmer cartoon with a yellow snake and a blue snake" title="Snake charmer cartoon with a yellow snake and a blue snake" /><br />
Use logzero for simple logging in Python</a></span>  </div>  </div>  <div class="views-row views-row-5 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/2/c-data-science"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/metrics_data_dashboard_system_computer_analytics.png?itok=CR7DSXPK" width="314" height="177" alt="metrics and data shown on a computer screen" title="metrics and data shown on a computer screen" /><br />
Using C and C++ for data science</a></span>  </div>  </div>  <div class="views-row views-row-6 views-row-even views-row-last">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/20/2/domain-specific-languages"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/programming_language_c.png?itok=-zpQtkr_" width="315" height="177" alt="Various programming languages in use" title="Various programming languages in use" /><br />
What developers need to know about domain-specific languages</a></span>  </div>  </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
    </div>
  
      <div class="os-article__footer">
      <div class="panel-pane pane-node-comments"  id="comments" >
  
        <h2 class="pane-title">
      3 Comments    </h2>
    
  
  <a id="comment-196311"></a>
<div class="comment first odd clearfix" about="/comment/196311#comment-196311" typeof="sioc:Post sioct:Comment">

  <div class="user-picture-badges">
    <img class="comment-avatar" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/comment_avatar/public/osdc_default_avatar.png?itok=pk-4pxZV" width="50" height="50" alt="Watson54" title="Watson54" />      </div>

  
  <div class="submitted">
    <span property="dc:date dc:created" content="2020-03-18T03:59:04-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/watson54" class="username">Watson54</a> on 18 Mar 2020</span>    <a href="/comment/196311#comment-196311" class="permalink" rel="bookmark">Permalink</a>      </div>

  <div class="content">
    <span rel="sioc:reply_of" resource="/article/20/3/zeromq-c-python" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>Sonalika DI 35 Tractor Price in India &amp; Sonalika DI 35 Specification, Features<br /><a href="https://tractorsinfo.in/sonalika-di-35-tractor-price-in-india/">https://tractorsinfo.in/sonalika-di-35-tractor-price-in-india/</a></p>
</div></div></div>      </div>

  <div class="comment__meta">
    <ul class="links inline"><li class="comment-reply first last"><a href="/comment/reply/61401/196311">reply</a></li>
</ul>    <div class="vud-widget vud-widget-upanddown" id="widget-comment-196311">
  <div class="up-score clear-block">
                    <div class="up-active" title="Vote up!"></div>
          <div class="element-invisible">Vote up!</div>
              <span class="up-current-score">0</span>
  </div>

  </div>
  </div>
</div>
<a id="comment-196341"></a>
<div class="comment even clearfix" about="/comment/196341#comment-196341" typeof="sioc:Post sioct:Comment">

  <div class="user-picture-badges">
    <img class="comment-avatar" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/comment_avatar/public/osdc_default_avatar.png?itok=pk-4pxZV" width="50" height="50" alt="liteblueusps" title="liteblueusps" />      </div>

  
  <div class="submitted">
    <span property="dc:date dc:created" content="2020-03-18T07:20:35-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/liteblueusps" class="username">liteblueusps</a> on 18 Mar 2020</span>    <a href="/comment/196341#comment-196341" class="permalink" rel="bookmark">Permalink</a>      </div>

  <div class="content">
    <span rel="sioc:reply_of" resource="/article/20/3/zeromq-c-python" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>wow Nice article to see.</p>
</div></div></div>      </div>

  <div class="comment__meta">
    <ul class="links inline"><li class="comment-reply first last"><a href="/comment/reply/61401/196341">reply</a></li>
</ul>    <div class="vud-widget vud-widget-upanddown" id="widget-comment-196341">
  <div class="up-score clear-block">
                    <div class="up-active" title="Vote up!"></div>
          <div class="element-invisible">Vote up!</div>
              <span class="up-current-score">0</span>
  </div>

  </div>
  </div>
</div>

<div class="indented"><a id="comment-196361"></a>
<div class="comment comment-by-node-author last odd clearfix" about="/comment/196361#comment-196361" typeof="sioc:Post sioct:Comment">

  <div class="user-picture-badges">
    <img class="comment-avatar" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/comment_avatar/public/pictures/cristiano_fontana.jpg?itok=BLgIsVC5" width="50" height="50" alt="cristiano.fontana" title="cristiano.fontana" />      </div>

  
  <div class="submitted">
    <span property="dc:date dc:created" content="2020-03-18T09:33:20-04:00" datatype="xsd:dateTime" rel="sioc:has_creator"><a href="/users/cristianofontana" class="username">Cristiano L. Fontana</a> on 18 Mar 2020</span>    <a href="/comment/196361#comment-196361" class="permalink" rel="bookmark">Permalink</a>      </div>

  <div class="content">
    <span rel="sioc:reply_of" resource="/article/20/3/zeromq-c-python" class="rdf-meta element-hidden"></span><span rel="sioc:reply_of" resource="/comment/196341#comment-196341" class="rdf-meta element-hidden"></span><div class="field field-name-comment-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><p>Thanks!</p>
</div></div></div>      </div>

  <div class="comment__meta">
    <ul class="links inline"><li class="comment-reply first last"><a href="/comment/reply/61401/196361">reply</a></li>
</ul>    <div class="vud-widget vud-widget-upanddown" id="widget-comment-196361">
  <div class="up-score clear-block">
                    <div class="up-active" title="Vote up!"></div>
          <div class="element-invisible">Vote up!</div>
              <span class="up-current-score">0</span>
  </div>

  </div>
  </div>
</div>
</div>
  
  </div>
<div class="panel-pane pane-node-comment-form"  >
  
        <h2 class="pane-title">
      Comment now    </h2>
    
  
  <form class="comment-form user-info-from-cookie" action="/article/20/3/zeromq-c-python#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div id="edit-login-register" class="form-item form-type-item">
 <a href="/user/login?destination=node/61401">Login or Register</a> to earn points for your comments.
</div>
<div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<input type="hidden" name="form_build_id" value="form-lhoEoNPfCckkfSh_wzpJW2k973ofl-1-vhXdlFkhs4I" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="honeypot_time" value="1584558195|I4G2Cgb2K2fmQkXCsAgXXSW_ImIvPYmuRsl6h1vcaNE" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/legal">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><fieldset class="captcha form-wrapper"><legend><span class="fieldset-legend">CAPTCHA</span></legend><div class="fieldset-wrapper"><div class="fieldset-description">This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.</div><input type="hidden" name="captcha_sid" value="270828946" />
<input type="hidden" name="captcha_token" value="37ea2b383e2fbfd3f9cc7d1073a4e14d" />
<input type="hidden" name="captcha_response" value="Google no captcha" />
<div class="g-recaptcha" data-sitekey="6LdyKzYUAAAAAIwIfHYM0eXeqI_HRmLhM-Msg6nM" data-theme="light" data-type="image"></div></div></fieldset>
<div class="website-url-textfield"><div class="form-item form-type-textfield form-item-website-url">
  <label for="edit-website-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-website-url" name="website-url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div></div></form>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-default-license"  >
  
      
  
  <div class="field field-name-field-default-license field-type-text field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:license"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" style="border-width:0" src="/sites/all/themes/opensource/images/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a></div></div></div>
  
  </div>
    </div>
  
</div>
                  </div>


        
        
      </div>

        <div class="region region-pre-footer">
    <div id="block-os-common-components-footer-call-to-action" class="block block-os-common-components first last odd">

      
  
<div class="fieldable-panels-pane cta cta--green-on-blue cta--no-link">

  <div class="cta__content cta__content--no-link">
            <h2 class="cta__title">Subscribe to our weekly newsletter</h2>
<div class="field field-name-field-cta-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><iframe class="eloqua-embedded-bottom" frameborder="0" height="50" id="fkfkx" scrolling="no" src="/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></p>

<p>Get the highlights in your inbox every week.</p>
</div></div></div>  </div>

</div>


</div>
  </div>

        <div class="region region-footer-nav">
    <div id="block-bean-social-media" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/social-media" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><span>Find us:</span> 
</p>
<ul>
<li><a class="footer-twitter" href="https://twitter.com/OpenSourceWay" title="Twitter">Twitter</a></li>
<li><a class="footer-facebook" href="https://www.facebook.com/opensourceway" title="Facebook">Facebook</a></li>
<li><a class="footer-youtube" href="http://www.youtube.com/opensourceway" title="Youtube">Youtube</a></li>
<li><a class="footer-mastodon" href="https://fosstodon.org/@osdc" title="">Mastodon</a></li>
<li><a class="footer-irc" href="/join-us-irc" title="IRC">IRC</a></li>
<li><a class="footer-feed" href="/feed" title="RSS">RSS</a></li>
</ul>
</div></div></div>  </div>
</div>

</div>
<div id="block-menu-menu-footer" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Footer</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/legal" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact" class="menu__link">Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="/opensourcecom-team" title="" class="menu__link">Meet the Team</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://opensource.org/" title="" class="menu__link">Visit opensource.org</a></li>
</ul>
</div>
  </div>

        <footer id="footer" class="region region-footer">
    <div id="block-bean-copyrigt-block" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/copyrigt-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>For more discussion on open source and the role of the CIO in the enterprise, join us at <a href="https://enterprisersproject.com">The EnterprisersProject.com</a>.</p>

<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>

<p>Opensource.com aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>

<p>Copyright ©2019 Red Hat, Inc.</p>
</div></div></div>  </div>
</div>

</div>
<div id="block-bean-footer-logo" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/footer-logo" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><img src="/sites/all/themes/opensource/images/footer_logo.svg" /></p>
</div></div></div>  </div>
</div>

</div>
  </footer>

    </div>

    
      <div class="region region-os-social">
    <div id="block-os-social-os-social-share" class="block block-os-social first last odd">

      
  <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style" data-a2a-url="https://opensource.com/article/20/3/zeromq-c-python">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <a class="a2a_button_mastodon a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <a class="a2a_button_mastodon a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div>
</div>
  </div>
    <div class="region region-page-bottom">
    <!-- begin Google Remarketing --><img height="1" width="1" style="border-style:none;display:block;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" onerror="this.src='/sites/all/themes/opensource/images/1x1.png';this.onerror=null" /><!-- end Google Remarketing -->  </div>
<script src="https://opensource.com/sites/default/files/js/js_29qYXJz8NLGg8Aomg-RZPjJcj9yEdEst1BMZ9gZbs-4.js"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script src="https://opensource.com/sites/default/files/js/js_skcw_uw28w93NamnwquPyMMZNIyaa2eQ6iAc5B_1jjA.js"></script>
<script>var a2a_config = a2a_config || {};
              a2a_config.callbacks = a2a_config.callbacks || [];
a2a_config.templates = {
    twitter: "Share data between C and Python with this messaging library https://red.ht/2Wh3rHz via @opensourceway by @cl_fontana"
};</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"65779638","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkgHX1xuW1BXU1YEF2pWCVxcbkBYXEVuEQRSXQ==","queueTime":0,"applicationTime":1044,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
