<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html class="no-js"  lang="en" dir="ltr" prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video# product: http://ogp.me/ns/product# content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema# schema: http://schema.org/"><!--<![endif]-->

<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
  <meta charset="utf-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1044.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script>
<link href="https://opensource.com/rss.xml" rel="alternate" title="Opensource.com RSS" />
<script src="https://www.google.com/recaptcha/api.js?hl=en" async="async" defer="defer"></script>
<link rel="shortcut icon" href="https://opensource.com/sites/all/themes/opensource/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="Created for utility and known for its dedicated users, Perl has proven staying power. Here&#039;s a brief history of the language and a look at some top user groups." />
<meta name="rating" content="general" />
<meta name="referrer" content="no-referrer" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://opensource.com/article/17/10/perl-turns-30" />
<link rel="shortlink" href="https://opensource.com/node/39146" />
<meta name="revisit-after" content="1 day" />
<meta property="og:site_name" content="Opensource.com" />
<meta property="og:url" content="https://opensource.com/article/17/10/perl-turns-30" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Perl turns 30 and its community continues to thrive" />
<meta property="og:description" content="Created for utility and known for its dedicated users, Perl has proven staying power. Here&#039;s a brief history of the language and a look at some top user groups." />
<meta property="og:image" content="https://opensource.com/sites/default/files/lead-images/camel-perl-lead.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@opensourceway" />
<meta name="twitter:creator" content="@GeekRuthie" />
<meta name="twitter:title" content="Perl turns 30 and its community continues to thrive" />
<meta name="twitter:description" content="Created for utility and known for its dedicated users, Perl has proven staying power. Here&#039;s a brief history of the language and a look at some top user groups." />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/lead-images/camel-perl-lead.png" />
  <title>Perl turns 30  | Opensource.com</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_Rdur8XVJnPlTNehlWLFbY-WXVG0stXacIOxyox8i_wE.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_4SjAN13THpTKjKDqOiAhqAPYfveOqI0m2fFwQMhK_Vc.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_brYLYWLFBAdSv6mFsN6pjWgKibdobzy_SbuWeDPGxpY.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_Tt_CmcLaZRNNG0Pvd0SuCl-uQphZBomvdAwRwTDvNF0.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans.css?oxpik1" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold.css?oxpik1" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-italic.css?oxpik1" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold-italic.css?oxpik1" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_wigS70piKQxAQ-PhuV0Kv5yYuTDEoD4yq0VyEj5L7HY.css" media="all" />
  <script src="https://use.typekit.net/elz3yuz.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  <script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js?v=1.7.2"></script>
<script src="https://opensource.com/misc/jquery.once.js?v=1.2"></script>
<script src="https://opensource.com/misc/drupal.js?oxpik1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.core.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.widget.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/media.core.js?v=7.x-2.8"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.tabs.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.accordion.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.button.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.mouse.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.draggable.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.position.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.resizable.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.dialog.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/better-autocomplete/jquery.better-autocomplete.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/util/json2.js?v=7.x-2.8"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/util/ba-debug.min.js?v=7.x-2.8"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/external/jquery.cookie.js?v=67fb34f6a866c40d0570"></script>
<script src="https://opensource.com/misc/form.js?v=7.56"></script>
<script src="https://opensource.com/sites/all/modules/contrib/comment_notify/comment_notify.js?oxpik1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_admin/panopoly-admin.js?oxpik1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_magic/panopoly-magic.js?oxpik1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_theme/js/panopoly-accordion.js?oxpik1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/caption_filter/js/caption-filter.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/loginlogout/loginlogout.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/modules/custom/os_events/os_events.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/pollanon/js/jquery.cookie.min.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/pollanon/js/pollanon.pack.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/captcha/captcha.js?oxpik1"></script>
<script src="https://opensource.com/misc/collapse.js?v=7.56"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/js/linkit.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/js/linkit.dialog.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/editors/ckeditor/linkitDialog.js?v=7.2"></script>
<script src="https://opensource.com/misc/textarea.js?v=7.56"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/media.popups.js?v=7.x-2.8"></script>
<script src="https://opensource.com/modules/filter/filter.js?oxpik1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/modules/media_wysiwyg/js/media_wysiwyg.filter.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/rate/rate.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/google_analytics/googleanalytics.js?oxpik1"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-33294138-1", {"cookieDomain":".opensource.com"});ga("send", "pageview");</script>
<script src="//static.addtoany.com/menu/page.js"></script>
<script src="//newsharecounts.s3-us-west-2.amazonaws.com/nsc.js"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/jquery.hoverIntent.minified.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/sftouchscreen.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/supposition.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/superfish.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/supersubs.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/modules/contrib/superfish/superfish.js?oxpik1"></script>
<script src="https://opensource.com/sites/all/themes/opensource/js/script.js?oxpik1"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-39146 node-type-article region-content section-article page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<header class="header" id="header" role="banner">

    
    <div class="header-banner">
      <div class="header-banner__inner">
                  <div class="header__name-and-slogan" id="name-and-slogan">
                          <div class="header__site-name" id="site-name">
                <a href="/" title="Home" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/logo.svg" onerror="this.src='/sites/all/themes/opensource/logo.png';this.onerror=null;" /></a>
                <a href="http://www.redhat.com/en?intcmp=701600000011l7VAAQ" title="Home" class="header__sponsor-link" rel="home"><img alt="RedHat" src="/sites/all/themes/opensource/images/redhat-logo.svg" onerror="this.src='/sites/all/themes/opensource/images/redhat-logo.png';this.onerror=null;"/></a>
              </div>
            
                      </div>
                <nav class="desktop-user-links">
            <div class="header__region region region-header">
    <div id="block-menu-block-1" class="block block-menu-block first last odd" role="navigation">

      
  <div class="menu-block-wrapper menu-block-1 menu-name-user-menu parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-195"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-1179"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul></div>

</div>
  </div>
        </nav>
      </div>
    </div>

    <div class="sf-nav">
      <div class="sf-nav__inner">
          <div class="js-mobile-header-buttons region region-navigation-top">
    <div id="block-os-solr-search-form" class="block block-os-solr-search first odd">

      
  <form action="/article/17/10/perl-turns-30" method="post" id="os-search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search">
  <label class="element-invisible" for="edit-search">Search </label>
 <input title="Enter the terms you wish to search for." placeholder="Search opensource.com" type="text" id="edit-search" name="search" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="GO" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-5nAODnuIz8bat_RsaT7fRJKPQHi0wwIidZhILAFPWpA" />
<input type="hidden" name="form_id" value="os_search_block_form" />
</div>
</div></form>
</div>
<div id="block-superfish-1" class="block block-superfish even">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-default sf-total-items-5 sf-parent-items-5 sf-single-items-0"><li id="menu-1906-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-8 sf-parent-children-4 sf-single-children-4 menuparent"><a href="/" title="" class="sf-depth-1 menuparent">Articles</a><ul><li id="menu-12341-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/containers" title="" class="sf-depth-2">Containers</a></li><li id="menu-12346-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/gaming" title="" class="sf-depth-2">Gaming</a></li><li id="menu-12351-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/hardware" title="" class="sf-depth-2 menuparent">Hardware</a><ul><li id="menu-12376-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/3d-printing" title="" class="sf-depth-3">3D printing</a></li><li id="menu-12386-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/arduino" title="" class="sf-depth-3">Arduino</a></li><li id="menu-12381-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/raspberry-pi" title="" class="sf-depth-3">Raspberry Pi</a></li></ul></li><li id="menu-1946-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/tags/law" title="" class="sf-depth-2 menuparent">Law</a><ul><li id="menu-12391-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/licensing" title="" class="sf-depth-3">Licensing</a></li><li id="menu-12396-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/patents" title="" class="sf-depth-3">Patents</a></li></ul></li><li id="menu-12356-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/tags/linux" title="" class="sf-depth-2">Linux</a></li><li id="menu-12361-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/tags/openstack" title="" class="sf-depth-2">OpenStack</a></li><li id="menu-12366-1" class="middle odd sf-item-7 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/programming" title="" class="sf-depth-2 menuparent">Programming</a><ul><li id="menu-12411-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/javascript" title="" class="sf-depth-3">JavaScript</a></li><li id="menu-12401-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/perl" title="" class="sf-depth-3">Perl</a></li><li id="menu-12406-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/python" title="" class="sf-depth-3">Python</a></li></ul></li><li id="menu-12371-1" class="last even sf-item-8 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/tags/sysadmin" title="" class="sf-depth-2 menuparent">SysAdmin</a><ul><li id="menu-12416-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/devops" title="" class="sf-depth-3">DevOps</a></li></ul></li></ul></li><li id="menu-1921-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-8 sf-parent-children-2 sf-single-children-6 menuparent"><a href="/resources" title="" class="sf-depth-1 menuparent">Resources</a><ul><li id="menu-2016-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/resources/projects-and-applications" title="" class="sf-depth-2">Projects and applications</a></li><li id="menu-2026-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/conferences-and-events-monthly" title="" class="sf-depth-2">Conferences and events</a></li><li id="menu-2021-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/resources/organizations" title="" class="sf-depth-2">Organizations</a></li><li id="menu-5556-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-9 sf-parent-children-0 sf-single-children-9 menuparent"><a href="/resources/cloud" title="" class="sf-depth-2 menuparent">The open source cloud</a><ul><li id="menu-5576-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/resources/big-data" title="" class="sf-depth-3">Big data</a></li><li id="menu-5566-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/what-docker" title="" class="sf-depth-3">Docker</a></li><li id="menu-5591-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/resources/internet-of-things" title="" class="sf-depth-3">Internet of things</a></li><li id="menu-5596-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/resources/what-is-kubernetes" title="" class="sf-depth-3">Kubernetes</a></li><li id="menu-5571-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/what-are-linux-containers" title="" class="sf-depth-3">Linux containers</a></li><li id="menu-5586-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/resources/what-are-microservices" title="" class="sf-depth-3">Microservices</a></li><li id="menu-5561-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/resources/what-is-openstack" title="" class="sf-depth-3">OpenStack</a></li><li id="menu-5581-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/resources/what-is-software-defined-networking" title="" class="sf-depth-3">Software defined networking</a></li><li id="menu-12601-1" class="last odd sf-item-9 sf-depth-3 sf-no-children"><a href="/resources/virtualization" title="" class="sf-depth-3">Virtualization</a></li></ul></li><li id="menu-2036-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-11 sf-parent-children-0 sf-single-children-11 menuparent"><a href="/alternatives" title="" class="sf-depth-2 menuparent">Open source alternatives</a><ul><li id="menu-4646-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/alternatives/adobe-acrobat" class="sf-depth-3">Alternatives to Acrobat</a></li><li id="menu-4656-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/alternatives/autocad" class="sf-depth-3">Alternatives to AutoCAD</a></li><li id="menu-4636-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/alternatives/dreamweaver" class="sf-depth-3">Alternatives to Dreamweaver</a></li><li id="menu-5506-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/alternatives/gmail" class="sf-depth-3">Alternatives to Gmail</a></li><li id="menu-5551-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/alternatives/matlab" class="sf-depth-3">Alternatives to MATLAB</a></li><li id="menu-5501-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/alternatives/minecraft" class="sf-depth-3">Alternatives to Minecraft</a></li><li id="menu-4651-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/alternatives/picasa" class="sf-depth-3">Alternatives to Picasa</a></li><li id="menu-4661-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/alternatives/microsoft-publisher" class="sf-depth-3">Alternatives to Publisher</a></li><li id="menu-5511-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/alternatives/slack" class="sf-depth-3">Alternatives to Slack</a></li><li id="menu-4641-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/alternatives/trello" class="sf-depth-3">Alternatives to Trello</a></li><li id="menu-5546-1" class="last odd sf-item-11 sf-depth-3 sf-no-children"><a href="/alternatives" title="" class="sf-depth-3">More...</a></li></ul></li><li id="menu-2011-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/ebooks" title="" class="sf-depth-2">eBooks</a></li><li id="menu-16886-1" class="middle odd sf-item-7 sf-depth-2 sf-no-children"><a href="/irc-cheat-sheet" class="sf-depth-2">IRC Cheat Sheet</a></li><li id="menu-12466-1" class="last even sf-item-8 sf-depth-2 sf-no-children"><a href="/yearbook/2016" title="" class="sf-depth-2">Open Source Yearbook</a></li></ul></li><li id="menu-4691-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/about" class="sf-depth-1 menuparent">About</a><ul><li id="menu-1991-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-source-way" class="sf-depth-2">The Open Source Way</a></li><li id="menu-1971-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/opensourcecom-team" class="sf-depth-2">Meet the team</a></li><li id="menu-2006-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/press-kit" class="sf-depth-2">Press kit</a></li><li id="menu-2001-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/contact" title="" class="sf-depth-2">Contact</a></li></ul></li><li id="menu-12511-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-6 sf-parent-children-2 sf-single-children-4 menuparent"><a href="/tags/opensourcecom-community" title="" class="sf-depth-1 menuparent">Community</a><ul><li id="menu-12516-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/participate" class="sf-depth-2 menuparent">Join the community</a><ul><li id="menu-12521-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/user/register" title="" class="sf-depth-3">Register</a></li><li id="menu-12526-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/rules-comments-and-discussions" title="" class="sf-depth-3">Rules for comments and discussions</a></li><li id="menu-12531-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/community-moderator-program" title="" class="sf-depth-3">Community Moderator program</a></li><li id="menu-12541-1" class="last even sf-item-4 sf-depth-3 sf-no-children"><a href="/points-and-badges" class="sf-depth-3">Points and badges</a></li></ul></li><li id="menu-12546-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/editorial-calendar" title="" class="sf-depth-2">Editorial calendar</a></li><li id="menu-12556-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/writer-testimonials" class="sf-depth-2">Writer testimonials</a></li><li id="menu-1966-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/writers" class="sf-depth-2 menuparent">Guides for writers</a><ul><li id="menu-2041-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/submission-style-guide" class="sf-depth-3">Article submission and style guide</a></li><li id="menu-4616-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/promoting-articles" class="sf-depth-3">Tips for promoting your Opensource.com article</a></li><li id="menu-12586-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/community/16/8/editorial-writing-topics" title="" class="sf-depth-3">Writing topics</a></li></ul></li><li id="menu-12581-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/resources/contributor-club" title="" class="sf-depth-2">Contributor Club</a></li><li id="menu-17761-1" class="last even sf-item-6 sf-depth-2 sf-no-children"><a href="/how-submit-article" class="sf-depth-2">Write for us</a></li></ul></li><li id="menu-2136-1" class="last odd sf-item-5 sf-depth-1 sf-total-children-5 sf-parent-children-3 sf-single-children-2 menuparent"><a href="/open-organization" title="" class="sf-depth-1 menuparent">The Open Org</a><ul><li id="menu-12471-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="sf-depth-2">What is an open organization?</a></li><li id="menu-15056-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-maturity-model" title="" class="sf-depth-2">How open is your organization?</a></li><li id="menu-15051-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/open-organization/resources/book-series" title="" class="sf-depth-2 menuparent">Book series</a><ul><li id="menu-16896-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/culture-change" class="sf-depth-3">Guide to IT Culture Change download</a></li><li id="menu-16891-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/leaders-manual" class="sf-depth-3">Leaders Manual download</a></li><li id="menu-16901-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/catalyst-in-chief" class="sf-depth-3">Catalyst in Chief download</a></li><li id="menu-16906-1" class="last even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/field-guide" class="sf-depth-3">Field guide download</a></li></ul></li><li id="menu-2146-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-7 sf-parent-children-0 sf-single-children-7 menuparent"><a href="/open-organization/resources" title="" class="sf-depth-2 menuparent">Resources</a><ul><li id="menu-2181-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/what-open-organization" title="" class="sf-depth-3">What is The Open Organization?</a></li><li id="menu-12421-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/open-decision-framework" title="" class="sf-depth-3">What is the Open Decision Framework?</a></li><li id="menu-2151-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/guides" title="" class="sf-depth-3">Discussion guide download</a></li><li id="menu-2246-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/faq" title="" class="sf-depth-3">Open Org FAQs</a></li><li id="menu-4606-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/twitter-chats" title="" class="sf-depth-3">Twitter chats</a></li><li id="menu-3201-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/reading-list" title="" class="sf-depth-3">Reading list</a></li><li id="menu-2256-1" class="last odd sf-item-7 sf-depth-3 sf-no-children"><a href="/open-organization/resources/2015-book-club" title="" class="sf-depth-3">Book club</a></li></ul></li><li id="menu-3166-1" class="last odd sf-item-5 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/open-organization/resources/ambassadors-program" title="" class="sf-depth-2 menuparent">Ambassadors program</a><ul><li id="menu-2691-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/meet-ambassadors" title="" class="sf-depth-3">Meet the ambassadors</a></li></ul></li></ul></li></ul>
</div>
<div id="block-system-user-menu" class="block block-system block-menu odd" role="navigation">

      
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf last leaf"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
</ul>
</div>
<div id="block-menu-block-2" class="block block-menu-block last even" role="navigation">

      
  <div class="menu-block-wrapper menu-block-2 menu-name-menu-social-links parent-mlid-0 menu-level-1">
  <ul class="menu"><li class="menu__item is-leaf first leaf menu-mlid-13171"><a href="http://twitter.com/opensourceway" title="twitter" class="menu__link">Twitter</a></li>
<li class="menu__item is-leaf leaf menu-mlid-13176"><a href="https://www.facebook.com/opensourceway" title="facebook" class="menu__link">Facebook</a></li>
<li class="menu__item is-leaf last leaf menu-mlid-13166"><a href="/feed" title="feed" class="menu__link">Feed</a></li>
</ul></div>

</div>
  </div>

        <div class="mobile--menu-region">
            <div class="region region-navigation">
    <div id="block-system-main-menu" class="block block-system block-menu first last odd" role="navigation">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/" title="" class="menu__link">Articles</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/containers" title="" class="menu__link">Containers</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/gaming" title="" class="menu__link">Gaming</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/hardware" title="" class="menu__link">Hardware</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/3d-printing" title="" class="menu__link">3D printing</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/arduino" title="" class="menu__link">Arduino</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/raspberry-pi" title="" class="menu__link">Raspberry Pi</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/law" title="" class="menu__link">Law</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/linux" title="" class="menu__link">Linux</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/openstack" title="" class="menu__link">OpenStack</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/programming" title="" class="menu__link">Programming</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/javascript" title="" class="menu__link">JavaScript</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/perl" title="" class="menu__link">Perl</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/python" title="" class="menu__link">Python</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded"><a href="/tags/sysadmin" title="" class="menu__link">SysAdmin</a><ul class="menu"><li class="menu__item is-leaf first last leaf"><a href="/tags/devops" title="" class="menu__link">DevOps</a></li>
</ul></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/projects-and-applications" title="" class="menu__link">Projects and applications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/conferences-and-events-monthly" title="" class="menu__link">Conferences and events</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/organizations" title="" class="menu__link">Organizations</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/resources/cloud" title="" class="menu__link">The open source cloud</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/alternatives" title="" class="menu__link">Open source alternatives</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/ebooks" title="" class="menu__link">eBooks</a></li>
<li class="menu__item is-leaf leaf"><a href="/irc-cheat-sheet" class="menu__link">IRC Cheat Sheet</a></li>
<li class="menu__item is-leaf last leaf"><a href="/yearbook/2016" title="" class="menu__link">Open Source Yearbook</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/about" class="menu__link">About</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/opensourcecom-community" title="" class="menu__link">Community</a></li>
<li class="menu__item is-expanded last expanded"><a href="/open-organization" title="" class="menu__link">The Open Org</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="menu__link">What is an open organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-org-maturity-model" title="" class="menu__link">How open is your organization?</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/open-organization/resources/book-series" title="" class="menu__link">Book series</a></li>
<li class="menu__item is-expanded expanded"><a href="/open-organization/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/what-open-organization" title="" class="menu__link">What is The Open Organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-decision-framework" title="" class="menu__link">What is the Open Decision Framework?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/guides" title="" class="menu__link">Discussion guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/faq" title="" class="menu__link">Open Org FAQs</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/twitter-chats" title="" class="menu__link">Twitter chats</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/reading-list" title="" class="menu__link">Reading list</a></li>
<li class="menu__item is-leaf last leaf"><a href="/open-organization/resources/2015-book-club" title="" class="menu__link">Book club</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/open-organization/resources/ambassadors-program" title="" class="menu__link">Ambassadors program</a></li>
</ul></li>
</ul>
</div>
  </div>
        </div>
      </div>
    </div>

</header>

<div id="page">

      <div id="main">
        <div class="pre-content">
                                                </div>
        <div id="content" class="column" role="main">
                              <a id="main-content"></a>
                                <h1 class="page__title title" id="page-title">Perl turns 30</h1>
                              



<div class="panel-display os-article clearfix os-article--with-image " id="article-template">

      <div class="os-article__top">
      <div class="os-article__top-inner">
        <div class="panel-pane pane-node-title" >
  
      
  
  <h1>Perl turns 30 and its community continues to thrive</h1>

  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-article-subhead" >
  
      
  
  <div class="field field-name-field-article-subhead field-type-text-long field-label-hidden">
    <div class="field-items">
          <h2>Created for utility and known for its dedicated users, Perl has proven staying power. Here&#039;s a brief history of the language and a look at some top user groups.</h2>
      </div>
</div>

  
  </div>
<div class="panel-pane pane-os-article-byline" >
  
      
  
  <div class="byline"><span class="byline__thumbnail"><a href="/users/druthb"><img class="byline-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/byline_thumbnail/public/pictures/dsc_0028.jpg?itok=VMbubnK2" width="50" height="50" alt="" title="Ruth Holloway" /></a></span>
<span class="byline__date">11 Oct 2017</span>
<span class="byline__author"><a href="/users/druthb" title="View user profile." class="username" xml:lang="" about="/users/druthb" typeof="sioc:UserAccount" property="foaf:name" datatype="">Ruth Holloway</a>&nbsp;<span class="byline__feed"><a href="/user/36051/feed">Feed</a></span>
</span>
<span class="byline__social"><span class="byline__voting-widget"><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-70181c460e34c17a49d57f335fccb517 rate-node-39146-1-1" id="rate-node-39146-1-1"><div class="rate-info">7</div><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/17/10/perl-turns-30?rate=kGEAtvU2zltcVH20DTxd2VmrGCoLLlKuzpG9-iG39q8" title="up">up</a></div></span>
</span>
</div>
  
  </div>
      </div>
    </div>
  
      <div class="os-article__image">
      <div class="panel-pane pane-entity-field pane-node-field-lead-image" >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/camel-perl-lead.png?itok=VyEv-C5o"><img class="image-full-size" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/image-full-size/public/lead-images/camel-perl-lead.png?itok=VyEv-C5o" width="520" height="292" alt="30 years on, Perl and its community continue to thrive" title="30 years on, Perl and its community continue to thrive" /></div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-file-field-file-image-caption" >
  
      
  
  <div class="field field-name-field-file-image-caption field-type-text-long field-label-inline clearfix"><div class="field-label">Image by :&nbsp;</div><div class="field-items"><div class="field-item even"><p><a href="https://www.flickr.com/photos/internetarchivebookimages/14760695741/in/photolist-oumqAa-hWgvqA-osL7YA-idkh78-odfLk5-od7JFa-oeS4Ad-oy6GQT-otFi5E-oxgJW2-od9fPq-ovfdoo-ouCN6c-ouNb46-ovbwce-owfpfN-ov6diQ-osTse5-otsMf3-ocKEiy-ouXLik-ow3onM-owqk2r-ouQJpS-ovvs3Z-owWJeZ-owfT1s-oy9bMv-od8xbL-oeTtKd-oeQ4mD-owSTJ8-ouAPcL-odE3nu-odZKnY-otRz8u-ouNurg-owopwK-tAxD42-ovwKYg-owkaCq-ouiBW3-ouRpBu-oeV3W8-odw4Z4-oufBcf-odPRAt-oeRd2x-oeWncf-otptgW" target="_blank">Internet Archive Book Images</a>. Modified by Opensource.com. <a href="https://creativecommons.org/licenses/by-sa/4.0/" target="_blank">CC BY-SA 4.0</a></p>
</div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__middle">
      <div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:articleBody content:encoded"><p>Larry Wall released Perl 1.0 to the comp.sources.misc Usenet newsgroup on December 18, 1987. In the nearly 30 years since then, both the language and the community of enthusiasts that sprung up around it have grown and thrived—and they continue to do so, despite suggestions to the contrary!</p>
<p>Wall's fundamental assertion—<em>there is more than one way to do it</em>—continues to resonate with developers. Perl allows programmers to embody the three chief virtues of a programmer: laziness, impatience, and hubris. Perl was originally designed for utility, not beauty. Perl is a programming language for fixing things, for quick hacks, and for making complicated things possible partly through the power of community. This was a conscious decision on Larry Wall's part: In an interview in 1999, he posed the question, "When's the last time you used duct tape on a duct?"</p>
<h2>A history lesson</h2>
<h3>Perl 1.0 - Perl 4.036</h3>
<p><div class="embedded-callout-text callout-float-right">Perl allows programmers to embody the three chief virtues of a programmer: laziness, impatience, and hubris.</div>Larry Wall developed the first Perl interpreter and language while working for System Development Corporation, later a part of Unisys. Early releases focused on the tools needed for the system engineering problems that he was trying to solve. Perl 2's release in 1988 made improvements on the regular expression engine. Perl 3, in 1989, added support for binary data streams. In March of 1991, Perl 4 was released, along with the first edition of <a href="http://shop.oreilly.com/product/9780596004927.do" target="_blank"><em>Programming Perl</em></a>, by Larry Wall and Randal L. Schwartz. Prior to Perl 4, the documentation for Perl had been maintained in a single document, but the O'Reilly-published "Camel Book," as it is called, continues to be the canonical reference for the Perl language. As Perl has changed over the years, <em>Programming Perl</em> has been updated, and it is now in its fourth edition.</p>
<h3>Early Perl 5</h3>
<p>Perl 5.000, released on October 17, 1994, was a nearly complete rewrite of the interpreter. New features included objects, references, lexical variables, and the use of external, reusable modules. This new modularity provides a tool for growing the language without modifying the underlying interpreter. Perl 5.004 introduced CGI.pm, which contributed to its use as an early scripting language for the internet. Many Perl-driven internet applications and sites still in use today emerged about this time, including IMDB, Craigslist, Bugzilla, and cPanel.</p>
<h3>Modern Perl 5</h3>
<p>Perl version 5.10 of Perl was released on the 20th anniversary of Perl 1.0: December 18, 2007. Version 5.10 marks the start of the "Modern Perl" movement. Modern Perl is a style of development that takes advantage of the newest language features, places a high importance on readable code, encourages testing, and relies heavily on the use of the CPAN ecosystem of contributed code. Development of Perl 5 continues along more modern lines, with attention in recent years to Unicode compatibility, JSON support, and other useful features for object-oriented coders.</p>
<h3>Perl 6</h3>
<p>On July 19, 2000, Larry Wall announced at the Perl Conference that he was interested in working on Perl 6, a redesign of the language, with the goal of removing historical warts from the language. Fifteen years later, in December of 2015, Perl 6 1.0 was released. Perl 6 is not backward-compatible with Perl 5, and although intended as a replacement, the Perl 6 team is in no great hurry for Perl 5 to be obsolete. "As for whether Perl 6 will replace Perl 5, yeah, probably, in about 40 years or so," Larry Wall said in an <a href="https://www.infoworld.com/article/3017418/application-development/developers-can-unwrap-perl-6-on-christmas.html" target="_blank">InfoWorld interview</a> in 2015. There have been starts and stops with several implementations of Perl 6, but only one remains under active development: <a href="http://rakudo.org/" target="_blank">Rakudo Perl 6</a>. Because Perl 6 is solely a specification (unlike all prior Perl), it is possible that many implementations could emerge. As the <a href="http://design.perl6.org/S01.html" target="_blank">original design documents</a> state, "Perl 6 is anything that passes the official test suite."</p>
<h2>The Perl community</h2>
<p>I have heard it said many times in the years I have been involved in the Perl community: Perl is about people. The people who create, maintain, support, and use Perl jointly create an environment where developers can learn and thrive, each working on the things that interest them.</p>
<h3>Larry Wall, the man who started it all</h3>
<p>At the center of it all, of course, is Larry Wall. Larry and his wife Gloria travel all over the world to Perl and other technical events. When I first joined the Perl community, there seemed to be a bit of hero worship going on around him, but Larry does not particularly enjoy that aspect of his notoriety. He's a kind, soft-spoken, brilliant man who enjoys coding and the community that has developed around his work. These days you'll usually see him wearing a broad-brimmed hat and bold print shirts; he's hard to miss even in a crowd as eclectic as the Perl community.</p>
<h3>
<div class="media media-element-container media-default media-wysiwyg-align-center">
<div id="file-370746" class="file file-image file-image-jpeg">
<h2 class="element-invisible"><a href="/file/370746">image_larry_wall.jpg</a></h2>
<div class="content">
    <img alt="Larry Wall, creator of Perl" title="Larry Wall image" class="media-element file-default" data-delta="1" typeof="foaf:Image" src="https://opensource.com/sites/default/files/images/life-uploads/image_larry_wall.jpg" width="2048" height="1363" /><br />
<div class="field field-name-field-file-image-caption field-type-text-long field-label-hidden">
<div class="field-items">
<div class="field-item even">
<p class="rtecenter"><sup>Larry Wall, creator of Perl (photo credit: Chris Jack, with permission: CC-BY-SA 4.0)</sup></p>
</div>
</div>
</div>
</div>
</div>
</div>
</h3>
<p>The son and grandson of pastors, Larry is himself a Christian. That heritage of ideas informs some of his work and advocacy on Perl, including the "idea that other people are important." He and his wife both attended graduate school in linguistics at Berkeley and UCLA and were planning to become missionaries, but they were forced to give up that dream for health reasons. Wall said in a 1999 Linux Journal <a href="https://www.linuxjournal.com/article/3394" target="_blank">interview</a>, "Funny thing is, now the missionaries probably get more good out of Perl than they'd have gotten out of me as a missionary. Go figure."</p>
<p>I was privileged to moderate a Q&amp;A session featuring Larry at YAPC::NA 2016, in Orlando, Florida, and got to spend time with him and Gloria. After that meeting, I am honored to call them both my friends. If you ever get a chance to spend time talking to this amazing couple, do so; your life will be enriched by the experience.</p>
<h3>Perl 5 Porters</h3>
<p>In May of 1994, the Perl 5 Porters email list was founded as a place to coordinate work on porting Perl 5 to different platforms. P5P, as it is now known, is the primary mailing list for discussion about maintenance and development of the standard distributions of Perl. A number of the "porters" are active <a href="irc://irc.perl.org/#p5p" target="_blank">on IRC</a> as well. The current overseer of this process is called the "Pumpking" or the "Holder of the <a href="http://perldoc.perl.org/perlhist.html#PUMPKIN%3f" target="_blank">Pumpkin.</a>" The current Pumpking is <a href="https://twitter.com/perlsawyer" target="_blank">Sawyer X</a>, who is also involved in <a href="http://perldancer.org" target="_blank">the Dancer project</a>, which I wrote about a couple of years ago on <a href="https://opensource.com/business/15/9/taking-spin-dancer-lightweight-perl-web-application-framework" target="_blank">Opensource.com</a>. P5P discussions can be energetic at times; there are a lot of talented people in there, many of whom have strong opinions. If you're looking for knowledge about the core workings of Perl, though, P5P is where that magic is wrought.</p>
</p>
<div class="media media-element-container media-default">
<div id="file-370751" class="file file-image file-image-jpeg">
<h2 class="element-invisible"><a href="/file/370751">image_sawyer.jpg</a></h2>
<div class="content">
    <img alt="Sawyer X, Perl 5 Pumpking" title="Sawyer X, Perl 5 Pumpking" class="media-element file-default" data-delta="2" typeof="foaf:Image" src="https://opensource.com/sites/default/files/images/life-uploads/image_sawyer.jpg" width="1363" height="2048" /><br />
<div class="field field-name-field-file-image-caption field-type-text-long field-label-hidden">
<div class="field-items">
<div class="field-item even">
<p class="rtecenter"><sup>Sawyer X, Perl 5 Pumpking (photo credit: Chris Jack, with permission: CC-BY-SA 4.0)</sup></p>
</div>
</div>
</div>
</div>
</div>
</div>
<h3>Perl Mongers</h3>
<p>In 1997, a group of Perl enthusiasts from the New York City area met at the first O'Reilly Perl Conference (which later became OSCON), and formed the New York Perl Mongers, or <a href="https://www.meetup.com/The-New-York-Perl-Meetup-Group/" target="_blank">NY.pm</a>. The ".pm" suffix for Perl Mongers groups is a play on the fact that shared-code Perl files are suffixed .pm, for "Perl module." The <a href="https://www.pm.org" target="_blank">Perl Mongers</a> organization has, for the past 20 years, provided a framework for the foundation and nurturing of local user groups all over the world and currently boasts of 250 Perl monger groups. Individual groups, or groups working as a team, sponsor and host conferences, hackathons, and workshops from time to time, as well as local meetings for technical and social discussions.</p>
<h3>PerlMonks</h3>
<p><div id="programming-and-development" class="embedded-callout-menu callout-float-right"><div class="view view-related-content-callout view-id-related_content_callout view-display-id-article_block view-dom-id-e9e1e411ee0863b3f7782b8bd7797d7e">
            <div class="view-header">
      <p>Programming and development</p>
    </div>
  
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">      
  <div class="views-field views-field-field-related-content-link">        <div class="field-content"><div class="item-list"><ul><li class="first"><a href="https://opensource.com/tags/python?src=programming_resource_menu1">New Python content</a></li>
<li><a href="https://opensource.com/tags/javascript?src=programming_resource_menu2">Our latest JavaScript articles</a></li>
<li><a href="https://opensource.com/tags/perl?src=programming_resource_menu3">Recent Perl posts</a></li>
<li class="last"><a href="https://developers.redhat.com/?intcmp=7016000000127cYAAQ&amp;src=programming_resource_menu4">Red Hat Developers Blog</a></li>
</ul></div></div>  </div>  </div>    </div>
  
  
  
  
  
  
</div></div>Have a question? Want to read the wisdom of some of the gurus of Perl? Check out <a href="http://perlmonks.org" target="_blank">PerlMonks</a>. You'll find numerous tutorials, a venue to ask questions and get answers from the community, along with lighthearted bits about Perl and the Perl community. The software that drives PerlMonks is getting a little long in the tooth, but the community continues to thrive, with new posts daily and a humorous take on the religious fervor that developers express about their favorite languages. As you participate, you gain <a href="http://perlmonks.org/?node=Levels%20of%20Monks" target="_blank">points and levels</a>. The <a href="http://perlmonks.org/?node=Meditations" target="_blank">Meditations</a> contains discussions about Perl, hacker culture, or other related things; some include suggestions and ideas for new features.</p>
<h3>CPAN</h3>
<p>Perl, like many other languages, is modular; new capabilities can be created and installed without having to update the core interpreter. The <a href="http://cpan.org" target="_blank">Consolidated Perl Archive Network</a>, founded in 1993 and online since October 1995, was created to help unify the assortment of scattered archives of Perl modules. The repository is mirrored on more than 250 servers around the world, and it currently contains almost 200,000 modules from over 13,000 authors. New releases of module distributions <a href="https://metacpan.org/recent" target="_blank">are uploaded daily</a>. One of CPAN's interesting artifacts is the Acme:: namespace. Acme:: is the area of CPAN reserved for experiments, entertaining-but-useless modules, frivolous, or trivial ideas. An article <a href="https://opensource.com/life/16/10/trick-or-treat-funny-perl-modules" target="_blank">on Opensource.com</a> from 2016 looked at a few of these modules just for fun. You can search the CPAN at <a href="http://metacpan.org" target="_blank">MetaCPAN</a> for anything you might need.</p>
<h3>The Perl Foundation</h3>
<p>In 1999, Kevin Lenzo founded the "Yet Another Society," which has become known as <a href="http://perlfoundation.org" target="_blank">The Perl Foundation</a>. The original intent was to assist in grassroots efforts for events in the North American Perl Conferences, including banking and organizational needs. The focus has since shifted, and TPF now offers grants for extending and improving both Perl 5 and Perl 6. The Perl Foundation also awards the <a href="https://www.perl.org/advocacy/white_camel/" target="_blank">White Camel</a>, in recognition of significant non-code contributions to the Perl community.</p>
<h3>YAPC Europe Foundation</h3>
<p>The <a href="http://yapceurope.org/" target="_blank">YEF</a> was formed in 2003 to help grow the European Perl community, primarily through public events. The YEF supports local Perl Mongers groups in efforts to sponsor conferences through providing online payment and registration system and kickstart donations. Their efforts support frequent workshops and hackathons in Europe, as well as the annual Perl Conference.</p>
<h3>Japan Perl Association</h3>
<p>The <a href="http://japan.perlassociation.org/" target="_blank">Japan Perl Association</a> helps promote Perl technology and culture in Asia through advocacy and sponsorship of the annual YAPC::Asia conference, frequently the world's largest conference on Perl. For many years, the conference was held in Tokyo, but it has recently started moving to other locations in Japan.</p>
<h3>Enlightened Perl Organisation</h3>
<p>Working in parallel with The Perl Foundation, the <a href="https://enlightenedperl.org" target="_blank">Enlightened Perl Organisation</a> works to support Perl projects that help Perl remain an enterprise-grade platform for development. EPO focuses its attention on code, toolchain elements, documentation, promotional materials, and tutorials that make corporate adoption of Perl easier. In addition to sponsorship of the London Perl Workshop and the <a href="http://strawberryperl.com" target="_blank">Strawberry Perl</a> initiative, the Enlightened Perl Organisation has provided substantial funding for the CPAN Testers. The Testers are a group of developers who test CPAN modules against many versions of Perl, on numerous OS platforms. The EPO also sponsors a Send-A-Newbie program, providing funding for first-time attendees to Perl conferences.</p>
<h3>YAPC and the Perl Conferences</h3>
<p>The first O'Reilly Perl Conference was held in 1997. In 1999, O'Reilly added additional open source content to the program, and that conference became known as <a href="https://conferences.oreilly.com/oscon" target="_blank">OSCON</a>. The first <a href="http://yapc.org" target="_blank">Yet Another Perl Conference</a> was held in June of that year, in Pittsburgh, and has been held in North America every year since. Additional similar conferences were organized in Europe starting in 2000, in Israel since 2003, in Australia since 2004, in Asia and Brazil since 2005, and in Russia since 2008.</p>
<p>The name "The Perl Conference" is owned by O'Reilly, but in 2016, it was announced that an agreement had been reached to allow use of the name for the YAPC conferences, beginning with the 2017 conferences. At each conference, speakers present on Perl and other development-related topics, and there are usually educational workshops before or after the conference. The North American and European conferences generally include 300-400 attendees. The conferences usually have content for both new Perl developers and substantial opportunities for core developers and other community members to interact and collaborate as well as present on their own work.</p>
<h2>A tried-and-true technology...and so much more</h2>
<p>As Perl turns 30, the community that emerged around Larry Wall's solution to sticky system administration problems continues to grow and thrive. New developers enter the community all the time, and substantial new work is being done to modernize the language and keep it useful for solving a new generation of problems. Interested? Find your local Perl Mongers group, or join us online, or attend a Perl Conference near you!</p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-tags" >
  
        <h2 class="pane-title">Topics</h2>
    
  
  <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:keywords"><a href="/tags/perl" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Perl</a></div><div class="field-item odd" rel="schema:keywords"><a href="/tags/programming" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Programming</a></div><div class="field-item even" rel="schema:keywords"><a href="/tags/yearbook" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">Yearbook</a></div><div class="field-item odd" rel="schema:keywords"><a href="/yearbook/2017" typeof="skos:Concept" property="rdfs:label skos:prefLabel" datatype="">2017 Open Source Yearbook</a></div></div></div>
  
  </div>
<div class="panel-pane pane-views-panes pane-author-info-panel-pane-1" >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-c0dbabc68ab18b970a3cb18b3a28115a">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><a href="/users/druthb"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/pictures/dsc_0028.jpg?itok=RS0GBh25" width="100" height="100" alt="" /></a></div>
<div class="authorbio__content">
  <span class="authorbio__name">Ruth Holloway</span> - <span class="authorbio__about">Ruth Holloway has been a system administrator and software developer for a long, long time, getting her professional start on a VAX 11/780, way back when. She spent a lot of her career (so far) serving the technology needs of libraries, and has been a contributor since 2008 to the Koha open source library automation suite.Ruth is currently a Perl Developer at cPanel in Houston, and also serves as chief of staff for an obnoxious cat. In her copious free time, she occasionally reviews old romance... <a href="/users/druthb" class="views-more-link">more about Ruth Holloway</a></span>
  <div class="authorbio__more-link"><a href="/users/druthb">More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-article-contributions" >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block" >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__bottom">
      <div class="panel-pane pane-views-panes pane-related-articles-panel-pane-1" >
  
        <h2 class="pane-title">Recommended reading</h2>
    
  
  <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 related-content view-dom-id-24996aaffc99889c67afca35938a10f5">
        
  
  
      <div id="related-content-footer" class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/10/set-postgres-database-your-raspberry-pi"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/raspiresources.png?itok=R2xq9qP3" width="314" height="177" alt="How to set up a Postgres database on a Raspberry Pi" title="How to set up a Postgres database on a Raspberry Pi" /><br />
How to set up a Postgres database on a Raspberry Pi</a></span>  </div>  </div>  <div class="views-row views-row-2 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/10/many-eyes"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/owl-eyes-watch-lead.png?itok=h2UR-8cd" width="315" height="177" alt="Disbelieving the &#039;many eyes&#039; hypothesis" title="Disbelieving the &#039;many eyes&#039; hypothesis" /><br />
Review by many eyes does not always prevent buggy code</a></span>  </div>  </div>  <div class="views-row views-row-3 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/resources/python/web-scraper-crawler"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/openweb-osdc-lead.png?itok=44wA54RN" width="315" height="177" alt="Python web scrapers and crawlers" title="Python web scrapers and crawlers" /><br />
3 Python web scrapers and crawlers</a></span>  </div>  </div>  <div class="views-row views-row-4 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/9/seven-stages-becoming-go-programmer"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/computer_keyboard_laptop_development_blue.png?itok=adXB6L3J" width="315" height="177" alt="The 7 stages of becoming a Go programmer" title="The 7 stages of becoming a Go programmer" /><br />
The 7 stages of becoming a Go programmer</a></span>  </div>  </div>  <div class="views-row views-row-5 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/9/programming-skills-poll"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/code_development_programming.png?itok=c9O1iKgN" width="315" height="177" alt="How strong are your programming skills?" title="How strong are your programming skills?" /><br />
How strong are your programming skills?</a></span>  </div>  </div>  <div class="views-row views-row-6 views-row-even views-row-last">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/9/introduction-machine-learning"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/lead-images/code_computer_development_programming.png?itok=-_hvKz9r" width="315" height="177" alt="An introduction to machine learning today" title="An introduction to machine learning today" /><br />
An introduction to machine learning today</a></span>  </div>  </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
    </div>
  
      <div class="os-article__footer">
      <div class="panel-pane pane-node-comment-form" >
  
        <h2 class="pane-title">Comment now</h2>
    
  
  <form class="comment-form user-info-from-cookie" action="/article/17/10/perl-turns-30#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div id="edit-login-register" class="form-item form-type-item">
 <a href="/user/login?destination=node/39146">Login or Register</a> to earn points for your comments.
</div>
<div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<input type="hidden" name="form_build_id" value="form-tH9x70MxU1-1kYDLaZ5Ub2yiYG9V5NwfjOQ9PpUaBxU" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<input type="hidden" name="honeypot_time" value="1507806353|zQruINjpq7oXnvG0b38Ks8dj47zoRfgWxuAZfHQdoho" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/legal">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><fieldset class="captcha form-wrapper"><legend><span class="fieldset-legend">CAPTCHA</span></legend><div class="fieldset-wrapper"><div class="fieldset-description">This question is for testing whether or not you are a human visitor and to prevent automated spam submissions.</div><input type="hidden" name="captcha_sid" value="15176546" />
<input type="hidden" name="captcha_token" value="e2fb61c26befaf7edb97ff0ab664ed42" />
<input type="hidden" name="captcha_response" value="Google no captcha" />
<div class="g-recaptcha" data-sitekey="6LesbSsUAAAAADyjn9uKvVRcgzGOWNYA-wUExJ-v" data-theme="light" data-type="image"></div></div></fieldset>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div><div class="url-textfield"><div class="form-item form-type-textfield form-item-url">
  <label for="edit-url">Leave this field blank </label>
 <input autocomplete="off" type="text" id="edit-url" name="url" value="" size="20" maxlength="128" class="form-text" />
</div>
</div></div></form>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-default-license" >
  
      
  
  <div class="field field-name-field-default-license field-type-text field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:license"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" style="border-width:0" src="/sites/all/themes/opensource/images/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a></div></div></div>
  
  </div>
    </div>
  
</div>
                  </div>


        
        
      </div>

        <div class="region region-pre-footer">
    <div id="block-os-common-components-footer-call-to-action" class="block block-os-common-components first last odd">

      
  
<div class="fieldable-panels-pane cta cta--green-on-blue cta--with-link">

  <div class="cta__content cta__content--with-link">
                <h2 class="cta__title">Share your sysadmin tricks</h2>
<div class="field field-name-field-cta-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>Send us home-grown sysadmin scripts. Submit an article proposal today.</p>
</div></div></div>  </div>

  <div class="cta__link">
    <div class="field field-name-field-cta-link field-type-link-field field-label-hidden"><div class="field-items"><div class="field-item even"><a href="https://opensource.com/how-submit-article?utm_source=intcta">Learn more</a></div></div></div>  </div>
</div>


</div>
  </div>

        <div class="region region-footer-nav">
    <div id="block-bean-social-media" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/social-media" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><span>Find us:</span> 
</p>
<ul>
<li><a class="footer-twitter" href="https://twitter.com/OpenSourceWay" title="Twitter">Twitter</a></li>
<li><a class="footer-facebook" href="https://www.facebook.com/opensourceway" title="Facebook">Facebook</a></li>
<li><a class="footer-gplus" href="https://plus.google.com/108750398488318674353" title="Google Plus">Google Plus</a></li>
<li><a class="footer-instagram" href="https://www.instagram.com/opensourceway/" title="Instagram">Instagram</a></li>
<li><a class="footer-youtube" href="http://www.youtube.com/opensourceway" title="Youtube">Youtube</a></li>
<li><a class="footer-linkedin" href="https://www.linkedin.com/grps/Open-Source-Professionals-Advocates-2769297" title="LinkedIn">LinkedIn</a></li>
<li><a class="footer-irc" href="/join-us-irc" title="IRC">IRC</a></li>
<li><a class="footer-feed" href="/feed" title="RSS">RSS</a></li>
</ul>
</div></div></div>  </div>
</div>

</div>
<div id="block-menu-menu-footer" class="block block-menu last even" role="navigation">

        <h2 class="block__title block-title">Footer</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/legal" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact" class="menu__link">Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="/opensourcecom-team" title="" class="menu__link">Meet the Team</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://opensource.org/" title="" class="menu__link">Visit opensource.org</a></li>
</ul>
</div>
  </div>

        <footer id="footer" class="region region-footer">
    <div id="block-bean-copyrigt-block" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/copyrigt-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>For more discussion on open source and the role of the CIO in the enterprise, join us at <a href="http://enterprisersproject.com">The EnterprisersProject.com</a>.</p>
<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>
<p>Opensource.com aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Shadowman logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div></div></div>  </div>
</div>

</div>
<div id="block-bean-footer-logo" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/footer-logo" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><img src="/sites/all/themes/opensource/images/footer_logo.svg" /></p>
</div></div></div>  </div>
</div>

</div>
  </footer>

    </div>

    
      <div class="region region-os-social">
    <div id="block-os-social-os-social-share" class="block block-os-social first last odd">

      
  <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div>
</div>
  </div>
    <div class="region region-page-bottom">
    <!-- begin Google Remarketing --><img height="1" width="1" style="border-style:none;display:block;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" onerror="this.src='/sites/all/themes/opensource/images/1x1.png';this.onerror=null" /><!-- end Google Remarketing -->  </div>
<script src="https://opensource.com/sites/all/modules/contrib/media_ckeditor/js/plugins/media/library.js?oxpik1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_widgets/panopoly-widgets.js?oxpik1"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_widgets/jquery-ui-tabs-rotate.js?oxpik1"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script>var a2a_config = a2a_config || {};
              a2a_config.callbacks = a2a_config.callbacks || [];
a2a_config.templates = {
    twitter: "Perl turns 30 and its community continues to thrive http://red.ht/2xYg2mH via @opensourceway by @GeekRuthie"
};</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"a03a21ae8a","applicationID":"65779638","transactionName":"ZlNTbUBQDxZUWxJRVl8ZcFpGWA4LGkgHX1xuW1BXU1YEF2pWCVxcbkBYXEVuEQRSXQ==","queueTime":0,"applicationTime":892,"atts":"ShRQGwhKHBg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
