<!DOCTYPE html>
<!--[if IEMobile 7]><html class="no-js iem7"  lang="en" dir="ltr"><![endif]-->
<!--[if lte IE 6]><html class="no-js lt-ie9 lt-ie8 lt-ie7"  lang="en" dir="ltr"><![endif]-->
<!--[if (IE 7)&(!IEMobile)]><html class="no-js lt-ie9 lt-ie8"  lang="en" dir="ltr"><![endif]-->
<!--[if IE 8]><html class="no-js lt-ie9"  lang="en" dir="ltr"><![endif]-->
<!--[if (gte IE 9)|(gt IEMobile 7)]><!--><html class="no-js"  lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/ dc: http://purl.org/dc/terms/ foaf: http://xmlns.com/foaf/0.1/ og: http://ogp.me/ns# rdfs: http://www.w3.org/2000/01/rdf-schema# sioc: http://rdfs.org/sioc/ns# sioct: http://rdfs.org/sioc/types# skos: http://www.w3.org/2004/02/skos/core# xsd: http://www.w3.org/2001/XMLSchema# schema: http://schema.org/ article: http://ogp.me/ns/article# book: http://ogp.me/ns/book# profile: http://ogp.me/ns/profile# video: http://ogp.me/ns/video#"><!--<![endif]-->

<head>
  <!-- Adobe Digital Data integration -->
  <script type="text/javascript">
    var digitalData = {};
  </script>
    <script id="adobe_dtm" src="https://www.redhat.com/dtm.js" type="text/javascript"></script>
  <meta charset="utf-8" /><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[(new Date).getTime()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=NREUM;"undefined"==typeof window.newrelic&&(newrelic=f);var s=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit"],l="api-",p=l+"ixn-";a(s,function(e,t){f[t]=o(l+t,!0,"api")}),f.addPageAction=o(l+"addPageAction",!0),f.setCurrentRouteName=o(l+"routeName",!0),t.exports=newrelic,f.interaction=function(){return(new r).get()};var d=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(p+"tracer",[Date.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[Date.now(),r,o],n),o)try{return t.apply(this,arguments)}finally{c.emit("fn-end",[Date.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){d[t]=o(p+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,(new Date).getTime()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o){if(!p.aborted){e&&e(n,r,o);for(var i=t(o),a=v(n),u=a.length,c=0;c<u;c++)a[c].apply(i,r);var f=s[w[n]];return f&&f.push([y,n,r,i]),i}}function d(e,t){b[e]=v(e).concat(t)}function v(e){return b[e]||[]}function g(e){return l[e]=l[e]||o(n)}function m(e,t){f(e,function(e,n){t=t||"feature",w[n]=t,t in s||(s[t]=[])})}var b={},w={},y={on:d,emit:n,get:g,listeners:v,context:t,buffer:m,abort:a,aborted:!1};return y}function i(){return new r}function a(){(s.api||s.feature)&&(p.aborted=!0,s=p.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},l={},p=t.exports=o();p.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!h++){var e=y.info=NREUM.info,t=l.getElementsByTagName("script")[0];if(setTimeout(f.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return f.abort();c(b,function(t,n){e[t]||(e[t]=n)}),u("mark",["onload",a()],null,"api");var n=l.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===l.readyState&&i()}function i(){u("mark",["domContent",a()],null,"api")}function a(){return(new Date).getTime()}var u=e("handle"),c=e(2),f=e("ee"),s=window,l=s.document,p="addEventListener",d="attachEvent",v=s.XMLHttpRequest,g=v&&v.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:v,REQ:s.Request,EV:s.Event,PR:s.Promise,MO:s.MutationObserver},e(1);var m=""+location,b={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-998.min.js"},w=v&&g&&g[p]&&!/CriOS/.test(navigator.userAgent),y=t.exports={offset:a(),origin:m,features:{},xhrWrappable:w};l[p]?(l[p]("DOMContentLoaded",i,!1),s[p]("load",r,!1)):(l[d]("onreadystatechange",o),s[d]("onload",r)),u("mark",["firstbyte",a()],null,"api");var h=0},{}]},{},["loader"]);</script>
<link rel="shortcut icon" href="https://opensource.com/sites/all/themes/opensource/favicon.ico" type="image/vnd.microsoft.icon" />
<link href="https://opensource.com/rss.xml" rel="alternate" title="Opensource.com RSS" />
<meta name="description" content="In this week&#039;s top 5, I highlight an intro to the Linux boot, a primer on the ESP8266 board, Linux command-line tools for data analysis, a Python script to find corrupted images, and open source applications for a Windows machine." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://opensource.com/article/17/2/top-5-february-24" />
<link rel="shortlink" href="https://opensource.com/node/34826" />
<meta name="revisit-after" content="1 day" />
<meta property="og:site_name" content="Opensource.com" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://opensource.com/article/17/2/top-5-february-24" />
<meta property="og:title" content="Top 5: Intro to the Linux boot, a primer on the ESP8266 board, and more" />
<meta property="og:description" content="In this week&#039;s top 5, I highlight an intro to the Linux boot, a primer on the ESP8266 board, Linux command-line tools for data analysis, a Python script to find corrupted images, and open source applications for a Windows machine." />
<meta property="og:image" content="https://opensource.com/sites/default/files/images/life/top5_flowers.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@opensourceway" />
<meta name="twitter:creator" content="@jenwike" />
<meta name="twitter:title" content="Top 5: Intro to the Linux boot, a primer on the ESP8266 board, and more" />
<meta name="twitter:description" content="In this week&#039;s top 5, I highlight an intro to the Linux boot, a primer on the ESP8266 board, Linux command-line tools for data analysis, a Python script to find corrupted images, and open source applications for a Windows machine." />
<meta name="twitter:image:src" content="https://opensource.com/sites/default/files/images/life/top5_flowers.png" />
  <title>Top 5 articles of the week for February 24 | Opensource.com</title>

      <meta name="MobileOptimized" content="width">
    <meta name="HandheldFriendly" content="true">
    <meta name="viewport" content="width=device-width">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <meta http-equiv="cleartype" content="on">

  <link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_lQaZfjVpwP_oGNqdtWCSpJT1EMqXdMiU84ekLLxQnc4.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_9l6C3kYa2UtdyBcxXB4DFxuteCTBikPA_st-XAMOo9M.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_P6yxQtOQeoGPm5Jqmt7Zs0aGtSznRIcpk9ZiCEZWWRU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_2sSTLhfz-nAupTlriBjCxX1Sq66ed6IcT_IYQDrIPg8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_rGVZaClcZruJ3gIBiwT2Va_GY2_jLHFJgKRif6TggWs.css" media="all" />

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans.css?ol3ozr" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold.css?ol3ozr" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-italic.css?ol3ozr" media="all" />
<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_core/css/panopoly-fonts-ie-open-sans-bold-italic.css?ol3ozr" media="all" />
<![endif]-->
<link type="text/css" rel="stylesheet" href="https://opensource.com/sites/default/files/css/css_wigS70piKQxAQ-PhuV0Kv5yYuTDEoD4yq0VyEj5L7HY.css" media="all" />
<style>.header-banner{position:relative;background-color:#008fbe;padding:17px 12px 17px 20px;background-image:url(/sites/all/themes/opensource/images/header-banner-desktop.png);background-size:cover;height:144px;}@media screen and (max-width:700px){.header-banner{padding:0;background-image:url(/sites/all/themes/opensource/images/header-banner-mobile.png);background-repeat:no-repeat;background-position:0 100%;background-color:#0b4f70;background-size:100%;height:auto;}}
</style>
  <script src="https://use.typekit.net/elz3yuz.js"></script>
  <script>try{Typekit.load({ async: true });}catch(e){}</script>
  <script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/jquery/1.7/jquery.min.js?v=1.7.2"></script>
<script src="https://opensource.com/misc/jquery.once.js?v=1.2"></script>
<script src="https://opensource.com/misc/drupal.js?ol3ozr"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.core.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.widget.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/media.core.js?v=7.x-2.0-alpha3+12-dev"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.tabs.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.accordion.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.mouse.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.resizable.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.draggable.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.button.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.position.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/ui/minified/jquery.ui.dialog.min.js?v=1.10.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/util/json2.js?v=7.x-2.0-alpha3+12-dev"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/util/ba-debug.min.js?v=7.x-2.0-alpha3+12-dev"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/better-autocomplete/jquery.better-autocomplete.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/jquery_update/replace/ui/external/jquery.cookie.js?v=67fb34f6a866c40d0570"></script>
<script src="https://opensource.com/misc/form.js?v=7.52"></script>
<script src="https://opensource.com/sites/all/modules/contrib/comment_notify/comment_notify.js?ol3ozr"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_admin/panopoly-admin.js?ol3ozr"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_magic/panopoly-magic.js?ol3ozr"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_theme/js/panopoly-accordion.js?ol3ozr"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/caption_filter/js/caption-filter.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/modules/contrib/loginlogout/loginlogout.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/modules/custom/os_events/os_events.js?ol3ozr"></script>
<script src="//static.addtoany.com/menu/page.js"></script>
<script src="https://opensource.com/sites/all/modules/contrib/pollanon/js/jquery.cookie.min.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/modules/contrib/pollanon/js/pollanon.pack.js?ol3ozr"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/media/js/media.popups.js?v=7.x-2.0-alpha3+12-dev"></script>
<script src="https://opensource.com/misc/collapse.js?v=7.52"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/js/linkit.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/js/linkit.dialog.js?v=7.2"></script>
<script src="https://opensource.com/profiles/panopoly/modules/contrib/linkit/editors/ckeditor/linkitDialog.js?v=7.2"></script>
<script src="https://opensource.com/misc/textarea.js?v=7.52"></script>
<script src="https://opensource.com/modules/filter/filter.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/modules/contrib/mollom/mollom.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/modules/contrib/rate/rate.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/modules/contrib/google_analytics/googleanalytics.js?ol3ozr"></script>
<script>(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-33294138-1", {"cookieDomain":".opensource.com"});ga("send", "pageview");</script>
<script src="https://opensource.com/sites/all/libraries/superfish/jquery.hoverIntent.minified.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/sfsmallscreen.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/supposition.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/superfish.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/libraries/superfish/supersubs.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/modules/contrib/superfish/superfish.js?ol3ozr"></script>
<script src="https://opensource.com/sites/all/themes/opensource/js/script.js?ol3ozr"></script>
<script>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</script>
      <!--[if lt IE 9]>
    <script src="/sites/all/themes/zen/js/html5-respond.js"></script>
    <![endif]-->
  </head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-34826 node-type-article region-content section-article page-panels" >
      <p id="skip-link">
      <a href="#main-menu" class="element-invisible element-focusable">Jump to navigation</a>
    </p>
      
<div id="page">

  <header class="header" id="header" role="banner">

    
      <div class="region region-navigation-top">
    <div id="block-system-user-menu" class="block block-system block-menu first odd" role="navigation">

      
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/login" class="menu__link">Log in</a></li>
<li class="menu__item is-leaf leaf"><a href="/user/register" title="Sign Up" class="menu__link">Sign Up</a></li>
<li class="menu__item is-leaf last leaf"><a href="/feed" title="Feeds" class="menu__link">Feed</a></li>
</ul>
</div>
<div id="block-superfish-1" class="block block-superfish last even">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul id="superfish-1" class="menu sf-menu sf-main-menu sf-horizontal sf-style-default sf-total-items-5 sf-parent-items-5 sf-single-items-0"><li id="menu-1906-1" class="first odd sf-item-1 sf-depth-1 sf-total-children-8 sf-parent-children-4 sf-single-children-4 menuparent"><a href="/" title="" class="sf-depth-1 menuparent">Articles</a><ul><li id="menu-12341-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/tags/containers" title="" class="sf-depth-2">Containers</a></li><li id="menu-12346-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/tags/gaming" title="" class="sf-depth-2">Gaming</a></li><li id="menu-12351-1" class="middle odd sf-item-3 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/hardware" title="" class="sf-depth-2 menuparent">Hardware</a><ul><li id="menu-12376-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/3d-printing" title="" class="sf-depth-3">3D printing</a></li><li id="menu-12386-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/arduino" title="" class="sf-depth-3">Arduino</a></li><li id="menu-12381-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/raspberry-pi" title="" class="sf-depth-3">Raspberry Pi</a></li></ul></li><li id="menu-1946-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-2 sf-parent-children-0 sf-single-children-2 menuparent"><a href="/tags/law" title="" class="sf-depth-2 menuparent">Law</a><ul><li id="menu-12391-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/licensing" title="" class="sf-depth-3">Licensing</a></li><li id="menu-12396-1" class="last even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/patents" title="" class="sf-depth-3">Patents</a></li></ul></li><li id="menu-12356-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/tags/linux" title="" class="sf-depth-2">Linux</a></li><li id="menu-12361-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/tags/openstack" title="" class="sf-depth-2">OpenStack</a></li><li id="menu-12366-1" class="middle odd sf-item-7 sf-depth-2 sf-total-children-3 sf-parent-children-0 sf-single-children-3 menuparent"><a href="/tags/programming" title="" class="sf-depth-2 menuparent">Programming</a><ul><li id="menu-12411-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/javascript" title="" class="sf-depth-3">JavaScript</a></li><li id="menu-12401-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/tags/perl" title="" class="sf-depth-3">Perl</a></li><li id="menu-12406-1" class="last odd sf-item-3 sf-depth-3 sf-no-children"><a href="/tags/python" title="" class="sf-depth-3">Python</a></li></ul></li><li id="menu-12371-1" class="last even sf-item-8 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/tags/sysadmin" title="" class="sf-depth-2 menuparent">SysAdmin</a><ul><li id="menu-12416-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/tags/devops" title="" class="sf-depth-3">DevOps</a></li></ul></li></ul></li><li id="menu-1921-1" class="middle even sf-item-2 sf-depth-1 sf-total-children-7 sf-parent-children-2 sf-single-children-5 menuparent"><a href="/resources" title="" class="sf-depth-1 menuparent">Resources</a><ul><li id="menu-2016-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/resources/projects-and-applications" title="" class="sf-depth-2">Projects and applications</a></li><li id="menu-2026-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/conferences-and-events-monthly" title="" class="sf-depth-2">Conferences and events</a></li><li id="menu-2021-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/resources/organizations" title="" class="sf-depth-2">Organizations</a></li><li id="menu-5556-1" class="middle even sf-item-4 sf-depth-2 sf-total-children-8 sf-parent-children-0 sf-single-children-8 menuparent"><a href="/resources/cloud" title="" class="sf-depth-2 menuparent">The open source cloud</a><ul><li id="menu-5576-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/resources/big-data" title="" class="sf-depth-3">Big data</a></li><li id="menu-5566-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/resources/what-docker" title="" class="sf-depth-3">Docker</a></li><li id="menu-5591-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/resources/internet-of-things" title="" class="sf-depth-3">Internet of things</a></li><li id="menu-5596-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/resources/what-is-kubernetes" title="" class="sf-depth-3">Kubernetes</a></li><li id="menu-5571-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/resources/what-are-linux-containers" title="" class="sf-depth-3">Linux containers</a></li><li id="menu-5586-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/resources/what-are-microservices" title="" class="sf-depth-3">Microservices</a></li><li id="menu-5561-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/resources/what-is-openstack" title="" class="sf-depth-3">OpenStack</a></li><li id="menu-5581-1" class="last even sf-item-8 sf-depth-3 sf-no-children"><a href="/resources/what-is-software-defined-networking" title="" class="sf-depth-3">Software defined networking</a></li></ul></li><li id="menu-2036-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-11 sf-parent-children-0 sf-single-children-11 menuparent"><a href="/alternatives" title="" class="sf-depth-2 menuparent">Open source alternatives</a><ul><li id="menu-4646-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/alternatives/adobe-acrobat" class="sf-depth-3">Alternatives to Acrobat</a></li><li id="menu-4656-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/alternatives/autocad" class="sf-depth-3">Alternatives to AutoCAD</a></li><li id="menu-4636-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/alternatives/dreamweaver" class="sf-depth-3">Alternatives to Dreamweaver</a></li><li id="menu-5506-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/alternatives/gmail" class="sf-depth-3">Alternatives to Gmail</a></li><li id="menu-5551-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/alternatives/matlab" class="sf-depth-3">Alternatives to MATLAB</a></li><li id="menu-5501-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/alternatives/minecraft" class="sf-depth-3">Alternatives to Minecraft</a></li><li id="menu-4651-1" class="middle odd sf-item-7 sf-depth-3 sf-no-children"><a href="/alternatives/picasa" class="sf-depth-3">Alternatives to Picasa</a></li><li id="menu-4661-1" class="middle even sf-item-8 sf-depth-3 sf-no-children"><a href="/alternatives/microsoft-publisher" class="sf-depth-3">Alternatives to Publisher</a></li><li id="menu-5511-1" class="middle odd sf-item-9 sf-depth-3 sf-no-children"><a href="/alternatives/slack" class="sf-depth-3">Alternatives to Slack</a></li><li id="menu-4641-1" class="middle even sf-item-10 sf-depth-3 sf-no-children"><a href="/alternatives/trello" class="sf-depth-3">Alternatives to Trello</a></li><li id="menu-5546-1" class="last odd sf-item-11 sf-depth-3 sf-no-children"><a href="/alternatives" title="" class="sf-depth-3">More...</a></li></ul></li><li id="menu-2011-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/ebooks" title="" class="sf-depth-2">eBooks</a></li><li id="menu-12466-1" class="last odd sf-item-7 sf-depth-2 sf-no-children"><a href="https://opensource.com/yearbook/2016" title="" class="sf-depth-2">Open Source Yearbook</a></li></ul></li><li id="menu-1911-1" class="middle odd sf-item-3 sf-depth-1 sf-total-children-7 sf-parent-children-2 sf-single-children-5 menuparent"><a href="/tags/community" title="" class="sf-depth-1 menuparent">Community</a><ul><li id="menu-1976-1" class="first odd sf-item-1 sf-depth-2 sf-total-children-5 sf-parent-children-0 sf-single-children-5 menuparent"><a href="/participate" class="sf-depth-2 menuparent">Join the community</a><ul><li id="menu-1981-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/user/register" title="" class="sf-depth-3">Register</a></li><li id="menu-2066-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/rules-comments-and-discussions" title="" class="sf-depth-3">Rules for comments and discussions</a></li><li id="menu-2056-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/community-moderator-program" class="sf-depth-3">Community Moderator program</a></li><li id="menu-4621-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/community-columnist-program" class="sf-depth-3">Community Columnist program</a></li><li id="menu-2061-1" class="last odd sf-item-5 sf-depth-3 sf-no-children"><a href="/points-and-badges" class="sf-depth-3">Points and badges</a></li></ul></li><li id="menu-1956-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/resources/editorial-calendar" title="" class="sf-depth-2">Editorial calendar</a></li><li id="menu-1986-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/how-submit-article" class="sf-depth-2">Submit your story</a></li><li id="menu-2251-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/writer-testimonials" title="" class="sf-depth-2">Writer testimonials</a></li><li id="menu-1966-1" class="middle odd sf-item-5 sf-depth-2 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/writers" class="sf-depth-2 menuparent">Guides for writers</a><ul><li id="menu-2041-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/submission-style-guide" class="sf-depth-3">Article submission and style guide</a></li><li id="menu-2046-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/how-conduct-interview-opensourcecom" class="sf-depth-3">How to conduct an interview</a></li><li id="menu-2051-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/article-entering-and-editing-guidelines" class="sf-depth-3">How to enter an article</a></li><li id="menu-4616-1" class="last even sf-item-4 sf-depth-3 sf-no-children"><a href="/promoting-articles" class="sf-depth-3">Tips for promoting your Opensource.com article</a></li></ul></li><li id="menu-4666-1" class="middle even sf-item-6 sf-depth-2 sf-no-children"><a href="/resources/contributor-club" title="" class="sf-depth-2">Contributor Club</a></li><li id="menu-4671-1" class="last odd sf-item-7 sf-depth-2 sf-no-children"><a href="/community/16/8/editorial-writing-topics" class="sf-depth-2">Editorial writing topics</a></li></ul></li><li id="menu-4691-1" class="middle even sf-item-4 sf-depth-1 sf-total-children-4 sf-parent-children-0 sf-single-children-4 menuparent"><a href="/about" class="sf-depth-1 menuparent">About</a><ul><li id="menu-1991-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-source-way" class="sf-depth-2">The Open Source Way</a></li><li id="menu-1971-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/opensourcecom-team" class="sf-depth-2">Meet the team</a></li><li id="menu-2006-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/press-kit" class="sf-depth-2">Press kit</a></li><li id="menu-2001-1" class="last even sf-item-4 sf-depth-2 sf-no-children"><a href="/contact" title="" class="sf-depth-2">Contact</a></li></ul></li><li id="menu-2136-1" class="last odd sf-item-5 sf-depth-1 sf-total-children-7 sf-parent-children-2 sf-single-children-5 menuparent"><a href="/open-organization" title="" class="sf-depth-1 menuparent">The Open Org</a><ul><li id="menu-12471-1" class="first odd sf-item-1 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="sf-depth-2">What is an open organization?</a></li><li id="menu-2181-1" class="middle even sf-item-2 sf-depth-2 sf-no-children"><a href="/open-organization/resources/what-open-organization" title="" class="sf-depth-2">What is The Open Organization?</a></li><li id="menu-12421-1" class="middle odd sf-item-3 sf-depth-2 sf-no-children"><a href="/open-organization/resources/open-decision-framework" title="" class="sf-depth-2">What is the Open Decision Framework?</a></li><li id="menu-4606-1" class="middle even sf-item-4 sf-depth-2 sf-no-children"><a href="/open-organization/resources/twitter-chats" title="" class="sf-depth-2">Twitter chats</a></li><li id="menu-2246-1" class="middle odd sf-item-5 sf-depth-2 sf-no-children"><a href="/open-organization/resources/faq" title="" class="sf-depth-2">Open Org FAQs</a></li><li id="menu-2146-1" class="middle even sf-item-6 sf-depth-2 sf-total-children-7 sf-parent-children-0 sf-single-children-7 menuparent"><a href="/open-organization/resources" title="" class="sf-depth-2 menuparent">Resources</a><ul><li id="menu-3206-1" class="first odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/field-guide" class="sf-depth-3">Field guide download</a></li><li id="menu-4631-1" class="middle even sf-item-2 sf-depth-3 sf-no-children"><a href="/open-organization/resources/catalyst-in-chief" class="sf-depth-3">Catalyst in Chief download</a></li><li id="menu-12456-1" class="middle odd sf-item-3 sf-depth-3 sf-no-children"><a href="/open-organization/resources/leaders-manual" title="Download the Open Organization Leaders Manual" class="sf-depth-3">Leaders Manual download</a></li><li id="menu-2271-1" class="middle even sf-item-4 sf-depth-3 sf-no-children"><a href="/open-organization/resources/chapter1" title="" class="sf-depth-3">Chapter download</a></li><li id="menu-2151-1" class="middle odd sf-item-5 sf-depth-3 sf-no-children"><a href="/open-organization/resources/guides" title="" class="sf-depth-3">Discussion guide download</a></li><li id="menu-3201-1" class="middle even sf-item-6 sf-depth-3 sf-no-children"><a href="/open-organization/resources/reading-list" title="" class="sf-depth-3">Readling list</a></li><li id="menu-2256-1" class="last odd sf-item-7 sf-depth-3 sf-no-children"><a href="/open-organization/resources/2015-book-club" title="" class="sf-depth-3">Book club</a></li></ul></li><li id="menu-3166-1" class="last odd sf-item-7 sf-depth-2 sf-total-children-1 sf-parent-children-0 sf-single-children-1 menuparent"><a href="/open-organization/resources/ambassadors-program" title="" class="sf-depth-2 menuparent">Ambassadors program</a><ul><li id="menu-2691-1" class="firstandlast odd sf-item-1 sf-depth-3 sf-no-children"><a href="/open-organization/resources/meet-ambassadors" title="" class="sf-depth-3">Meet the ambassadors</a></li></ul></li></ul></li></ul>
</div>
  </div>

    <div class="header-banner">
      <div class="js-mobile-header-buttons"></div>
              <div class="header__name-and-slogan" id="name-and-slogan">
                      <div class="header__site-name" id="site-name">
              <a href="/" title="Home" class="header__site-link" rel="home"><img alt="Opensource.com" src="/sites/all/themes/opensource/logo.svg" onerror="this.src='/sites/all/themes/opensource/logo.png';this.onerror=null;" /></a>
              <a href="http://www.redhat.com/en?intcmp=701600000011l7VAAQ" title="Home" class="header__sponsor-link" rel="home"><img alt="RedHat" src="/sites/all/themes/opensource/images/redhat-logo.svg" onerror="this.src='/sites/all/themes/opensource/images/redhat-logo.png';this.onerror=null;"/></a>
            </div>
          
                  </div>
      
        <div class="header__region region region-header">
    <div id="block-search-form" class="block block-search first last odd" role="search">

      
  <form action="/article/17/2/top-5-february-24" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions--2"><input type="submit" id="edit-submit--2" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-HCSBKcgeicuiWhvEu7bRZeU2b50Nvjiko2L42BCUlSk" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>
</div>
  </div>
    </div>

    <div class="mobile--menu-region">
        <div class="region region-navigation">
    <div id="block-system-main-menu" class="block block-system block-menu first last odd" role="navigation">

        <h2 class="block__title block-title">Main menu</h2>
    
  <ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/" title="" class="menu__link">Articles</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/containers" title="" class="menu__link">Containers</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/gaming" title="" class="menu__link">Gaming</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/hardware" title="" class="menu__link">Hardware</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/3d-printing" title="" class="menu__link">3D printing</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/arduino" title="" class="menu__link">Arduino</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/raspberry-pi" title="" class="menu__link">Raspberry Pi</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/tags/law" title="" class="menu__link">Law</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/linux" title="" class="menu__link">Linux</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/openstack" title="" class="menu__link">OpenStack</a></li>
<li class="menu__item is-expanded expanded"><a href="/tags/programming" title="" class="menu__link">Programming</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/tags/javascript" title="" class="menu__link">JavaScript</a></li>
<li class="menu__item is-leaf leaf"><a href="/tags/perl" title="" class="menu__link">Perl</a></li>
<li class="menu__item is-leaf last leaf"><a href="/tags/python" title="" class="menu__link">Python</a></li>
</ul></li>
<li class="menu__item is-expanded last expanded"><a href="/tags/sysadmin" title="" class="menu__link">SysAdmin</a><ul class="menu"><li class="menu__item is-leaf first last leaf"><a href="/tags/devops" title="" class="menu__link">DevOps</a></li>
</ul></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/resources/projects-and-applications" title="" class="menu__link">Projects and applications</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/conferences-and-events-monthly" title="" class="menu__link">Conferences and events</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/organizations" title="" class="menu__link">Organizations</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/resources/cloud" title="" class="menu__link">The open source cloud</a></li>
<li class="menu__item is-collapsed collapsed"><a href="/alternatives" title="" class="menu__link">Open source alternatives</a></li>
<li class="menu__item is-leaf leaf"><a href="/resources/ebooks" title="" class="menu__link">eBooks</a></li>
<li class="menu__item is-leaf last leaf"><a href="https://opensource.com/yearbook/2016" title="" class="menu__link">Open Source Yearbook</a></li>
</ul></li>
<li class="menu__item is-expanded expanded"><a href="/tags/community" title="" class="menu__link">Community</a><ul class="menu"><li class="menu__item is-expanded first expanded"><a href="/participate" class="menu__link">Join the community</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/user/register" title="" class="menu__link">Register</a></li>
<li class="menu__item is-leaf leaf"><a href="/rules-comments-and-discussions" title="" class="menu__link">Rules for comments and discussions</a></li>
<li class="menu__item is-leaf leaf"><a href="/community-moderator-program" class="menu__link">Community Moderator program</a></li>
<li class="menu__item is-leaf leaf"><a href="/community-columnist-program" class="menu__link">Community Columnist program</a></li>
<li class="menu__item is-leaf last leaf"><a href="/points-and-badges" class="menu__link">Points and badges</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/resources/editorial-calendar" title="" class="menu__link">Editorial calendar</a></li>
<li class="menu__item is-leaf leaf"><a href="/how-submit-article" class="menu__link">Submit your story</a></li>
<li class="menu__item is-leaf leaf"><a href="/writer-testimonials" title="" class="menu__link">Writer testimonials</a></li>
<li class="menu__item is-expanded expanded"><a href="/writers" class="menu__link">Guides for writers</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/submission-style-guide" class="menu__link">Article submission and style guide</a></li>
<li class="menu__item is-leaf leaf"><a href="/how-conduct-interview-opensourcecom" class="menu__link">How to conduct an interview</a></li>
<li class="menu__item is-leaf leaf"><a href="/article-entering-and-editing-guidelines" class="menu__link">How to enter an article</a></li>
<li class="menu__item is-leaf last leaf"><a href="/promoting-articles" class="menu__link">Tips for promoting your Opensource.com article</a></li>
</ul></li>
<li class="menu__item is-leaf leaf"><a href="/resources/contributor-club" title="" class="menu__link">Contributor Club</a></li>
<li class="menu__item is-leaf last leaf"><a href="/community/16/8/editorial-writing-topics" class="menu__link">Editorial writing topics</a></li>
</ul></li>
<li class="menu__item is-collapsed collapsed"><a href="/about" class="menu__link">About</a></li>
<li class="menu__item is-expanded last expanded"><a href="/open-organization" title="" class="menu__link">The Open Org</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/open-org-definition" title="What is an open organization?" class="menu__link">What is an open organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/what-open-organization" title="" class="menu__link">What is The Open Organization?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/open-decision-framework" title="" class="menu__link">What is the Open Decision Framework?</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/twitter-chats" title="" class="menu__link">Twitter chats</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/faq" title="" class="menu__link">Open Org FAQs</a></li>
<li class="menu__item is-expanded expanded"><a href="/open-organization/resources" title="" class="menu__link">Resources</a><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/open-organization/resources/field-guide" class="menu__link">Field guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/catalyst-in-chief" class="menu__link">Catalyst in Chief download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/leaders-manual" title="Download the Open Organization Leaders Manual" class="menu__link">Leaders Manual download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/chapter1" title="" class="menu__link">Chapter download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/guides" title="" class="menu__link">Discussion guide download</a></li>
<li class="menu__item is-leaf leaf"><a href="/open-organization/resources/reading-list" title="" class="menu__link">Readling list</a></li>
<li class="menu__item is-leaf last leaf"><a href="/open-organization/resources/2015-book-club" title="" class="menu__link">Book club</a></li>
</ul></li>
<li class="menu__item is-collapsed last collapsed"><a href="/open-organization/resources/ambassadors-program" title="" class="menu__link">Ambassadors program</a></li>
</ul></li>
</ul>
</div>
  </div>
    </div>

  </header>

      <div id="main">
        <div class="pre-content">
                                                          </div>
        <div id="content" class="column" role="main">
                    <a id="main-content"></a>
                                <h1 class="page__title title" id="page-title">Top 5 articles of the week for February 24</h1>
                              



<div class="panel-display os-article clearfix " id="article-template">

      <div class="os-article__sidebar">
      <div class="panel-pane pane-views-panes pane-author-info-panel-pane-1" >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-5f75a12974da5fc69a4cbd1e37ea3dff">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/jen-headshot-square.jpeg?itok=GTMugLtD" width="100" height="100" alt="" /></div>
<div class="authorbio__content">
  <span class="authorbio__name">Jen Wike Huger</span> - <span class="authorbio__about">Jen Wike Huger is the Content Manager for Opensource.com. She manages the publication calendar, coordinates the editing team, and guides new and current writers. Follow her on Twitter <a href="https://twitter.com/JenWike" target="_blank" title="on Twitter">@jenwike</a>, and see her extended portfolio at <a href="http://jen.io" target="_blank" title="Jen's past and present projects">Jen.io</a>.
</span>
  <div class="authorbio__more-link"><a href="/users/jen-wike">» More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-article-contributions" >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block" >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__header">
      <div class="panel-pane pane-node-title" >
  
      
  
  <h1>Top 5: Intro to the Linux boot, a primer on the ESP8266 board, and more</h1>

  
  </div>
<div class="panel-pane pane-os-article-byline" >
  
      
  
  <div class="byline"><span class="byline__date">Posted 24 Feb 2017</span>
<span class="byline__author"><a href="/users/jen-wike" title="View user profile." class="username" xml:lang="" about="/users/jen-wike" typeof="sioc:UserAccount" property="foaf:name" datatype="">Jen Wike Huger <span class="redhat-employee">(Red Hat)</span></a><span class="byline__feed"><a href="/user/16534/feed">Feed</a></span>
</span>
<span class="byline__social"><span class="byline__voting-widget"><div class="rate-widget-1 rate-widget clear-block rate-average rate-widget-thumbs_up rate-f48fa64d0d82b185aad5069261dc7c1e rate-node-34826-1-1" id="rate-node-34826-1-1"><div class="rate-info">2</div><a class="rate-button rate-thumbs-up-btn-up" id="rate-button-1" rel="nofollow" href="/article/17/2/top-5-february-24?rate=j1_vVw9lYoEdmXtWmx01i55hN8J7z5_PhY8LR10X1GA" title="up">up</a></div></span>
</span>
</div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-lead-image" >
  
      
  
  <div class="field field-name-field-lead-image field-type-image field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:contentUrl" resource="https://opensource.com/sites/default/files/styles/image-full-size/public/images/life/top5_flowers.png?itok=fCH-5AUj"><img class="image-full-size" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/image-full-size/public/images/life/top5_flowers.png?itok=fCH-5AUj" width="610" height="343" alt="Top 5 articles of the week on Opensource.com" title="Top 5 articles of the week on Opensource.com" /></div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-file-field-file-image-caption" >
  
      
  
  <div class="field field-name-field-file-image-caption field-type-text-long field-label-inline clearfix"><div class="field-label">Image by :&nbsp;</div><div class="field-items"><div class="field-item even"><p>opensource.com</p>
</div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__content">
      <div class="panel-pane pane-entity-field pane-node-body" >
  
      
  
  <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:articleBody content:encoded"><p>In this week's top 5, I highlight an intro to the Linux boot, a primer on the ESP8266 board, Linux command-line tools for data analysis, a Python script to find corrupted images, and open source applications for a Windows machine.</p>
<p><iframe allowfullscreen="" frameborder="0" height="315" src="https://www.youtube.com/embed/wMV7_NT3agM" width="560"></iframe><p>re</p>
<h2>Top 5 articles of the week</h2>
<p><strong>5. <a href="/article/17/2/open-source-tools-on-closed-system">6 open source tools I use on my Windows machine</a></strong></p>
<p>When Jimmy gets a new work computer, it's always a Windows machine. So, he makes quick work of installing these six favorite open source applications.</p>
<p><div class="embedded-callout-menu callout-float-right"><div class="view view-related-content-callout view-id-related_content_callout view-display-id-article_block view-dom-id-d7685f890777bf965f169f1bd560ec27">
            <div class="view-header">
      <p>More Linux Resources</p>
    </div>
  
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">      
  <div class="views-field views-field-field-related-content-link">        <div class="field-content"><div class="item-list"><ul><li class="first"><a href="https://opensource.com/resources/what-is-linux?src=linux_resource_menu">What is Linux?</a></li>
<li><a href="https://opensource.com/resources/what-are-linux-containers?src=linux_resource_menu">What are Linux containers?</a></li>
<li><a href="https://opensource.com/article/16/11/managing-devices-linux?src=linux_resource_menu">Managing devices in Linux</a></li>
<li class="last"><a href="https://opensource.com/article/16/11/25-years-linux-5-minutes?src=linux_resource_menu">25 years of Linux in 5 minutes</a></li>
</ul></div></div>  </div>  </div>    </div>
  
  
  
  
  
  
</div></div></p>
<p><strong>4. <a href="/article/17/2/python-tricks-artists">Using Python to find corrupted images</a></strong></p>
<p>In this tutorial, Jason van Gumster teaches readers how to root out corruption in their image folders with a Python script.</p>
<p><strong>3. <a href="/article/17/2/command-line-tools-data-analysis-linux">10 command-line tools for data analysis in Linux</a></strong></p>
<p>Step one: You find some data you want to analyze. Step two? Jason Baker shows us how the command line can be faster and more powerful than a spreadsheet.</p>
<p><strong>2. <a href="/article/17/2/internet-microcontroller-board-esp8266">Internet-enable your microcontroller projects for under $6 with ESP8266</a></strong></p>
<p>After many hours spent on home, open hardware projects, David Egts shares a primer with readers of the ESP8266 board.</p>
<p><strong>1. <a href="/article/17/2/linux-boot-and-startup">An introduction to the Linux boot and startup processes</a></strong></p>
<p>David Both writes that "understanding the Linux boot and startup processes is important to being able to both configure Linux and to resolving startup issues." Find out what it takes to get your system initialized and ready to run applications.</p>
</div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-default-license" >
  
      
  
  <div class="field field-name-field-default-license field-type-text field-label-hidden"><div class="field-items"><div class="field-item even" property="schema:license"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" style="border-width:0" src="/sites/all/themes/opensource/images/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a></div></div></div>
  
  </div>
<div class="panel-pane pane-entity-field pane-node-field-tags" >
  
        <h2 class="pane-title">Tags</h2>
    
  
  <div class="field field-name-field-tags field-type-taxonomy-term-reference field-label-hidden"><div class="field-items"><div class="field-item even" rel="schema:keywords"><a href="/tags/top-5">Top 5</a></div></div></div>
  
  </div>
    </div>
  
      <div class="os-article__sidebar--bottom">
      <div class="panel-pane pane-views-panes pane-author-info-panel-pane-1" >
  
      
  
  <div class="view view-author-info view-id-author_info view-display-id-panel_pane_1 view-dom-id-5f75a12974da5fc69a4cbd1e37ea3dff">
        
  
  
      <div class="view-content">
              
  <div class="authorbio">        <h2 class="authorbio__pane-title pane-title">About the author</h2>
<div class="authorbio__thumbnail"><img class="profile-pictures" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/profile_pictures/public/jen-headshot-square.jpeg?itok=GTMugLtD" width="100" height="100" alt="" /></div>
<div class="authorbio__content">
  <span class="authorbio__name">Jen Wike Huger</span> - <span class="authorbio__about">Jen Wike Huger is the Content Manager for Opensource.com. She manages the publication calendar, coordinates the editing team, and guides new and current writers. Follow her on Twitter <a href="https://twitter.com/JenWike" target="_blank" title="on Twitter">@jenwike</a>, and see her extended portfolio at <a href="http://jen.io" target="_blank" title="Jen's past and present projects">Jen.io</a>.
</span>
  <div class="authorbio__more-link"><a href="/users/jen-wike">» More about me</a></div>
</div>  </div>      </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-os-article-contributions" >
  
      
  
  <div class="item-list"><ul><li class="first last"><a href="/participate">Learn how you can contribute</a></li>
</ul></div>
  
  </div>
<div class="panel-pane pane-block pane-bean-article-promo-block" >
  
      
  
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/article-promo-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"></div></div></div>  </div>
</div>

  
  </div>
    </div>
  
      <div class="os-article__content-below">
      <div class="panel-pane pane-views-panes pane-related-articles-panel-pane-1" >
  
        <h2 class="pane-title">Recommended reading</h2>
    
  
  <div class="view view-related-articles view-id-related_articles view-display-id-panel_pane_1 related-content view-dom-id-30f87dce3bc3dcd86862ea6540f49d80">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/2/top-5-february-17"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/top5_flowers.png?itok=cvyEi28O" width="288" height="162" alt="Top 5 articles of the week on Opensource.com" title="Top 5 articles of the week on Opensource.com" /><br />
Top 5: Dropping GPL license usage, a quick intro to tmux, and more</a></span>  </div>  </div>  <div class="views-row views-row-2 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/2/top-5-february-10"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/top5_flowers.png?itok=cvyEi28O" width="288" height="162" alt="Top 5 articles of the week on Opensource.com" title="Top 5 articles of the week on Opensource.com" /><br />
Top 5: Vim plugins for writers, Raspberry Pi&#039;s PIXEL OS, and more</a></span>  </div>  </div>  <div class="views-row views-row-3 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/2/top-5-february-3"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/top5_flowers.png?itok=cvyEi28O" width="288" height="162" alt="Top 5 articles of the week on Opensource.com" title="Top 5 articles of the week on Opensource.com" /><br />
Top 5: Orange Pi tiny computer, Cozy for personal clouds, and more</a></span>  </div>  </div>  <div class="views-row views-row-4 views-row-even">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/1/top-5-january-27"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/top5_flowers.png?itok=cvyEi28O" width="288" height="162" alt="Top 5 articles of the week on Opensource.com" title="Top 5 articles of the week on Opensource.com" /><br />
Top 5: Solid state drives in Linux, Brotli compression algorithm, and more</a></span>  </div>  </div>  <div class="views-row views-row-5 views-row-odd">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/1/top-5-january-20"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/top5_clover_leaf.jpg?itok=vJvEMv7o" width="288" height="162" alt="Top 5" title="Top 5" /><br />
Top 5: Shell scripting, the Cinnamon Linux desktop environment, and more</a></span>  </div>  </div>  <div class="views-row views-row-6 views-row-even views-row-last">      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/article/17/1/top-5-january-13"><img class="related-content-lead-thumbnail" typeof="foaf:Image" src="https://opensource.com/sites/default/files/styles/related-content-lead-thumbnail/public/images/life/top5_flowers.png?itok=cvyEi28O" width="288" height="162" alt="Top 5 articles of the week on Opensource.com" title="Top 5 articles of the week on Opensource.com" /><br />
Top 5: Most common Linux issues, Exercism for programming skills, and more</a></span>  </div>  </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-node-comment-form" >
  
        <h2 class="pane-title">Comment now</h2>
    
  
  <form class="comment-form user-info-from-cookie" action="/article/17/2/top-5-february-24#comment-form" method="post" id="comment-form" accept-charset="UTF-8"><div><div id="edit-login-register" class="form-item form-type-item">
 <a href="/user/login?destination=node/34826">Login or Register</a> to earn points for your comments.
</div>
<div class="form-item form-type-textfield form-item-name">
  <label for="edit-name">Your name <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-name" name="name" value="" size="30" maxlength="60" class="form-text required" />
</div>
<div class="form-item form-type-textfield form-item-mail">
  <label for="edit-mail">E-mail <span class="form-required" title="This field is required.">*</span></label>
 <input type="text" id="edit-mail" name="mail" value="" size="30" maxlength="64" class="form-text required" />
<div class="description">The content of this field is kept private and will not be shown publicly.</div>
</div>
<input type="hidden" name="form_build_id" value="form-eDr82tdQ4oBXxMsMRep7G71V7YmqHo2a3eq0BTmaBBw" />
<input type="hidden" name="form_id" value="comment_node_article_form" />
<div class="form-item form-type-checkbox form-item-legal-checkbox">
 <input type="checkbox" id="edit-legal-checkbox" name="legal_checkbox" value="1" class="form-checkbox required" />  <label class="option" for="edit-legal-checkbox">Accept the <a href="/legal">Terms of Use</a> to continue.  You are licensing your contribution(s) as CC-BY-SA. <span class="form-required" title="This field is required.">*</span></label>

</div>
<div class="field-type-text-long field-name-comment-body field-widget-text-textarea form-wrapper" id="edit-comment-body"><div id="comment-body-add-more-wrapper"><div class="text-format-wrapper"><div class="form-item form-type-textarea form-item-comment-body-und-0-value">
  <label for="edit-comment-body-und-0-value">Comment <span class="form-required" title="This field is required.">*</span></label>
 <div class="form-textarea-wrapper resizable"><textarea class="text-full form-textarea required" id="edit-comment-body-und-0-value" name="comment_body[und][0][value]" cols="60" rows="5"></textarea></div>
</div>
</div>
</div></div><input class="mollom-content-id" type="hidden" name="mollom[contentId]" value="" />
<input class="mollom-captcha-id" type="hidden" name="mollom[captchaId]" value="1702251761030fda3f" />
<div class="form-item form-type-textfield form-item-mollom-captcha">
  <label for="edit-mollom-captcha">Verification <span class="form-required" title="This field is required.">*</span></label>
 <span class="field-prefix">
<span class="mollom-captcha-container">
  <a href="javascript:void(0);" class="mollom-refresh-captcha mollom-refresh-image"><img typeof="foaf:Image" src="https://opensource.com/sites/all/modules/contrib/mollom/images/refresh.png" alt="Refresh" /></a>
  <span class="mollom-captcha-content mollom-image-captcha"><img typeof="foaf:Image" src="https://rest-production.mollom.com:443/v1/captcha/1702251761030fda3f.png" alt="Type the characters you see in this picture." /></span>
  <span class="mollom-image-captcha-instructions">Type the characters you see in the picture; if you can't read them, submit the form and a new image will be generated. Not case sensitive.&nbsp;&nbsp;<a href="#" class="mollom-switch-captcha mollom-audio-captcha">Switch to audio verification.</a></span>
</span>
</span> <input title="Enter the characters from the verification above." type="text" id="edit-mollom-captcha" name="mollom[captcha]" value="" size="10" maxlength="128" class="form-text required" />
</div>
<div style="display: none;"><div class="form-item form-type-textfield form-item-mollom-homepage">
  <label for="edit-mollom-homepage">Home page </label>
 <input autocomplete="off" type="text" id="edit-mollom-homepage" name="mollom[homepage]" value="" size="60" maxlength="128" class="form-text" />
</div>
</div><div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Save" class="form-submit" /></div></div></form>
  
  </div>
    </div>
  
</div><!-- /.os-article -->
                  </div>


        
        
      </div>

        <div class="region region-pre-footer">
    <div id="block-os-common-components-footer-call-to-action" class="block block-os-common-components first last odd">

      
  
<div class="fieldable-panels-pane cta cta--green-on-blue cta--no-link">

  <div class="cta__content cta__content--no-link">
            <h2 class="cta__title">Sign up for Opensource.com news</h2>
<div class="field field-name-field-cta-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><iframe frameborder="0" height="50" id="fkfkx" scrolling="no" src="/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></p>
</div></div></div>  </div>

</div>


</div>
  </div>

        <div class="region region-footer-nav">
    <div id="block-menu-menu-footer" class="block block-menu first odd" role="navigation">

        <h2 class="block__title block-title">Footer</h2>
    
  <ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/privacy-policy" class="menu__link">Privacy Policy</a></li>
<li class="menu__item is-leaf leaf"><a href="/legal" class="menu__link">Terms of Use</a></li>
<li class="menu__item is-leaf leaf"><a href="/contact" class="menu__link">Contact</a></li>
<li class="menu__item is-leaf leaf"><a href="/opensourcecom-team" title="" class="menu__link">Meet the Team</a></li>
<li class="menu__item is-leaf last leaf"><a href="http://opensource.org/" title="" class="menu__link">Visit opensource.org</a></li>
</ul>
</div>
<div id="block-bean-social-media" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/social-media" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><span>Find us:</span> 
</p>
<ul>
<li><a class="footer-twitter" href="https://twitter.com/OpenSourceWay" title="Twitter">Twitter</a></li>
<li><a class="footer-facebook" href="https://www.facebook.com/opensourceway" title="Facebook">Facebook</a></li>
<li><a class="footer-gplus" href="https://plus.google.com/108750398488318674353" title="Google Plus">Google Plus</a></li>
<li><a class="footer-instagram" href="https://www.instagram.com/opensourceway/" title="Instagram">Instagram</a></li>
<li><a class="footer-youtube" href="http://www.youtube.com/opensourceway" title="Youtube">Youtube</a></li>
<li><a class="footer-linkedin" href="https://www.linkedin.com/grps/Open-Source-Professionals-Advocates-2769297" title="LinkedIn">LinkedIn</a></li>
<li><a class="footer-flickr" href="http://www.flickr.com/photos/opensourceway" title="Flickr">Flickr</a></li>
<li><a class="footer-feed" href="https://opensource.com/rss-feeds" title="RSS">RSS</a></li>
</ul>
</div></div></div>  </div>
</div>

</div>
  </div>

        <footer id="footer" class="region region-footer">
    <div id="block-bean-copyrigt-block" class="block block-bean first odd">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/copyrigt-block" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p>For more discussion on open source and the role of the CIO in the enterprise, join us at <a href="http://enterprisersproject.com">The EnterprisersProject.com</a>.</p>
<p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>
<p>Opensource.com aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Shadowman logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
</div></div></div>  </div>
</div>

</div>
<div id="block-bean-footer-logo" class="block block-bean last even">

      
  <div class="entity entity-bean bean-generic-block clearfix" about="/block/footer-logo" typeof="">

  <div class="content">
    <div class="field field-name-field-body field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"><p><img src="/sites/all/themes/opensource/images/footer_logo.svg" /></p>
</div></div></div>  </div>
</div>

</div>
  </footer>

    </div>

    
      <div class="region region-os-social">
    <div id="block-os-social-os-social-share" class="block block-os-social first last odd">

      
  <div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_vertical_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div><div class="a2a_kit a2a_kit_size_32 a2a_floating_style a2a_default_style">
  <a class="a2a_button_twitter a2a_counter"></a>
  <a class="a2a_button_facebook a2a_counter"></a>
  <a class="a2a_button_linkedin a2a_counter"></a>
  <a class="a2a_button_reddit a2a_counter"></a>
  <a class="a2a_button_google_plus a2a_counter"></a>
  <a class="a2a_button_email a2a_counter"></a>
  <!--a class="a2a_dd" href="https://www.addtoany.com/share"></a-->
  </div>
</div>
  </div>
    <div class="region region-page-bottom">
    <!-- begin Eloqua tracking -->
<script type='text/javascript' language='JavaScript' src='//www.redhat.com/j/elqNow/elqCfg.js'></script>
<script type='text/javascript' language='JavaScript' src='//www.redhat.com/j/elqNow/elqImg.js'></script>
<!-- end Eloqua tracking -->
<!-- begin Adobe Analytics -->
<script type="text/javascript" src="/sites/all/libraries/sitecatalyst/s_code.js?20100731?ol3ozr"></script>
<script type="text/javascript" language="JavaScript"><!--

s.pageName="opensource||article|top-5:-intro-to-the-linux-boot,-a-primer-on the-esp8266-board,-and-more";
s.server="opensource.com";
s.channel="opensource";
s.prop13="osdc 34826";
s.eVar26="osdc 34826";
s.prop14="";
s.eVar27="";
s.prop61="2017-02-24";
/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
//--></script><script type="text/javascript" src="/sites/all/libraries/sitecatalyst/rh_omni_footer.js"></script>
<script language="JavaScript" type="text/javascript"><!--
if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')
//--></script><noscript><img src="https://smtrcs.redhat.com/b/ss/redhatglobal,redhatopensourcecom/1/H.25--NS/0?[AQB]&amp;amp;amp;cdp=3&amp;amp;amp;[AQE]" height="1" width="1" border="0" alt="" /></noscript><!--/DO NOT REMOVE/-->
<!-- end Adobe Analytics1 --><!-- begin Google Remarketing -->
<img height="1" width="1" style="border-style:none;display:block;" alt=""  src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/990030321/?value=0&amp;label=rxV4CN_35QQQ8dOK2AM&amp;guid=ON&amp;script=0" onerror="this.src='/sites/all/themes/opensource/images/1x1.png';this.onerror=null" /><!-- end Google Remarketing -->
  </div>
<script src="https://opensource.com/sites/all/modules/contrib/ckeditor/plugins/media/library.js?ol3ozr"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_widgets/panopoly-widgets.js?ol3ozr"></script>
<script src="https://opensource.com/profiles/panopoly/modules/panopoly/panopoly_widgets/jquery-ui-tabs-rotate.js?ol3ozr"></script>
<script>if (("undefined" !== typeof _satellite) && ("function" === typeof _satellite.pageBottom)) {_satellite.pageBottom();}</script>
<script>var a2a_config = a2a_config || {};
a2a_config.templates = {
    twitter: "Top 5: Intro to the Linux boot, a primer on the ESP8266 board, and more http://red.ht/2liiStm via @opensourceway by @jenwike"
};</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"6c4ce4505c","applicationID":"10821422","transactionName":"Y1EEZkdRXkVXUxVdXlobJ1FBWV9YGUAAU1RrWQdcVFdVRGleDlBUa0IPV0JvQFdRVQ==","queueTime":0,"applicationTime":927,"atts":"TxYHEA9LTUs=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
