<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="og: https://ogp.me/ns#">
  <head>
    <meta charset="utf-8" /><script type="text/javascript">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</script>
<link rel="canonical" href="https://opensource.com/article/22/8/automate-file-edits-sed-linux" />
<link rel="shortlink" href="https://opensource.com/node/70127" />
<meta name="description" content="Here are some tips and tricks to automating file edits from the Linux command line." />
<meta property="og:type" content="How I use the Linux sed command to automate file edits" />
<meta property="og:url" content="https://opensource.com/article/22/8/automate-file-edits-sed-linux" />
<meta property="og:title" content="How I use the Linux sed command to automate file edits" />
<meta property="og:description" content="Here are some tips and tricks to automating file edits from the Linux command line." />
<meta property="og:image" content="https://opensource.com/sites/default/files/lead-images/features_solutions_command_data.png" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Here are some tips and tricks to automating file edits from the Linux command line." />
<meta name="twitter:title" content="How I use the Linux sed command to automate file edits" />
<meta name="twitter:creator" content="@jimfhall" />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/lead-images/features_solutions_command_data.png" />
<meta name="Generator" content="Drupal 9 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="icon" href="/themes/osdc/assets/img/favicons/favicon.ico" type="image/vnd.microsoft.icon" />

    <title>How I use the Linux sed command to automate file edits | Opensource.com</title>
    <link rel="stylesheet" media="all" href="/sites/default/files/css/css_G5pAaR4ZJDuk3M1Ws0PhOVFEzHL-MTALCtZ51bx1jRs.css" />
<link rel="stylesheet" media="all" href="https://opensource.com/sites/default/files/geshi/geshifilter-languages.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_reumvhai1JF4j5JfsaewAZnyPmGfRbnSWRsbBv7zm3o.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_n7bVhPAn37GlkB_PWkNqkdhh4vNbPZdHszqkQU57TUU.css" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css2?family=Red+Hat+Text:wght@400;500;700&amp;display=swap" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css2?family=Red+Hat+Mono:wght@400;500;700&amp;display=swap" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_ENRPjc6QCuPKRfbVAJ9MRRqVB3Ko5tA4owYjyc7njr8.css" />

    <script id="adobe_dtm" src="https://www.redhat.com/ma/dpal.js" type="text/javascript"></script>
    
    <script type="module" src="/themes/osdc/node_modules/@patternfly/pfe-modal/dist/pfe-modal.min.js"></script>
  </head>
  <body class="path-node page-node-type-article">
        <a href="#main-content" class="visually-hidden focusable skip-link">
      Skip to main content
    </a>
    
      <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    <div class="layout-container">

  <header>
      <div class="region region-messages">
    <div data-drupal-messages-fallback class="hidden"></div>

  </div>

    
<div class="region-top-bar">
  <div class="region wrapper region-user-menu">
    <div class="hamburger__container">
        <div class="hamburger">
            <button id="mobnav-btn" aria-label="Toggle main menu" class="button--plain toggle-menu"></button>
            <div class="bar"></div>
        </div>
    </div>

    <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" target="_blank" class="flex-center support-logo">
        <img alt="Supported by Red Hat" src="/themes/osdc/assets/img/l_supported-by-redhat-white.svg" title="Supported by Red Hat" width="125" height="56" class="support-logo__image">
    </a>

    <button id="toggle-search" aria-label="Toggle Search" class="button--plain toggle-search">
        <i class="icon-search"></i>
    </button>
    <nav role="navigation" aria-labelledby="block-useraccountmenu-menu" id="block-useraccountmenu" class="block block-menu navigation menu--account">
            
  <h2 class="visually-hidden" id="block-useraccountmenu-menu">User account menu</h2>
  

        
    
                    <ul class="account">
    
                            <li class="log-in account__item">
        <a href="/user/login?current=/node/70127" class="account__link" data-drupal-link-system-path="user/login">Log in</a>
                </li>
                            <li class="sign-up account__item">
        <a href="/user/register" class="account__link" data-drupal-link-system-path="user/register">Sign Up</a>
                </li>
                            <li class="facebook account__item">
        <a href="https://www.facebook.com/opensourceway" title="facebook" class="account__link">Facebook</a>
                </li>
                            <li class="twitter account__item">
        <a href="http://twitter.com/opensourceway" title="twitter" class="account__link">Twitter</a>
                </li>
                            <li class="rss account__item">
        <a href="/feed" title="RSS" class="account__link" data-drupal-link-system-path="rss.xml">RSS</a>
                </li>
            </ul>
    


  </nav>

  </div>
</div>

      <div class="region region-header">
    <div id="block-osdc-branding" class="block block-system block-system-branding-block">
  
    
    <div class="branding">
          <a href="/" rel="home" aria-label="Opensource.com" class="branding__logo">
        <img src="/themes/osdc/logo.svg" alt="Home"/>
      </a>
        <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" target="_blank" class="branding__supported-by">
      <img src="/themes/osdc/assets/img/l_supported-by-redhat-white.svg" width="125" height="56" class="branding__supported-by__image" alt="Supported by Red Hat">
    </a>
  </div>
  <div class="branding__slogan"></div>
</div>

  </div>

  </header>

    <div class="region region-main-nav">
    <nav role="navigation" aria-labelledby="block-mainnavigation-menu" id="block-mainnavigation" class="block block-menu navigation menu--main">
            
  <h2 class="visually-hidden" id="block-mainnavigation-menu">Main navigation</h2>
  

        
    
                    <ul class="main" id="main-menu">
    
                            <li class="main__item is-expanded">
        <a href="/" class="main__link" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item is-expanded">
        <a href="/tags/linux" class="main__link" data-drupal-link-system-path="taxonomy/term/6803">Linux</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/tags/command-line" class="main__link" data-drupal-link-system-path="taxonomy/term/5276">Command line</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/tags/kubernetes" class="main__link" data-drupal-link-system-path="taxonomy/term/9749">Kubernetes</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/tags/programming" class="main__link" data-drupal-link-system-path="taxonomy/term/7866">Programming</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/tags/go-programming-language" class="main__link" data-drupal-link-system-path="taxonomy/term/15746">Go</a>
                </li>
                            <li class="main__item">
        <a href="/tags/javascript" class="main__link" data-drupal-link-system-path="taxonomy/term/6609">JavaScript</a>
                </li>
                            <li class="main__item">
        <a href="/tags/python" class="main__link" data-drupal-link-system-path="taxonomy/term/7934">Python</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/tags/containers" class="main__link" data-drupal-link-system-path="taxonomy/term/9523">Containers</a>
                </li>
                            <li class="main__item">
        <a href="/tags/sysadmin" class="main__link" data-drupal-link-system-path="taxonomy/term/8596">Sysadmin</a>
                </li>
                            <li class="main__item">
        <a href="/tags/devops" class="main__link" data-drupal-link-system-path="taxonomy/term/9255">DevOps</a>
                </li>
                            <li class="main__item">
        <a href="/tags/gaming" class="main__link" data-drupal-link-system-path="taxonomy/term/6089">Gaming</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/tags/hardware" class="main__link" data-drupal-link-system-path="taxonomy/term/6284">Hardware</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/tags/3d-printing" class="main__link" data-drupal-link-system-path="taxonomy/term/4635">3D printing</a>
                </li>
                            <li class="main__item">
        <a href="/tags/arduino" class="main__link" data-drupal-link-system-path="taxonomy/term/4740">Arduino</a>
                </li>
                            <li class="main__item">
        <a href="/tags/raspberry-pi" class="main__link" data-drupal-link-system-path="taxonomy/term/7974">Raspberry Pi</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/tags/government" class="main__link" data-drupal-link-system-path="taxonomy/term/6211">Government</a>
                </li>
                            <li class="main__item">
        <a href="/tags/law" class="main__link" data-drupal-link-system-path="taxonomy/term/6744">Law</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/tags/open-organization" class="main__link" data-drupal-link-system-path="taxonomy/term/14761">Open Organization</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/open-organization/resources/open-org-definition" class="main__link" data-drupal-link-system-path="node/33506">What is an open organization?</a>
                </li>
                            <li class="main__item">
        <a href="/open-organization/resources/open-decision-framework" class="main__link" data-drupal-link-system-path="node/30866">What is an open decision?</a>
                </li>
            </ul>
    
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/resources" class="main__link" data-drupal-link-system-path="node/17752">Resources</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item is-expanded">
        <a href="/resources/what-open-source" class="main__link" data-drupal-link-system-path="node/17753">What is open source?</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/open-source-way" class="main__link" data-drupal-link-system-path="node/17730">The open source way</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/resources/projects-and-applications" class="main__link" data-drupal-link-system-path="node/17760">Projects and applications</a>
                </li>
                            <li class="main__item">
        <a href="/resources/organizations" class="main__link" data-drupal-link-system-path="node/17763">Organizations</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/resources/cloud" class="main__link" data-drupal-link-system-path="node/31366">Cloud technology</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/resources/what-ansible" class="main__link" data-drupal-link-system-path="node/56241">Ansible</a>
                </li>
                            <li class="main__item">
        <a href="/resources/big-data" class="main__link" data-drupal-link-system-path="node/21471">Big data</a>
                </li>
                            <li class="main__item">
        <a href="/resources/data-science" class="main__link" data-drupal-link-system-path="node/55831">Data science</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-docker" class="main__link" data-drupal-link-system-path="node/18438">Docker</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-git" class="main__link" data-drupal-link-system-path="node/29816">Git</a>
                </li>
                            <li class="main__item">
        <a href="/resources/internet-of-things" class="main__link" data-drupal-link-system-path="node/25831">Internet of things</a>
                </li>
                            <li class="main__item">
        <a href="/resources/java" class="main__link" data-drupal-link-system-path="node/38936">Java</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-kubernetes" class="main__link" data-drupal-link-system-path="node/27941">Kubernetes</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-are-linux-containers" class="main__link" data-drupal-link-system-path="node/29741">Linux containers</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-are-microservices" class="main__link" data-drupal-link-system-path="node/23541">Microservices</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-openstack" class="main__link" data-drupal-link-system-path="node/17870">OpenStack</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/resources/python" class="main__link" data-drupal-link-system-path="node/37296">Python</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/resources/python/gui-frameworks" class="main__link" data-drupal-link-system-path="node/28806">Python GUI frameworks</a>
                </li>
                            <li class="main__item">
        <a href="/resources/python/ides" class="main__link" data-drupal-link-system-path="node/24166">Python IDEs</a>
                </li>
                            <li class="main__item">
        <a href="/resources/python/template-libraries" class="main__link" data-drupal-link-system-path="node/44451">Python template libraries</a>
                </li>
                            <li class="main__item">
        <a href="/resources/python/web-scraper-crawler" class="main__link" data-drupal-link-system-path="node/39381">Python web scrapers</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-software-defined-networking" class="main__link" data-drupal-link-system-path="node/19276">Software defined networking</a>
                </li>
                            <li class="main__item">
        <a href="/resources/virtualization" class="main__link" data-drupal-link-system-path="node/36551">Virtualization</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/alternatives" class="main__link" data-drupal-link-system-path="node/30871">Open source alternatives</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/alternatives/adobe-acrobat" class="main__link" data-drupal-link-system-path="node/29486">Alternatives to Acrobat</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/autocad" class="main__link" data-drupal-link-system-path="node/29001">Alternatives to AutoCAD</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/dreamweaver" class="main__link" data-drupal-link-system-path="node/27646">Alternatives to Dreamweaver</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/gmail" class="main__link" data-drupal-link-system-path="node/22941">Alternatives to Gmail</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/matlab" class="main__link" data-drupal-link-system-path="node/29276">Alternatives to MATLAB</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/minecraft" class="main__link" data-drupal-link-system-path="node/22786">Alternatives to Minecraft</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/google-photos" class="main__link" data-drupal-link-system-path="node/27211">Alternatives to Google Photos</a>
                </li>
                            <li class="main__item">
        <a href="/life/12/6/design-without-debt-five-tools-for-designers" class="main__link" data-drupal-link-system-path="node/16365">Alternatives to Photoshop</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/skype" class="main__link" data-drupal-link-system-path="node/45576">Alternatives to Skype</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/slack" class="main__link" data-drupal-link-system-path="node/23286">Alternatives to Slack</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/trello" class="main__link" data-drupal-link-system-path="node/22546">Alternatives to Trello</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives" class="main__link" data-drupal-link-system-path="node/30871">More...</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/resources/linux" class="main__link" data-drupal-link-system-path="node/19796">Linux</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/downloads" class="main__link" data-drupal-link-system-path="downloads">Downloads</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/downloads/cheat-sheets" class="main__link" data-drupal-link-system-path="downloads/cheat-sheets">Cheat sheets</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/devops-guides" class="main__link" data-drupal-link-system-path="downloads/devops-guides">DevOps guides</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/programming-guides" class="main__link" data-drupal-link-system-path="downloads/programming-guides">Programming guides</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/sysadmin-guides" class="main__link" data-drupal-link-system-path="downloads/sysadmin-guides">Sysadmin guides</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/ebooks" class="main__link" data-drupal-link-system-path="downloads/ebooks">eBooks</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/open-source-yearbook" class="main__link" data-drupal-link-system-path="downloads/open-source-yearbook">Open Source Yearbook</a>
                </li>
                            <li class="main__item">
        <a href="/open-organization/resources/book-series" class="main__link" data-drupal-link-system-path="node/37936">Open Organization series</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/about" class="main__link" data-drupal-link-system-path="node/17734">Community</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item is-expanded">
        <a href="/about" class="main__link" data-drupal-link-system-path="node/17734">About Opensource.com</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/participate" class="main__link" data-drupal-link-system-path="node/17735">Welcome to the Opensource.com community</a>
                </li>
                            <li class="main__item">
        <a href="/team" class="main__link" data-drupal-link-system-path="node/17744">Meet the team</a>
                </li>
                            <li class="main__item">
        <a href="/user/register" class="main__link" data-drupal-link-system-path="user/register">Create an account</a>
                </li>
                            <li class="main__item">
        <a href="/code-of-conduct" class="main__link" data-drupal-link-system-path="node/17710">Rules for comments and discussions</a>
                </li>
                            <li class="main__item">
        <a href="/correspondent-program" class="main__link" data-drupal-link-system-path="node/17743">Correspondent Program</a>
                </li>
                            <li class="main__item">
        <a href="/faq" class="main__link" data-drupal-link-system-path="node/62466">Frequently Asked Questions</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/writers" class="main__link" data-drupal-link-system-path="node/18340">Contribute to Opensource.com</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/submission-style-guide" class="main__link" data-drupal-link-system-path="node/18705">Opensource.com style guide</a>
                </li>
                            <li class="main__item">
        <a href="/article/20/1/write-for-us" class="main__link" data-drupal-link-system-path="node/60351">Writing topics</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/contact" class="main__link" data-drupal-link-system-path="node/68921">Contact Us</a>
                </li>
            </ul>
    
                </li>
            </ul>
    


  </nav>
<div class="views-exposed-form block block-views block-views-exposed-filter-blockacquia-search-page" data-drupal-selector="views-exposed-form-acquia-search-page" id="block-exposedformacquia-searchpage">
  
    
      <form action="/site-search" method="get" id="views-exposed-form-acquia-search-page" accept-charset="UTF-8">
  <div class="form--inline clearfix">
  <div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-search form-item-search">
      <label for="edit-search">Search</label>
        <input placeholder="Search" data-drupal-selector="edit-search" type="text" id="edit-search" name="search" value="" size="30" maxlength="128" class="form-text" />

        </div>
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions"><input data-drupal-selector="edit-submit-acquia-search" type="submit" id="edit-submit-acquia-search" value="Search" class="button js-form-submit form-submit" />
</div>

</div>

</form>

  </div>


  </div>


  <main>
    <a id="main-content" tabindex="-1"></a>
    <div class="wrapper wrapper--870">
        <div class="region region-content">
    <div id="block-subscribetoourweeklynewsletterflyin" class="block subscribe-float hide block-block-content block-block-content53f83537-7483-486d-9cf3-65f15e0c01c2">
  <button id="subscribe-float-close" class="subscribe-float__close"><span>x</span></button>
  
  
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><h2 class="subscribe-float__title">Subscribe to our <span>newsletter</span>.</h2>
<p>Stay on top of the latest thoughts, strategies and insights from enterprising peers.</p>
<p><iframe frameborder="0" height="229" id="fkfkx" scrolling="no" title="Subscribe to our weekly newsletter" src="https://opensource.com/eloqua-embedded-email-capture-block-sticky.html?offer_id=70160000000QzXNAA0"></iframe></p>
</div>
      
  </div>

<div id="block-osdc-page-title" class="block block-core block-page-title-block">
  
    
      
  <h1 class="published page-title">
    <span class="field field--name-title field--type-string field--label-hidden">How I use the Linux sed command to automate file edits</span>

      </h1>


  </div>
<div id="block-mainpagecontent" class="block block-system block-system-main-block">
  
    
      
<article class="node node--type-article node--promoted node--view-mode-full">

  
  <div class="article__subhead">Here are some tips and tricks to automating file edits from the Linux command line. </div>

      <footer class="author__meta">
      <div class="author__submitted">
        <div class="author__list">
          By 
<article class="profile">
            <a href="/users/jim-hall" hreflang="en">Jim Hall</a>
      
<span class="user-attributes">(Correspondent)
</span>
</article>
 
        </div>
        <div class="author__meta-date-container">
                    <span class="author__meta-date">August 2, 2022</span>          <span class="author__date-pipe">|</span>
          <a href="#comments"><span class="author__comment-count">3 Comments </span></a>
          <span class="author__date-pipe">|</span>
          <pfe-readtime class="pf-global--FontSize--lg" for="#article_content" hidden>%t min read</pfe-readtime>

        </div>
      </div>
    </footer>
    <div id="article_content" class="author__content">

      <div class="layout layout--onecol">
    <div  class="layout__region layout__region--content">
      <div class="block block-layout-builder block-extra-field-blocknodearticlerate-vote-widget">
  
    
      <div data-drupal-selector="rate-node-70127" class="rate-widget-thumbs-up" title="Register or Login to like.">
    <div class="rate-thumbs-up-btn-up vote-pending">4 readers like this</div>
    <div class="rate-score">4 readers like this</div>
    
</div>

  </div>
<div class="block block-layout-builder block-extra-field-blocknodearticlecontent-moderation-control">
  
    
      
  </div>

    </div>
  </div>
  <div class="layout layout--onecol">
    <div  class="layout__region layout__region--content">
      <div class="block block-layout-builder block-field-blocknodearticlefield-lead-image">
  
    
      
            <div class="field field--name-field-lead-image field--type-entity-reference field--label-hidden field__item"><article class="media media--type-image media--view-mode-caption">
  
      
            <div class="field field--name-field-media-image field--type-image field--label-hidden field__item">  <img loading="lazy" src="/sites/default/files/lead-images/features_solutions_command_data.png" width="520" height="293" alt="computer screen " title="computer screen " />

</div>
      
   <div class="field field--name-field-caption field--type-text-long field--label-hidden caption field__item"><span class="caption__byline">Image by: </span><p>Opensource.com</p>
</div>

  </article>
</div>
      
  </div>
<div class="block block-layout-builder block-field-blocknodearticlebody">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>When I use the Linux command line, whether I'm writing a new program on my desktop computer or managing a website on my web server, I often need to process text files. Linux provides powerful tools that I leverage to get my work done. I frequently use <code>sed</code>, an editor that can modify text according to a pattern.</p>
<p><code>sed</code> stands for <em>stream editor</em>, and it edits text in a file and prints the results. One way to use <code>sed</code> is to identify several occurrences of one string in a file and replace them with a different string. You can use <code>sed</code> to process text files to a seemingly endless degree, but I'd like to share a few ways I use <code>sed</code> to help me manage files.</p>
<h2>Search and replace text in a file on Linux</h2>
<p>To use <code>sed</code>, you need to use a <em>regular expression</em>. A regular expression is a set of special characters that define a pattern. My most frequent example of using <code>sed</code> is replacing text in a file. The syntax for replacing text looks like this: <code>s/originaltext/newtext/</code>. The <code>s</code> tells sed to perform text replacement or swap occurrences of text. Provide the original text and new text between slashes.</p>
<p>This syntax will only replace the first occurrence of <code>originaltext</code> on each line. To replace every occurrence, even if the original text appears more than once on a line, append <code>g</code> to the end of the expression. Here is an example: <code>s/originaltext/newtext/g</code>.</p>
<p>To use this with <code>sed</code>, specify this regular expression with the <code>-e</code> option:</p>
<pre>
<span class="geshifilter"><code class="bash geshifilter-bash"><span class="co4">$ </span><span class="kw2">sed</span> <span class="re5">-e</span> <span class="st_h">'s/originaltext/newtext/g'</span></code></span></pre><p>For example, let's say I have a Makefile for a program called <strong>game</strong>, which simulates Conway's Game of Life:</p>
<pre>
<div class="geshifilter"><div class="text geshifilter-text">.PHONY: all run clean<br />
<br />
all: game<br />
<br />
game: game.o<br />
        $(CC) $(CFLAGS) -o game game.o $(LDFLAGS)<br />
<br />
run: game<br />
        ./game<br />
<br />
clean:<br />
        $(RM) *~<br />
        $(RM) *.o<br />
        $(RM) game</div></div></pre><p>The name <strong>game</strong> isn't very descriptive, so I might choose to rename it <strong>life</strong>. Renaming the <code>game.c</code> source file to <code>life.c</code> is easy enough, but now I need to modify the Makefile to use the new name. I can use <code>sed</code> to change every occurrence of <strong>game</strong> to <strong>life</strong>:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">sed</span> <span class="re5">-e</span> <span class="st_h">'s/game/life/g'</span> Makefile<br />
.PHONY: all run clean<br />
<br />
all: life<br />
<br />
life: life.o<br />
        $<span class="br0">(</span>CC<span class="br0">)</span> $<span class="br0">(</span>CFLAGS<span class="br0">)</span> <span class="re5">-o</span> life life.o $<span class="br0">(</span>LDFLAGS<span class="br0">)</span><br />
<br />
run: life<br />
        .<span class="sy0">/</span>life<br />
<br />
clean:<br />
        $<span class="br0">(</span>RM<span class="br0">)</span> <span class="sy0">*</span>~<br />
        $<span class="br0">(</span>RM<span class="br0">)</span> <span class="sy0">*</span>.o<br />
        $<span class="br0">(</span>RM<span class="br0">)</span> life</div></div></pre><p>This prints the <code>sed</code> output to the screen, which is a good way to check if the text replacement will do what you want. To make these changes to the Makefile, first, make a backup of the file, then run <code>sed</code> and save the output to the original filename:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">cp</span> Makefile Makefile.old<br />
$ <span class="kw2">sed</span> <span class="re5">-e</span> <span class="st_h">'s/game/life/g'</span> Makefile.old <span class="sy0">&gt;</span> Makefile</div></div></pre><p>If you are confident that your changes are exactly what you want, use the <code>-i</code> or <code>--in-place</code> option to edit the file in place. However, I recommend adding a backup filename suffix like <code>--in-place=.old</code> to save a copy of the original file in case you need to restore it later. It looks like this:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">sed</span> <span class="re5">--in-place</span>=.old <span class="re5">-e</span> <span class="st_h">'s/game/life/g'</span> Makefile<br />
$ <span class="kw2">ls</span> Makefile<span class="sy0">*</span><br />
Makefile  Makefile.old</div></div></pre><p></p><div class="embedded-resource-list callout-float-right">
            <div class="field field--name-title field--type-string field--label-hidden field__item">More Linux resources</div>
      
      <div class="field field--name-links field--type-link field--label-hidden field__items">
              <div class="field__item"><a href="https://developers.redhat.com/cheat-sheets/linux-commands-cheat-sheet/?intcmp=70160000000h1jYAAQ">Linux commands cheat sheet</a></div>
              <div class="field__item"><a href="https://developers.redhat.com/cheat-sheets/advanced-linux-commands/?intcmp=70160000000h1jYAAQ">Advanced Linux commands cheat sheet</a></div>
              <div class="field__item"><a href="https://www.redhat.com/en/services/training/rh024-red-hat-linux-technical-overview?intcmp=70160000000h1jYAAQ">Free online course: RHEL technical overview</a></div>
              <div class="field__item"><a href="https://opensource.com/downloads/cheat-sheet-networking?intcmp=70160000000h1jYAAQ">Linux networking cheat sheet</a></div>
              <div class="field__item"><a href="https://opensource.com/downloads/cheat-sheet-selinux?intcmp=70160000000h1jYAAQ">SELinux cheat sheet</a></div>
              <div class="field__item"><a href="https://opensource.com/downloads/linux-common-commands-cheat-sheet?intcmp=70160000000h1jYAAQ">Linux common commands cheat sheet</a></div>
              <div class="field__item"><a href="https://opensource.com/resources/what-are-linux-containers?intcmp=70160000000h1jYAAQ">What are Linux containers?</a></div>
              <div class="field__item"><a href="https://opensource.com/tags/linux?intcmp=70160000000h1jYAAQ">Our latest Linux articles</a></div>
          </div>
  </div>
<h2>Quoting files with sed on Linux</h2>
<p>You can use other features of regular expressions to match specific instances of text. For example, you might need to replace text that occurs at the start of a line. With <code>sed</code>, you can match the beginning of a line with <strong>^</strong>, the caret character.</p>
<p>One way I use "start of line" in replacing text is when I need to quote a file in an email. Let's say I want to share my Makefile in an email, but I don't want to include it as a file attachment. Instead, I prefer to "quote" the file in the body of an email, using <strong>&gt;</strong> before each line. I can use the following <code>sed</code> command to print out an edited version to my terminal, which I can copy and paste into a new email:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">sed</span> <span class="re5">-e</span> <span class="st_h">'s/^/&gt;/'</span> Makefile<br />
<span class="sy0">&gt;</span>.PHONY: all run clean<br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>all: life<br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>life: life.o<br />
<span class="sy0">&gt;</span>       $<span class="br0">(</span>CC<span class="br0">)</span> $<span class="br0">(</span>CFLAGS<span class="br0">)</span> <span class="re5">-o</span> life life.o $<span class="br0">(</span>LDFLAGS<span class="br0">)</span><br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>run: life<br />
<span class="sy0">&gt;</span>       .<span class="sy0">/</span>life<br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>clean:<br />
<span class="sy0">&gt;</span>       $<span class="br0">(</span>RM<span class="br0">)</span> <span class="sy0">*</span>~<br />
<span class="sy0">&gt;</span>       $<span class="br0">(</span>RM<span class="br0">)</span> <span class="sy0">*</span>.o<br />
<span class="sy0">&gt;</span>       $<span class="br0">(</span>RM<span class="br0">)</span> life</div></div></pre><p>The <code>s/^/&gt;/</code> regular expression matches the start of each line (<strong>^</strong>) and places a <strong>&gt;</strong> there. Effectively, this starts each line with the <strong>&gt;</strong> symbol.</p>
<p>The tabs might not show up correctly in an email, but I can replace all tabs in the Makefile with a few spaces by adding another regular expression:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">sed</span> <span class="re5">-e</span> <span class="st_h">'s/^/&gt;/'</span> <span class="re5">-e</span> <span class="st_h">'s/\t/  /g'</span> Makefile<br />
<span class="sy0">&gt;</span>.PHONY: all run clean<br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>all: life<br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>life: life.o<br />
<span class="sy0">&gt;</span>  $<span class="br0">(</span>CC<span class="br0">)</span> $<span class="br0">(</span>CFLAGS<span class="br0">)</span> <span class="re5">-o</span> life life.o $<span class="br0">(</span>LDFLAGS<span class="br0">)</span><br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>run: life<br />
<span class="sy0">&gt;</span>  .<span class="sy0">/</span>life<br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>clean:<br />
<span class="sy0">&gt;</span>  $<span class="br0">(</span>RM<span class="br0">)</span> <span class="sy0">*</span>~<br />
<span class="sy0">&gt;</span>  $<span class="br0">(</span>RM<span class="br0">)</span> <span class="sy0">*</span>.o<br />
<span class="sy0">&gt;</span>  $<span class="br0">(</span>RM<span class="br0">)</span> life</div></div></pre><p>The <code>\t</code> indicates a literal tab, so <code>s/\t/ /g </code>tells sed to replace all tabs in the input with two spaces in the output.</p>
<p>If you need to apply lots of edits to files, you can save your <code>-e</code> commands in a file and use <code>-f</code> to tell <code>sed</code> to use that file as a "script." This approach is especially useful if you need to make the same edits frequently. I might have prepared the Makefile for quoting in email using a script file called <code>quotemail.sed</code>:</p>
<pre>
<div class="geshifilter"><div class="bash geshifilter-bash">$ <span class="kw2">cat</span> quotemail.sed<br />
s<span class="sy0">/</span>^<span class="sy0">/&gt;/</span><br />
s<span class="sy0">/</span>\t<span class="sy0">/</span>  <span class="sy0">/</span>g<br />
$ <span class="kw2">sed</span> <span class="re5">-f</span> quotemail.sed Makefile<br />
<span class="sy0">&gt;</span>.PHONY: all run clean<br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>all: life<br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>life: life.o<br />
<span class="sy0">&gt;</span>  $<span class="br0">(</span>CC<span class="br0">)</span> $<span class="br0">(</span>CFLAGS<span class="br0">)</span> <span class="re5">-o</span> life life.o $<span class="br0">(</span>LDFLAGS<span class="br0">)</span><br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>run: life<br />
<span class="sy0">&gt;</span>  .<span class="sy0">/</span>life<br />
<span class="sy0">&gt;</span><br />
<span class="sy0">&gt;</span>clean:<br />
<span class="sy0">&gt;</span>  $<span class="br0">(</span>RM<span class="br0">)</span> <span class="sy0">*</span>~<br />
<span class="sy0">&gt;</span>  $<span class="br0">(</span>RM<span class="br0">)</span> <span class="sy0">*</span>.o<br />
<span class="sy0">&gt;</span>  $<span class="br0">(</span>RM<span class="br0">)</span> life</div></div></pre><h2>Learn to work with sed on Linux</h2>
<p><code>sed</code> is a great tool to keep in your Linux command-line toolkit. Explore the <code>sed</code> manual page and learn more about how to use it. Type <code>man sed</code> at the command line to get complete documentation about the different command line options and how to use <code>sed</code> to process text files.</p>
</div>
      
  </div>
<div class="block block-layout-builder block-field-blocknodearticlefield-listicle-title">
  
    
      
            <div class="hidden field field--name-field-listicle-title field--type-string field--label-hidden field__item">What to read next</div>
      
  </div>
<div class="block block-layout-builder block-field-blocknodearticlefield-tags">
  
    
      
  <div class="field field--name-field-tags field--type-entity-reference field--label-inline clearfix">
    <div class="field__label">Tags</div>
          <div class="field__items">
              <div class="field__item"><a href="/tags/linux" hreflang="en">Linux</a></div>
              </div>
      </div>

  </div>
<div class="views-element-container author-block block block-views block-views-blockauthor-info-author-info">
  <div class="author-block__wrapper">
  
    
      <div><div class="view view-author-info view-id-author_info view-display-id-author_info js-view-dom-id-bc71bc6a7d2dd740cca00e36bf2325842659fb3b924adc8bb59cd0ea81e845e1">
  
    
      
      <div class="view-content">
          <div class="views-row"><div class="views-field views-field-field-display-name"><div class="field-content"><a href="/users/jim-hall" hreflang="en">Jim Hall</a></div></div><div class="views-field views-field-field-user-picture"><div class="field-content">  <img src="/sites/default/files/styles/150x150/public/pictures/jimhall1.jpg?itok=F9E_3NCo" width="150" height="150" alt="photo of Jim Hall" loading="lazy" class="image-style-_50x150" />


</div></div><div class="views-field views-field-field-user-about"><span class="field-content">Jim Hall is an open source software advocate and developer, best known for usability testing in GNOME and as the founder + project coordinator of FreeDOS. At work, Jim is CEO of Hallmentum, an IT executive consulting company that provides hands-on IT Leadership training, workshops, and coaching.
</span></div><div class="views-field views-field-nothing"><span class="field-content"><a href="/users/jim-hall">More about me</a></span></div></div>

    </div>
  
      
          </div>
</div>

    </div>
</div>


<div class="views-element-container author-block block block-views block-views-blockauthor-info-block-1">
  <div class="author-block__wrapper plain">
  
    
      <div><div class="view view-author-info view-id-author_info view-display-id-block_1 js-view-dom-id-2bebbf65b2c934511da10f0d499d3e2b944ed375e0fd06fedd57fbc68066785a">
  
    
      
  
      
          </div>
</div>

    </div>
</div>


<div class="block block-layout-builder block-field-blocknodearticlefield-comments">
  
    
      <section id='comments'  class="field field--name-field-comments field--type-comment field--label-hidden comment-wrapper">
  

  <div class="comments__count">
          <h2>3 Comments</h2>
        <div class="login"><a href="/user/register?absolute=1">Register</a> or <a href="/user/login?current=/node/70127&amp;absolute=1">Login</a> to post a comment.</div>
  </div>

    
<article  data-comment-user-id="30666" id="comment-219731" class="comment js-comment">
    <mark class="hidden" data-comment-timestamp="1659445479"></mark>

  <footer class="comment__meta">
    <article class="media media--type-image media--view-mode-byline">
  
      
            <div class="field field--name-field-media-image field--type-image field--label-hidden field__item">  <img loading="lazy" src="/sites/default/files/styles/medium/public/20150529_gregp.jpg?itok=pjjrMm9R" width="189" height="220" class="image-style-medium" />


</div>
      
  </article>

    <div>
      <div class="comment__submitted">
        <a href="/users/greg-p">Greg Pittman</a> | August 2, 2022
        
      </div>
      <div class="content">
        
            <div class="clearfix text-formatted field field--name-comment-body field--type-text-long field--label-hidden field__item"><p>Something else you can do to test whether you want to switch text is to run grep for the text you think you want to switch. You will see highlighted all the instances of that text.</p>
</div>
      <ul class="links inline"><li class="comment-forbidden"><a href="/user/login?destination=/article/22/8/automate-file-edits-sed-linux%23comment-form">Log in</a> or <a href="/user/register?destination=/article/22/8/automate-file-edits-sed-linux%23comment-form">register</a> to post comments</li></ul>
      </div>
    </div>
        
  </footer>

</article>

  
<article  data-comment-user-id="216961" id="comment-219732" class="comment js-comment">
    <mark class="hidden" data-comment-timestamp="1659459467"></mark>

  <footer class="comment__meta">
    <article class="media media--type-image media--view-mode-byline">
  
      
            <div class="field field--name-field-media-image field--type-image field--label-hidden field__item">  <img loading="lazy" src="/sites/default/files/styles/medium/public/pictures/twitprof_400x400_0.jpg?itok=uaQn8kdH" width="220" height="220" alt="Alan Formy-Duval Opensource.com Correspondent" class="image-style-medium" />


</div>
      
  </article>

    <div>
      <div class="comment__submitted">
        <a href="/users/alanfdoss">Alan Formy-Duval</a> | August 2, 2022
        
      </div>
      <div class="content">
        
            <div class="clearfix text-formatted field field--name-comment-body field--type-text-long field--label-hidden field__item"><p>Great article, sed is such a useful tool!</p>
</div>
      <ul class="links inline"><li class="comment-forbidden"><a href="/user/login?destination=/article/22/8/automate-file-edits-sed-linux%23comment-form">Log in</a> or <a href="/user/register?destination=/article/22/8/automate-file-edits-sed-linux%23comment-form">register</a> to post comments</li></ul>
      </div>
    </div>
        
  </footer>

</article>

  
<article  data-comment-user-id="65856" id="comment-219733" class="comment js-comment">
    <mark class="hidden" data-comment-timestamp="1659526490"></mark>

  <footer class="comment__meta">
    <article class="media media--type-image media--view-mode-byline">
  
      
            <div class="field field--name-field-media-image field--type-image field--label-hidden field__item">  <img loading="lazy" src="/sites/default/files/styles/medium/public/osdc_default_avatar_1.png?itok=G0WcUo3c" width="100" height="100" alt="Avatar" title="Avatar" class="image-style-medium" />


</div>
      
  </article>

    <div>
      <div class="comment__submitted">
        <a href="/users/martymonroe">MartyMonroe</a> | August 3, 2022
        
      </div>
      <div class="content">
        
            <div class="clearfix text-formatted field field--name-comment-body field--type-text-long field--label-hidden field__item"><p>Recently we moved our Moodle instance to a new box and decided to change the web address to something more sensible. Editing the MySQL database dump was a breeze with sed under cygwin. In fact, that was the only way to do it. The 5.5MB dump could not be opened in notepad, wordpad, etc.</p>
</div>
      <ul class="links inline"><li class="comment-forbidden"><a href="/user/login?destination=/article/22/8/automate-file-edits-sed-linux%23comment-form">Log in</a> or <a href="/user/register?destination=/article/22/8/automate-file-edits-sed-linux%23comment-form">register</a> to post comments</li></ul>
      </div>
    </div>
        
  </footer>

</article>


  
</section>

  </div>
<div class="views-element-container related-articles block block-views block-views-blockrelated-articles-related-articles">
  
      <h2 class="related-articles__title">Related Content</h2>
    
      <div><div class="view view-related-articles view-id-related_articles view-display-id-related_articles js-view-dom-id-d63f2f1f99077d8fcdc93fa2bdebce8f5e3dae854721a6abe97b25e98c2570fb">
  
    
      
      <div class="view-content">
          <div class="views-row"><div class="views-field views-field-field-lead-image"><div class="field-content">  <a href="/article/22/8/network-configuration-files" hreflang="en"><img src="/sites/default/files/styles/222x125/public/lead-images/yearbook-haff-rx-linux-file-lead_0.png?itok=cY_J8Rmm" width="222" height="125" alt="﻿Why the operating system matters even more in 2017" title="﻿Why the operating system matters even more in 2017" loading="lazy" class="image-style-_22x125" />

</a>
</div></div><div class="views-field views-field-title"><span class="field-content"><a href="/article/22/8/network-configuration-files" hreflang="en">A sysadmin&#039;s guide to network interface configuration files</a></span></div></div>
    <div class="views-row"><div class="views-field views-field-field-lead-image"><div class="field-content">  <a href="/article/22/8/disable-ipv6" hreflang="en"><img src="/sites/default/files/styles/222x125/public/lead-images/connections_wires_sysadmin_cable.png?itok=JNVdVEU0" width="222" height="125" alt="Multi-colored and directional network computer cables" title="Multi-colored and directional network computer cables" loading="lazy" class="image-style-_22x125" />

</a>
</div></div><div class="views-field views-field-title"><span class="field-content"><a href="/article/22/8/disable-ipv6" hreflang="en">How I disabled IPv6 on Linux</a></span></div></div>
    <div class="views-row"><div class="views-field views-field-field-lead-image"><div class="field-content">  <a href="/article/22/7/print-stack-trace-bash-scripts" hreflang="en"><img src="/sites/default/files/styles/222x125/public/lead-images/bug_software_issue_tracking_computer_screen.jpg?itok=Y28dIsy3" width="222" height="125" alt="Bug tracking magnifying glass on computer screen" title="Bug tracking magnifying glass on computer screen" loading="lazy" class="image-style-_22x125" />

</a>
</div></div><div class="views-field views-field-title"><span class="field-content"><a href="/article/22/7/print-stack-trace-bash-scripts" hreflang="en">Fix bugs in Bash scripts by printing a stack trace</a></span></div></div>

    </div>
  
          </div>
</div>

  </div>

<div class="block block-layout-builder block-field-blocknodearticlefield-default-license">
  
    
      
            <div class="field field--name-field-default-license field--type-list-string field--label-hidden field__item"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" src="/themes/osdc/assets/img/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a>This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License.</div>
      
  </div>

    </div>
  </div>

  </div>
</article>




  </div>
<div id="block-socialmediashareicons" class="block block-osdc-system block-osdc-social-block">
  
    
      <div><a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A//red.ht/3OEpvmM&amp;title=How%20I%20use%20the%20Linux%20sed%20command%20to%20automate%20file%20edits&amp;summary=Here%20are%20some%20tips%20and%20tricks%20to%20automating%20file%20edits%20from%20the%20Linux%20command%20line.%20&amp;source=Opensource.com" class="linkedin-icon">LinkedIn</a><a href="https://twitter.com/intent/tweet?text=How%20I%20use%20the%20Linux%20sed%20command%20to%20automate%20file%20edits%20https%3A//red.ht/3OEpvmM%20via%20%40opensourceway%20by%20%40jimfhall&amp;related=opensourceway%2Cjimfhall" class="twitter-icon">Twitter</a><a href="https://www.facebook.com/sharer.php?u=https%3A//red.ht/3OEpvmM" class="facebook-icon">Facebook</a><a href="https://api.whatsapp.com/send?text=How%20I%20use%20the%20Linux%20sed%20command%20to%20automate%20file%20edits%20%7C%20Opensource.com%20https%3A//red.ht/3OEpvmM" class="whatsapp-icon">WhatsApp</a><a href="mailto:?subject=How%20I%20use%20the%20Linux%20sed%20command%20to%20automate%20file%20edits%20%7C%20OpenSource.com&amp;body=https%3A//red.ht/3OEpvmM" class="email-icon">Email</a><a href="https://www.reddit.com/submit?url=https%3A//red.ht/3OEpvmM&amp;title=How%20I%20use%20the%20Linux%20sed%20command%20to%20automate%20file%20edits%20%7C%20OpenSource.com" class="reddit-icon">Reddit</a><pfe-modal><button slot="pfe-modal--trigger" class="mastodon-icon"><span class="screen-reader-text">Mastodon</span></button><div id="mastodon-container"></div></pfe-modal><form id="mastodon-form" class="mastodon-form" data-drupal-selector="mastodon-form" action="/article/22/8/automate-file-edits-sed-linux" method="post" accept-charset="UTF-8">
  <div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-mastodon-url form-item-mastodon-url">
      <label for="edit-mastodon-url">Location of your Mastodon instance:</label>
        <input data-drupal-selector="edit-mastodon-url" type="text" id="edit-mastodon-url" name="mastodon_url" value="" size="60" maxlength="128" class="form-text" />

        </div>
<input autocomplete="off" data-drupal-selector="form-muznvpeycbrl8kfxckridgv45a0qu0hlwsha6ktdj2y" type="hidden" name="form_build_id" value="form-muZnVPeYCBRL8kFXcKrIDgv45a0qU0HLWShA6kTDj2Y" />
<input data-drupal-selector="edit-mastodon-form" type="hidden" name="form_id" value="mastodon_form" />
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions"><input data-query="?url=https://red.ht/3OEpvmM&amp;text=How I use the Linux sed command to automate file edits | OpenSource.com" data-drupal-selector="edit-submit" type="submit" id="edit-submit" name="op" value="Toot" class="button button--primary js-form-submit form-submit" />
</div>

</form>
</div>

  </div>

<div id="subscribe-cta" class="subscribe-cta block block-block-content block-block-contente8c82e66-7bc7-4c25-9c7c-f7bbdcb3c2d3">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><div class="cta__text-and-form">
<div class="cta__text">
<h2 class="cta__title">Subscribe to our weekly newsletter</h2>
</div>
<div class="cta__form">
<iframe class="eloqua-embedded-bottom" frameborder="0" height="192" id="fkfkx" scrolling="no" src="https://opensource.com/eloqua-embedded-subscribe.html?offer_id=70160000000QzXNAA0" style="max-width:600px;margin:0 auto;" width="100%"></iframe></div>
<p><a href="https://www.redhat.com/footer/privacy-policy.html" target="_blank">Privacy Statement</a></p>
</div>
</div>
      
  </div>


  </div>

    </div>
  </main>

      <footer class="global_footer">
      <div class="wrapper">
          <div class="region region-left-footer">
    <div id="block-aboutthissitefooter" class="block block-block-content block-block-content1d00183d-1f84-4ed3-9367-c632014cd322">
  
      <h2>About This Site</h2>
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>
<p><a href="https://opensource.com/">Opensource.com</a> aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
<p>A note on advertising: Opensource.com does not sell advertising on the site or in any of its newsletters.</p>
</div>
      
  </div>

  </div>

          <div class="region region-right-footer">
    <div id="block-connectfooter" class="block block-block-content block-block-content04a63217-9bba-49ac-9d2c-b2eb30fb8526">
  
      <h2>Contact</h2>
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p class="footer-twitter"><a href="https://twitter.com/OpenSourceWay" target="_blank">Follow us @opensource.com on Twitter</a></p>
<p class="footer-facebook"><a href="https://www.facebook.com/opensourceway" target="_blank">Like Opensource.com on Facebook</a></p>
<p class="footer-youtube"><a href="http://www.youtube.com/opensourceway" target="_blank">Watch us at Opensource.com</a></p>
<p class="footer-mastodon"><a href="https://fosstodon.org/@osdc">Follow us on Mastodon</a></p>
<p class="footer-rss"><a href="https://opensource.com/feed">RSS Feed</a></p>
</div>
      
  </div>
<div id="block-sitebranding" class="block block-system block-system-branding-block">
  
    
    <div class="branding">
          <a href="/" rel="home" aria-label="" class="branding__logo">
        <img src="/themes/osdc/logo.svg" alt="Home"/>
      </a>
      </div>
</div>

  </div>

          <div class="region region-copyright">
    <div id="block-copyrightfooter" class="block block-block-content block-block-contentc0a744a4-2740-4f8a-a693-ee8d7cb5ff86">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>Copyright ©<span id="copyright-year">2021</span> Red Hat, Inc.</p>
</div>
      
  </div>
<nav role="navigation" aria-labelledby="block-legal-menu" id="block-legal" class="block block-menu navigation menu--legal">
            
  <h2 class="visually-hidden" id="block-legal-menu">Legal</h2>
  

        
              <ul class="menu">
                    <li class="menu-item">
        <a href="/privacy-policy" data-drupal-link-system-path="node/17705">Privacy Policy</a>
              </li>
                <li class="menu-item">
        <a href="/legal" data-drupal-link-system-path="legal">Terms of use</a>
              </li>
                <li class="menu-item">
        <a href="/contact" data-drupal-link-system-path="node/68921">Contact</a>
              </li>
        </ul>
  


  </nav>

  </div>

      </div>
    </footer>
  
</div>
  </div>

    
    <script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/70127","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ajaxPageState":{"libraries":"classy\/base,classy\/indented,classy\/messages,classy\/node,codesnippet\/codesnippet.highlightjs,codesnippet\/codesnippet.style.vs,comment\/drupal.comment-by-viewer,core\/normalize,flag\/flag.link_ajax,geshifilter\/geshifilter,layout_discovery\/onecol,osdc\/author-block,osdc\/author-meta,osdc\/comments,osdc\/global,osdc\/poll,osdc\/related-content,osdc\/search,osdc\/social-shares,osdc\/subscribe-float,poll\/drupal.poll-links,rate\/thumbs-up,system\/base,views\/views.module","theme":"osdc","theme_token":null},"ajaxTrustedUrl":{"form_action_p_pvdeGsVG5zNF_XLGPTvYSKCf43t8qZYSwcfZl2uzM":true,"\/site-search":true},"user":{"uid":0,"permissionsHash":"af4858ad1c65186ac44e3cbfc73c8006e4259986d4e743bd7f73e117f9447519"}}</script>
<script src="/sites/default/files/js/js_husSYrzUWeiB1ynd2OR98yjZPlgHRjVEgB-r5u7Eihc.js"></script>
<script src="/themes/osdc/node_modules/%40patternfly/pfe-readtime/dist/pfe-readtime.min.js?rfy24c" type="module"></script>
<script src="/sites/default/files/js/js_pCdFIxDeIxvY9rDnz6NXaaBahWSbbwPONf_V2pSGL0k.js"></script>

  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"NRJS-6128485344987227876","applicationID":"1384502491","transactionName":"NlJbMERZV0FXBURbDA8YeAdCUVZcGRZRVQY+VFgHXl0=","queueTime":0,"applicationTime":44,"atts":"GhVYRgxDRE8=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
