<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="og: https://ogp.me/ns#">
  <head>
    <meta charset="utf-8" /><script type="text/javascript">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</script>
<script id="datalayer-page-load-started" type="application/ld+json" data-event="Page Load Started">
    {
        "userAttributes": [
            "Correspondent"
        ],
        "authoredOn": "Sat, 12/24/2022 - 03:00",
        "blogAuthor": "Don Watkins",
        "coAuthorDisplayNames": [],
        "commentCount": "0",
        "contentID": "70384",
        "contentType": "Article",
        "creditsDisplayNames": [],
        "destinationURL": "https://opensource.com/article/22/12/open-source-education",
        "pageName": "9 resources about open source for educators and students",
        "siteName": "Opensource.com",
        "pageStatus": "1",
        "taxonomyTags": [
            "Best of Opensource.com",
            "Education"
        ],
        "pageTitle": "9 resources about open source for educators and students"
    }
</script>
<script id="datalayer_inline_js" type="application/javascript" src="/modules/custom/datalayer_metatag/libraries/dist/js/eddl_top.min.js?v=rn59ma" module></script>
<link rel="canonical" href="https://opensource.com/article/22/12/open-source-education" />
<link rel="shortlink" href="https://opensource.com/node/70384" />
<meta name="description" content="Open source helps educators, scholars, students, and lifelong learners explore new horizons." />
<meta property="og:type" content="9 resources about open source for educators and students" />
<meta property="og:url" content="https://opensource.com/article/22/12/open-source-education" />
<meta property="og:title" content="9 resources about open source for educators and students" />
<meta property="og:description" content="Open source helps educators, scholars, students, and lifelong learners explore new horizons." />
<meta property="og:image" content="https://opensource.com/sites/default/files/2022-12/daffodils_seth-kenlon_cc0.webp" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Open source helps educators, scholars, students, and lifelong learners explore new horizons." />
<meta name="twitter:title" content="9 resources about open source for educators and students" />
<meta name="twitter:creator" content="@Don_Watkins" />
<meta name="twitter:image" content="https://opensource.com/sites/default/files/2022-12/daffodils_seth-kenlon_cc0.webp" />
<meta name="Generator" content="Drupal 9 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="icon" href="/themes/osdc/assets/img/favicons/favicon.ico" type="image/vnd.microsoft.icon" />

    <title>9 resources about open source for educators and students | Opensource.com</title>
    <link rel="stylesheet" media="all" href="/sites/default/files/css/css_G5pAaR4ZJDuk3M1Ws0PhOVFEzHL-MTALCtZ51bx1jRs.css" />
<link rel="stylesheet" media="all" href="https://opensource.com/sites/default/files/geshi/geshifilter-languages.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_kUcDg88y4LI4YGqbiH05mKoOMiA-EBZwEiW5XDlnSJ0.css" />
<link rel="stylesheet" media="all" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_IsrhMO6jbGDkZitSt1z1LW_KADKyUP4sObpfnB58uoE.css" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_87ZKMv1qGU139S7Ds0tE9cyBeWcN0Mx2GsiDXHvMSI8.css" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css2?family=Red+Hat+Text:wght@400;500;700&amp;display=swap" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css2?family=Red+Hat+Mono:wght@400;500;700&amp;display=swap" />
<link rel="stylesheet" media="all" href="/sites/default/files/css/css_t4Wzu7GYLua_B1yapNksTrR2YVpuBz4vY3V1_qnTBSk.css" />

    <script id="adobe_dtm" src="https://www.redhat.com/ma/dpal.js" type="text/javascript"></script>
    
    <script type="module" src="/themes/osdc/node_modules/@patternfly/pfe-modal/dist/pfe-modal.min.js"></script>
  </head>
  <body class="path-node page-node-type-article">
        <a href="#main-content" class="focusable skip-link">
      Skip to main content
    </a>
    
      <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    <div class="layout-container">

  <header>
      <div class="region region-messages">
    <div data-drupal-messages-fallback class="hidden"></div>

  </div>

    
<div class="region-top-bar">
  <div class="region wrapper region-user-menu">
    <div class="hamburger__container">
        <div class="hamburger">
            <button id="mobnav-btn" aria-label="Toggle main menu" class="button--plain toggle-menu"></button>
            <div class="bar"></div>
        </div>
    </div>

    <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" target="_blank" class="flex-center support-logo">
        <img alt="Supported by Red Hat" src="/themes/osdc/assets/img/l_supported-by-redhat-white.svg" title="Supported by Red Hat" width="125" height="56" class="support-logo__image">
    </a>

    <button id="toggle-search" aria-label="Toggle Search" class="button--plain toggle-search">
        <i class="icon-search"></i>
    </button>
    <nav role="navigation" aria-labelledby="block-useraccountmenu-menu" id="block-useraccountmenu" class="block block-menu navigation menu--account">
            
  <h2 class="visually-hidden" id="block-useraccountmenu-menu">User account menu</h2>
  

        
    
                    <ul class="account">
    
                            <li class="log-in account__item">
        <a href="/user/login?destination=/article/22/12/open-source-education" class="account__link" data-drupal-link-system-path="user/login">Log in</a>
                </li>
                            <li class="sign-up account__item">
        <a href="/user/register" class="account__link" data-drupal-link-system-path="user/register">Sign Up</a>
                </li>
                            <li class="facebook account__item">
        <a href="https://www.facebook.com/opensourceway" title="facebook" class="account__link">Facebook</a>
                </li>
                            <li class="twitter account__item">
        <a href="http://twitter.com/opensourceway" title="twitter" class="account__link">Twitter</a>
                </li>
                            <li class="rss account__item">
        <a href="/feed" title="RSS" class="account__link" data-drupal-link-system-path="rss.xml">RSS</a>
                </li>
            </ul>
    


  </nav>

  </div>
</div>

      <div class="region region-header">
    <div id="block-osdc-branding" class="block block-system block-system-branding-block">
  
    
    <div class="branding">
          <a href="/" rel="home" aria-label="Opensource.com" class="branding__logo">
        <img src="/themes/osdc/logo.svg" alt="Home"/>
      </a>
        <a href="https://www.redhat.com/en?intcmp=701600000011l7VAAQ" target="_blank" class="branding__supported-by">
      <img src="/themes/osdc/assets/img/l_supported-by-redhat-white.svg" width="125" height="56" class="branding__supported-by__image" alt="Supported by Red Hat">
    </a>
  </div>
  <div class="branding__slogan"></div>
</div>

  </div>

  </header>

    <div class="region region-main-nav">
    <nav role="navigation" aria-labelledby="block-mainnavigation-menu" id="block-mainnavigation" class="block block-menu navigation menu--main">
            
  <h2 class="visually-hidden" id="block-mainnavigation-menu">Main navigation</h2>
  

        
    
                    <ul class="main" id="main-menu">
    
                            <li class="main__item is-expanded">
        <a href="/" class="main__link" data-drupal-link-system-path="&lt;front&gt;">Articles</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item is-expanded">
        <a href="/tags/linux" class="main__link" data-drupal-link-system-path="taxonomy/term/6803">Linux</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/tags/command-line" class="main__link" data-drupal-link-system-path="taxonomy/term/5276">Command line</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/tags/kubernetes" class="main__link" data-drupal-link-system-path="taxonomy/term/9749">Kubernetes</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/tags/programming" class="main__link" data-drupal-link-system-path="taxonomy/term/7866">Programming</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/tags/go-programming-language" class="main__link" data-drupal-link-system-path="taxonomy/term/15746">Go</a>
                </li>
                            <li class="main__item">
        <a href="/tags/javascript" class="main__link" data-drupal-link-system-path="taxonomy/term/6609">JavaScript</a>
                </li>
                            <li class="main__item">
        <a href="/tags/python" class="main__link" data-drupal-link-system-path="taxonomy/term/7934">Python</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/tags/containers" class="main__link" data-drupal-link-system-path="taxonomy/term/9523">Containers</a>
                </li>
                            <li class="main__item">
        <a href="/tags/sysadmin" class="main__link" data-drupal-link-system-path="taxonomy/term/8596">Sysadmin</a>
                </li>
                            <li class="main__item">
        <a href="/tags/devops" class="main__link" data-drupal-link-system-path="taxonomy/term/9255">DevOps</a>
                </li>
                            <li class="main__item">
        <a href="/tags/gaming" class="main__link" data-drupal-link-system-path="taxonomy/term/6089">Gaming</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/tags/hardware" class="main__link" data-drupal-link-system-path="taxonomy/term/6284">Hardware</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/tags/3d-printing" class="main__link" data-drupal-link-system-path="taxonomy/term/4635">3D printing</a>
                </li>
                            <li class="main__item">
        <a href="/tags/arduino" class="main__link" data-drupal-link-system-path="taxonomy/term/4740">Arduino</a>
                </li>
                            <li class="main__item">
        <a href="/tags/raspberry-pi" class="main__link" data-drupal-link-system-path="taxonomy/term/7974">Raspberry Pi</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/tags/government" class="main__link" data-drupal-link-system-path="taxonomy/term/6211">Government</a>
                </li>
                            <li class="main__item">
        <a href="/tags/law" class="main__link" data-drupal-link-system-path="taxonomy/term/6744">Law</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/tags/open-organization" class="main__link" data-drupal-link-system-path="taxonomy/term/14761">Open Organization</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/open-organization/resources/open-org-definition" class="main__link" data-drupal-link-system-path="node/33506">What is an open organization?</a>
                </li>
                            <li class="main__item">
        <a href="/open-organization/resources/open-decision-framework" class="main__link" data-drupal-link-system-path="node/30866">What is an open decision?</a>
                </li>
            </ul>
    
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/resources" class="main__link" data-drupal-link-system-path="node/17752">Resources</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item is-expanded">
        <a href="/resources/what-open-source" class="main__link" data-drupal-link-system-path="node/17753">What is open source?</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/open-source-way" class="main__link" data-drupal-link-system-path="node/17730">The open source way</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/resources/projects-and-applications" class="main__link" data-drupal-link-system-path="node/17760">Projects and applications</a>
                </li>
                            <li class="main__item">
        <a href="/resources/organizations" class="main__link" data-drupal-link-system-path="node/17763">Organizations</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/resources/cloud" class="main__link" data-drupal-link-system-path="node/31366">Cloud technology</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/resources/what-ansible" class="main__link" data-drupal-link-system-path="node/56241">Ansible</a>
                </li>
                            <li class="main__item">
        <a href="/resources/big-data" class="main__link" data-drupal-link-system-path="node/21471">Big data</a>
                </li>
                            <li class="main__item">
        <a href="/resources/data-science" class="main__link" data-drupal-link-system-path="node/55831">Data science</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-docker" class="main__link" data-drupal-link-system-path="node/18438">Docker</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-git" class="main__link" data-drupal-link-system-path="node/29816">Git</a>
                </li>
                            <li class="main__item">
        <a href="/resources/internet-of-things" class="main__link" data-drupal-link-system-path="node/25831">Internet of things</a>
                </li>
                            <li class="main__item">
        <a href="/resources/java" class="main__link" data-drupal-link-system-path="node/38936">Java</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-kubernetes" class="main__link" data-drupal-link-system-path="node/27941">Kubernetes</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-are-linux-containers" class="main__link" data-drupal-link-system-path="node/29741">Linux containers</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-are-microservices" class="main__link" data-drupal-link-system-path="node/23541">Microservices</a>
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-openstack" class="main__link" data-drupal-link-system-path="node/17870">OpenStack</a>
                </li>
                            <li class="main__item is-expanded">
        <a href="/resources/python" class="main__link" data-drupal-link-system-path="node/37296">Python</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/resources/python/gui-frameworks" class="main__link" data-drupal-link-system-path="node/28806">Python GUI frameworks</a>
                </li>
                            <li class="main__item">
        <a href="/resources/python/ides" class="main__link" data-drupal-link-system-path="node/24166">Python IDEs</a>
                </li>
                            <li class="main__item">
        <a href="/resources/python/template-libraries" class="main__link" data-drupal-link-system-path="node/44451">Python template libraries</a>
                </li>
                            <li class="main__item">
        <a href="/resources/python/web-scraper-crawler" class="main__link" data-drupal-link-system-path="node/39381">Python web scrapers</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/resources/what-is-software-defined-networking" class="main__link" data-drupal-link-system-path="node/19276">Software defined networking</a>
                </li>
                            <li class="main__item">
        <a href="/resources/virtualization" class="main__link" data-drupal-link-system-path="node/36551">Virtualization</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/alternatives" class="main__link" data-drupal-link-system-path="node/30871">Open source alternatives</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/alternatives/adobe-acrobat" class="main__link" data-drupal-link-system-path="node/29486">Alternatives to Acrobat</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/autocad" class="main__link" data-drupal-link-system-path="node/29001">Alternatives to AutoCAD</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/dreamweaver" class="main__link" data-drupal-link-system-path="node/27646">Alternatives to Dreamweaver</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/gmail" class="main__link" data-drupal-link-system-path="node/22941">Alternatives to Gmail</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/matlab" class="main__link" data-drupal-link-system-path="node/29276">Alternatives to MATLAB</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/minecraft" class="main__link" data-drupal-link-system-path="node/22786">Alternatives to Minecraft</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/google-photos" class="main__link" data-drupal-link-system-path="node/27211">Alternatives to Google Photos</a>
                </li>
                            <li class="main__item">
        <a href="/life/12/6/design-without-debt-five-tools-for-designers" class="main__link" data-drupal-link-system-path="node/16365">Alternatives to Photoshop</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/skype" class="main__link" data-drupal-link-system-path="node/45576">Alternatives to Skype</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/slack" class="main__link" data-drupal-link-system-path="node/23286">Alternatives to Slack</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives/trello" class="main__link" data-drupal-link-system-path="node/22546">Alternatives to Trello</a>
                </li>
                            <li class="main__item">
        <a href="/alternatives" class="main__link" data-drupal-link-system-path="node/30871">More...</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/resources/linux" class="main__link" data-drupal-link-system-path="node/19796">Linux</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/downloads" class="main__link" data-drupal-link-system-path="downloads">Downloads</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/downloads/cheat-sheets" class="main__link" data-drupal-link-system-path="downloads/cheat-sheets">Cheat sheets</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/devops-guides" class="main__link" data-drupal-link-system-path="downloads/devops-guides">DevOps guides</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/programming-guides" class="main__link" data-drupal-link-system-path="downloads/programming-guides">Programming guides</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/sysadmin-guides" class="main__link" data-drupal-link-system-path="downloads/sysadmin-guides">Sysadmin guides</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/ebooks" class="main__link" data-drupal-link-system-path="downloads/ebooks">eBooks</a>
                </li>
                            <li class="main__item">
        <a href="/downloads/open-source-yearbook" class="main__link" data-drupal-link-system-path="downloads/open-source-yearbook">Open Source Yearbook</a>
                </li>
                            <li class="main__item">
        <a href="/open-organization/resources/book-series" class="main__link" data-drupal-link-system-path="node/37936">Open Organization series</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/about" class="main__link" data-drupal-link-system-path="node/17734">Community</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item is-expanded">
        <a href="/about" class="main__link" data-drupal-link-system-path="node/17734">About Opensource.com</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/participate" class="main__link" data-drupal-link-system-path="node/17735">Welcome to the Opensource.com community</a>
                </li>
                            <li class="main__item">
        <a href="/team" class="main__link" data-drupal-link-system-path="node/17744">Meet the team</a>
                </li>
                            <li class="main__item">
        <a href="/user/register" class="main__link" data-drupal-link-system-path="user/register">Create an account</a>
                </li>
                            <li class="main__item">
        <a href="/code-of-conduct" class="main__link" data-drupal-link-system-path="node/17710">Rules for comments and discussions</a>
                </li>
                            <li class="main__item">
        <a href="/correspondent-program" class="main__link" data-drupal-link-system-path="node/17743">Correspondent Program</a>
                </li>
                            <li class="main__item">
        <a href="/faq" class="main__link" data-drupal-link-system-path="node/62466">Frequently Asked Questions</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item is-expanded">
        <a href="/writers" class="main__link" data-drupal-link-system-path="node/18340">Contribute to Opensource.com</a>
                        
                    <ul class="main__submenu">
    
                            <li class="main__item">
        <a href="/submission-style-guide" class="main__link" data-drupal-link-system-path="node/18705">Opensource.com style guide</a>
                </li>
                            <li class="main__item">
        <a href="/article/22/1/open-source-community-writing-topics" class="main__link" data-drupal-link-system-path="node/69156">Writing topics</a>
                </li>
            </ul>
    
                </li>
                            <li class="main__item">
        <a href="/contact" class="main__link" data-drupal-link-system-path="node/68921">Contact Us</a>
                </li>
            </ul>
    
                </li>
            </ul>
    


  </nav>
<div class="views-exposed-form block block-views block-views-exposed-filter-blockacquia-search-page" data-drupal-selector="views-exposed-form-acquia-search-page" id="block-exposedformacquia-searchpage">
  
    
      <form action="/site-search" method="get" id="views-exposed-form-acquia-search-page" accept-charset="UTF-8">
  <div class="form--inline clearfix">
  <div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-search form-item-search">
      <label for="edit-search">Search</label>
        <input placeholder="Search" data-drupal-selector="edit-search" type="text" id="edit-search" name="search" value="" size="30" maxlength="128" class="form-text" />

        </div>
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions--2"><input data-drupal-selector="edit-submit-acquia-search" type="submit" id="edit-submit-acquia-search" value="Search" class="button js-form-submit form-submit" />
</div>

</div>

</form>

  </div>


  </div>


  <main>
    <a id="main-content" tabindex="-1"></a>
    <div class="wrapper wrapper--870">
        <div class="region region-content">
    <div class="dyfo-float hide block block-rhcomdev-dyfo-block block-rhcomdev-dyfo-block-dynamic-form-block subscribe-float" id="block-dynamicformblock-2">
  <button id="subscribe-float-close" class="subscribe-float__close"><span>x</span></button>
  
  
      <h2 class="subscribe-float__title">Subscribe to our <span>newsletter.</span></h2>

<div class="rh-dyfo" data-rh-dyfo-instance="67a6eb65-87cf-46a5-b2d8-e23f686b615a"></div>

<p><a href="https://www.redhat.com/en/about/privacy-policy">Privacy Statement</a></p>
  </div>

<div id="block-osdc-page-title" class="block block-core block-page-title-block">
  
    
      
  <h1 class="published page-title">
    <span class="field field--name-title field--type-string field--label-hidden">9 resources about open source for educators and students</span>

      </h1>


  </div>
<div id="block-mainpagecontent" class="block block-system block-system-main-block">
  
    
      
<article class="node node--type-article node--promoted node--view-mode-full">

  
  <div class="article__subhead">Open source helps educators, scholars, students, and lifelong learners explore new horizons.</div>

      <footer class="author__meta">
      <div class="author__submitted">
        <div class="author__list">
          By 
<article class="profile">
            <a href="/users/don-watkins" hreflang="en">Don Watkins</a>
      <span class="user-attributes">(Correspondent)</span>

</article>
 
        </div>
        <div class="author__meta-date-container">
                    <span class="author__meta-date">December 24, 2022</span>          <span class="author__date-pipe">|</span>
          <a href="#comments"><span class="author__comment-count">0 Comments </span></a>
          <span class="author__date-pipe">|</span>
          <pfe-readtime class="pf-global--FontSize--lg" for="#article_content" hidden>%t min read</pfe-readtime>

        </div>
      </div>
    </footer>
    <div id="article_content" class="author__content">

      <div class="layout layout--onecol">
    <div  class="layout__region layout__region--content">
      <div class="block block-layout-builder block-extra-field-blocknodearticlerate-rate-widget">
  
    
      <div class="rate-widget thumbsup"><form class="node-article-70384-updown-rate-widget-0 vote-form" id="rate-widget-base-form" data-drupal-selector="node-article-70384-updown-rate-widget-0" action="/article/22/12/open-source-education" method="post" accept-charset="UTF-8">
    <div class="rate-widget-thumbs-up">
    <div class="thumbsup-rating-wrapper rate-disabled" can-edit="false"><div class="form-item js-form-item form-type-radio js-form-type-radio form-item-value js-form-item-value form-disabled">
  <label  class="form-item js-form-item form-type-radio js-form-type-radio form-item-value js-form-item-value form-disabled rating-label thumbsup-rating-label thumbsup-rating-label-up vote-pending rate-thumbs-up-btn-up"><input twig-suggestion="rating-input" class="rating-input thumbsup-rating-input form-radio" data-drupal-selector="edit-value-1" disabled="disabled" type="radio" id="edit-value-1" name="value" value="1" />
</label>
    </div>
</div><input autocomplete="off" data-drupal-selector="form-nu8va7x0-esk-svivn0vdpgbn0qksp-xw-z0blmc0qu" type="hidden" name="form_build_id" value="form-nU8va7x0_ESK_SvIvn0vDPgbN0QKSp_XW-Z0BlMC0QU" />
<input data-drupal-selector="edit-node-article-70384-updown-rate-widget-0" type="hidden" name="form_id" value="node_article_70384_updown_rate_widget_0" />
<input class="thumbsup-rating-submit button button--primary js-form-submit form-submit" data-drupal-selector="edit-submit" type="submit" id="edit-submit--2" name="op" value="Save" />
<div class="vote-result js-form-wrapper form-wrapper" data-drupal-selector="edit-result" id="edit-result">  <div title="Register or Login to like."><a href="/user/register">Register</a> or <a href="/user/login?destination=/article/22/12/open-source-education">Login</a> to like</div>

</div>

    <div class="rate-score"></div>
  </div>


</form>
</div>

  </div>
<div class="block block-layout-builder block-extra-field-blocknodearticlecontent-moderation-control">
  
    
      
  </div>

    </div>
  </div>
  <div class="layout layout--onecol">
    <div  class="layout__region layout__region--content">
      <div class="block block-layout-builder block-field-blocknodearticlefield-lead-image">
  
    
      
            <div class="field field--name-field-lead-image field--type-entity-reference field--label-hidden field__item"><article class="media media--type-image media--view-mode-caption">
  
      
            <div class="field field--name-field-media-image field--type-image field--label-hidden field__item">  <img loading="lazy" src="/sites/default/files/2022-12/daffodils_seth-kenlon_cc0.webp" width="1920" height="1080" alt="Daffodils in a field" />

</div>
      
   <div class="field field--name-field-caption field--type-text-long field--label-hidden caption field__item"><span class="caption__byline">Image by: </span><p>(Seth Kenlon, CC0)</p>
</div>

  </article>
</div>
      
  </div>
<div class="block block-layout-builder block-field-blocknodearticlebody">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>Open source provides fertile ground for innovation, not only in the cloud but in the classroom. Whether you are homeschooled, in a traditional K-12, university, someone looking to learn new skills, open source provides rich opportunities for personal and professional development. This year, <a href="https://opensource.com/" target="_blank">Opensource.com </a>writers provided readers with a considerable list of opportunities for continuing education regardless of where you are on the continuum.</p>
<h2 id="compsci">Lack of computer science classes</h2>
<p>Did you know that only 51% of the high schools in the United States offer courses in computer science? Only 4.7% of students are enrolled in the courses available. This statistic is telling at a time when the US News and World Report recently ranked software development as one of the best jobs in America in 2022. Candace Sheremeta provided us with a list of three open source efforts to reverse that trend in her article about <a href="https://opensource.com/article/22/3/open-source-learn-computer-science" target="_blank">open source tools</a> to introduce students to computer science.</p>
<p>As computer science grows, it's important to have an understanding of what it means to be "cloud native." It's also necessary to understand the nuance of cloud native architecture. Anita Ihuman provides a beginner's guide to <a href="https://opensource.com/article/22/6/cloud-native-open-source-communities">cloud native open source communities</a>. This comprehensive article provides you with everything you need to know about cloud native and cloud native architecture.</p>
<h2 id="ada">Ada Lovelace day crowdsourcing</h2>
<p>Managing editor Lauren Pritchett, invited us to celebrate Ada Lovelace day with a <a href="https://opensource.com/article/22/10/ada-lovelace-day-tech-books-kids">crowdsourced list</a> of hands-on programming tutorials to fictional adventure novels. Opensource.com contributors shared their favorite books for programmers who are just starting out. You can start from Scratch and add to that a complete list of programming books available from NoStarch Press.  This includes my favorite book, <a href="https://opensource.com/education/15/9/review-bryson-payne-teach-your-kids-code">Teach Your Kids to Code</a> by Bryson Payne. There's also a list of three books for very young children to read about coding pioneer Ada Lovelace.</p>
<h2 id="security">Security and interoperability</h2>
<p>Concerns for security and interoperability have provided universities the impetus to move toward <a href="https://opensource.com/article/22/1/universities-open-source-software-rocketchat" target="_blank">Rocket.chat</a> for collaboration. Sara Cemazar has six compelling reasons why academia has adopted Rocket.chat. At the top of the list is how it improves hybrid and remote learning which have become mainstays of higher education. In addition it ensures complete data privacy and compliance with both FERPA in the United States, and GDPR in the EU.</p>
<p></p><div class="embedded-resource-list callout-float-right">
            <div class="field field--name-title field--type-string field--label-hidden field__item">More great content</div>
      
      <div class="field field--name-links field--type-link field--label-hidden field__items">
              <div class="field__item"><a href="https://www.redhat.com/en/services/training/rh024-red-hat-linux-technical-overview?intcmp=7016000000127cYAAQ">Free online course: RHEL technical overview</a></div>
              <div class="field__item"><a href="https://developers.redhat.com/cheat-sheets/advanced-linux-commands/?intcmp=7016000000127cYAAQ">Learn advanced Linux commands</a></div>
              <div class="field__item"><a href="https://opensource.com/downloads/cheat-sheets?intcmp=7016000000127cYAAQ">Download cheat sheets</a></div>
              <div class="field__item"><a href="https://opensource.com/tags/linux?intcmp=7016000000127cYAAQ">Find an open source alternative</a></div>
              <div class="field__item"><a href="https://opensource.com/resources?intcmp=7016000000127cYAAQ">Explore open source resources</a></div>
          </div>
  </div>
<h2 id="publishing">Publishing in academia</h2>
<p>Publishing is the life blood of academics and yet it's largely siloed and inordinately expensive to do. That's changing and Joshua Pearce has written about how the paradigm is changing and why open source is leading the way. Joshua writes, “Academics routinely give away their work to companies for free — and then they buy it back." Academics like Joshua have been trapped for decades in a scheme where they give away their work freely in exchange for job security. Then they pay millions of dollars a year to read our own writing. Now <a href="https://opensource.com/article/22/5/platinum-open-access-academic-journals">academics can read free</a>, publish free, and stay on track for professional success.</p>
<h2 id="google">Google</h2>
<p>Google Summer of Code (GSoC) can benefit anyone at various stages of their career, including people changing careers, those who are self-taught, those returning to the workforce, and more. You might be one of those people! Stefan Miklosovic provides the details of how you can get involved in GSOC by contributing to <a href="https://opensource.com/article/22/4/apache-cassandra-google-summer-code-program">Apache Cassandra</a>. Start the new year by getting involved.</p>
<h2 id="hardware">Open source hardware</h2>
<p>The open source hardware field is growing exponentially with the growth of the internet of things that includes wearables, single board computers, cameras, and robotics. This year Joshua Pearce introduced readers to an <a href="https://opensource.com/article/22/3/trailblazer-funding-open-hardware-academia">amazing opportunity</a> created by the confluence of open hardware in academia and the Sloan Foundation. Supported by fellowships worth up to $100,000 individuals will be able to tackle some of the latest issues for integrating open hardware deep into academia. If you are in the U.S. and interested in one of the eight Fellowships, check out the <a href="https://www.oshwa.org/2022/03/05/were-launching-a-new-open-hardware-trailblazers-fellowship/">Request for Proposals here</a>!</p>
<h2>Education and open source</h2>
<p>It is stunning how many opportunities open source projects give people to learn and improve themselves. Education can be costly but it does not have to be if one takes advantage of the myriad open source resources available on the web. You don't have to look too hard to find something free to learn! Try finding an open source learning resource now. You will not regret it.</p>
</div>
      
  </div>
<div class="block block-layout-builder block-field-blocknodearticlefield-listicle-title">
  
    
      
            <div class="field field--name-field-listicle-title field--type-string field--label-hidden field__item">What to read next</div>
      
  </div>
<div class="block block-layout-builder block-field-blocknodearticlefield-listicles">
  
    
      
      <div class="field field--name-field-listicles field--type-entity-reference field--label-hidden field__items">
              <div class="field__item"><article class="teaser">
  <figure>
            <div class="field field--name-field-lead-image field--type-entity-reference field--label-hidden field__item">  <a href="/education/13/11/open-source-materials-children-teens" hreflang="und"><img src="/sites/default/files/styles/article_teaser/public/lead-images/EDUCATION_doodles.png?itok=Upb359mz" width="360" height="202" alt="Doodles of the word open" title="Doodles of the word open" loading="lazy" class="image-style-article-teaser" />

</a>
</div>
      </figure>
  <div class="teaser__content">
    
          <h2>
        <a href="/education/13/11/open-source-materials-children-teens" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden">Free and open source education materials for children and teens</span>
</a>
      </h2>
        
          
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>I am a community moderator for opensource.com as well as a mother, a librarian, and a former public school teacher. When I began writing for this site over two years ago, it…</p>
</div>
      
              <footer>
                <div class="teaser__author">
          
<div class="user__item">
  <pfe-avatar name="Carolyn Fox" shape="circle" pattern="squares" src="/sites/default/files/pictures/picture-10747-d42cf027c6875264db1b0e78404352f6.jpg" pfelement="" class="PFElement"></pfe-avatar>
  <div class="user__name">
            <a href="/users/wivenhoe" hreflang="en">Carolyn Fox</a>
      </div>
  <span class="user__attributes"><span class="user-attributes">(Alumni)</span>
</span>
</div>

        </div>
                <span class="teaser__date">November 7, 2013</span>
      </footer>
      </div>
</article>




</div>
              <div class="field__item"><article class="teaser">
  <figure>
            <div class="field field--name-field-lead-image field--type-entity-reference field--label-hidden field__item">  <a href="/article/22/9/python-interpreters-2022" hreflang="en"><img src="/sites/default/files/styles/article_teaser/public/lead-images/python-programming-code-keyboard.png?itok=4gsBVekG" width="360" height="202" alt="Hands on a keyboard with a Python book " title="Hands on a keyboard with a Python book " loading="lazy" class="image-style-article-teaser" />

</a>
</div>
      </figure>
  <div class="teaser__content">
    
          <h2>
        <a href="/article/22/9/python-interpreters-2022" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden">6 Python interpreters to try in 2022</span>
</a>
      </h2>
        
          
            <div class="clearfix text-formatted field field--name-field-article-subhead field--type-text-long field--label-hidden field__item"><p>It could be interesting to see how your code behaves on another interpreter than what you&#039;re used to.</p>
</div>
      
              <footer>
                <div class="teaser__author">
          
<div class="user__item">
  <pfe-avatar name="Stephan Avenwedde" shape="circle" pattern="squares" src="/sites/default/files/pictures/avenwedde_stephan_4x6_cm_21-01-2014.jpg" pfelement="" class="PFElement"></pfe-avatar>
  <div class="user__name">
            <a href="/users/hansic99" hreflang="en">Stephan Avenwedde</a>
      </div>
  <span class="user__attributes"><span class="user-attributes">(Correspondent)</span>
</span>
</div>

        </div>
                <span class="teaser__date">September 21, 2022</span>
      </footer>
      </div>
</article>




</div>
              <div class="field__item"><article class="teaser">
  <figure>
            <div class="field field--name-field-lead-image field--type-entity-reference field--label-hidden field__item">  <a href="/article/22/11/learn-python" hreflang="en"><img src="/sites/default/files/styles/article_teaser/public/lead-images/coffee_python.jpg?itok=DDkfU_Or" width="360" height="202" alt="How to write a web service using Python Flask" title="How to write a web service using Python Flask" loading="lazy" class="image-style-article-teaser" />

</a>
</div>
      </figure>
  <div class="teaser__content">
    
          <h2>
        <a href="/article/22/11/learn-python" rel="bookmark"><span class="field field--name-title field--type-string field--label-hidden">Learn Python: 7 of my favorite resources</span>
</a>
      </h2>
        
          
            <div class="clearfix text-formatted field field--name-field-article-subhead field--type-text-long field--label-hidden field__item"><p>Over the years, I&#039;ve honed my Python skills thanks to these open source resources.</p>
</div>
      
              <footer>
                <div class="teaser__author">
          
<div class="user__item">
  <pfe-avatar name="Don Watkins" shape="circle" pattern="squares" src="/sites/default/files/donw2-crop.jpg" pfelement="" class="PFElement"></pfe-avatar>
  <div class="user__name">
            <a href="/users/don-watkins" hreflang="en">Don Watkins</a>
      </div>
  <span class="user__attributes"><span class="user-attributes">(Correspondent)</span>
</span>
</div>

        </div>
                <span class="teaser__date">November 12, 2022</span>
      </footer>
      </div>
</article>




</div>
          </div>
  
  </div>
<div class="block block-layout-builder block-field-blocknodearticlefield-tags">
  
    
      
  <div class="field field--name-field-tags field--type-entity-reference field--label-inline clearfix">
    <div class="field__label">Tags</div>
          <div class="field__items">
              <div class="field__item"><a href="/tags/best-opensourcecom" hreflang="en">Best of Opensource.com</a></div>
          <div class="field__item"><a href="/tags/education" hreflang="en">Education</a></div>
              </div>
      </div>

  </div>
<div class="views-element-container author-block block block-views block-views-blockauthor-info-author-info">
  <div class="author-block__wrapper">
  
    
      <div><div class="view view-author-info view-id-author_info view-display-id-author_info js-view-dom-id-e4f801f6232f5cbfdebbbac4bbe2b15290663da93df94f95837015b43d238c4c">
  
    
      
      <div class="view-content">
          <div class="views-row"><div class="views-field views-field-field-display-name"><div class="field-content"><a href="/users/don-watkins" hreflang="en">Don Watkins</a></div></div><div class="views-field views-field-field-user-picture"><div class="field-content"><article class="media media--type-image media--view-mode-_50x150">
  
      
            <div class="field field--name-field-media-image field--type-image field--label-hidden field__item">  <img loading="lazy" src="/sites/default/files/styles/150x150/public/donw2-crop.jpg?itok=nhDj400c" width="150" height="150" alt="User profile image." class="image-style-_50x150" />


</div>
      
  </article>
</div></div><div class="views-field views-field-field-user-about"><span class="field-content">Educator, entrepreneur, open source advocate, life long learner, Python teacher. M.A. in Educational Psychology, MSED in Educational Leadership, Linux system administrator, Follow me at @Don_Watkins .
Mastodon ID
</span></div><div class="views-field views-field-nothing"><span class="field-content"><a href="/users/don-watkins">More about me</a></span></div></div>

    </div>
  
      
          </div>
</div>

    </div>
</div>


<div class="views-element-container author-block block block-views block-views-blockauthor-info-block-1">
  <div class="author-block__wrapper plain">
  
    
      <div><div class="view view-author-info view-id-author_info view-display-id-block_1 js-view-dom-id-206a456d62149357095ba29fffbf8f00d6dde5b98647cd8e4524fd772ea14b7c">
  
    
      
  
      
          </div>
</div>

    </div>
</div>


<div class="block block-layout-builder block-field-blocknodearticlefield-comments">
  
    
      <section id='comments'  class="field field--name-field-comments field--type-comment field--label-hidden comment-wrapper">
  

  <div class="comments__count">
                  <div class="login"><a href="/user/register?absolute=1">Register</a> or <a href="/user/login?destination=/article/22/12/open-source-education&amp;absolute=1">Login</a> to post a comment.</div>
  </div>

  
  
</section>

  </div>
<div class="views-element-container related-articles block block-views block-views-blockrelated-articles-related-articles">
  
      <h2 class="related-articles__title">Related Content</h2>
    
      <div><div class="view view-related-articles view-id-related_articles view-display-id-related_articles js-view-dom-id-5eceef3276eea2a4a89354f413308c25fb77f7ee4121f358edcfeac547d4d7a6">
  
    
      
      <div class="view-content">
          <div class="views-row"><div class="views-field views-field-field-lead-image"><div class="field-content">  <a href="/article/22/12/open-source-alternatives" hreflang="en"><img src="/sites/default/files/styles/222x125/public/lead-images/EDUCATION_doodles.png?itok=PC9Mqt8r" width="222" height="125" alt="Doodles of the word open" title="Doodles of the word open" loading="lazy" class="image-style-_22x125" />

</a>
</div></div><div class="views-field views-field-title"><span class="field-content"><a href="/article/22/12/open-source-alternatives" hreflang="en">My favorite open source alternatives this year</a></span></div></div>
    <div class="views-row"><div class="views-field views-field-field-lead-image"><div class="field-content">  <a href="/article/22/12/kubernetes-articles" hreflang="en"><img src="/sites/default/files/styles/222x125/public/lead-images/ship_captain_devops_kubernetes_steer.png?itok=KZfIj-YV" width="222" height="125" alt="Ship captain sailing the Kubernetes seas" title="Ship captain sailing the Kubernetes seas" loading="lazy" class="image-style-_22x125" />

</a>
</div></div><div class="views-field views-field-title"><span class="field-content"><a href="/article/22/12/kubernetes-articles" hreflang="en">6 Kubernetes articles every open source enthusiast should read</a></span></div></div>
    <div class="views-row"><div class="views-field views-field-field-lead-image"><div class="field-content">  <a href="/article/22/12/linux-command-line" hreflang="en"><img src="/sites/default/files/styles/222x125/public/lead-images/command_line_prompt.png?itok=3XdZCT_k" width="222" height="125" alt="Command line prompt" title="Command line prompt" loading="lazy" class="image-style-_22x125" />

</a>
</div></div><div class="views-field views-field-title"><span class="field-content"><a href="/article/22/12/linux-command-line" hreflang="en">5 must-read resources for using the Linux command line</a></span></div></div>

    </div>
  
          </div>
</div>

  </div>

<div class="block block-layout-builder block-field-blocknodearticlefield-default-license">
  
    
      
            <div class="field field--name-field-default-license field--type-list-string field--label-hidden field__item"><a rel="license" href="http://creativecommons.org/licenses/by-sa/4.0/">
        <img alt="Creative Commons License" src="/themes/osdc/assets/img/cc-by-sa-4.png" title="This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License." /></a>This work is licensed under a Creative Commons Attribution-Share Alike 4.0 International License.</div>
      
  </div>

    </div>
  </div>

  </div>
</article>




  </div>
<div id="block-socialmediashareicons" class="block block-osdc-system block-osdc-social-block">
  
    
      <div><a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https%3A//red.ht/3PHIXRO&amp;title=9%20resources%20about%20open%20source%20for%20educators%20and%20students&amp;summary=Open%20source%20helps%20educators%2C%20scholars%2C%20students%2C%20and%20lifelong%20learners%20explore%20new%20horizons.&amp;source=Opensource.com" class="linkedin-icon">LinkedIn</a><a href="https://twitter.com/intent/tweet?text=9%20resources%20about%20open%20source%20for%20educators%20and%20students%20https%3A//red.ht/3PHIXRO%20via%20%40opensourceway%20by%20%40Don_Watkins&amp;related=opensourceway%2CDon_Watkins" class="twitter-icon">Twitter</a><a href="https://www.facebook.com/sharer.php?u=https%3A//red.ht/3PHIXRO" class="facebook-icon">Facebook</a><a href="https://api.whatsapp.com/send?text=9%20resources%20about%20open%20source%20for%20educators%20and%20students%20%7C%20Opensource.com%20https%3A//red.ht/3PHIXRO" class="whatsapp-icon">WhatsApp</a><a href="mailto:?subject=9%20resources%20about%20open%20source%20for%20educators%20and%20students%20%7C%20OpenSource.com&amp;body=https%3A//red.ht/3PHIXRO" class="email-icon">Email</a><a href="https://www.reddit.com/submit?url=https%3A//red.ht/3PHIXRO&amp;title=9%20resources%20about%20open%20source%20for%20educators%20and%20students%20%7C%20OpenSource.com" class="reddit-icon">Reddit</a><pfe-modal><button slot="pfe-modal--trigger" class="mastodon-icon"><span class="screen-reader-text">Mastodon</span></button><div id="mastodon-container"></div></pfe-modal><form id="mastodon-form" class="mastodon-form" data-drupal-selector="mastodon-form" action="/article/22/12/open-source-education" method="post" accept-charset="UTF-8">
  <div class="js-form-item form-item js-form-type-textfield form-type-textfield js-form-item-mastodon-url form-item-mastodon-url">
      <label for="edit-mastodon-url">Location of your Mastodon instance:</label>
        <input data-drupal-selector="edit-mastodon-url" type="text" id="edit-mastodon-url" name="mastodon_url" value="" size="60" maxlength="128" class="form-text" />

        </div>
<input autocomplete="off" data-drupal-selector="form-imgfh530phkyoo9mhzpuyu9uh6ea0o1impr8ho-ffz0" type="hidden" name="form_build_id" value="form-ImgFh530PHKyOo9MHZPUYU9Uh6EA0O1ImPr8Ho_FFZ0" />
<input data-drupal-selector="edit-mastodon-form" type="hidden" name="form_id" value="mastodon_form" />
<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions--2"><input data-query="?url=https://red.ht/3PHIXRO&amp;text=9 resources about open source for educators and students | OpenSource.com" data-drupal-selector="edit-submit" type="submit" id="edit-submit--3" name="op" value="Toot" class="button button--primary js-form-submit form-submit" />
</div>

</form>
</div>

  </div>

<div class="dyfo-cta green-on-blue block block-rhcomdev-dyfo-block block-rhcomdev-dyfo-block-dynamic-form-block subscribe-cta" id="subscribe-cta">
  
    
      <div class="cta__text-and-form image-none">
        <div class="cta__content">
        <div class="cta__text">
            <h2 class="cta__title">Subscribe to our weekly newsletter</h2>

        </div>
        <div class="cta__form">
            <div class="rh-dyfo" data-rh-dyfo-instance="67a6eb65-87cf-46a5-b2d8-e23f686b615a"></div>

        </div>
        <div class="cta__privacy-link"><a href="https://www.redhat.com/en/about/privacy-policy">Privacy Statement</a></div>
    </div>
</div>

  </div>


  </div>

    </div>
  </main>

      <footer class="global_footer">
      <div class="wrapper">
          <div class="region region-left-footer">
    <div id="block-aboutthissitefooter" class="block block-block-content block-block-content1d00183d-1f84-4ed3-9367-c632014cd322">
  
      <h2>About This Site</h2>
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>The opinions expressed on this website are those of each author, not of the author's employer or of Red Hat.</p>
<p><a href="https://opensource.com/">Opensource.com</a> aspires to publish all content under a <a href="http://creativecommons.org/licenses/">Creative Commons license</a> but may not be able to do so in all cases. You are responsible for ensuring that you have the necessary permission to reuse any work on this site. Red Hat and the Red Hat logo are trademarks of Red Hat, Inc., registered in the United States and other countries.</p>
<p>A note on advertising: Opensource.com does not sell advertising on the site or in any of its newsletters.</p>
</div>
      
  </div>

  </div>

          <div class="region region-right-footer">
    <div id="block-connectfooter" class="block block-block-content block-block-content04a63217-9bba-49ac-9d2c-b2eb30fb8526">
  
      <h2>Contact</h2>
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p class="footer-twitter"><a href="https://twitter.com/OpenSourceWay" target="_blank">Follow us @opensource.com on Twitter</a></p>
<p class="footer-facebook"><a href="https://www.facebook.com/opensourceway" target="_blank">Like Opensource.com on Facebook</a></p>
<p class="footer-youtube"><a href="http://www.youtube.com/opensourceway" target="_blank">Watch us at Opensource.com</a></p>
<p class="footer-mastodon"><a href="https://mastodon.sdf.org/@Opensource">Follow us on Mastodon</a></p>
<p class="footer-rss"><a href="https://opensource.com/feed">RSS Feed</a></p>
</div>
      
  </div>
<div id="block-sitebranding" class="block block-system block-system-branding-block">
  
    
    <div class="branding">
          <a href="/" rel="home" aria-label="" class="branding__logo">
        <img src="/themes/osdc/logo.svg" alt="Home"/>
      </a>
      </div>
</div>

  </div>

          <div class="region region-copyright">
    <div id="block-copyrightfooter" class="block block-block-content block-block-contentc0a744a4-2740-4f8a-a693-ee8d7cb5ff86">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p>Copyright ©<span id="copyright-year">2021</span> Red Hat, Inc.</p>
</div>
      
  </div>
<nav role="navigation" aria-labelledby="block-legal-menu" id="block-legal" class="block block-menu navigation menu--legal">
            
  <h2 class="visually-hidden" id="block-legal-menu">Legal</h2>
  

        
              <ul class="menu">
                    <li class="menu-item">
        <a href="/privacy-policy" data-drupal-link-system-path="node/17705">Privacy Policy</a>
              </li>
                <li class="menu-item">
        <a href="/legal" data-drupal-link-system-path="legal">Terms of use</a>
              </li>
                <li class="menu-item">
        <a href="/contact" data-drupal-link-system-path="node/68921">Contact</a>
              </li>
        </ul>
  


  </nav>

  </div>

      </div>
    </footer>
    </div>
  </div>

    
    <script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/70384","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ajaxPageState":{"libraries":"classy\/base,classy\/messages,classy\/node,codesnippet\/codesnippet.highlightjs,codesnippet\/codesnippet.style.vs,core\/internal.jquery.form,core\/normalize,datalayer_metatag\/eddl_bottom,datalayer_metatag\/eddl_user,geshifilter\/geshifilter,layout_discovery\/onecol,osdc\/article-teaser,osdc\/author-block,osdc\/author-meta,osdc\/global,osdc\/poll,osdc\/related-content,osdc\/search,osdc\/social-shares,osdc\/subscribe-cta,osdc\/subscribe-float,poll\/drupal.poll-links,rate\/unvote-helper,rate\/w-thumbsup,rhcomdev_dyfo_block\/dyfo,system\/base,views\/views.module","theme":"osdc","theme_token":null},"ajaxTrustedUrl":{"form_action_p_pvdeGsVG5zNF_XLGPTvYSKCf43t8qZYSwcfZl2uzM":true,"\/article\/22\/12\/open-source-education?ajax_form=1":true,"\/site-search":true},"ajax":{"edit-submit--2":{"callback":"::ajaxSubmit","event":"click","wrapper":"rate-widget-base-form","progress":{"type":null},"url":"\/article\/22\/12\/open-source-education?ajax_form=1","dialogType":"ajax","submit":{"_triggering_element_name":"op","_triggering_element_value":"Save"}}},"user":{"uid":0,"permissionsHash":"efef4bb818358d7be55a2908527d563aff971f63e089f82fcd4a08e18f56135e"}}</script>
<script src="/sites/default/files/js/js_inKmFW3PlI-5035lf8_1GR6psPAtGGZzu7PDKN1c_Vs.js"></script>
<script src="/modules/custom/datalayer_metatag/libraries/dist/js/eddl_user.min.js?rn59ma" type="text/javascript"></script>
<script src="/modules/custom/datalayer_metatag/libraries/dist/js/eddl_bottom.min.js?rn59ma" type="text/javascript"></script>
<script src="https://www.redhat.com/libraries/dyfo-client/dist/main.js"></script>
<script src="https://www.redhat.com/libraries/dyfo-client/dist/main.ie11.js" nomodule="nomodule"></script>
<script src="/sites/default/files/js/js_SmbPMlW1XdDdf7S6QqekKgnpz2ANRvSduUXsmrOznfA.js"></script>
<script src="/themes/osdc/node_modules/%40patternfly/pfe-readtime/dist/pfe-readtime.min.js?rn59ma" type="module"></script>
<script src="/themes/osdc/node_modules/%40patternfly/pfe-avatar/dist/pfe-avatar.min.js?rn59ma" type="module"></script>
<script src="/sites/default/files/js/js_ZjRdzI1grgTn9HlT9QHaztY8V-8HWJn4kz9buq0_hz0.js"></script>

  <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"NRJS-6128485344987227876","applicationID":"1384502491","transactionName":"NlJbMERZV0FXBURbDA8YeAdCUVZcGRZRVQY+VFgHXl0=","queueTime":0,"applicationTime":27,"atts":"GhVYRgxDRE8=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
